sync w/devel branch for qt45 goodness

This commit is contained in:
Rex Dieter 2009-03-25 18:42:33 +00:00
parent f21588d73a
commit 5fccd62588
12 changed files with 327 additions and 122 deletions

View File

@ -1,4 +1,4 @@
hi128-app-qt4-logo.png
hi48-app-qt4-logo.png
qt-x11-opensource-src-4.4.3.tar.bz2
qt-copy-patches-20090304svn.tar.bz2
qt-x11-opensource-src-4.5.0.tar.bz2
qt-copy-patches-20090325svn.tar.bz2

60
qt-4.5-sparc64.patch Normal file
View File

@ -0,0 +1,60 @@
--- qt-x11-opensource-src-4.5.0/src/3rdparty/webkit/JavaScriptCore/wtf/Threading.h.orig 2009-03-15 00:21:08.000000000 -0500
+++ qt-x11-opensource-src-4.5.0/src/3rdparty/webkit/JavaScriptCore/wtf/Threading.h 2009-03-15 00:22:38.000000000 -0500
@@ -196,14 +196,14 @@
#elif COMPILER(GCC)
#define WTF_USE_LOCKFREE_THREADSAFESHARED 1
-inline void atomicIncrement(int volatile* addend) { __gnu_cxx::__atomic_add(addend, 1); }
-inline int atomicDecrement(int volatile* addend) { return __gnu_cxx::__exchange_and_add(addend, -1) - 1; }
+inline void atomicIncrement(_Atomic_word volatile* addend) { __gnu_cxx::__atomic_add(addend, 1); }
+inline _Atomic_word atomicDecrement(_Atomic_word volatile* addend) { return __gnu_cxx::__exchange_and_add(addend, -1) - 1; }
#endif
template<class T> class ThreadSafeShared : Noncopyable {
public:
- ThreadSafeShared(int initialRefCount = 1)
+ ThreadSafeShared(_Atomic_word initialRefCount = 1)
: m_refCount(initialRefCount)
{
}
@@ -237,16 +237,16 @@
return refCount() == 1;
}
- int refCount() const
+ _Atomic_word refCount() const
{
#if !USE(LOCKFREE_THREADSAFESHARED)
MutexLocker locker(m_mutex);
#endif
- return static_cast<int const volatile &>(m_refCount);
+ return static_cast<_Atomic_word const volatile &>(m_refCount);
}
private:
- int m_refCount;
+ _Atomic_word m_refCount;
#if !USE(LOCKFREE_THREADSAFESHARED)
mutable Mutex m_mutex;
#endif
--- qt-x11-opensource-src-4.5.0/src/3rdparty/webkit/JavaScriptCore/wtf/Platform.h.orig 2009-03-15 00:21:37.000000000 -0500
+++ qt-x11-opensource-src-4.5.0/src/3rdparty/webkit/JavaScriptCore/wtf/Platform.h 2009-03-15 00:22:38.000000000 -0500
@@ -214,9 +214,16 @@
#endif
/* PLATFORM(SPARC64) */
-#if defined(__sparc64__)
+#if defined(__sparc64__) \
+ || defined(__sparc__) && defined(_arch64__)
#define WTF_PLATFORM_SPARC64 1
#define WTF_PLATFORM_BIG_ENDIAN 1
+#else
+/* PLATFORM(SPARC) */
+#if defined(__sparc__)
+#define WTF_PLATFORM_SPARC 1
+#define WTF_PLATFORM_BIG_ENDIAN 1
+#endif
#endif
/* PLATFORM(WIN_CE) && PLATFORM(QT)

View File

@ -7,7 +7,7 @@ set -x
rm -rf $EXPORT_DIR
# trunk tracking qt-4.5 now
SVN_ROOT=svn://anonsvn.kde.org/home/kde/branches/qt/4.4
SVN_ROOT=svn://anonsvn.kde.org/home/kde/trunk/qt-copy
svn export --non-recursive $SVN_ROOT $EXPORT_DIR/
svn export $SVN_ROOT/patches $EXPORT_DIR/patches

View File

@ -1,18 +0,0 @@
diff -ur qt-x11-opensource-src-4.4.0/src/gui/kernel/qapplication_x11.cpp qt-x11-opensource-src-4.4.0-qgtkstyle/src/gui/kernel/qapplication_x11.cpp
--- qt-x11-opensource-src-4.4.0/src/gui/kernel/qapplication_x11.cpp 2008-04-28 15:11:18.000000000 +0200
+++ qt-x11-opensource-src-4.4.0-qgtkstyle/src/gui/kernel/qapplication_x11.cpp 2008-05-27 05:43:57.000000000 +0200
@@ -2262,9 +2262,11 @@
QApplicationPrivate::app_style = QStyleFactory::create(QLatin1String("windows"));
break;
case DE_GNOME:
- if (X11->use_xrender)
- QApplicationPrivate::app_style = QStyleFactory::create(QLatin1String("cleanlooks"));
- else
+ if (X11->use_xrender) {
+ QApplicationPrivate::app_style = QStyleFactory::create(QLatin1String("gtk"));
+ if (!QApplicationPrivate::app_style)
+ QApplicationPrivate::app_style = QStyleFactory::create(QLatin1String("cleanlooks"));
+ } else
QApplicationPrivate::app_style = QStyleFactory::create(QLatin1String("windows"));
break;
case DE_CDE:

View File

@ -1,67 +0,0 @@
diff -up qt-x11-opensource-src-4.4.3/src/plugins/inputmethods/imsw-multi/qmultiinputcontext.cpp.orig qt-x11-opensource-src-4.4.3/src/plugins/inputmethods/imsw-multi/qmultiinputcontext.cpp
--- qt-x11-opensource-src-4.4.3/src/plugins/inputmethods/imsw-multi/qmultiinputcontext.cpp.orig 2008-11-06 14:19:08.000000000 +0100
+++ qt-x11-opensource-src-4.4.3/src/plugins/inputmethods/imsw-multi/qmultiinputcontext.cpp 2008-11-06 14:18:34.000000000 +0100
@@ -69,12 +69,15 @@ QMultiInputContext::QMultiInputContext()
if (keys.at(i).contains(QLatin1String("imsw")))
keys.removeAt(i);
+ m_keys = keys;
+
QString def = QLatin1String(getenv("QT_IM_MODULE"));
if (def.isEmpty()) {
- QSettings settings;
- def = settings.value(QLatin1String("/qt/DefaultInputMethod"), QLatin1String("xim")).toString();
+ QSettings settings(QSettings::UserScope, QLatin1String("Trolltech"));
+ settings.beginGroup(QLatin1String("Qt"));
+ def = settings.value(QLatin1String("DefaultInputMethod"), QLatin1String("xim")).toString();
}
- current = keys.indexOf(def);
+ current = m_keys.indexOf(def);
if (current < 0)
current = 0;
@@ -83,13 +86,16 @@ QMultiInputContext::QMultiInputContext()
separator->setSeparator(true);
QActionGroup *group = new QActionGroup(this);
- for (int i = 0; i < keys.size(); ++i) {
- slaves.append(QInputContextFactory::create(keys.at(i), this));
- QAction *a = menu->addAction(slaves.at(i)->identifierName());
+ for (int i = 0; i < m_keys.size(); ++i) {
+ //slaves.append(QInputContextFactory::create(keys.at(i), this));
+ slaves.append(NULL);
+ QAction *a = menu->addAction(m_keys.at(i));
a->setCheckable(true);
group->addAction(a);
- if (i == current)
+ if (i == current) {
+ slaves.replace(current, QInputContextFactory::create(m_keys.at(i), this));
a->setChecked(true);
+ }
}
connect(group, SIGNAL(triggered(QAction*)), this, SLOT(changeSlave(QAction*)));
@@ -181,8 +187,10 @@ QList<QAction *> QMultiInputContext::act
void QMultiInputContext::changeSlave(QAction *a)
{
- for (int i = 0; i < slaves.size(); ++i) {
- if (slaves.at(i)->identifierName() == a->text()) {
+ for (int i = 0; i < m_keys.size(); ++i) {
+ if (m_keys.at(i) == a->text()) {
+ if (NULL == slaves.at(i))
+ slaves.replace(i, QInputContextFactory::create(m_keys.at(i), this));
current = i;
return;
}
diff -up qt-x11-opensource-src-4.4.3/src/plugins/inputmethods/imsw-multi/qmultiinputcontext.h.orig qt-x11-opensource-src-4.4.3/src/plugins/inputmethods/imsw-multi/qmultiinputcontext.h
--- qt-x11-opensource-src-4.4.3/src/plugins/inputmethods/imsw-multi/qmultiinputcontext.h.orig 2008-09-27 10:58:48.000000000 +0200
+++ qt-x11-opensource-src-4.4.3/src/plugins/inputmethods/imsw-multi/qmultiinputcontext.h 2008-11-06 14:19:53.000000000 +0100
@@ -103,6 +103,7 @@ private:
QList<QInputContext *> slaves;
QMenu *menu;
QAction *separator;
+ QStringList m_keys;
};
#endif // Q_NO_IM

View File

@ -0,0 +1,41 @@
diff -up qt-x11-opensource-src-4.5.0/tools/linguist/shared/profileevaluator.cpp.orig qt-x11-opensource-src-4.5.0/tools/linguist/shared/profileevaluator.cpp
--- qt-x11-opensource-src-4.5.0/tools/linguist/shared/profileevaluator.cpp.orig 2009-03-16 12:50:03.000000000 +0100
+++ qt-x11-opensource-src-4.5.0/tools/linguist/shared/profileevaluator.cpp 2009-03-17 00:42:51.000000000 +0100
@@ -86,6 +86,7 @@ public:
void enterScope(bool multiLine);
void leaveScope();
void finalizeBlock();
+ void cleanup();
// implementation of AbstractProItemVisitor
bool visitBeginProBlock(ProBlock *block);
@@ -164,6 +165,15 @@ ProFileEvaluator::Private::Private(ProFi
m_contNextLine = false;
}
+void ProFileEvaluator::Private::cleanup()
+{
+ m_commentItem = 0;
+ m_block = 0;
+ m_proitem.clear();
+ m_blockstack.clear();
+ m_pendingComment.clear();
+}
+
bool ProFileEvaluator::Private::read(ProFile *pro)
{
QFile file(pro->fileName());
@@ -180,11 +190,14 @@ bool ProFileEvaluator::Private::read(Pro
while (!ts.atEnd()) {
QString line = ts.readLine();
if (!parseLine(line)) {
+ cleanup();
q->errorMessage(format(".pro parse failure."));
return false;
}
++m_lineNo;
}
+
+ cleanup();
return true;
}

View File

@ -0,0 +1,11 @@
--- qt-x11-opensource-src-4.5.0/tools/linguist/lrelease/main.cpp.orig 2009-03-24 13:42:02.000000000 +0100
+++ qt-x11-opensource-src-4.5.0/tools/linguist/lrelease/main.cpp 2009-03-24 13:47:21.000000000 +0100
@@ -102,7 +102,7 @@
if (!msg.comment().isEmpty())
qWarning("\n* Comment: %s", qPrintable(msg.comment()));
}
- ok = false;
+ //ok = false;
}
}
return ok;

View File

@ -0,0 +1,22 @@
diff -up qt-x11-opensource-src-4.5.0/tools/qdoc3/qdoc3.pro.qdoc3 qt-x11-opensource-src-4.5.0/tools/qdoc3/qdoc3.pro
--- qt-x11-opensource-src-4.5.0/tools/qdoc3/qdoc3.pro.qdoc3 2009-02-25 15:09:26.000000000 -0600
+++ qt-x11-opensource-src-4.5.0/tools/qdoc3/qdoc3.pro 2009-03-04 09:30:05.000000000 -0600
@@ -106,3 +106,7 @@ win32 {
QT_WINCONFIG = debug
}
}
+
+TARGET= qdoc3
+target.path = $$[QT_INSTALL_BINS]
+INSTALLS += target
diff -up qt-x11-opensource-src-4.5.0/tools/tools.pro.qdoc3 qt-x11-opensource-src-4.5.0/tools/tools.pro
--- qt-x11-opensource-src-4.5.0/tools/tools.pro.qdoc3 2009-02-25 15:09:27.000000000 -0600
+++ qt-x11-opensource-src-4.5.0/tools/tools.pro 2009-03-04 09:44:18.000000000 -0600
@@ -13,6 +13,7 @@ no-png {
SUBDIRS += designer
}
SUBDIRS += linguist
+ SUBDIRS += qdoc3
wince*: SUBDIRS = qtestlib designer
unix:!mac:!embedded:contains(QT_CONFIG, qt3support):SUBDIRS += qtconfig
win32:!wince*:!contains(QT_EDITION, OpenSource|Console):SUBDIRS += activeqt

View File

@ -0,0 +1,12 @@
diff -up qt-x11-opensource-src-4.5.0-rc1/src/corelib/arch/qatomic_powerpc.h.orig qt-x11-opensource-src-4.5.0-rc1/src/corelib/arch/qatomic_powerpc.h
--- qt-x11-opensource-src-4.5.0-rc1/src/corelib/arch/qatomic_powerpc.h.orig 2009-02-14 22:51:51.000000000 +0100
+++ qt-x11-opensource-src-4.5.0-rc1/src/corelib/arch/qatomic_powerpc.h 2009-02-14 22:53:03.000000000 +0100
@@ -188,7 +188,7 @@ inline bool QBasicAtomicInt::testAndSetR
"lwarx %[result]," _Q_VALUE "\n"
"xor. %[result], %[result], %[expectedValue]\n"
"bne $+12\n"
- "stwcx. %[newValue],0,%[_q_value]\n"
+ "stwcx. %[newValue]," _Q_VALUE "\n"
"bne- $-16\n"
: [result] "=&r" (result),
_Q_VALUE_MEMORY_OPERAND

View File

@ -0,0 +1,11 @@
diff -up qt-x11-opensource-src-4.5.0-rc1/src/network/kernel/qhostaddress.h.qhostaddress qt-x11-opensource-src-4.5.0-rc1/src/network/kernel/qhostaddress.h
--- qt-x11-opensource-src-4.5.0-rc1/src/network/kernel/qhostaddress.h.qhostaddress 2009-02-04 10:05:29.000000000 -0600
+++ qt-x11-opensource-src-4.5.0-rc1/src/network/kernel/qhostaddress.h 2009-02-22 13:32:08.000000000 -0600
@@ -37,6 +37,7 @@
#ifndef QHOSTADDRESS_H
#define QHOSTADDRESS_H
+#include <QtCore/qpair.h>
#include <QtCore/qstring.h>
#include <QtNetwork/qabstractsocket.h>

197
qt.spec
View File

@ -1,6 +1,9 @@
# Fedora Review: http://bugzilla.redhat.com/188180
# configure options
# -no-pch disables precompiled headers, make ccache-friendly
#define no_pch -no-pch
Summary: Qt toolkit
%if 0%{?fedora} > 8
Name: qt
@ -8,13 +11,13 @@ Epoch: 1
%else
Name: qt4
%endif
Version: 4.4.3
Release: 15%{?dist}
Version: 4.5.0
Release: 10%{?dist}
# GPLv2 exceptions(see GPL_EXCEPTIONS*.txt)
License: GPLv3 with exceptions or GPLv2 with exceptions
# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
License: LGPLv2 with exceptions or GPLv3 with exceptions
Group: System Environment/Libraries
Url: http://www.trolltech.com/products/qt/
Url: http://www.qtsoftware.com/
Source0: ftp://ftp.trolltech.com/qt/source/qt-x11-opensource-src-%{version}.tar.bz2
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@ -34,13 +37,18 @@ Source5: qconfig-multilib.h
Patch2: qt-x11-opensource-src-4.2.2-multilib-optflags.patch
Patch3: qt-x11-opensource-src-4.2.2-multilib-QMAKEPATH.patch
Patch5: qt-all-opensource-src-4.4.0-rc1-as_IN-437440.patch
# under GNOME, default to QGtkStyle if available
# (otherwise fall back to QCleanlooksStyle)
Patch9: qt-x11-opensource-src-4.4.0-qgtkstyle.patch
Patch10: qt-x11-opensource-src-4.4.3-im.patch
Patch10: qt-x11-opensource-src-4.5.0-rc1-ppc64.patch
Patch11: qt-x11-opensource-src-4.5.0-linguist-crash.patch
Patch12: qt-x11-opensource-src-4.5.0-lrelease.patch
## upstreamable bits
# http://bugzilla.redhat.com/485677
Patch50: qt-x11-opensource-src-4.5.0-rc1-qhostaddress.patch
Patch51: qt-x11-opensource-src-4.5.0-qdoc3.patch
Patch52: qt-4.5-sparc64.patch
## qt-copy patches
%define qt_copy 20090304
%define qt_copy 20090325
Source1: qt-copy-patches-svn_checkout.sh
%{?qt_copy:Source2: qt-copy-patches-%{qt_copy}svn.tar.bz2}
%{?qt_copy:Provides: qt-copy = %{qt_copy}}
@ -66,7 +74,10 @@ Source31: hi48-app-qt4-logo.png
%define odbc -plugin-sql-odbc
%define psql -plugin-sql-psql
%define sqlite -plugin-sql-sqlite
%define phonon -phonon
%define phonon_backend -no-phonon-backend
%define webkit -webkit
%define gtkstyle -gtkstyle
#define nas -system-nas-sound
%define nas -no-nas-sound
@ -130,6 +141,15 @@ BuildRequires: nas-devel
BuildRequires: mysql-devel >= 4.0
%endif
%if "%{?phonon_backend}" == "-phonon-backend"
BuildRequires: gstreamer-devel
BuildRequires: gstreamer-plugins-base-devel
%endif
%if "%{?gtkstyle}" == "-gtkstyle"
BuildRequires: gtk2-devel
%endif
%if "%{?psql}" != "-no-sql-psql"
BuildRequires: postgresql-devel
# added deps to workaround http://bugzilla.redhat.com/440673
@ -145,12 +165,14 @@ BuildRequires: unixODBC-devel
BuildRequires: sqlite-devel
%endif
Obsoletes: qt4-config < %{version}-%{release}
Obsoletes: qgtkstyle < 0.1
Provides: qgtkstyle = 0.1-1
Obsoletes: qt4-config < 4.5.0
Provides: qt4-config = %{version}-%{release}
Obsoletes: qt4-sqlite < %{version}-%{release}
Obsoletes: qt4-sqlite < 4.5.0
Provides: qt4-sqlite = %{version}-%{release}
%if "%{name}" == "qt"
Obsoletes: qt-sqlite < %{?epoch:%{epoch}:}%{version}-%{release}
Obsoletes: qt-sqlite < %{?epoch:%{epoch}:}4.5.0
Provides: qt-sqlite = %{?epoch:%{epoch}:}%{version}-%{release}
%endif
@ -169,6 +191,11 @@ Requires: %{x_deps}
Requires: libpng-devel
Requires: libjpeg-devel
Requires: pkgconfig
%if 0%{?phonon:1}
# No, let's avoid the circular dependency (for now) -- Rex
#Requires: phonon-devel
Provides: qt4-phonon-devel = %{version}-%{release}
%endif
%if 0%{?webkit:1}
Obsoletes: WebKit-qt-devel < 1.0.0-1
Provides: WebKit-qt-devel = 1.0.0-1
@ -249,6 +276,9 @@ Provides: qt4-postgresql = %{version}-%{release}
%package x11
Summary: Qt GUI-related libraries
Group: System Environment/Libraries
%if 0%{?phonon:1}
Provides: qt4-phonon = %{version}-%{release}
%endif
%if 0%{?webkit:1}
Obsoletes: WebKit-qt < 1.0.0-1
Provides: WebKit-qt = 1.0.0-1
@ -268,12 +298,10 @@ Qt libraries which are used for drawing widgets and OpenGL items.
%prep
%setup -q -n qt-x11-opensource-src-%{version}%{?pre} %{?qt_copy:-a 2}
%setup -q -n qt-x11-opensource-src-%{version} %{?qt_copy:-a 2}
%if 0%{?qt_copy:1}
echo "0242" >> patches/DISABLED
%if 0%{?qt_copy}
echo "0250" >> patches/DISABLED
echo "0251" >> patches/DISABLED
test -x apply_patches && ./apply_patches
%endif
@ -284,8 +312,12 @@ test -x apply_patches && ./apply_patches
%patch3 -p1 -b .multilib-QMAKEPATH
%endif
%patch5 -p1 -b .bz#437440-as_IN-437440
%patch9 -p1 -b .qgtkstyle
%patch10 -p1 -b .im
%patch10 -p1 -b .ppc64
%patch11 -p1 -b .linguist-crash
%patch12 -p1 -b .lrelease
%patch50 -p1 -b .qhostaddress
%patch51 -p1 -b .qdoc3
%patch52 -p1 -b .sparc64
# drop -fexceptions from $RPM_OPT_FLAGS
RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS | sed 's|-fexceptions||g'`
@ -348,11 +380,14 @@ fi
-cups \
-fontconfig \
-largefile \
-gtkstyle \
-qt-gif \
-no-rpath \
-reduce-relocations \
-no-separate-debug-info \
-no-phonon -no-gstreamer \
%{?phonon} \
%{?phonon_backend} \
%{?no_pch} \
-sm \
-stl \
-system-libmng \
@ -360,7 +395,7 @@ fi
-system-libjpeg \
-system-libtiff \
-system-zlib \
-tablet \
-xinput \
-xcursor \
-xfixes \
-xinerama \
@ -394,11 +429,16 @@ desktop-file-install \
%{SOURCE20} %{SOURCE21} %{SOURCE22} %{SOURCE23} %{SOURCE24}
## pkg-config
# strip extraneous dirs/libraries -- Rex
# strip extraneous dirs/libraries
# FIXME?: qt-4.5 seems to use Libs.private properly, so this hackery should
# no longer be required -- Rex
# safe ones
glib2_libs=$(pkg-config --libs glib-2.0 gthread-2.0)
for dep in -laudio -ldbus-1 -lfreetype -lfontconfig ${glib2_libs} -lmng -ljpeg -lpng -lm -lz -lssl -lcrypto -lsqlite3 \
-L%{_builddir}/qt-x11%{?preview}-opensource-src-%{version}%{?pre}/lib -L/usr/X11R6/%{_lib} ; do
glib2_libs=$(pkg-config --libs glib-2.0 gobject-2.0 gthread-2.0)
ssl_libs=$(pkg-config --libs openssl)
for dep in \
-laudio -ldbus-1 -lfreetype -lfontconfig ${glib2_libs} \
-ljpeg -lm -lmng -lpng ${ssl_libs} -lsqlite3 -lz \
-L/usr/X11R6/%{_lib} -L%{_libdir} ; do
sed -i -e "s|$dep ||g" %{buildroot}%{_qt4_libdir}/lib*.la ||:
sed -i -e "s|$dep ||g" %{buildroot}%{_qt4_libdir}/pkgconfig/*.pc
sed -i -e "s|$dep ||g" %{buildroot}%{_qt4_libdir}/*.prl
@ -409,7 +449,8 @@ for dep in -lXrender -lXrandr -lXcursor -lXfixes -lXinerama -lXi -lXft -lXt -lXe
sed -i -e "s|$dep ||g" %{buildroot}%{_qt4_libdir}/pkgconfig/*.pc
sed -i -e "s|$dep ||g" %{buildroot}%{_qt4_libdir}/*.prl
done
# nuke dandling reference(s) to %buildroot
# nuke dangling reference(s) to %buildroot
sed -i -e "/^QMAKE_PRL_BUILD_DIR/d" %{buildroot}%{_qt4_libdir}/*.prl
%if "%{_qt4_docdir}" != "%{_qt4_prefix}/doc"
@ -517,6 +558,7 @@ EOF
mkdir -p %{buildroot}%{_sysconfdir}/rpm
cat >%{buildroot}%{_sysconfdir}/rpm/macros.qt4<<EOF
%%_qt4 %{name}
%%_qt45 %{version}
%%_qt4_version %{version}
%%_qt4_prefix %%{_libdir}/qt4
%%_qt4_bindir %%{_qt4_prefix}/bin
@ -535,6 +577,20 @@ EOF
# create/own %%_qt4_plugindir/styles
mkdir %{buildroot}%{_qt4_plugindir}/styles
%if 0%{?phonon:1}
mkdir -p %{buildroot}%{_qt4_plugindir}/phonon_backend
# if building with phonon support, nuke it
rm -fv %{buildroot}%{_qt4_libdir}/libphonon.so*
rm -rfv %{buildroot}%{_libdir}/pkgconfig/phonon.pc
# contents slightly different between phonon-4.3.1 and qt-4.5.0
rm -fv %{buildroot}%{_includedir}/phonon/phononnamespace.h
# contents dup'd but should remove just in case
rm -fv %{buildroot}%{_includedir}/phonon/*.h
#rm -rfv %{buildroot}%{_qt4_headerdir}/phonon*
#rm -rfv %{buildroot}%{_qt4_headerdir}/Qt/phonon*
%endif
%clean
rm -rf %{buildroot}
@ -565,9 +621,7 @@ gtk-update-icon-cache -q %{_datadir}/icons/hicolor 2> /dev/null ||:
%files
%defattr(-,root,root,-)
%doc README*
%doc LICENSE.GPL2 GPL_EXCEPTION*.TXT
%doc LICENSE.GPL3
%doc README* LGPL_EXCEPTION.txt LICENSE.LGPL LICENSE.GPL3
#config /etc/profile.d/qt4.*
%if "%{_qt4_libdir}" != "%{_libdir}"
/etc/ld.so.conf.d/*
@ -611,6 +665,9 @@ gtk-update-icon-cache -q %{_datadir}/icons/hicolor 2> /dev/null ||:
%files x11
%defattr(-,root,root,-)
%{_sysconfdir}/rpm/macros.*
%if 0%{?phonon:1}
#{_qt4_libdir}/libphonon.so.4*
%endif
%{_qt4_libdir}/libQt3Support.so.*
%{_qt4_libdir}/libQtAssistantClient.so.*
%{_qt4_libdir}/libQtCLucene.so.*
@ -619,6 +676,7 @@ gtk-update-icon-cache -q %{_datadir}/icons/hicolor 2> /dev/null ||:
%{_qt4_libdir}/libQtGui.so.*
%{_qt4_libdir}/libQtHelp.so.*
%{_qt4_libdir}/libQtOpenGL.so.*
%{_qt4_libdir}/libQtScriptTools.so.*
%{_qt4_libdir}/libQtSvg.so.*
%{?webkit:%{_qt4_libdir}/libQtWebKit.so.*}
%{_qt4_plugindir}/*
@ -636,10 +694,12 @@ gtk-update-icon-cache -q %{_datadir}/icons/hicolor 2> /dev/null ||:
%files devel
%defattr(-,root,root,-)
%{_qt4_bindir}/lconvert
%{_qt4_bindir}/lrelease*
%{_qt4_bindir}/lupdate*
%{_qt4_bindir}/moc*
%{_qt4_bindir}/pixeltool*
%{_qt4_bindir}/qdoc3*
%{_qt4_bindir}/qmake*
%{_qt4_bindir}/qt3to4
%{_qt4_bindir}/rcc*
@ -653,10 +713,12 @@ gtk-update-icon-cache -q %{_datadir}/icons/hicolor 2> /dev/null ||:
%{_qt4_bindir}/qhelpgenerator
%{_qt4_bindir}/xmlpatterns
%if "%{_qt4_bindir}" != "%{_bindir}"
%{_bindir}/lconvert
%{_bindir}/lrelease*
%{_bindir}/lupdate*
%{_bindir}/pixeltool*
%{_bindir}/moc*
%{_bindir}/qdoc3
%{_bindir}/qmake*
%{_bindir}/qt3to4
%{_bindir}/rcc*
@ -681,6 +743,10 @@ gtk-update-icon-cache -q %{_datadir}/icons/hicolor 2> /dev/null ||:
%{_qt4_prefix}/mkspecs/
%endif
%{_qt4_datadir}/q3porting.xml
%if 0%{?phonon:1}
%{_qt4_libdir}/libphonon.prl
#{_qt4_libdir}/libphonon.so
%endif
%{_qt4_libdir}/libQt*.so
# remaining static lib: libQtUiTools.a
%{_qt4_libdir}/libQt*.a
@ -732,9 +798,76 @@ gtk-update-icon-cache -q %{_datadir}/icons/hicolor 2> /dev/null ||:
%changelog
* Wed Mar 04 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.4.3-15
* Fri Mar 25 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.0-10
- qt-copy-patches-20090325
* Tue Mar 24 2009 Than Ngo <than@redhat.com> - 4.5.0-9
- lrelease only shows warning when duplicate messages found in *.ts( #491514)
* Fri Mar 20 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.0-8
- qt-copy-patches-20090319
* Thu Mar 19 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.0-7
- include more phonon bits, attempt to fix/provide phonon bindings
for qtscriptgenerator, PyQt, ...
* Tue Mar 17 2009 Than Ngo <than@redhat.com> - 4.5.0-6
- fix lupdate segfault (#486866)
* Sat Mar 14 2009 Dennis Gilmore <dennis@ausil.us> - 4.5.0-5
- add patch for sparc64.
- _Atomic_word is not always an int
* Tue Mar 10 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.0-4
- macros.qt4: %%_qt45
- cleanup more phonon-related left-overs
* Wed Mar 04 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.0-3
- -no-phonon-backend
- include qdoc3
- move designer plugins to runtime (#487622)
- qt-copy-patches-20090304
* Tue Mar 03 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.0-2
- License: LGPLv2 with exceptions or GPLv3 with exceptions
- BR: gstreamer-devel
- drop qgtkstyle patch (no longer needed)
- -x11: move libQtScriptTools here (linked with libQtGui)
* Tue Mar 03 2009 Than Ngo <than@redhat.com> - 4.5.0-1
- 4.5.0
* Fri Feb 27 2009 Rex Dieter <rdieter@fedoraproject.org> - 1:4.5.0-0.8.20090224
- 20090224 snapshot
- adjust pkgconfig hackery
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:4.5.0-0.7.rc1
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
* Sun Feb 22 2009 Rex Dieter <rdieter@fedoraproject.org> 4.5.0-0.5.rc1
- revert license, change won't land until official 4.5.0 release
- workaround broken qhostaddress.h (#485677)
- Provides: qgtkstyle = 0.1
* Fri Feb 20 2009 Rex Dieter <rdieter@fedoraproject.org> 4.5.0-0.4.rc1
- saner versioned Obsoletes
- -gtkstyle, Obsoletes: qgtkstyle < 0.1
- enable phonon support and associated hackery
* Mon Feb 16 2009 Than Ngo <than@redhat.com> 4.5.0-0.3.rc1
- fix callgrindChildExitCode is uninitialzed
* Sun Feb 15 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.0-0.2.rc1
- qt-copy-patches-20090215
- License: +LGPLv2
* Wed Feb 11 2009 Than Ngo <than@redhat.com> - 4.5.0-0.rc1.0
- 4.5.0 rc1
* Thu Feb 05 2009 Rex Dieter <rdieter@fedoraproject.org> 4.4.3-16
- track branches/qt-copy/4.4, and backout previous trunk(qt45) ones
* Mon Feb 02 2009 Than Ngo <than@redhat.com> 4.4.3-15
- disable 0269,0270,0271 patches, it causes issue in systray
* Thu Jan 29 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.4.3-14
- qt-copy-patches-20090129

View File

@ -1,4 +1,4 @@
d9f511e4b51983b4e10eb58b320416d5 hi128-app-qt4-logo.png
6dcc0672ff9e60a6b83f95c5f42bec5b hi48-app-qt4-logo.png
00e00c6324d342a7b0d8653112b4f08c qt-x11-opensource-src-4.4.3.tar.bz2
b91571d22a32437c865ee4848829bebc qt-copy-patches-20090304svn.tar.bz2
55e8c74a89e1bc128a5a6f1ff6b8b5ba qt-x11-opensource-src-4.5.0.tar.bz2
74cac34a16b483ddc0a90204a0af8314 qt-copy-patches-20090325svn.tar.bz2