- update to 3.3.7
- fix #209097, ml_IN font rendering - fix #209970, pa font rendering - fix #209098, or_IN font rendering - fix #209972, as_IN font rendering - fix #209975, bn_IN font rendering - fix #211259, te_IN font rendering - fix #211436, as_IN font rendering thanks Sachin Tawniya, LingNing Zhang for the fixes - move html files to devel
This commit is contained in:
parent
a6377b8cdb
commit
5afbcc346e
11
qt-3.3.6-fontrendering-bn_IN-209975.patch
Normal file
11
qt-3.3.6-fontrendering-bn_IN-209975.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- qt-x11-free-3.3.6/src/kernel/qscriptengine_x11.cpp.bak 2006-10-18 17:55:23.308589840 +0800
|
||||||
|
+++ qt-x11-free-3.3.6/src/kernel/qscriptengine_x11.cpp 2006-10-18 17:57:45.284006296 +0800
|
||||||
|
@@ -164,7 +164,7 @@
|
||||||
|
Matra, Matra, Matra, Matra,
|
||||||
|
Matra, Invalid, Invalid, Matra,
|
||||||
|
Matra, Invalid, Invalid, Matra,
|
||||||
|
- Matra, Halant, Unknown, Unknown,
|
||||||
|
+ Matra, Halant, Consonant, Unknown,
|
||||||
|
|
||||||
|
Invalid, Invalid, Invalid, Invalid,
|
||||||
|
Invalid, Invalid, Invalid, VowelMark,
|
60
qt-3.3.6-fontrendering-ml_IN-209097.patch
Normal file
60
qt-3.3.6-fontrendering-ml_IN-209097.patch
Normal file
@ -0,0 +1,60 @@
|
|||||||
|
--- qt-x11-free-3.3.6/src/kernel/qscriptengine_x11.cpp.bak 2006-10-13 13:21:37.000000000 +0800
|
||||||
|
+++ qt-x11-free-3.3.6/src/kernel/qscriptengine_x11.cpp 2006-10-13 13:57:36.000000000 +0800
|
||||||
|
@@ -868,7 +868,7 @@
|
||||||
|
None, None, None, None,
|
||||||
|
None, None, None, Post,
|
||||||
|
|
||||||
|
- Post, None, Below, None,
|
||||||
|
+ None, None, None, None,
|
||||||
|
None, Post, None, None,
|
||||||
|
None, None, None, None,
|
||||||
|
None, None, Post, Post,
|
||||||
|
@@ -1271,6 +1271,16 @@
|
||||||
|
int base = 0;
|
||||||
|
int reph = -1;
|
||||||
|
|
||||||
|
+ //for the special conjuctions about Cons+0d4d+0d30 and Cons+0d40+0d31 of Malayalam
|
||||||
|
+ bool is_special_conjuction_malayalam = false;
|
||||||
|
+
|
||||||
|
+ if ((len == 3) &&
|
||||||
|
+ ((reordered[2] == 0x0d30) || (reordered[2] == 0x0d31)) &&
|
||||||
|
+ (reordered[1] == 0x0d4d) &&
|
||||||
|
+ ((reordered[0] >= 0x0d15) && (reordered[0] <= 0x0d39))) {
|
||||||
|
+ is_special_conjuction_malayalam = true;
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
#ifdef INDIC_DEBUG
|
||||||
|
IDEBUG("original:");
|
||||||
|
for (i = 0; i < len; i++) {
|
||||||
|
@@ -1547,6 +1557,15 @@
|
||||||
|
reph = i;
|
||||||
|
}
|
||||||
|
|
||||||
|
+ //for the special conjuctions about Cons+0d4d+0d30 and Cons+0d40+0d31 of Malayalam
|
||||||
|
+ if (is_special_conjuction_malayalam) {
|
||||||
|
+ unsigned short temp;
|
||||||
|
+
|
||||||
|
+ temp = reordered[0];
|
||||||
|
+ reordered[0] = reordered[2];
|
||||||
|
+ reordered[2] = temp;
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
if (item->font->stringToCMap((const QChar *)reordered.data(), len, item->glyphs, item->advances,
|
||||||
|
&item->num_glyphs, item->flags & QTextEngine::RightToLeft) != QFontEngine::NoError)
|
||||||
|
return FALSE;
|
||||||
|
@@ -1658,6 +1677,15 @@
|
||||||
|
|
||||||
|
// halant always applies
|
||||||
|
|
||||||
|
+ //for the special conjuctions about Cons+0d4d+0d30 and Cons+0d40+0d31 of Malayalam
|
||||||
|
+ if (is_special_conjuction_malayalam) {
|
||||||
|
+ unsigned int temp;
|
||||||
|
+
|
||||||
|
+ temp = properties[0];
|
||||||
|
+ properties[0] = ~PreSubstProperty;
|
||||||
|
+ properties[2] = temp;
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
#ifdef INDIC_DEBUG
|
||||||
|
{
|
||||||
|
IDEBUG("OT properties:");
|
64
qt-3.3.6-fontrendering-or_IN-209098.patch
Normal file
64
qt-3.3.6-fontrendering-or_IN-209098.patch
Normal file
@ -0,0 +1,64 @@
|
|||||||
|
--- qt-x11-free-3.3.6/src/kernel/qscriptengine_x11.cpp.bak 2006-10-13 13:21:37.000000000 +0800
|
||||||
|
+++ qt-x11-free-3.3.6/src/kernel/qscriptengine_x11.cpp 2006-10-13 13:42:11.000000000 +0800
|
||||||
|
@@ -280,7 +280,7 @@
|
||||||
|
Consonant, Consonant, Consonant, Consonant,
|
||||||
|
|
||||||
|
Consonant, Invalid, Consonant, Consonant,
|
||||||
|
- Invalid, Invalid, Consonant, Consonant,
|
||||||
|
+ Invalid, Consonant, Consonant, Consonant,
|
||||||
|
Consonant, Consonant, Unknown, Unknown,
|
||||||
|
Nukta, Other, Matra, Matra,
|
||||||
|
|
||||||
|
@@ -299,7 +299,7 @@
|
||||||
|
Other, Other, Other, Other,
|
||||||
|
Other, Other, Other, Other,
|
||||||
|
|
||||||
|
- Other, Other, Other, Other,
|
||||||
|
+ Other, Consonant, Other, Other,
|
||||||
|
Other, Other, Other, Other,
|
||||||
|
Other, Other, Other, Other,
|
||||||
|
Other, Other, Other, Other,
|
||||||
|
@@ -695,18 +695,18 @@
|
||||||
|
None, None, None, None,
|
||||||
|
|
||||||
|
None, None, None, None,
|
||||||
|
- None, None, None, None,
|
||||||
|
- None, None, None, None,
|
||||||
|
- None, None, None, None,
|
||||||
|
+ None, Below, Below, Below,
|
||||||
|
+ Below, Below, Below, Below,
|
||||||
|
+ Below, Below, None, Below,
|
||||||
|
|
||||||
|
- None, None, None, None,
|
||||||
|
- Below, None, None, None,
|
||||||
|
- Below, None, None, None,
|
||||||
|
+ Below, Below, Below, Below,
|
||||||
|
+ Below, Below, Below, Below,
|
||||||
|
+ Below, None, Below, Below,
|
||||||
|
Below, Below, Below, Post,
|
||||||
|
|
||||||
|
Below, None, Below, Below,
|
||||||
|
- None, None, None, None,
|
||||||
|
- None, None, None, None,
|
||||||
|
+ None, Below, Below, Below,
|
||||||
|
+ Below, Below, None, None,
|
||||||
|
None, None, Post, Above,
|
||||||
|
|
||||||
|
Post, Below, Below, Below,
|
||||||
|
@@ -717,14 +717,14 @@
|
||||||
|
None, None, None, None,
|
||||||
|
None, None, Above, Post,
|
||||||
|
None, None, None, None,
|
||||||
|
- None, None, None, None,
|
||||||
|
+ None, None, None, Post,
|
||||||
|
|
||||||
|
None, None, None, None,
|
||||||
|
None, None, None, None,
|
||||||
|
None, None, None, None,
|
||||||
|
None, None, None, None,
|
||||||
|
|
||||||
|
- None, None, None, None,
|
||||||
|
+ None, Below, None, None,
|
||||||
|
None, None, None, None,
|
||||||
|
None, None, None, None,
|
||||||
|
None, None, None, None,
|
11
qt-3.3.6-fontrendering-punjabi-209970.patch
Normal file
11
qt-3.3.6-fontrendering-punjabi-209970.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- qt-x11-free-3.3.6/src/kernel/qscriptengine_x11.cpp.bak 2006-10-18 17:55:23.000000000 +0800
|
||||||
|
+++ qt-x11-free-3.3.6/src/kernel/qscriptengine_x11.cpp 2006-10-19 11:22:13.226804056 +0800
|
||||||
|
@@ -217,7 +217,7 @@
|
||||||
|
Other, Other, Other, Other,
|
||||||
|
Other, Other, Other, Other,
|
||||||
|
|
||||||
|
- StressMark, StressMark, Other, Other,
|
||||||
|
+ StressMark, StressMark, Consonant, Consonant,
|
||||||
|
Other, Other, Other, Other,
|
||||||
|
Other, Other, Other, Other,
|
||||||
|
Other, Other, Other, Other,
|
11
qt-3.3.6-fontrendering-te_IN-211259.patch
Normal file
11
qt-3.3.6-fontrendering-te_IN-211259.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- qt-x11-free-3.3.6/src/kernel/qscriptengine_x11.cpp.bak 2006-10-18 17:55:23.000000000 +0800
|
||||||
|
+++ qt-x11-free-3.3.6/src/kernel/qscriptengine_x11.cpp 2006-10-19 16:42:31.641160984 +0800
|
||||||
|
@@ -786,7 +786,7 @@
|
||||||
|
Below, None, Below, Below,
|
||||||
|
Below, Below, Below, Below,
|
||||||
|
|
||||||
|
- Below, None, Below, Below,
|
||||||
|
+ Below, Below, Below, Below,
|
||||||
|
None, Below, Below, Below,
|
||||||
|
Below, Below, None, None,
|
||||||
|
None, None, Post, Above,
|
36
qt.spec
36
qt.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: The shared library for the Qt GUI toolkit.
|
Summary: The shared library for the Qt GUI toolkit.
|
||||||
Name: qt
|
Name: qt
|
||||||
Version: 3.3.6
|
Version: 3.3.7
|
||||||
Release: 13
|
Release: 1%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
License: GPL/QPL
|
License: GPL/QPL
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
@ -27,7 +27,14 @@ Patch14: qt-x11-free-3.3.3-gl.patch
|
|||||||
Patch19: qt-3.3.3-gtkstyle.patch
|
Patch19: qt-3.3.3-gtkstyle.patch
|
||||||
Patch20: qt-x11-free-3.3.5-gcc4-buildkey.patch
|
Patch20: qt-x11-free-3.3.5-gcc4-buildkey.patch
|
||||||
Patch24: qt-x11-free-3.3.5-uic.patch
|
Patch24: qt-x11-free-3.3.5-uic.patch
|
||||||
Patch25: qt-x11-free-3.3.6-uic-multilib.patch
|
Patch25: qt-x11-free-3.3.7-uic-multilib.patch
|
||||||
|
Patch26: qt-3.3.6-fontrendering-punjabi-209970.patch
|
||||||
|
Patch27: qt-3.3.6-fontrendering-ml_IN-209097.patch
|
||||||
|
Patch28: qt-3.3.6-fontrendering-or_IN-209098.patch
|
||||||
|
Patch29: qt-3.3.6-fontrendering-as_IN-209972.patch
|
||||||
|
Patch30: qt-3.3.6-fontrendering-bn_IN-209975.patch
|
||||||
|
Patch31: qt-3.3.6-fontrendering-te_IN-211259.patch
|
||||||
|
Patch32: qt-3.3.6-fontrendering-as_IN-211436.patch
|
||||||
|
|
||||||
# immodule patches
|
# immodule patches
|
||||||
Patch50: qt-x11-free-3.3.6-qt-x11-immodule-unified-qt3.3.5-20060318-pre.patch
|
Patch50: qt-x11-free-3.3.6-qt-x11-immodule-unified-qt3.3.5-20060318-pre.patch
|
||||||
@ -143,7 +150,7 @@ Requires: mesa-libGLU-devel
|
|||||||
%package devel-docs
|
%package devel-docs
|
||||||
Summary: Documentation for the Qt GUI toolkit.
|
Summary: Documentation for the Qt GUI toolkit.
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
Requires: %{name} = %{epoch}:%{version}-%{release}
|
Requires: %{name}-devel = %{epoch}:%{version}-%{release}
|
||||||
|
|
||||||
|
|
||||||
%package ODBC
|
%package ODBC
|
||||||
@ -237,6 +244,13 @@ for the Qt toolkit.
|
|||||||
%patch20 -p1 -b .gcc4-buildkey
|
%patch20 -p1 -b .gcc4-buildkey
|
||||||
%patch24 -p1 -b .uic
|
%patch24 -p1 -b .uic
|
||||||
%patch25 -p1 -b .uic-multilib
|
%patch25 -p1 -b .uic-multilib
|
||||||
|
%patch26 -p1 -b .fontrendering-punjabi-bz#209970
|
||||||
|
%patch27 -p1 -b .fontrendering-ml_IN-bz#209097
|
||||||
|
%patch28 -p1 -b .fontrendering-or_IN-bz#209098
|
||||||
|
%patch29 -p1 -b .fontrendering-as_IN-bz#209972
|
||||||
|
%patch30 -p1 -b .fontrendering-bn_IN-bz#209975
|
||||||
|
%patch31 -p1 -b .fontrendering-te_IN-bz#211259
|
||||||
|
%patch32 -p1 -b .fontrendering-as_IN-bz211436
|
||||||
|
|
||||||
%if %{immodule}
|
%if %{immodule}
|
||||||
%patch50 -p1 -b .pre
|
%patch50 -p1 -b .pre
|
||||||
@ -484,10 +498,10 @@ rm -rf %{buildroot}
|
|||||||
%{_datadir}/applications/*assistant*.desktop
|
%{_datadir}/applications/*assistant*.desktop
|
||||||
%{_datadir}/pixmaps/linguist3.png
|
%{_datadir}/pixmaps/linguist3.png
|
||||||
%{_datadir}/pixmaps/assistant3.png
|
%{_datadir}/pixmaps/assistant3.png
|
||||||
|
%doc %{qt_docdir}/html
|
||||||
|
|
||||||
%files devel-docs
|
%files devel-docs
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%doc %{qt_docdir}/html
|
|
||||||
%doc examples
|
%doc examples
|
||||||
%doc tutorial
|
%doc tutorial
|
||||||
%{_mandir}/*/*
|
%{_mandir}/*/*
|
||||||
@ -515,6 +529,18 @@ rm -rf %{buildroot}
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Nov 09 2006 Than Ngo <than@redhat.com> 1:3.3.7-1.fc6
|
||||||
|
- update to 3.3.7
|
||||||
|
- fix #209097, ml_IN font rendering
|
||||||
|
- fix #209970, pa font rendering
|
||||||
|
- fix #209098, or_IN font rendering
|
||||||
|
- fix #209972, as_IN font rendering
|
||||||
|
- fix #209975, bn_IN font rendering
|
||||||
|
- fix #211259, te_IN font rendering
|
||||||
|
- fix #211436, as_IN font rendering
|
||||||
|
thanks Sachin Tawniya, LingNing Zhang for the fixes
|
||||||
|
- move html files to devel
|
||||||
|
|
||||||
* Thu Aug 31 2006 Than Ngo <than@redhat.com> 1:3.3.6-13
|
* Thu Aug 31 2006 Than Ngo <than@redhat.com> 1:3.3.6-13
|
||||||
- add missing desktop files
|
- add missing desktop files
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
|||||||
dc1384c03ac08af21f6fefab32d982cf qt-x11-free-3.3.6.tar.bz2
|
|
||||||
0c07b36cd8da9f796437dd398365c204 qt-x11-immodule-unified-qt3.3.5-20060318.diff.bz2
|
0c07b36cd8da9f796437dd398365c204 qt-x11-immodule-unified-qt3.3.5-20060318.diff.bz2
|
||||||
|
655e21cf6a7e66daf8ec6ceda81aae1e qt-x11-free-3.3.7.tar.bz2
|
||||||
|
Loading…
x
Reference in New Issue
Block a user