sync from F-10/ branch
This commit is contained in:
parent
4b9cb2ee1e
commit
56c49c3c39
14
qt-x11-opensource-src-4.5.0-gcc_hack.patch
Normal file
14
qt-x11-opensource-src-4.5.0-gcc_hack.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
diff -up qt-x11-opensource-src-4.5.0/src/corelib/tools/qstring.cpp.gcc_hack qt-x11-opensource-src-4.5.0/src/corelib/tools/qstring.cpp
|
||||||
|
--- qt-x11-opensource-src-4.5.0/src/corelib/tools/qstring.cpp.gcc_hack 2009-02-25 15:09:22.000000000 -0600
|
||||||
|
+++ qt-x11-opensource-src-4.5.0/src/corelib/tools/qstring.cpp 2009-03-27 11:56:51.000000000 -0500
|
||||||
|
@@ -102,8 +102,8 @@ static QHash<void *, QByteArray> *asciiC
|
||||||
|
// internal
|
||||||
|
int qFindString(const QChar *haystack, int haystackLen, int from,
|
||||||
|
const QChar *needle, int needleLen, Qt::CaseSensitivity cs);
|
||||||
|
-int qFindStringBoyerMoore(const QChar *haystack, int haystackLen, int from,
|
||||||
|
- const QChar *needle, int needleLen, Qt::CaseSensitivity cs);
|
||||||
|
+//int qFindStringBoyerMoore(const QChar *haystack, int haystackLen, int from,
|
||||||
|
+// const QChar *needle, int needleLen, Qt::CaseSensitivity cs);
|
||||||
|
|
||||||
|
|
||||||
|
// Unicode case-insensitive comparison
|
3
qt.spec
3
qt.spec
@ -40,6 +40,8 @@ Patch5: qt-all-opensource-src-4.4.0-rc1-as_IN-437440.patch
|
|||||||
Patch10: qt-x11-opensource-src-4.5.0-rc1-ppc64.patch
|
Patch10: qt-x11-opensource-src-4.5.0-rc1-ppc64.patch
|
||||||
Patch11: qt-x11-opensource-src-4.5.0-linguist-crash.patch
|
Patch11: qt-x11-opensource-src-4.5.0-linguist-crash.patch
|
||||||
Patch12: qt-x11-opensource-src-4.5.0-lrelease.patch
|
Patch12: qt-x11-opensource-src-4.5.0-lrelease.patch
|
||||||
|
# hack around gcc/ppc crasher, http://bugzilla.redhat.com/492185
|
||||||
|
Patch13: qt-x11-opensource-src-4.5.0-gcc_hack.patch
|
||||||
|
|
||||||
## upstreamable bits
|
## upstreamable bits
|
||||||
# http://bugzilla.redhat.com/485677
|
# http://bugzilla.redhat.com/485677
|
||||||
@ -315,6 +317,7 @@ test -x apply_patches && ./apply_patches
|
|||||||
%patch10 -p1 -b .ppc64
|
%patch10 -p1 -b .ppc64
|
||||||
%patch11 -p1 -b .linguist-crash
|
%patch11 -p1 -b .linguist-crash
|
||||||
%patch12 -p1 -b .lrelease
|
%patch12 -p1 -b .lrelease
|
||||||
|
%patch13 -p1 -b .gcc_hack
|
||||||
%patch50 -p1 -b .qhostaddress
|
%patch50 -p1 -b .qhostaddress
|
||||||
%patch51 -p1 -b .qdoc3
|
%patch51 -p1 -b .qdoc3
|
||||||
%patch52 -p1 -b .sparc64
|
%patch52 -p1 -b .sparc64
|
||||||
|
Loading…
Reference in New Issue
Block a user