- backport patch to fix ix a crash when reparenting an item in

QGraphicsView, QTBUG-6932
- drop dangling reference(s) to %%buildroot in *.pc
This commit is contained in:
Than Ngo 2010-03-22 10:46:22 +00:00
parent 6aec805cce
commit 520181c4ff
2 changed files with 34 additions and 1 deletions

View File

@ -0,0 +1,22 @@
diff -up qt-everywhere-opensource-src-4.6.2/src/gui/graphicsview/qgraphicsitem.cpp.orig qt-everywhere-opensource-src-4.6.2/src/gui/graphicsview/qgraphicsitem.cpp
--- qt-everywhere-opensource-src-4.6.2/src/gui/graphicsview/qgraphicsitem.cpp.orig 2010-02-11 16:55:22.000000000 +0100
+++ qt-everywhere-opensource-src-4.6.2/src/gui/graphicsview/qgraphicsitem.cpp 2010-03-22 11:26:50.291692144 +0100
@@ -1125,6 +1125,9 @@ void QGraphicsItemPrivate::setParentItem
}
}
+ // Resolve depth.
+ invalidateDepthRecursively();
+
if ((parent = newParent)) {
if (parent->d_func()->scene && parent->d_func()->scene != scene) {
// Move this item to its new parent's scene
@@ -1175,8 +1178,6 @@ void QGraphicsItemPrivate::setParentItem
}
}
- // Resolve depth.
- invalidateDepthRecursively();
dirtySceneTransform = 1;
// Restore the sub focus chain.

13
qt.spec
View File

@ -13,7 +13,7 @@ Summary: Qt toolkit
Name: qt
Epoch: 1
Version: 4.6.2
Release: 8%{?dist}
Release: 9%{?dist}
# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
License: LGPLv2 with exceptions or GPLv3 with exceptions
@ -79,6 +79,9 @@ Patch208: 0008-This-patch-makes-the-raster-graphics-system-use-shar.patch
Patch209: 0009-Restore-a-section-of-the-file-that-got-removed-due-t.patch
Patch212: 0012-Add-context-to-tr-calls-in-QShortcut.patch
Patch213: qt-x11-opensource-src-4.6.2-tablet-wacom-QTBUG-8599.patch
# backport from 4.7 to fix a crash when reparenting an item in QGraphicsView
# it should be included in 4.6.3
Patch214: qt-everywhere-opensource-src-4.6.2-QTBUG-6932.patch
Source10: http://gstreamer.freedesktop.org/data/images/artwork/gstreamer-logo.svg
Source11: hi16-phonon-gstreamer.png
@ -433,6 +436,7 @@ Qt libraries used for drawing widgets and OpenGL items.
%patch207 -p1 -b .kde-qt-0007
%patch212 -p1 -b .kde-qt-0012
%patch213 -p1 -b .tablet-wacom-QTBUG-8599
%patch214 -p1 -b .QTBUG-6932
# drop -fexceptions from $RPM_OPT_FLAGS
RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS | sed 's|-fexceptions||g'`
@ -586,6 +590,8 @@ done
# nuke dangling reference(s) to %buildroot
sed -i -e "/^QMAKE_PRL_BUILD_DIR/d" %{buildroot}%{_qt4_libdir}/*.prl
sed -i -e "s|-L%{_builddir}/qt-everywhere-opensource-src-%{version}/lib||g" \
%{buildroot}%{_qt4_libdir}/pkgconfig/*.pc
# nuke QMAKE_PRL_LIBS, seems similar to static linking and .la files (#520323)
sed -i -e "s|^QMAKE_PRL_LIBS|#QMAKE_PRL_LIBS|" %{buildroot}%{_qt4_libdir}/*.prl
@ -1027,6 +1033,11 @@ fi
%changelog
* Mon Mar 22 2010 Than Ngo <than@redhat.com> - 4.6.2-9
- backport patch to fix ix a crash when reparenting an item
in QGraphicsView, QTBUG-6932
- drop dangling reference(s) to %%buildroot in *.pc
* Wed Mar 17 2010 Jaroslav Reznik <jreznik@redhat.com> - 4.6.2-8
- WebKit security update:
CVE-2010-0046, CVE-2010-0049, CVE-2010-0050, CVE-2010-0051,