drop patches, both are included in 4.8.2
This commit is contained in:
parent
e9629e4208
commit
4d4b19d3f8
@ -1,27 +0,0 @@
|
||||
diff -up qt-everywhere-opensource-src-4.8.0/src/3rdparty/javascriptcore/JavaScriptCore/runtime/JSGlobalObject.h.me qt-everywhere-opensource-src-4.8.0/src/3rdparty/javascriptcore/JavaScriptCore/runtime/JSGlobalObject.h
|
||||
--- qt-everywhere-opensource-src-4.8.0/src/3rdparty/javascriptcore/JavaScriptCore/runtime/JSGlobalObject.h.me 2012-01-24 11:24:14.729942043 +0100
|
||||
+++ qt-everywhere-opensource-src-4.8.0/src/3rdparty/javascriptcore/JavaScriptCore/runtime/JSGlobalObject.h 2012-01-24 14:28:39.848109534 +0100
|
||||
@@ -57,9 +57,7 @@ namespace JSC {
|
||||
|
||||
class JSGlobalObject : public JSVariableObject {
|
||||
protected:
|
||||
- using JSVariableObject::JSVariableObjectData;
|
||||
-
|
||||
- struct JSGlobalObjectData : public JSVariableObjectData {
|
||||
+ struct JSGlobalObjectData : public JSVariableObject::JSVariableObjectData {
|
||||
// We use an explicit destructor function pointer instead of a
|
||||
// virtual destructor because we want to avoid adding a vtable
|
||||
// pointer to this struct. Adding a vtable pointer would force the
|
||||
diff -up qt-everywhere-opensource-src-4.8.0/src/3rdparty/javascriptcore/JavaScriptCore/runtime/JSStaticScopeObject.h.me qt-everywhere-opensource-src-4.8.0/src/3rdparty/javascriptcore/JavaScriptCore/runtime/JSStaticScopeObject.h
|
||||
--- qt-everywhere-opensource-src-4.8.0/src/3rdparty/javascriptcore/JavaScriptCore/runtime/JSStaticScopeObject.h.me 2012-01-24 11:40:07.167856677 +0100
|
||||
+++ qt-everywhere-opensource-src-4.8.0/src/3rdparty/javascriptcore/JavaScriptCore/runtime/JSStaticScopeObject.h 2012-01-24 14:28:34.640306629 +0100
|
||||
@@ -32,8 +32,7 @@ namespace JSC{
|
||||
|
||||
class JSStaticScopeObject : public JSVariableObject {
|
||||
protected:
|
||||
- using JSVariableObject::JSVariableObjectData;
|
||||
- struct JSStaticScopeObjectData : public JSVariableObjectData {
|
||||
+ struct JSStaticScopeObjectData : public JSVariableObject::JSVariableObjectData {
|
||||
JSStaticScopeObjectData()
|
||||
: JSVariableObjectData(&symbolTable, ®isterStore + 1)
|
||||
{
|
@ -1,12 +0,0 @@
|
||||
diff -up qt-everywhere-opensource-src-4.8.0/tools/qvfb/qvfb.pro.qvfb qt-everywhere-opensource-src-4.8.0/tools/qvfb/qvfb.pro
|
||||
--- qt-everywhere-opensource-src-4.8.0/tools/qvfb/qvfb.pro.qvfb 2011-12-27 21:02:19.765512041 -0600
|
||||
+++ qt-everywhere-opensource-src-4.8.0/tools/qvfb/qvfb.pro 2011-12-27 21:02:39.271268187 -0600
|
||||
@@ -38,8 +38,6 @@ SOURCES = qvfb.cpp \
|
||||
|
||||
!embedded {
|
||||
DEFINES += QT_NO_QWS_SIGNALHANDLER
|
||||
- HEADERS += ../../src/gui/embedded/qlock_p.h
|
||||
- SOURCES += ../../src/gui/embedded/qlock.cpp
|
||||
}
|
||||
|
||||
include(../shared/deviceskin/deviceskin.pri)
|
8
qt.spec
8
qt.spec
@ -108,15 +108,9 @@ Patch76: qt-everywhere-opensource-src-4.8.0-s390-atomic.patch
|
||||
# don't spam in release/no_debug mode if libicu is not present at runtime
|
||||
Patch77: qt-everywhere-opensource-src-4.8.1-icu_no_debug.patch
|
||||
|
||||
# fix qvfb build
|
||||
Patch79: qt-everywhere-opensource-src-4.8.0-qvfb.patch
|
||||
|
||||
# gcc doesn't support flag -fuse-ld=gold
|
||||
Patch80: qt-everywhere-opensource-src-4.8.0-ld-gold.patch
|
||||
|
||||
# gcc-4.7 build issue
|
||||
Patch81: qt-everywhere-opensource-src-4.8.0-gcc-4.7.patch
|
||||
|
||||
# upstream patches
|
||||
# http://codereview.qt-project.org/#change,22006
|
||||
Patch100: qt-everywhere-opensource-src-4.8.1-qtgahandle.patch
|
||||
@ -459,9 +453,7 @@ rm -fv mkspecs/linux-g++*/qmake.conf.multilib-optflags
|
||||
%patch74 -p1 -b .tds_no_strict_aliasing
|
||||
%patch76 -p1 -b .s390-atomic
|
||||
%patch77 -p1 -b .icu_no_debug
|
||||
%patch79 -p1 -b .qvfb
|
||||
%patch80 -p1 -b .ld.gold
|
||||
%patch81 -p1 -b .gcc-4.7
|
||||
|
||||
# upstream patches
|
||||
%patch100 -p1 -b .QTgaHandler
|
||||
|
Loading…
Reference in New Issue
Block a user