initialize callgrindChildExitCode
This commit is contained in:
parent
fcd6753d10
commit
47eb6e4a3b
@ -1,11 +1,21 @@
|
||||
diff -up qt-x11-opensource-src-4.5.0-rc1/src/testlib/qtestcase.cpp.orig qt-x11-opensource-src-4.5.0-rc1/src/testlib/qtestcase.cpp
|
||||
--- qt-x11-opensource-src-4.5.0-rc1/src/testlib/qtestcase.cpp.orig 2009-02-11 13:14:12.000000000 +0100
|
||||
+++ qt-x11-opensource-src-4.5.0-rc1/src/testlib/qtestcase.cpp 2009-02-11 13:20:37.000000000 +0100
|
||||
@@ -1486,6 +1486,7 @@ int QTest::qExec(QObject *testObject, in
|
||||
#else
|
||||
diff -up qt-x11-opensource-src-4.5.0-rc1/src/testlib/qtestcase.cpp.misc qt-x11-opensource-src-4.5.0-rc1/src/testlib/qtestcase.cpp
|
||||
--- qt-x11-opensource-src-4.5.0-rc1/src/testlib/qtestcase.cpp.misc 2009-02-04 17:05:30.000000000 +0100
|
||||
+++ qt-x11-opensource-src-4.5.0-rc1/src/testlib/qtestcase.cpp 2009-02-16 11:04:50.000000000 +0100
|
||||
@@ -1359,6 +1359,9 @@ int QTest::qExec(QObject *testObject, in
|
||||
QBenchmarkGlobalData benchmarkData;
|
||||
QBenchmarkGlobalData::current = &benchmarkData;
|
||||
|
||||
+#ifdef QTESTLIB_USE_VALGRIND
|
||||
+ int callgrindChildExitCode = 0;
|
||||
+#endif
|
||||
|
||||
#ifdef Q_WS_MAC
|
||||
bool macNeedsActivate = qApp && qstrcmp(qApp->metaObject()->className(), "QApplicaion");
|
||||
@@ -1411,7 +1414,6 @@ int QTest::qExec(QObject *testObject, in
|
||||
QTestResult::setCurrentTestObject(metaObject->className());
|
||||
qParseArgs(argc, argv);
|
||||
#ifdef QTESTLIB_USE_VALGRIND
|
||||
+ int callgrindChildExitCode;
|
||||
if (QBenchmarkGlobalData::current->mode() == QBenchmarkGlobalData::CallgrindParentProcess)
|
||||
return callgrindChildExitCode;
|
||||
#endif
|
||||
- int callgrindChildExitCode;
|
||||
if (QBenchmarkGlobalData::current->mode() == QBenchmarkGlobalData::CallgrindParentProcess) {
|
||||
const QStringList origAppArgs(QCoreApplication::arguments());
|
||||
if (!QBenchmarkValgrindUtils::rerunThroughCallgrind(origAppArgs, callgrindChildExitCode))
|
||||
|
5
qt.spec
5
qt.spec
@ -9,7 +9,7 @@ Epoch: 1
|
||||
Name: qt4
|
||||
%endif
|
||||
Version: 4.5.0
|
||||
Release: 0.2.rc1%{?dist}
|
||||
Release: 0.3.rc1%{?dist}
|
||||
|
||||
# GPLv2 exceptions(see GPL_EXCEPTIONS*.txt)
|
||||
License: LGPLv2 or GPLv3 with exceptions
|
||||
@ -737,6 +737,9 @@ gtk-update-icon-cache -q %{_datadir}/icons/hicolor 2> /dev/null ||:
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Feb 16 2009 Than Ngo <than@redhat.com> 4.5.0-0.3.rc1
|
||||
- fix callgrindChildExitCode is uninitialzed
|
||||
|
||||
* Sun Feb 15 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.0-0.2.rc1
|
||||
- qt-copy-patches-20090215
|
||||
- License: +LGPLv2
|
||||
|
Loading…
x
Reference in New Issue
Block a user