4.5.0
This commit is contained in:
parent
21aafed52a
commit
4583d39684
@ -2,3 +2,5 @@ hi128-app-qt4-logo.png
|
||||
hi48-app-qt4-logo.png
|
||||
qt-copy-patches-20090220svn.tar.bz2
|
||||
qt-x11-opensource-src-4.5.0-snapshot-20090224.tar.gz
|
||||
qt-x11-opensource-src-4.5.0.tar.bz2
|
||||
qt-copy-patches-20090303svn.tar.bz2
|
||||
|
@ -1,21 +0,0 @@
|
||||
diff -up qt-x11-opensource-src-4.5.0-rc1/src/testlib/qtestcase.cpp.misc qt-x11-opensource-src-4.5.0-rc1/src/testlib/qtestcase.cpp
|
||||
--- qt-x11-opensource-src-4.5.0-rc1/src/testlib/qtestcase.cpp.misc 2009-02-04 17:05:30.000000000 +0100
|
||||
+++ qt-x11-opensource-src-4.5.0-rc1/src/testlib/qtestcase.cpp 2009-02-16 11:04:50.000000000 +0100
|
||||
@@ -1359,6 +1359,9 @@ int QTest::qExec(QObject *testObject, in
|
||||
QBenchmarkGlobalData benchmarkData;
|
||||
QBenchmarkGlobalData::current = &benchmarkData;
|
||||
|
||||
+#ifdef QTESTLIB_USE_VALGRIND
|
||||
+ int callgrindChildExitCode = 0;
|
||||
+#endif
|
||||
|
||||
#ifdef Q_WS_MAC
|
||||
bool macNeedsActivate = qApp && qstrcmp(qApp->metaObject()->className(), "QApplicaion");
|
||||
@@ -1411,7 +1414,6 @@ int QTest::qExec(QObject *testObject, in
|
||||
QTestResult::setCurrentTestObject(metaObject->className());
|
||||
qParseArgs(argc, argv);
|
||||
#ifdef QTESTLIB_USE_VALGRIND
|
||||
- int callgrindChildExitCode;
|
||||
if (QBenchmarkGlobalData::current->mode() == QBenchmarkGlobalData::CallgrindParentProcess) {
|
||||
const QStringList origAppArgs(QCoreApplication::arguments());
|
||||
if (!QBenchmarkValgrindUtils::rerunThroughCallgrind(origAppArgs, callgrindChildExitCode))
|
@ -1,12 +0,0 @@
|
||||
diff -up qt-x11-opensource-src-4.5.0-rc1/src/corelib/arch/qatomic_powerpc.h.orig qt-x11-opensource-src-4.5.0-rc1/src/corelib/arch/qatomic_powerpc.h
|
||||
--- qt-x11-opensource-src-4.5.0-rc1/src/corelib/arch/qatomic_powerpc.h.orig 2009-02-14 22:51:51.000000000 +0100
|
||||
+++ qt-x11-opensource-src-4.5.0-rc1/src/corelib/arch/qatomic_powerpc.h 2009-02-14 22:53:03.000000000 +0100
|
||||
@@ -188,7 +188,7 @@ inline bool QBasicAtomicInt::testAndSetR
|
||||
"lwarx %[result]," _Q_VALUE "\n"
|
||||
"xor. %[result], %[result], %[expectedValue]\n"
|
||||
"bne $+12\n"
|
||||
- "stwcx. %[newValue],0,%[_q_value]\n"
|
||||
+ "stwcx. %[newValue]," _Q_VALUE "\n"
|
||||
"bne- $-16\n"
|
||||
: [result] "=&r" (result),
|
||||
_Q_VALUE_MEMORY_OPERAND
|
11
qt.spec
11
qt.spec
@ -14,11 +14,7 @@ Name: qt4
|
||||
Version: 4.5.0
|
||||
Release: 1%{?dist}
|
||||
|
||||
## for 4.5.0 final:
|
||||
##License: LGPLv2 or GPLv3 with exceptions
|
||||
## but, until then,
|
||||
# see GPL_EXCEPTIONS*.txt
|
||||
License: GPLv3 with exceptions or GPLv2 with exceptions
|
||||
License: LGPLv2 or GPLv3 with exceptions
|
||||
Group: System Environment/Libraries
|
||||
Url: http://www.qtsoftware.com/
|
||||
Source0: ftp://ftp.trolltech.com/qt/source/qt-x11-opensource-src-%{version}.tar.bz2
|
||||
@ -298,7 +294,6 @@ Qt libraries which are used for drawing widgets and OpenGL items.
|
||||
|
||||
%if 0%{?qt_copy}
|
||||
echo "0250" >> patches/DISABLED
|
||||
echo "0272" >> patches/DISABLED
|
||||
test -x apply_patches && ./apply_patches
|
||||
%endif
|
||||
|
||||
@ -611,9 +606,7 @@ gtk-update-icon-cache -q %{_datadir}/icons/hicolor 2> /dev/null ||:
|
||||
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%doc README*
|
||||
%doc LICENSE.GPL2 GPL_EXCEPTION*.TXT
|
||||
%doc LICENSE.GPL3
|
||||
%doc README* LGPL_EXCEPTION.txt LICENSE.LGPL LICENSE.GPL3
|
||||
#config /etc/profile.d/qt4.*
|
||||
%if "%{_qt4_libdir}" != "%{_libdir}"
|
||||
/etc/ld.so.conf.d/*
|
||||
|
4
sources
4
sources
@ -1,4 +1,4 @@
|
||||
d9f511e4b51983b4e10eb58b320416d5 hi128-app-qt4-logo.png
|
||||
6dcc0672ff9e60a6b83f95c5f42bec5b hi48-app-qt4-logo.png
|
||||
d371c9807e43528ef188be59549e58e1 qt-copy-patches-20090220svn.tar.bz2
|
||||
eac497de448bf38c969119ad979ad699 qt-x11-opensource-src-4.5.0-snapshot-20090224.tar.gz
|
||||
55e8c74a89e1bc128a5a6f1ff6b8b5ba qt-x11-opensource-src-4.5.0.tar.bz2
|
||||
fcc348cd5997c978e882849bad65b1c0 qt-copy-patches-20090303svn.tar.bz2
|
||||
|
Loading…
Reference in New Issue
Block a user