add missing method for QBasicAtomicPointer on s390(x)
This commit is contained in:
parent
9f74aac72e
commit
41cb7e3491
20
qt-everywhere-opensource-src-4.8.0-s390-atomic.patch
Normal file
20
qt-everywhere-opensource-src-4.8.0-s390-atomic.patch
Normal file
@ -0,0 +1,20 @@
|
|||||||
|
diff -up qt-everywhere-opensource-src-4.8.0/src/corelib/arch/qatomic_s390.h.s390-atomic qt-everywhere-opensource-src-4.8.0/src/corelib/arch/qatomic_s390.h
|
||||||
|
--- qt-everywhere-opensource-src-4.8.0/src/corelib/arch/qatomic_s390.h.s390-atomic 2011-12-18 16:15:20.000000000 +0100
|
||||||
|
+++ qt-everywhere-opensource-src-4.8.0/src/corelib/arch/qatomic_s390.h 2011-12-18 16:17:34.000000000 +0100
|
||||||
|
@@ -400,6 +400,16 @@ Q_INLINE_TEMPLATE T* QBasicAtomicPointer
|
||||||
|
|
||||||
|
|
||||||
|
template <typename T>
|
||||||
|
+Q_INLINE_TEMPLATE T *QBasicAtomicPointer<T>::fetchAndAddOrdered(qptrdiff valueToAdd)
|
||||||
|
+{
|
||||||
|
+#ifndef __s390x__
|
||||||
|
+ return (T *)__CS_OLD_LOOP(&_q_value, valueToAdd * sizeof(T), "ar", "", "bcr 15,0\n");
|
||||||
|
+#else
|
||||||
|
+ return (T *)__CSG_OLD_LOOP(&_q_value, valueToAdd * sizeof(T), "agr", "", "bcr 15,0\n");
|
||||||
|
+#endif
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
+template <typename T>
|
||||||
|
Q_INLINE_TEMPLATE T *QBasicAtomicPointer<T>::fetchAndAddRelaxed(qptrdiff valueToAdd)
|
||||||
|
{
|
||||||
|
return fetchAndAddOrdered(valueToAdd);
|
9
qt.spec
9
qt.spec
@ -11,7 +11,7 @@ Summary: Qt toolkit
|
|||||||
Name: qt
|
Name: qt
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 4.8.0
|
Version: 4.8.0
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
|
|
||||||
# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
|
# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
|
||||||
License: (LGPLv2 with exceptions or GPLv3 with exceptions) and ASL 2.0 and BSD and FTL and MIT
|
License: (LGPLv2 with exceptions or GPLv3 with exceptions) and ASL 2.0 and BSD and FTL and MIT
|
||||||
@ -94,6 +94,9 @@ Patch74: qt-everywhere-opensource-src-4.7.4-tds_no_strict_aliasing.patch
|
|||||||
# workaround crash on ppc64
|
# workaround crash on ppc64
|
||||||
Patch75: qt-ppc64-crash.patch
|
Patch75: qt-ppc64-crash.patch
|
||||||
|
|
||||||
|
# add missing method for QBasicAtomicPointer on s390(x)
|
||||||
|
Patch76: qt-everywhere-opensource-src-4.8.0-s390-atomic.patch
|
||||||
|
|
||||||
# upstream patches
|
# upstream patches
|
||||||
|
|
||||||
# security patches
|
# security patches
|
||||||
@ -420,6 +423,7 @@ popd
|
|||||||
%endif
|
%endif
|
||||||
%patch74 -p1 -b .tds_no_strict_aliasing
|
%patch74 -p1 -b .tds_no_strict_aliasing
|
||||||
%patch75 -p1 -b .ppc64-crash
|
%patch75 -p1 -b .ppc64-crash
|
||||||
|
%patch76 -p1 -b .s390-atomic
|
||||||
|
|
||||||
# upstream patches
|
# upstream patches
|
||||||
|
|
||||||
@ -1046,6 +1050,9 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Dec 19 2011 Dan Horák <dan[at]dannu.cz> 4.8.0-2
|
||||||
|
- add missing method for QBasicAtomicPointer on s390(x)
|
||||||
|
|
||||||
* Thu Dec 15 2011 Jaroslav Reznik <jreznik@redhat.com> 4.8.0-1
|
* Thu Dec 15 2011 Jaroslav Reznik <jreznik@redhat.com> 4.8.0-1
|
||||||
- 4.8.0
|
- 4.8.0
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user