- update qt-x11-immodule-unified-qt3.3.5-20051012
- disable some debug messages - apply patch to fix build problem with the new immodule patch
This commit is contained in:
parent
dde17c20c9
commit
4136158d46
@ -3,3 +3,4 @@ qt-x11-immodule-unified-qt3.3.3-20040910.diff.bz2
|
|||||||
qt-x11-immodule-unified-qt3.3.4-20041203.diff.bz2
|
qt-x11-immodule-unified-qt3.3.4-20041203.diff.bz2
|
||||||
qt-x11-free-3.3.4.tar.bz2
|
qt-x11-free-3.3.4.tar.bz2
|
||||||
qt-x11-free-3.3.5.tar.bz2
|
qt-x11-free-3.3.5.tar.bz2
|
||||||
|
qt-x11-immodule-unified-qt3.3.5-20051012.diff.bz2
|
||||||
|
126
qt-x11-immodule-unified-qt3.3.5-20051012-quiet.patch
Normal file
126
qt-x11-immodule-unified-qt3.3.5-20051012-quiet.patch
Normal file
@ -0,0 +1,126 @@
|
|||||||
|
diff -Nur qt-x11-free-3.3.5.orig/plugins/src/inputmethods/imsw-multi/qmultiinputcontext.cpp qt-x11-free-3.3.5/plugins/src/inputmethods/imsw-multi/qmultiinputcontext.cpp
|
||||||
|
--- qt-x11-free-3.3.5.orig/plugins/src/inputmethods/imsw-multi/qmultiinputcontext.cpp 2005-10-13 16:09:36.000000000 +0200
|
||||||
|
+++ qt-x11-free-3.3.5/plugins/src/inputmethods/imsw-multi/qmultiinputcontext.cpp 2005-10-13 16:09:31.000000000 +0200
|
||||||
|
@@ -306,8 +306,8 @@
|
||||||
|
|
||||||
|
currentIMKey = key;
|
||||||
|
|
||||||
|
- qDebug( "QMultiInputContext::changeInputMethod(): index=%d, slave=%s",
|
||||||
|
- imIndex, (const char *)_slave->identifierName() );
|
||||||
|
+ /* qDebug( "QMultiInputContext::changeInputMethod(): index=%d, slave=%s",
|
||||||
|
+ imIndex, (const char *)_slave->identifierName() ); */
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
||||||
|
diff -Nur qt-x11-free-3.3.5.orig/plugins/src/inputmethods/simple/qsimpleinputcontext.cpp qt-x11-free-3.3.5/plugins/src/inputmethods/simple/qsimpleinputcontext.cpp
|
||||||
|
--- qt-x11-free-3.3.5.orig/plugins/src/inputmethods/simple/qsimpleinputcontext.cpp 2005-10-13 16:09:36.000000000 +0200
|
||||||
|
+++ qt-x11-free-3.3.5/plugins/src/inputmethods/simple/qsimpleinputcontext.cpp 2005-10-13 16:09:31.000000000 +0200
|
||||||
|
@@ -140,7 +140,7 @@
|
||||||
|
// only one character. See description of
|
||||||
|
// QInputContext::filterEvent() about key compression.
|
||||||
|
val = text[0].unicode();
|
||||||
|
- qDebug( "str = %s", (const char*)keyevent->text().local8Bit() );
|
||||||
|
+ // qDebug( "str = %s", (const char*)keyevent->text().local8Bit() );
|
||||||
|
}
|
||||||
|
|
||||||
|
// Store value
|
||||||
|
@@ -164,14 +164,14 @@
|
||||||
|
|
||||||
|
void QSimpleInputContext::setFocus()
|
||||||
|
{
|
||||||
|
- qDebug( "QSimpleInputContext: %p->setFocus(), focusWidget()=%p",
|
||||||
|
- this, focusWidget() );
|
||||||
|
+ /* qDebug( "QSimpleInputContext: %p->setFocus(), focusWidget()=%p",
|
||||||
|
+ this, focusWidget() ); */
|
||||||
|
}
|
||||||
|
|
||||||
|
void QSimpleInputContext::unsetFocus()
|
||||||
|
{
|
||||||
|
- qDebug( "QSimpleInputContext: %p->unsetFocus(), focusWidget()=%p",
|
||||||
|
- this, focusWidget() );
|
||||||
|
+ /* qDebug( "QSimpleInputContext: %p->unsetFocus(), focusWidget()=%p",
|
||||||
|
+ this, focusWidget() ); */
|
||||||
|
reset();
|
||||||
|
}
|
||||||
|
|
||||||
|
@@ -188,8 +188,8 @@
|
||||||
|
case QEvent::MouseButtonRelease:
|
||||||
|
case QEvent::MouseButtonDblClick:
|
||||||
|
case QEvent::MouseMove:
|
||||||
|
- qDebug( "QSimpleInputContext::mouseHandler: "
|
||||||
|
- "x=%d, type=%d, button=%d, state=%d", x, type, button, state );
|
||||||
|
+ /* qDebug( "QSimpleInputContext::mouseHandler: "
|
||||||
|
+ "x=%d, type=%d, button=%d, state=%d", x, type, button, state ); */
|
||||||
|
break;
|
||||||
|
default:
|
||||||
|
break;
|
||||||
|
@@ -240,7 +240,7 @@
|
||||||
|
|
||||||
|
// no entries were found
|
||||||
|
if ( p == composeTable->data + composeTable->size ) {
|
||||||
|
- qDebug( "no match" );
|
||||||
|
+ // qDebug( "no match" );
|
||||||
|
clearComposeBuffer();
|
||||||
|
return FALSE;
|
||||||
|
}
|
||||||
|
@@ -250,18 +250,18 @@
|
||||||
|
|
||||||
|
// check if partial match
|
||||||
|
if ( composeBuffer[i] == 0 && p->keys[i] ) {
|
||||||
|
- qDebug("partial match");
|
||||||
|
+ // qDebug("partial match");
|
||||||
|
return TRUE;
|
||||||
|
}
|
||||||
|
|
||||||
|
if ( composeBuffer[i] != p->keys[i] ) {
|
||||||
|
- qDebug("different entry");
|
||||||
|
+ // qDebug("different entry");
|
||||||
|
clearComposeBuffer();
|
||||||
|
return i!=0;
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
||||||
|
- qDebug("match exactly");
|
||||||
|
+ // qDebug("match exactly");
|
||||||
|
|
||||||
|
// match exactly
|
||||||
|
commitChar( p->value );
|
||||||
|
diff -Nur qt-x11-free-3.3.5.orig/plugins/src/inputmethods/xim/qximinputcontext_x11.cpp qt-x11-free-3.3.5/plugins/src/inputmethods/xim/qximinputcontext_x11.cpp
|
||||||
|
--- qt-x11-free-3.3.5.orig/plugins/src/inputmethods/xim/qximinputcontext_x11.cpp 2005-10-13 16:09:36.000000000 +0200
|
||||||
|
+++ qt-x11-free-3.3.5/plugins/src/inputmethods/xim/qximinputcontext_x11.cpp 2005-10-13 16:09:31.000000000 +0200
|
||||||
|
@@ -742,7 +742,7 @@
|
||||||
|
|
||||||
|
void QXIMInputContext::close( const QString &errMsg )
|
||||||
|
{
|
||||||
|
- qDebug( errMsg );
|
||||||
|
+ // qDebug( errMsg );
|
||||||
|
emit deletionRequested();
|
||||||
|
}
|
||||||
|
|
||||||
|
diff -Nur qt-x11-free-3.3.5.orig/src/kernel/qinputcontext.cpp qt-x11-free-3.3.5/src/kernel/qinputcontext.cpp
|
||||||
|
--- qt-x11-free-3.3.5.orig/src/kernel/qinputcontext.cpp 2005-10-13 16:09:37.000000000 +0200
|
||||||
|
+++ qt-x11-free-3.3.5/src/kernel/qinputcontext.cpp 2005-10-13 16:09:31.000000000 +0200
|
||||||
|
@@ -526,17 +526,17 @@
|
||||||
|
return;
|
||||||
|
|
||||||
|
if ( type == QEvent::IMStart ) {
|
||||||
|
- qDebug( "sending IMStart with %d chars to %p",
|
||||||
|
- text.length(), receiver );
|
||||||
|
+ /* qDebug( "sending IMStart with %d chars to %p",
|
||||||
|
+ text.length(), receiver ); */
|
||||||
|
event = new QIMEvent( type, text, cursorPosition );
|
||||||
|
} else if ( type == QEvent::IMEnd ) {
|
||||||
|
- qDebug( "sending IMEnd with %d chars to %p, text=%s",
|
||||||
|
- text.length(), receiver, (const char*)text.local8Bit() );
|
||||||
|
+ /* qDebug( "sending IMEnd with %d chars to %p, text=%s",
|
||||||
|
+ text.length(), receiver, (const char*)text.local8Bit() ); */
|
||||||
|
event = new QIMEvent( type, text, cursorPosition );
|
||||||
|
} else if ( type == QEvent::IMCompose ) {
|
||||||
|
- qDebug( "sending IMCompose to %p with %d chars, cpos=%d, sellen=%d, text=%s",
|
||||||
|
+ /* qDebug( "sending IMCompose to %p with %d chars, cpos=%d, sellen=%d, text=%s",
|
||||||
|
receiver, text.length(), cursorPosition, selLength,
|
||||||
|
- (const char*)text.local8Bit() );
|
||||||
|
+ (const char*)text.local8Bit() ); */
|
||||||
|
event = new QIMComposeEvent( type, text, cursorPosition, selLength );
|
||||||
|
}
|
||||||
|
|
26
qt.spec
26
qt.spec
@ -85,7 +85,7 @@
|
|||||||
Summary: The shared library for the Qt GUI toolkit.
|
Summary: The shared library for the Qt GUI toolkit.
|
||||||
Name: qt
|
Name: qt
|
||||||
Version: %{ver}
|
Version: %{ver}
|
||||||
Release: 4
|
Release: 5
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
License: GPL/QPL
|
License: GPL/QPL
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
@ -110,13 +110,9 @@ Patch23: qt-visibility.patch
|
|||||||
Patch24: qt-x11-free-3.3.5-uic.patch
|
Patch24: qt-x11-free-3.3.5-uic.patch
|
||||||
|
|
||||||
# immodule patches
|
# immodule patches
|
||||||
Patch50: qt-x11-immodule-unified-qt3.3.4-20041203-pre.patch
|
Patch50: qt-x11-immodule-unified-qt3.3.5-20051012.diff.bz2
|
||||||
Patch51: qt-x11-immodule-unified-qt3.3.4-20041203.diff.bz2
|
Patch51: qt-x11-immodule-unified-qt3.3.5-20051012-build.patch
|
||||||
Patch52: qt-x11-immodule-unified-qt3.3.4-20041203-post.patch
|
Patch54: qt-x11-immodule-unified-qt3.3.5-20051012-quiet.patch
|
||||||
Patch53: qximinputcontext_x11.cpp.patch
|
|
||||||
Patch54: qt-x11-free-3.3.3-immodule-quiet.patch
|
|
||||||
Patch55: qt-x11-free-3.3.3-immodule-qinputcontext.patch
|
|
||||||
Patch56: qt-x11-free-3.3.4-immodule-xim.patch
|
|
||||||
Patch57: qt-x11-free-3.3.4-imm-key.patch
|
Patch57: qt-x11-free-3.3.4-imm-key.patch
|
||||||
|
|
||||||
# qt-copy patches
|
# qt-copy patches
|
||||||
@ -327,14 +323,9 @@ for the Qt toolkit.
|
|||||||
%patch24 -p1 -b .uic
|
%patch24 -p1 -b .uic
|
||||||
|
|
||||||
%if %{immodule}
|
%if %{immodule}
|
||||||
bunzip2 -c %{_sourcedir}/qt-x11-immodule-unified-qt3.3.4-20041203.diff.bz2 > qt-x11-immodule-unified-qt3.3.4-20041203.diff
|
%patch50 -p1 -b .im
|
||||||
patch -p0 < %{_sourcedir}/qt-x11-immodule-unified-qt3.3.4-20041203-pre.patch
|
%patch51 -p1 -b .build
|
||||||
patch -p1 < qt-x11-immodule-unified-qt3.3.4-20041203.diff
|
|
||||||
%patch52 -p1 -b .immodule-unified-qt3.3.4-20041203-post
|
|
||||||
%patch53 -p0 -b .qximinputcontext_x11
|
|
||||||
%patch54 -p1 -b .quiet
|
%patch54 -p1 -b .quiet
|
||||||
%patch55 -p1 -b .im
|
|
||||||
%patch56 -p1 -b .xim
|
|
||||||
%patch57 -p1 -b .key
|
%patch57 -p1 -b .key
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
@ -722,6 +713,11 @@ rm -rf %{buildroot}
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Oct 13 2005 Than Ngo <than@redhat.com> 1:3.3.5-5
|
||||||
|
- update qt-x11-immodule-unified-qt3.3.5-20051012
|
||||||
|
- disable some debug messages
|
||||||
|
- apply patch to fix build problem with the new immodule patch
|
||||||
|
|
||||||
* Tue Sep 27 2005 Than Ngo <than@redhat.com> 1:3.3.5-4
|
* Tue Sep 27 2005 Than Ngo <than@redhat.com> 1:3.3.5-4
|
||||||
- apply patch to fix gcc warnings
|
- apply patch to fix gcc warnings
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
|||||||
85fdf8ac3264a8849ebae74aa9c37a9b qt-x11-immodule-unified-qt3.3.4-20041203.diff.bz2
|
|
||||||
05d04688c0c0230ed54e89102d689ca4 qt-x11-free-3.3.5.tar.bz2
|
05d04688c0c0230ed54e89102d689ca4 qt-x11-free-3.3.5.tar.bz2
|
||||||
|
93c6ee9861f097bf6152baf6af2bc7e3 qt-x11-immodule-unified-qt3.3.5-20051012.diff.bz2
|
||||||
|
Loading…
x
Reference in New Issue
Block a user