rm qt-4.5.2-pulseaudio.patch entirely, not only is this a patch to the
bundled Phonon which we aren't even building in Fedora, but it isn't needed at all for the Phonon which ships with Qt 4.7 even if we build Qt's Phonon. Qt 4.7 now ships a Phonon with the upstream PulseAudio integration.
This commit is contained in:
parent
98af2ffded
commit
40ea442909
@ -1,43 +0,0 @@
|
||||
diff -up qt-x11-opensource-src-4.5.2/src/3rdparty/phonon/phonon/globalconfig.cpp.phonon-pulseaudio qt-x11-opensource-src-4.5.2/src/3rdparty/phonon/phonon/globalconfig.cpp
|
||||
--- qt-x11-opensource-src-4.5.2/src/3rdparty/phonon/phonon/globalconfig.cpp.phonon-pulseaudio 2009-06-20 06:57:54.000000000 +0200
|
||||
+++ qt-x11-opensource-src-4.5.2/src/3rdparty/phonon/phonon/globalconfig.cpp 2009-08-21 00:11:55.000000000 +0200
|
||||
@@ -31,6 +31,7 @@
|
||||
#include "phononnamespace_p.h"
|
||||
|
||||
#include <QtCore/QList>
|
||||
+#include <QtCore/QHash>
|
||||
#include <QtCore/QVariant>
|
||||
|
||||
QT_BEGIN_NAMESPACE
|
||||
@@ -167,6 +168,15 @@ QList<int> GlobalConfig::audioOutputDevi
|
||||
| ((override & HideUnavailableDevices) ? FilterUnavailableDevices : 0)
|
||||
);
|
||||
}
|
||||
+ // make PulseAudio the global default (assume it is already default in this list)
|
||||
+ if (!list.isEmpty()) {
|
||||
+ int firstIndex = list.first();
|
||||
+ if (backendIface->objectDescriptionProperties(Phonon::AudioOutputDeviceType,
|
||||
+ firstIndex)["name"].toString() == "PulseAudio") {
|
||||
+ list.removeFirst();
|
||||
+ defaultList.prepend(firstIndex);
|
||||
+ }
|
||||
+ }
|
||||
defaultList += list;
|
||||
}
|
||||
|
||||
@@ -222,6 +232,15 @@ QList<int> GlobalConfig::audioCaptureDev
|
||||
| ((override & HideUnavailableDevices) ? FilterUnavailableDevices : 0)
|
||||
);
|
||||
}
|
||||
+ // make PulseAudio the global default (assume it is already default in this list)
|
||||
+ if (!list.isEmpty()) {
|
||||
+ int firstIndex = list.first();
|
||||
+ if (backendIface->objectDescriptionProperties(Phonon::AudioCaptureDeviceType,
|
||||
+ firstIndex)["name"].toString() == "PulseAudio") {
|
||||
+ list.removeFirst();
|
||||
+ defaultList.prepend(firstIndex);
|
||||
+ }
|
||||
+ }
|
||||
defaultList += list;
|
||||
}
|
||||
|
4
qt.spec
4
qt.spec
@ -42,8 +42,6 @@ Patch13: qt-x11-opensource-src-4.5.0-gcc_hack.patch
|
||||
Patch15: qt-x11-opensource-src-4.5.1-enable_ft_lcdfilter.patch
|
||||
# include kde4 plugin path, http://bugzilla.redhat.com/498809
|
||||
Patch16: qt-x11-opensource-src-4.5.1-kde4_plugins.patch
|
||||
# make PulseAudio the default device in Phonon
|
||||
Patch17: qt-x11-opensource-src-4.5.2-pulseaudio.patch
|
||||
Patch19: qt-x11-opensource-src-4.5.1-phonon.patch
|
||||
# use system ca-bundle certs, http://bugzilla.redhat.com/521911
|
||||
Patch22: qt-x11-opensource-src-4.5.3-system_ca_certificates.patch
|
||||
@ -400,8 +398,6 @@ Qt libraries used for drawing widgets and OpenGL items.
|
||||
%patch13 -p1 -b .gcc_hack
|
||||
%patch15 -p1 -b .enable_ft_lcdfilter
|
||||
%patch16 -p1 -b .kde4_plugins
|
||||
# pretty sure this isnt needed anymore, besides, doesnt' build as-is -- Rex
|
||||
#patch17 -p1 -b .phonon-pulseaudio
|
||||
%patch19 -p1 -b .servicesfile
|
||||
%patch22 -p1 -b .system_ca_certificates
|
||||
%patch51 -p1 -b .qdoc3
|
||||
|
Loading…
x
Reference in New Issue
Block a user