drop upstreamed patch
This commit is contained in:
parent
529fc5e1f4
commit
3eee5c4831
@ -1,14 +0,0 @@
|
||||
diff -up qt-everywhere-opensource-src-4.7.0-beta1/src/gui/kernel/qapplication.cpp.QT_GRAPHICSSYSTEM qt-everywhere-opensource-src-4.7.0-beta1/src/gui/kernel/qapplication.cpp
|
||||
--- qt-everywhere-opensource-src-4.7.0-beta1/src/gui/kernel/qapplication.cpp.QT_GRAPHICSSYSTEM 2010-05-03 19:43:24.000000000 -0500
|
||||
+++ qt-everywhere-opensource-src-4.7.0-beta1/src/gui/kernel/qapplication.cpp 2010-05-17 13:56:33.851069964 -0500
|
||||
@@ -774,6 +774,10 @@ void QApplicationPrivate::construct(
|
||||
|
||||
qt_is_gui_used = (qt_appType != QApplication::Tty);
|
||||
process_cmdline();
|
||||
+ // the environment variable has the lowest precedence of runtime graphicssystem switches
|
||||
+ if (graphics_system_name.isEmpty()) {
|
||||
+ graphics_system_name = QString::fromLocal8Bit(qgetenv("QT_GRAPHICSSYSTEM"));
|
||||
+ }
|
||||
// Must be called before initialize()
|
||||
qt_init(this, qt_appType
|
||||
#ifdef Q_WS_X11
|
3
qt.spec
3
qt.spec
@ -85,8 +85,6 @@ Patch207: 0007-When-using-qmake-outside-qt-src-tree-it-sometimes-ge.patch
|
||||
Patch208: 0008-This-patch-makes-the-raster-graphics-system-use-shar.patch
|
||||
Patch209: 0009-Restore-a-section-of-the-file-that-got-removed-due-t.patch
|
||||
Patch212: 0012-Add-context-to-tr-calls-in-QShortcut.patch
|
||||
# based on http://qt.gitorious.org/+kde-developers/qt/kde-qt/commit/55ef01d93f8257b5927660290fc1ead0b2b74ec9.patch
|
||||
Patch217: qt-everywhere-opensource-src-4.7.0-beta1-QT_GRAPHICSSYSTEM.patch
|
||||
|
||||
Source10: http://gstreamer.freedesktop.org/data/images/artwork/gstreamer-logo.svg
|
||||
Source11: hi16-phonon-gstreamer.png
|
||||
@ -448,7 +446,6 @@ Qt libraries used for drawing widgets and OpenGL items.
|
||||
#patch207 -p1 -b .kde-qt-0007
|
||||
%patch212 -p1 -b .kde-qt-0012
|
||||
%endif
|
||||
%patch217 -p1 -b .QT_GRAPHICSSYSTEM
|
||||
|
||||
# drop -fexceptions from $RPM_OPT_FLAGS
|
||||
RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS | sed 's|-fexceptions||g'`
|
||||
|
Loading…
Reference in New Issue
Block a user