drop the patch, it's already fixed in upstream
This commit is contained in:
parent
ee8290ceac
commit
3e6009be04
@ -1,41 +0,0 @@
|
||||
diff -ur qt-all-opensource-src-4.4.0-rc1/src/3rdparty/harfbuzz/src/harfbuzz-indic.cpp qt-all-opensource-src-4.4.0-rc1-as_IN-437440/src/3rdparty/harfbuzz/src/harfbuzz-indic.cpp
|
||||
--- qt-all-opensource-src-4.4.0-rc1/src/3rdparty/harfbuzz/src/harfbuzz-indic.cpp 2008-04-02 18:33:48.000000000 +0200
|
||||
+++ qt-all-opensource-src-4.4.0-rc1-as_IN-437440/src/3rdparty/harfbuzz/src/harfbuzz-indic.cpp 2008-04-08 04:37:45.000000000 +0200
|
||||
@@ -552,7 +552,7 @@
|
||||
None, None, None, None,
|
||||
None, None, None, None,
|
||||
|
||||
- None, None, None, None,
|
||||
+ Below, None, None, None,
|
||||
None, None, None, None,
|
||||
None, None, None, None,
|
||||
None, None, None, None,
|
||||
@@ -1169,7 +1169,7 @@
|
||||
HB_Script script = item->item.script;
|
||||
assert(script >= HB_Script_Devanagari && script <= HB_Script_Sinhala);
|
||||
const unsigned short script_base = 0x0900 + 0x80*(script-HB_Script_Devanagari);
|
||||
- const unsigned short ra = script_base + 0x30;
|
||||
+ unsigned short ra = script_base + 0x30;
|
||||
const unsigned short halant = script_base + 0x4d;
|
||||
const unsigned short nukta = script_base + 0x3c;
|
||||
bool control = false;
|
||||
@@ -1212,6 +1212,19 @@
|
||||
HB_UChar16 *uc = reordered;
|
||||
bool beginsWithRa = false;
|
||||
|
||||
+ // Exception in Bengali Script
|
||||
+ //
|
||||
+ // Bengali script supports two languages bengali and assamese
|
||||
+ // Unfortunately for both languages there is different ra defined in same script chart
|
||||
+ // for Bengali it ra is 'Base+ 0x30' and for assamese 'Base+0x70'
|
||||
+ // Base is same 0x0980
|
||||
+ // To handle this exception we need to change ra to from const to normal variable
|
||||
+ // and aslo need to change ra to 'Base+0x70' whenever we will get assamese language
|
||||
+ //character in data
|
||||
+ if((script == HB_Script_Bengali) && (*uc==0x09F0)){
|
||||
+ ra = script_base + 0x70;
|
||||
+ }
|
||||
+
|
||||
// Rule 1: find base consonant
|
||||
//
|
||||
// The shaping engine finds the base consonant of the
|
7
qt.spec
7
qt.spec
@ -17,7 +17,7 @@ Summary: Qt toolkit
|
||||
Name: qt
|
||||
Epoch: 1
|
||||
Version: 4.7.0
|
||||
Release: 0.28.%{pre}%{?dist}
|
||||
Release: 0.29.%{pre}%{?dist}
|
||||
|
||||
# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
|
||||
License: LGPLv2 with exceptions or GPLv3 with exceptions
|
||||
@ -39,7 +39,6 @@ Source5: qconfig-multilib.h
|
||||
Patch2: qt-x11-opensource-src-4.2.2-multilib-optflags.patch
|
||||
Patch3: qt-x11-opensource-src-4.2.2-multilib-QMAKEPATH.patch
|
||||
Patch4: qt-everywhere-opensource-src-4.7.0-beta1-uic_multilib.patch
|
||||
Patch5: qt-all-opensource-src-4.4.0-rc1-as_IN-437440.patch
|
||||
Patch15: qt-x11-opensource-src-4.5.1-enable_ft_lcdfilter.patch
|
||||
# include kde4 plugin path, http://bugzilla.redhat.com/498809
|
||||
# omit for now, (seems?) causes unwelcome side-effects -- Rex
|
||||
@ -407,7 +406,6 @@ Qt libraries used for drawing widgets and OpenGL items.
|
||||
%prep
|
||||
%setup -q -n qt-everywhere-opensource-src-%{version}%{?pre:-%{pre}}
|
||||
|
||||
%patch5 -p1 -b .bz#437440-as_IN-437440
|
||||
%patch15 -p1 -b .enable_ft_lcdfilter
|
||||
#patch16 -p1 -b .kde4_plugins
|
||||
%patch19 -p1 -b .phonon_servicesfile
|
||||
@ -1088,6 +1086,9 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Aug 30 2010 Than Ngo <than@redhat.com> - 4.7.0-0.29.rc1
|
||||
- drop the patch, it's already fixed in upstream
|
||||
|
||||
* Thu Aug 26 2010 Than Ngo <than@redhat.com> - 4.7.0-0.28.rc1
|
||||
- 4.7.0 rc1
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user