- X11Embed broken (rh#609757,(QTBUG-10809)
This commit is contained in:
parent
3ba8c12fa9
commit
3190d33000
30
9a1b0695277a3864b42d082095962f8742cdcf04.patch
Normal file
30
9a1b0695277a3864b42d082095962f8742cdcf04.patch
Normal file
@ -0,0 +1,30 @@
|
||||
From 9a1b0695277a3864b42d082095962f8742cdcf04 Mon Sep 17 00:00:00 2001
|
||||
From: Denis Dzyubenko <denis.dzyubenko@nokia.com>
|
||||
Date: Thu, 1 Jul 2010 12:00:05 +0200
|
||||
Subject: [PATCH] Fixed QX11EmbedContainer.
|
||||
|
||||
Enforce the creation of the native window id for the focusproxy widget inside
|
||||
the container to make sure we won't get a CreateNotify event to try to embed
|
||||
the focusproxy itself.
|
||||
|
||||
Task-number: QTBUG-10809
|
||||
Reviewed-by: Bradley T. Hughes
|
||||
---
|
||||
src/gui/kernel/qx11embed_x11.cpp | 1 +
|
||||
1 files changed, 1 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/src/gui/kernel/qx11embed_x11.cpp b/src/gui/kernel/qx11embed_x11.cpp
|
||||
index b527e72..9f1b1f8 100644
|
||||
--- a/src/gui/kernel/qx11embed_x11.cpp
|
||||
+++ b/src/gui/kernel/qx11embed_x11.cpp
|
||||
@@ -1070,6 +1070,7 @@ QX11EmbedContainer::QX11EmbedContainer(QWidget *parent)
|
||||
d->focusProxy = new QWidget(this);
|
||||
d->focusProxy->setAttribute(Qt::WA_NativeWindow);
|
||||
d->focusProxy->setAttribute(Qt::WA_DontCreateNativeAncestors);
|
||||
+ d->focusProxy->createWinId();
|
||||
d->focusProxy->setGeometry(-1, -1, 1, 1);
|
||||
|
||||
// We need events from the window (activation status) and
|
||||
--
|
||||
1.6.1
|
||||
|
8
qt.spec
8
qt.spec
@ -19,7 +19,7 @@ Summary: Qt toolkit
|
||||
Name: qt
|
||||
Epoch: 1
|
||||
Version: 4.7.0
|
||||
Release: 0.23.%{pre}%{?dist}
|
||||
Release: 0.24.%{pre}%{?dist}
|
||||
|
||||
# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
|
||||
License: LGPLv2 with exceptions or GPLv3 with exceptions
|
||||
@ -71,6 +71,8 @@ Patch58: qt-everywhere-opensource-src-4.7.0-beta1-qtwebkit_pluginpath.patch
|
||||
# upstream patches
|
||||
# https://bugs.webkit.org/show_bug.cgi?id=40567
|
||||
Patch100: qt-everywhere-opensource-src-4.7.0-beta1-qtwebkit_gtk_init.patch
|
||||
# http://bugreports.qt.nokia.com/browse/QTBUG-10809
|
||||
Patch101: http://qt.gitorious.org/+qt-developers/qt/staging/commit/9a1b0695277a3864b42d082095962f8742cdcf04.patch
|
||||
|
||||
# kde-qt git patches
|
||||
Patch201: 0001-This-patch-uses-object-name-as-a-fallback-for-window.patch
|
||||
@ -434,6 +436,7 @@ Qt libraries used for drawing widgets and OpenGL items.
|
||||
|
||||
# upstream patches
|
||||
%patch100 -p1 -b .qtwebkit_gtk_init
|
||||
%patch101 -p1 -b .QTBUG-10809
|
||||
|
||||
# kde-qt branch
|
||||
%if 0%{?kde_qt}
|
||||
@ -1102,6 +1105,9 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Jul 01 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.7.0-0.24.beta1
|
||||
- X11Embed broken (rh#609757,(QTBUG-10809)
|
||||
|
||||
* Tue Jul 01 2010 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.7.0-0.23.beta1
|
||||
- use find_lang to package the qm files (#609749)
|
||||
- put the qm files into the correct subpackages
|
||||
|
Loading…
Reference in New Issue
Block a user