apply patch bz#437440 to fix [as-IN] Consonant combination issue, thanks to
Pravin Satpute
This commit is contained in:
parent
6555ccf319
commit
2df14c171a
26
qt-x11-opensource-src-4.3.4-as_IN-437440.patch
Normal file
26
qt-x11-opensource-src-4.3.4-as_IN-437440.patch
Normal file
@ -0,0 +1,26 @@
|
||||
--- qt-x11-opensource-src-4.3.4/src/gui/text/qscriptengine.cpp 2008-02-19 23:17:19.000000000 +0530
|
||||
+++ qt-x11-opensource-src-4.3.4/src/gui/text/qscriptengine.cpp_mod 2008-03-26 12:02:54.000000000 +0530
|
||||
@@ -2174,7 +2174,7 @@ static const unsigned char indicPosition
|
||||
None, None, None, None,
|
||||
None, None, None, None,
|
||||
|
||||
- None, None, None, None,
|
||||
+ Below, None, None, None,
|
||||
None, None, None, None,
|
||||
None, None, None, None,
|
||||
None, None, None, None,
|
||||
@@ -2814,9 +2814,13 @@ static bool indic_shape_syllable(QOpenTy
|
||||
int script = item->script;
|
||||
Q_ASSERT(script >= QUnicodeTables::Devanagari && script <= QUnicodeTables::Sinhala);
|
||||
const unsigned short script_base = 0x0900 + 0x80*(script-QUnicodeTables::Devanagari);
|
||||
- const unsigned short ra = script_base + 0x30;
|
||||
+ unsigned short ra = script_base + 0x30;
|
||||
const unsigned short halant = script_base + 0x4d;
|
||||
const unsigned short nukta = script_base + 0x3c;
|
||||
+ if(script==14)
|
||||
+ {
|
||||
+ ra= script_base + 0x70;
|
||||
+ }
|
||||
|
||||
int len = item->length;
|
||||
IDEBUG(">>>>> indic shape: from=%d, len=%d invalid=%d", item->from, item->length, invalid);
|
5
qt.spec
5
qt.spec
@ -36,6 +36,7 @@ Patch2: qt-x11-opensource-src-4.2.2-multilib.patch
|
||||
# strict aliasing violations in tool classes
|
||||
Patch3: qt-43-aliasing.diff
|
||||
Patch4: qt-x11-opensource-src-4.3.4-aliasing.patch
|
||||
Patch5: qt-x11-opensource-src-4.3.4-as_IN-437440.patch
|
||||
|
||||
## qt-copy patches
|
||||
%define qt_copy 20080305
|
||||
@ -281,6 +282,7 @@ test -x apply_patches && ./apply_patches
|
||||
# don't use -b on mkspec files, else they get installed too.
|
||||
%patch2 -p1
|
||||
%patch4 -p1
|
||||
%patch5 -p1 -b .bz#437440-as_IN-437440
|
||||
|
||||
# drop -fexceptions from $RPM_OPT_FLAGS
|
||||
RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS | sed 's|-fexceptions||g'`
|
||||
@ -696,6 +698,9 @@ gtk-update-icon-cache -q %{_datadir}/icons/hicolor 2> /dev/null ||:
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Mar 26 2008 Than Ngo <than@redhat.com> 4.3.4-9
|
||||
- apply patch bz#437440 to fix [as-IN] Consonant combination issue, thanks to Pravin Satpute
|
||||
|
||||
* Sun Mar 23 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 4.3.4-8
|
||||
- -x11: add missing Provides: qt4-assistant when building as qt
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user