This commit is contained in:
Than Ngo 2007-03-19 10:26:53 +00:00
parent 7f14c3d0ea
commit 2d04ae4719
3 changed files with 126 additions and 7 deletions

View File

@ -0,0 +1,40 @@
--- qt-x11-free-3.3.8/src/widgets/qtextedit.cpp.im 2007-03-19 10:19:10.000000000 +0100
+++ qt-x11-free-3.3.8/src/widgets/qtextedit.cpp 2007-03-19 10:19:47.000000000 +0100
@@ -5059,6 +5059,10 @@
void QTextEdit::setDocument( QTextDocument *dc )
{
+ if ( dc == 0 ) {
+ qWarning( "Q3TextEdit::setDocument() called with null Q3TextDocument pointer" );
+ return;
+ }
if ( dc == doc )
return;
resetInputContext();
--- qt-x11-free-3.3.8/src/widgets/qlineedit.cpp.im 2007-03-19 10:20:03.000000000 +0100
+++ qt-x11-free-3.3.8/src/widgets/qlineedit.cpp 2007-03-19 10:22:11.000000000 +0100
@@ -457,10 +457,10 @@
\property QLineEdit::text
\brief the line edit's text
- Setting this property clears the selection, clears the undo/redo
- history, moves the cursor to the end of the line and resets the
- \c modified property to FALSE. The text is not validated when
- inserted with setText().
+ Note that setting this property clears the selection, clears the
+ undo/redo history, moves the cursor to the end of the line and
+ resets the \c modified property to FALSE. The text is not
+ validated when inserted with setText().
The text is truncated to maxLength() length.
@@ -1014,6 +1014,9 @@
/*!
Selects text from position \a start and for \a length characters.
+ Note that this function sets the cursor's position to the end of
+ the selection regardless of its current position.
+
\sa deselect() selectAll() getSelection() cursorForward() cursorBackward()
*/

View File

@ -0,0 +1,83 @@
--- qt-x11-free-3.3.8/src/kernel/qwidget_x11.cpp 2007-02-02 15:01:13.000000000 +0100
+++ qt-x11-free-3.3.7/src/kernel/qwidget_x11.cpp 2006-10-19 16:25:16.000000000 +0200
@@ -1442,7 +1442,16 @@
QWidget *tlw = topLevelWidget();
if ( tlw->isVisible() && !tlw->topData()->embedded && !qt_deferred_map_contains(tlw) ) {
XSetInputFocus( x11Display(), tlw->winId(), RevertToNone, qt_x_time);
- focusInputContext();
+
+#ifndef QT_NO_XIM
+ // trigger input context creation if it hasn't happened already
+ createInputContext();
+
+ if (tlw->topData()->xic) {
+ QInputContext *qic = (QInputContext *) tlw->topData()->xic;
+ qic->setFocus();
+ }
+#endif
}
}
@@ -2717,16 +2726,14 @@
{
#ifndef QT_NO_XIM
QWidget *tlw = topLevelWidget();
- if (!tlw->isPopup() || isInputMethodEnabled()) {
- QTLWExtra *topdata = tlw->topData();
+ QTLWExtra *topdata = tlw->topData();
- // trigger input context creation if it hasn't happened already
- createInputContext();
+ // trigger input context creation if it hasn't happened already
+ createInputContext();
- if (topdata->xic) {
- QInputContext *qic = (QInputContext *) topdata->xic;
- qic->setFocus();
- }
+ if (topdata->xic) {
+ QInputContext *qic = (QInputContext *) topdata->xic;
+ qic->setFocus();
}
#endif // QT_NO_XIM
}
--- qt-x11-free-3.3.8/src/widgets/qtextedit.cpp 2007-02-02 15:01:23.000000000 +0100
+++ qt-x11-free-3.3.7/src/widgets/qtextedit.cpp 2006-10-19 16:25:34.000000000 +0200
@@ -4972,10 +4972,6 @@
void QTextEdit::setDocument( QTextDocument *dc )
{
- if ( dc == 0 ) {
- qWarning( "Q3TextEdit::setDocument() called with null Q3TextDocument pointer" );
- return;
- }
if ( dc == doc )
return;
resetInputContext();
--- qt-x11-free-3.3.8/src/widgets/qlineedit.cpp 2007-02-02 15:01:24.000000000 +0100
+++ qt-x11-free-3.3.7/src/widgets/qlineedit.cpp 2006-10-19 16:25:36.000000000 +0200
@@ -446,10 +446,10 @@
\property QLineEdit::text
\brief the line edit's text
- Note that setting this property clears the selection, clears the
- undo/redo history, moves the cursor to the end of the line and
- resets the \c modified property to FALSE. The text is not
- validated when inserted with setText().
+ Setting this property clears the selection, clears the undo/redo
+ history, moves the cursor to the end of the line and resets the
+ \c modified property to FALSE. The text is not validated when
+ inserted with setText().
The text is truncated to maxLength() length.
@@ -1002,9 +1002,6 @@
/*!
Selects text from position \a start and for \a length characters.
- Note that this function sets the cursor's position to the end of
- the selection regardless of its current position.
-
\sa deselect() selectAll() getSelection() cursorForward() cursorBackward()
*/

10
qt.spec
View File

@ -40,9 +40,9 @@ Patch34: qt-3.3.6-fontrendering-ml_IN-209974.patch
Patch35: qt-3.3.6-fontrendering-ml_IN-217657.patch
# immodule patches
Patch50: qt-x11-free-3.3.6-qt-x11-immodule-unified-qt3.3.5-20060318-pre.patch
Patch50: qt-x11-free-3.3.8-qt-x11-immodule-unified-qt3.3.7-20061229-pre.patch
Patch51: qt-x11-immodule-unified-qt3.3.7-20061229.diff.bz2
Patch52: qt-x11-free-3.3.6-qt-x11-immodule-unified-qt3.3.5-20060318-post.patch
Patch52: qt-x11-free-3.3.8-qt-x11-immodule-unified-qt3.3.7-20061229-post.patch
Patch53: qt-x11-immodule-unified-qt3.3.5-20051012-quiet.patch
Patch54: qt-x11-free-3.3.6-fix-key-release-event-with-imm.diff
Patch55: qt-x11-free-3.3.6-qt-x11-immodule-unified-qt3.3.5-20060318-resetinputcontext.patch
@ -52,8 +52,6 @@ Patch100: 0038-dragobject-dont-prefer-unknown.patch
Patch101: 0047-fix-kmenu-width.diff
Patch102: 0048-qclipboard_hack_80072.patch
Patch103: 0056-khotkeys_input_84434.patch
Patch104: 0069-fix-minsize.patch
Patch105: 0070-fix-broken-fonts.patch
# upstream patches
Patch200: qt-x11-free-3.3.4-fullscreen.patch
@ -284,8 +282,6 @@ for the Qt toolkit.
%patch101 -p0 -b .0047-fix-kmenu-width
%patch102 -p0 -b .0048-qclipboard_hack_80072
%patch103 -p0 -b .0056-khotkeys_input_84434
%patch104 -p0 -b .0069-fix-minsize
%patch105 -p0 -b .0070-fix-broken-fonts
%patch200 -p1 -b .fullscreen
# convert to UTF-8
@ -557,7 +553,7 @@ rm -rf %{buildroot}
%changelog
* Mon Mar 19 2007 Than Ngo <than@redhat.com> 1:3.3.8-1
* Mon Mar 19 2007 Than Ngo <than@redhat.com> 1:3.3.8-1.fc7
- update to 3.3.8
* Wed Dec 06 2006 Than Ngo <than@redhat.com> - 1:3.3.7-2.fc7