Merge branch 'master' into f16

This commit is contained in:
Than Ngo 2012-05-23 09:51:55 +02:00
commit 266a47c2dc
13 changed files with 182 additions and 124 deletions

1
.gitignore vendored
View File

@ -10,3 +10,4 @@
/qt-everywhere-opensource-src-4.7.4.tar.gz
/qt-everywhere-opensource-src-4.8.0.tar.gz
/qt-everywhere-opensource-src-4.8.1.tar.gz
/qt-everywhere-opensource-src-4.8.2.tar.gz

View File

@ -1,27 +0,0 @@
diff -up qt-everywhere-opensource-src-4.8.0/src/3rdparty/javascriptcore/JavaScriptCore/runtime/JSGlobalObject.h.me qt-everywhere-opensource-src-4.8.0/src/3rdparty/javascriptcore/JavaScriptCore/runtime/JSGlobalObject.h
--- qt-everywhere-opensource-src-4.8.0/src/3rdparty/javascriptcore/JavaScriptCore/runtime/JSGlobalObject.h.me 2012-01-24 11:24:14.729942043 +0100
+++ qt-everywhere-opensource-src-4.8.0/src/3rdparty/javascriptcore/JavaScriptCore/runtime/JSGlobalObject.h 2012-01-24 14:28:39.848109534 +0100
@@ -57,9 +57,7 @@ namespace JSC {
class JSGlobalObject : public JSVariableObject {
protected:
- using JSVariableObject::JSVariableObjectData;
-
- struct JSGlobalObjectData : public JSVariableObjectData {
+ struct JSGlobalObjectData : public JSVariableObject::JSVariableObjectData {
// We use an explicit destructor function pointer instead of a
// virtual destructor because we want to avoid adding a vtable
// pointer to this struct. Adding a vtable pointer would force the
diff -up qt-everywhere-opensource-src-4.8.0/src/3rdparty/javascriptcore/JavaScriptCore/runtime/JSStaticScopeObject.h.me qt-everywhere-opensource-src-4.8.0/src/3rdparty/javascriptcore/JavaScriptCore/runtime/JSStaticScopeObject.h
--- qt-everywhere-opensource-src-4.8.0/src/3rdparty/javascriptcore/JavaScriptCore/runtime/JSStaticScopeObject.h.me 2012-01-24 11:40:07.167856677 +0100
+++ qt-everywhere-opensource-src-4.8.0/src/3rdparty/javascriptcore/JavaScriptCore/runtime/JSStaticScopeObject.h 2012-01-24 14:28:34.640306629 +0100
@@ -32,8 +32,7 @@ namespace JSC{
class JSStaticScopeObject : public JSVariableObject {
protected:
- using JSVariableObject::JSVariableObjectData;
- struct JSStaticScopeObjectData : public JSVariableObjectData {
+ struct JSStaticScopeObjectData : public JSVariableObject::JSVariableObjectData {
JSStaticScopeObjectData()
: JSVariableObjectData(&symbolTable, &registerStore + 1)
{

View File

@ -1,21 +0,0 @@
diff -up qt-everywhere-opensource-src-4.8.0/src/corelib/tools/qlocale_icu.cpp.icu_no_spam qt-everywhere-opensource-src-4.8.0/src/corelib/tools/qlocale_icu.cpp
--- qt-everywhere-opensource-src-4.8.0/src/corelib/tools/qlocale_icu.cpp.icu_no_spam 2011-12-07 23:06:03.000000000 -0600
+++ qt-everywhere-opensource-src-4.8.0/src/corelib/tools/qlocale_icu.cpp 2011-12-20 10:20:19.659502966 -0600
@@ -83,7 +83,7 @@ bool qt_initIcu(const QString &localeStr
// resolve libicui18n
QLibrary lib(QLatin1String("icui18n"), QLatin1String(U_ICU_VERSION_SHORT));
if (!lib.load()) {
- qWarning() << "Unable to load library icui18n" << lib.errorString();
+ // qWarning() << "Unable to load library icui18n" << lib.errorString();
status = ErrorLoading;
return false;
}
@@ -112,7 +112,7 @@ bool qt_initIcu(const QString &localeStr
// resolve libicuuc
QLibrary ucLib(QLatin1String("icuuc"), QLatin1String(U_ICU_VERSION_SHORT));
if (!ucLib.load()) {
- qWarning() << "Unable to load library icuuc" << ucLib.errorString();
+ // qWarning() << "Unable to load library icuuc" << ucLib.errorString();
status = ErrorLoading;
return false;
}

View File

@ -1,12 +0,0 @@
diff -up qt-everywhere-opensource-src-4.8.0/tools/qvfb/qvfb.pro.qvfb qt-everywhere-opensource-src-4.8.0/tools/qvfb/qvfb.pro
--- qt-everywhere-opensource-src-4.8.0/tools/qvfb/qvfb.pro.qvfb 2011-12-27 21:02:19.765512041 -0600
+++ qt-everywhere-opensource-src-4.8.0/tools/qvfb/qvfb.pro 2011-12-27 21:02:39.271268187 -0600
@@ -38,8 +38,6 @@ SOURCES = qvfb.cpp \
!embedded {
DEFINES += QT_NO_QWS_SIGNALHANDLER
- HEADERS += ../../src/gui/embedded/qlock_p.h
- SOURCES += ../../src/gui/embedded/qlock.cpp
}
include(../shared/deviceskin/deviceskin.pri)

View File

@ -1,14 +0,0 @@
diff -up qt-everywhere-opensource-src-4.8.1/src/gui/text/qtextlayout.cpp.QTBUG-24718 qt-everywhere-opensource-src-4.8.1/src/gui/text/qtextlayout.cpp
--- qt-everywhere-opensource-src-4.8.1/src/gui/text/qtextlayout.cpp.QTBUG-24718 2012-03-14 15:01:14.000000000 +0100
+++ qt-everywhere-opensource-src-4.8.1/src/gui/text/qtextlayout.cpp 2012-04-03 10:53:12.973058622 +0200
@@ -2508,6 +2508,10 @@ qreal QTextLine::cursorToX(int *cursorPo
int pos = *cursorPos;
int itm;
const HB_CharAttributes *attributes = eng->attributes();
+ if (!attributes) {
+ *cursorPos = 0;
+ return x.toReal();
+ }
while (pos < line.from + line.length && !attributes[pos].charStop)
pos++;
if (pos == line.from + (int)line.length) {

View File

@ -0,0 +1,23 @@
diff -up qt-everywhere-opensource-src-4.8.1/src/corelib/tools/qlocale_icu.cpp.icu_no_spam qt-everywhere-opensource-src-4.8.1/src/corelib/tools/qlocale_icu.cpp
--- qt-everywhere-opensource-src-4.8.1/src/corelib/tools/qlocale_icu.cpp.icu_no_spam 2012-03-14 09:01:17.000000000 -0500
+++ qt-everywhere-opensource-src-4.8.1/src/corelib/tools/qlocale_icu.cpp 2012-04-17 07:30:01.652251482 -0500
@@ -83,7 +83,9 @@ bool qt_initIcu(const QString &localeStr
// resolve libicui18n
QLibrary lib(QLatin1String("icui18n"), QLatin1String(U_ICU_VERSION_SHORT));
if (!lib.load()) {
+#ifndef QT_NO_DEBUG
qWarning() << "Unable to load library icui18n" << lib.errorString();
+#endif
status = ErrorLoading;
return false;
}
@@ -112,7 +114,9 @@ bool qt_initIcu(const QString &localeStr
// resolve libicuuc
QLibrary ucLib(QLatin1String("icuuc"), QLatin1String(U_ICU_VERSION_SHORT));
if (!ucLib.load()) {
+#ifndef QT_NO_DEBUG
qWarning() << "Unable to load library icuuc" << ucLib.errorString();
+#endif
status = ErrorLoading;
return false;
}

View File

@ -0,0 +1,24 @@
diff -up qt-everywhere-opensource-src-4.8.1/tools/linguist/lrelease/main.cpp.qmake-qt4 qt-everywhere-opensource-src-4.8.1/tools/linguist/lrelease/main.cpp
--- qt-everywhere-opensource-src-4.8.1/tools/linguist/lrelease/main.cpp.qmake-qt4 2012-03-14 09:01:12.000000000 -0500
+++ qt-everywhere-opensource-src-4.8.1/tools/linguist/lrelease/main.cpp 2012-05-11 08:58:12.902149676 -0500
@@ -316,7 +316,7 @@ int main(int argc, char **argv)
#ifdef QT_BOOTSTRAPPED
option.initProperties(binDir + QLatin1String("/qmake"));
#else
- option.initProperties(app.applicationDirPath() + QLatin1String("/qmake"));
+ option.initProperties(app.applicationDirPath() + QLatin1String("/qmake-qt4"));
#endif
ProFileParser parser(0, &parseHandler);
ProFileEvaluator visitor(&option, &parser, &evalHandler);
diff -up qt-everywhere-opensource-src-4.8.1/tools/linguist/lupdate/main.cpp.qmake-qt4 qt-everywhere-opensource-src-4.8.1/tools/linguist/lupdate/main.cpp
--- qt-everywhere-opensource-src-4.8.1/tools/linguist/lupdate/main.cpp.qmake-qt4 2012-03-14 09:01:12.000000000 -0500
+++ qt-everywhere-opensource-src-4.8.1/tools/linguist/lupdate/main.cpp 2012-05-11 09:02:47.393718054 -0500
@@ -765,7 +765,7 @@ int main(int argc, char **argv)
parseHandler.verbose = evalHandler.verbose = !!(options & Verbose);
ProFileOption option;
- option.initProperties(app.applicationDirPath() + QLatin1String("/qmake"));
+ option.initProperties(app.applicationDirPath() + QLatin1String("/qmake-qt4"));
option.setCommandLineArguments(QStringList() << QLatin1String("CONFIG+=lupdate_run"));
ProFileParser parser(0, &parseHandler);

View File

@ -0,0 +1,14 @@
diff -up qt-everywhere-opensource-src-4.8.1/src/dbus/qdbusconnection.cpp.qdbusconnection_nodebug qt-everywhere-opensource-src-4.8.1/src/dbus/qdbusconnection.cpp
--- qt-everywhere-opensource-src-4.8.1/src/dbus/qdbusconnection.cpp.qdbusconnection_nodebug 2012-04-17 07:18:51.536629078 -0500
+++ qt-everywhere-opensource-src-4.8.1/src/dbus/qdbusconnection.cpp 2012-04-17 07:18:56.910561895 -0500
@@ -1109,8 +1109,10 @@ public:
// make sure this connection is running on the main thread
QCoreApplication *instance = QCoreApplication::instance();
if (!instance) {
+#ifndef QT_NO_DEBUG
qWarning("QDBusConnection: %s D-Bus connection created before QCoreApplication. Application may misbehave.",
type == SessionBus ? "session" : type == SystemBus ? "system" : "generic");
+#endif
} else {
QDBusConnectionPrivate::d(*this)->moveToThread(instance->thread());
}

View File

@ -0,0 +1,10 @@
diff -up qt-everywhere-opensource-src-4.8.1/src/qt3support/qt3support.pro.debuginfo qt-everywhere-opensource-src-4.8.1/src/qt3support/qt3support.pro
--- qt-everywhere-opensource-src-4.8.1/src/qt3support/qt3support.pro.debuginfo 2012-03-14 09:01:17.000000000 -0500
+++ qt-everywhere-opensource-src-4.8.1/src/qt3support/qt3support.pro 2012-05-11 11:55:37.780070386 -0500
@@ -34,6 +34,3 @@ MOCDIR = .moc
*-g++*: QMAKE_CXXFLAGS += -fno-strict-aliasing
-CONFIG -= separate_debug_info
-CONFIG += no_debug_info
-

View File

@ -0,0 +1,26 @@
diff -up qt-everywhere-opensource-src-4.8.1/src/corelib/plugin/qelfparser_p.cpp.me qt-everywhere-opensource-src-4.8.1/src/corelib/plugin/qelfparser_p.cpp
--- qt-everywhere-opensource-src-4.8.1/src/corelib/plugin/qelfparser_p.cpp.me 2012-05-16 14:45:30.542709580 +0200
+++ qt-everywhere-opensource-src-4.8.1/src/corelib/plugin/qelfparser_p.cpp 2012-05-16 14:49:02.266017265 +0200
@@ -61,8 +61,8 @@ const char *QElfParser::parseSectionHead
+ sizeof(qelfaddr_t); // sh_addr
sh->offset = read<qelfoff_t>(data);
data += sizeof(qelfoff_t); // sh_offset
- sh->size = read<qelfword_t>(data);
- data += sizeof(qelfword_t); // sh_size
+ sh->size = read<qelfoff_t>(data);
+ data += sizeof(qelfoff_t); // sh_size
return data;
}
diff -up qt-everywhere-opensource-src-4.8.1/src/corelib/plugin/qelfparser_p.h.me qt-everywhere-opensource-src-4.8.1/src/corelib/plugin/qelfparser_p.h
--- qt-everywhere-opensource-src-4.8.1/src/corelib/plugin/qelfparser_p.h.me 2012-05-16 14:45:41.006724793 +0200
+++ qt-everywhere-opensource-src-4.8.1/src/corelib/plugin/qelfparser_p.h 2012-05-16 14:47:49.017910811 +0200
@@ -80,7 +80,7 @@ public:
qelfword_t name;
qelfword_t type;
qelfoff_t offset;
- qelfword_t size;
+ qelfoff_t size;
};
int m_endian;

View File

@ -1,21 +0,0 @@
diff -up qt-4.8/src/corelib/plugin/qlibrary.cpp.crash_ppc qt-4.8/src/corelib/plugin/qlibrary.cpp
--- qt-4.8/src/corelib/plugin/qlibrary.cpp.crash_ppc 2011-10-04 05:44:32.000000000 +0200
+++ qt-4.8/src/corelib/plugin/qlibrary.cpp 2011-11-30 15:49:44.185001452 +0100
@@ -371,7 +371,7 @@ static bool qt_unix_query(const QString
long pos = 0;
const char pattern[] = "pattern=QT_PLUGIN_VERIFICATION_DATA";
const ulong plen = qstrlen(pattern);
-#if defined (Q_OF_ELF) && defined(Q_CC_GNU)
+#if defined (Q_OF_ELF) && defined(Q_CC_GNU) && !(defined(__powerpc64__) || defined(__ppc64__))
int r = QElfParser().parse(filedata, fdlen, library, lib, &pos, &fdlen);
if (r == QElfParser::NoQtSection) {
if (pos > 0) {
@@ -393,7 +393,7 @@ static bool qt_unix_query(const QString
}
#else
pos = qt_find_pattern(filedata, fdlen, pattern, plen);
-#endif // defined(Q_OF_ELF) && defined(Q_CC_GNU)
+#endif // defined(Q_OF_ELF) && defined(Q_CC_GNU) && !(defined(__powerpc64__) || defined(__ppc64__))
bool ret = false;
if (pos >= 0)
ret = qt_parse_pattern(filedata + pos, version, debug, key);

111
qt.spec
View File

@ -7,17 +7,22 @@
# See http://bugzilla.redhat.com/223663
%define multilib_archs x86_64 %{ix86} ppc64 ppc s390x s390 sparc64 sparcv9
%if 0%{?fedora} > 16 || 0%{?rhel} > 6
# use external qt_settings pkg
%define qt_settings 1
%endif
Summary: Qt toolkit
Name: qt
Epoch: 1
Version: 4.8.1
Release: 5%{?dist}
Version: 4.8.2
Release: 1%{?dist}
# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
License: (LGPLv2 with exceptions or GPLv3 with exceptions) and ASL 2.0 and BSD and FTL and MIT
Group: System Environment/Libraries
Url: http://qt.nokia.com/
Source0: http://get.qt.nokia.com/qt/source/qt-everywhere-opensource-src-%{version}.tar.gz
Source0: http://releases.qt-project.org/qt4/source/qt-everywhere-opensource-src-%{version}.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Obsoletes: qt4 < %{version}-%{release}
@ -46,6 +51,16 @@ Patch23: qt-everywhere-opensource-src-4.6.3-glib_eventloop_nullcheck.patch
# workaround for a MOC issue with Boost 1.48 headers (#756395)
Patch24: qt-everywhere-opensource-src-4.8.0-rc1-moc-boost148.patch
# hack out largely useless (to users) warnings about qdbusconnection
# (often in kde apps), keep an eye on https://git.reviewboard.kde.org/r/103699/
Patch25: qt-everywhere-opensource-src-4.8.1-qdbusconnection_no_debug.patch
# lrelease-qt4 tries to run qmake not qmake-qt4 (http://bugzilla.redhat.com/820767)
Patch26: qt-everywhere-opensource-src-4.8.1-linguist_qmake-qt4.patch
# enable debuginfo in libQt3Support
Patch27: qt-everywhere-opensource-src-4.8.1-qt3support_debuginfo.patch
## upstreamable bits
# fix invalid inline assembly in qatomic_{i386,x86_64}.h (de)ref implementations
Patch53: qt-x11-opensource-src-4.5.0-fix-qatomic-inline-asm.patch
@ -87,30 +102,21 @@ Patch73: qt-everywhere-opensource-src-4.8.0-qtwebkit-glib231.patch
# sql/drivers/tds/qsql_tds.cpp:341:49: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
Patch74: qt-everywhere-opensource-src-4.7.4-tds_no_strict_aliasing.patch
# workaround crash on ppc64
Patch75: qt-ppc64-crash.patch
# add missing method for QBasicAtomicPointer on s390(x)
Patch76: qt-everywhere-opensource-src-4.8.0-s390-atomic.patch
# don't spam if libicu is not present at runtime
Patch77: qt-everywhere-opensource-src-4.8.0-icu_no_spam.patch
# fix qvfb build
Patch79: qt-everywhere-opensource-src-4.8.0-qvfb.patch
# don't spam in release/no_debug mode if libicu is not present at runtime
Patch77: qt-everywhere-opensource-src-4.8.1-icu_no_debug.patch
# gcc doesn't support flag -fuse-ld=gold
Patch80: qt-everywhere-opensource-src-4.8.0-ld-gold.patch
# gcc-4.7 build issue
Patch81: qt-everywhere-opensource-src-4.8.0-gcc-4.7.patch
# upstream patches
# http://codereview.qt-project.org/#change,22006
Patch100: qt-everywhere-opensource-src-4.8.1-qtgahandle.patch
# Fix a crash in cursorToX() when new block is added
# http://codereview.qt-project.org/22142
Patch101: qt-everywhere-opensource-src-4.8.1-QTBUG-24718.patch
# fix crash on big endian machines
# https://bugreports.qt-project.org/browse/QTBUG-22960
Patch102: qt-everywhere-opensource-src-4.8.1-type.patch
# security patches
# CVE-2011-3922 qt: Stack-based buffer overflow in embedded harfbuzz code
@ -132,20 +138,26 @@ Source31: hi48-app-qt4-logo.png
## optional plugin bits
# set to -no-sql-<driver> to disable
# set to -qt-sql-<driver> to enable *in* qt library
%define ibase -plugin-sql-ibase
%define mysql -plugin-sql-mysql
%define odbc -plugin-sql-odbc
%define psql -plugin-sql-psql
%define sqlite -plugin-sql-sqlite
%define tds -plugin-sql-tds
%define phonon -phonon
%define phonon_backend -phonon-backend
%define dbus -dbus-linked
%define graphicssystem -graphicssystem raster
%define gtkstyle -gtkstyle
%if 0%{?fedora}
# FIXME/TODO: use system webkit for assistant, examples/webkit, demos/browser
%define webkit -webkit
%define ibase -plugin-sql-ibase
%define tds -plugin-sql-tds
%endif
%if 0%{?rhel}
%define no_javascript_jit -no-javascript-jit
%define ibase -no-sql-ibase
%define tds -no-sql-tds
%endif
# See http://bugzilla.redhat.com/196901
%define _qt4 %{name}
@ -233,6 +245,9 @@ BuildRequires: freetds-devel
Obsoletes: qgtkstyle < 0.1
Provides: qgtkstyle = 0.1-1
Requires: ca-certificates
%if 0%{?qt_settings}
Requires: qt-settings
%endif
%description
Qt is a software toolkit for developing applications.
@ -415,6 +430,9 @@ rm -fv mkspecs/linux-g++*/qmake.conf.multilib-optflags
%patch15 -p1 -b .enable_ft_lcdfilter
%patch23 -p1 -b .glib_eventloop_nullcheck
%patch24 -p1 -b .moc-boost148
%patch25 -p1 -b .qdbusconnection_no_debug.patch
%patch26 -p1 -b .linguist_qtmake-qt4
%patch27 -p1 -b .qt3support_debuginfo
## TODO: still worth carrying? if so, upstream it.
%patch53 -p1 -b .qatomic-inline-asm
## TODO: upstream me
@ -427,22 +445,19 @@ rm -fv mkspecs/linux-g++*/qmake.conf.multilib-optflags
%patch69 -p1 -b .QTBUG-22037
%patch70 -p1 -b .QTBUG-14724
%patch71 -p1 -b .QTBUG-21900
%if 0%{?fedora} > 16
%if 0%{?fedora} > 16 || 0%{?rhel} > 6
# This quick fix works ONLY with GLib >= 2.31. It's harder to fix this portably.
# See https://bugs.webkit.org/show_bug.cgi?id=69840 for the gory details.
%patch73 -p1 -b .qtwebkit-glib231
%endif
%patch74 -p1 -b .tds_no_strict_aliasing
%patch75 -p1 -b .ppc64-crash
%patch76 -p1 -b .s390-atomic
%patch77 -p1 -b .icu_no_spam
%patch79 -p1 -b .qvfb
%patch77 -p1 -b .icu_no_debug
%patch80 -p1 -b .ld.gold
%patch81 -p1 -b .gcc-4.7
# upstream patches
%patch100 -p1 -b .QTgaHandler
%patch101 -p1 -b .QTBUG-24718
%patch102 -p1 -b .bigendian
# security fixes
%patch200 -p1 -b .CVE-2011-3922
@ -463,8 +478,7 @@ RPM_OPT_FLAGS=`echo $RPM_OPT_FLAGS | sed 's|-fexceptions||g'`
%endif
sed -i -e "s|-O2|$RPM_OPT_FLAGS|g" \
mkspecs/%{platform}/qmake.conf \
mkspecs/common/g*base.conf
mkspecs/%{platform}/qmake.conf
# undefine QMAKE_STRIP, so we get useful -debuginfo pkgs
sed -i -e "s|^QMAKE_STRIP.*=.*|QMAKE_STRIP =|" mkspecs/common/linux.conf
@ -668,17 +682,22 @@ popd
echo "%{_qt4_libdir}" > %{buildroot}/etc/ld.so.conf.d/qt4-%{__isa_bits}.conf
%endif
%if ! 0%{?qt_settings}
# Trolltech.conf
install -p -m644 -D %{SOURCE4} %{buildroot}%{_qt4_sysconfdir}/Trolltech.conf
%endif
# qt4-logo (generic) icons
install -p -m644 -D %{SOURCE30} %{buildroot}%{_datadir}/icons/hicolor/128x128/apps/qt4-logo.png
install -p -m644 -D %{SOURCE31} %{buildroot}%{_datadir}/icons/hicolor/48x48/apps/qt4-logo.png
# assistant icons
install -p -m644 -D tools/assistant/tools/assistant/images/assistant.png %{buildroot}%{_datadir}/icons/hicolor/32x32/apps/assistant.png
install -p -m644 -D tools/assistant/tools/assistant/images/assistant-128.png %{buildroot}%{_datadir}/icons/hicolor/128x128/apps/assistant.png
# designer icons
install -p -m644 -D tools/designer/src/designer/images/designer.png %{buildroot}%{_datadir}/icons/hicolor/128x128/apps/designer.png
# linguist icons
for icon in tools/linguist/linguist/images/icons/linguist-*-32.png ; do
size=$(echo $(basename ${icon}) | cut -d- -f2)
@ -749,6 +768,7 @@ rm -fv %{buildroot}%{_qt4_plugindir}/designer/libphononwidgets.so
# backend
rm -fv %{buildroot}%{_qt4_plugindir}/phonon_backend/*_gstreamer.so
rm -fv %{buildroot}%{_datadir}/kde4/services/phononbackends/gstreamer.desktop
# nuke bundled webkit bits
rm -fv %{buildroot}%{_qt4_datadir}/mkspecs/modules/qt_webkit_version.pri
rm -fv %{buildroot}%{_qt4_headerdir}/Qt/qgraphicswebview.h
@ -844,7 +864,9 @@ fi
%if "%{_qt4_sysconfdir}" != "%{_sysconfdir}"
%dir %{_qt4_sysconfdir}
%endif
%if ! 0%{?qt_settings}
%config(noreplace) %{_qt4_sysconfdir}/Trolltech.conf
%endif
%{_qt4_datadir}/phrasebooks/
%{_qt4_libdir}/libQtCore.so.4*
%if 0%{?dbus:1}
@ -1067,6 +1089,39 @@ fi
%changelog
* Tue May 22 2012 Than Ngo <than@redhat.com> - 4.8.2-1
- 4.8.2
* Fri May 18 2012 Than Ngo <than@redhat.com> - 4.8.1-15
- add rhel/fedora condition
* Thu May 17 2012 Rex Dieter <rdieter@fedoraproject.org> 4.8.1-14
- Can't build 32bit Qt release application on 64bit (#822710)
* Wed May 16 2012 Than Ngo <than@redhat.com> - 4.8.1-13
- add upstream patch to fix crash on big endian machine
* Fri May 11 2012 Rex Dieter <rdieter@fedoraproject.org> 4.8.1-12
- enable debuginfo in libQt3Support
* Fri May 11 2012 Rex Dieter <rdieter@fedoraproject.org> 4.8.1-11
- lrelease-qt4 tries to run qmake not qmake-qt4 (#820767)
* Thu May 10 2012 Rex Dieter <rdieter@fedoraproject.org> 4.8.1-10
- Requires: qt-settings (f17+)
* Tue May 08 2012 Rex Dieter <rdieter@fedoraproject.org> 4.8.1-9
- rebuild (libtiff)
* Thu May 03 2012 Than Ngo <than@redhat.com> - 4.8.1-8
- add rhel/fedora condition
* Wed Apr 18 2012 Than Ngo <than@redhat.com> - 4.8.1-7
- add rhel condition
* Tue Apr 17 2012 Rex Dieter <rdieter@fedoraproject.org> 4.8.1-6
- omit qdbusconnection warnings in release/no-debug mode
* Tue Apr 03 2012 Jaroslav Reznik <jreznik@redhat.com> - 4.8.1-5
- Fix a crash in cursorToX() when new block is added (QTBUG-24718)

View File

@ -1,3 +1,3 @@
d9f511e4b51983b4e10eb58b320416d5 hi128-app-qt4-logo.png
6dcc0672ff9e60a6b83f95c5f42bec5b hi48-app-qt4-logo.png
7960ba8e18ca31f0c6e4895a312f92ff qt-everywhere-opensource-src-4.8.1.tar.gz
3c1146ddf56247e16782f96910a8423b qt-everywhere-opensource-src-4.8.2.tar.gz