add more moc/boost workarounds, thanks boost-1.53 (QTBUG-22829)

This commit is contained in:
Rex Dieter 2013-02-11 07:11:51 -06:00
parent 8637627296
commit 22f92f680b
3 changed files with 22 additions and 39 deletions

View File

@ -1,33 +0,0 @@
From a6305580b27f0bf1d268b5a3531c8332a57c3864 Mon Sep 17 00:00:00 2001
From: Kevin Kofler <Kevin@tigcc.ticalc.org>
Date: Sun, 25 Nov 2012 16:20:00 +0000
Subject: [PATCH 13/90] Fix moc from choking on boost headers.
Fixes several build failures with boost >= 1.48, for example
the kdepim build: https://bugs.kde.org/show_bug.cgi?id=304111
Task-number: QTBUG-22829
Change-Id: Ic37a5290955fbfd18894a228cc9d57615edddea6
Reviewed-by: Olivier Goffart <ogoffart@woboq.com>
---
src/tools/moc/main.cpp | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/src/tools/moc/main.cpp b/src/tools/moc/main.cpp
index 33344fc..f558a5e 100644
--- a/src/tools/moc/main.cpp
+++ b/src/tools/moc/main.cpp
@@ -187,6 +187,10 @@ int runMoc(int _argc, char **_argv)
Moc moc;
pp.macros["Q_MOC_RUN"];
pp.macros["__cplusplus"];
+
+ // Workaround a bug while parsing the boost/type_traits/has_operator.hpp header. See QTBUG-22829
+ pp.macros["BOOST_TT_HAS_OPERATOR_HPP_INCLUDED"];
+
QByteArray filename;
QByteArray output;
FILE *in = 0;
--
1.8.1

View File

@ -0,0 +1,15 @@
diff -up qt-everywhere-opensource-src-4.8.4/src/tools/moc/main.cpp.moc-boost148 qt-everywhere-opensource-src-4.8.4/src/tools/moc/main.cpp
--- qt-everywhere-opensource-src-4.8.4/src/tools/moc/main.cpp.moc-boost148 2012-11-23 04:09:53.000000000 -0600
+++ qt-everywhere-opensource-src-4.8.4/src/tools/moc/main.cpp 2013-02-11 07:07:18.942748176 -0600
@@ -187,6 +187,11 @@ int runMoc(int _argc, char **_argv)
Moc moc;
pp.macros["Q_MOC_RUN"];
pp.macros["__cplusplus"];
+
+ // Workaround a bugs while parsing some boost headers. See QTBUG-22829
+ pp.macros["BOOST_TT_HAS_OPERATOR_HPP_INCLUDED"];
+ pp.macros["BOOST_LEXICAL_CAST_INCLUDED"];
+
QByteArray filename;
QByteArray output;
FILE *in = 0;

13
qt.spec
View File

@ -20,7 +20,7 @@ Summary: Qt toolkit
Name: qt
Epoch: 1
Version: 4.8.4
Release: 11%{?dist}
Release: 12%{?dist}
# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
License: (LGPLv2 with exceptions or GPLv3 with exceptions) and ASL 2.0 and BSD and FTL and MIT
@ -124,10 +124,8 @@ Patch100: qt-everywhere-opensource-src-4.8.1-qtgahandle.patch
# http://bugzilla.redhat.com/702493
# https://bugreports.qt-project.org/browse/QTBUG-5545
Patch102: qt-everywhere-opensource-src-4.8.4-qgtkstyle_disable_gtk_theme_check.patch
# workaround for a MOC issue with Boost 1.48 headers (#756395)
# FIXME: add PROGRAM_OPTIONS_VP_2003_05_19 (boost/program_options.hpp) akonadi
# FIXME: add PYTHON_DWA2002810_HPP (boost/python.hpp) avogadro
Patch113: 0013-Fix-moc-from-choking-on-boost-headers.patch
# workaround for MOC issues with Boost headers (#756395,QTBUG-22829)
Patch113: qt-everywhere-opensource-src-4.8.4-QTBUG-22829.patch
# QSslSocket may report incorrect errors when certificate verification fails
# https://codereview.qt-project.org/#change,42461
Patch154: 0054-Fix-binary-incompatibility-between-openssl-versions.patch
@ -480,7 +478,7 @@ rm -fv mkspecs/linux-g++*/qmake.conf.multilib-optflags
# upstream patches
%patch100 -p1 -b .QTgaHandler
%patch102 -p1 -b .qgtkstyle_disable_gtk_theme_check
%patch113 -p1 -b .moc-boost148
%patch113 -p1 -b .QTBUG-22829
%patch154 -p1 -b .0054
%patch180 -p1 -b .0080
%patch190 -p1 -b .0090
@ -1149,6 +1147,9 @@ fi
%changelog
* Mon Feb 11 2013 Rex Dieter <rdieter@fedoraproject.org> 4.8.4-12
- add more moc/boost workarounds, thanks boost-1.53 (QTBUG-22829)
* Mon Feb 04 2013 Than Ngo <than@redhat.com> - 4.8.4-11
- backport: fix security flaw was found in the way QSharedMemory class, CVE-2013-0254