more gcc5 detection fixes, in particular, ensure same QT_BUILD_KEY as gcc4 for now

This commit is contained in:
Rex Dieter 2015-02-16 08:37:08 -06:00
parent b888d1c64e
commit 1244f6a379
3 changed files with 36 additions and 6 deletions

View File

@ -1,7 +1,16 @@
diff -up qt-everywhere-opensource-src-4.8.6/configure.gcc5 qt-everywhere-opensource-src-4.8.6/configure
--- qt-everywhere-opensource-src-4.8.6/configure.gcc5 2015-02-13 06:57:07.229735742 -0600
+++ qt-everywhere-opensource-src-4.8.6/configure 2015-02-13 07:00:59.103801127 -0600
@@ -8038,6 +8038,11 @@ g++*)
diff -up qt-everywhere-opensource-src-4.8.6/configure.fix_detection_of_gcc5 qt-everywhere-opensource-src-4.8.6/configure
--- qt-everywhere-opensource-src-4.8.6/configure.fix_detection_of_gcc5 2014-04-10 13:37:08.000000000 -0500
+++ qt-everywhere-opensource-src-4.8.6/configure 2015-02-16 08:36:16.363785377 -0600
@@ -7729,7 +7729,7 @@ case "$XPLATFORM" in
*-g++*)
# Check gcc's version
case "$(${QMAKE_CONF_COMPILER} -dumpversion)" in
- 4*|3.4*)
+ 5*|4*|3.4*)
;;
3.3*)
canBuildWebKit="no"
@@ -8031,6 +8031,11 @@ g++*)
QT_GCC_MINOR_VERSION=`echo $COMPILER_VERSION | sed 's,^\([0-9]*\)\.\([0-9]*\).*,\2,'`
QT_GCC_PATCH_VERSION=0
;;

View File

@ -0,0 +1,12 @@
diff -up qt-everywhere-opensource-src-4.8.6/configure.qt_build_key qt-everywhere-opensource-src-4.8.6/configure
--- qt-everywhere-opensource-src-4.8.6/configure.qt_build_key 2015-02-16 08:00:01.698531648 -0600
+++ qt-everywhere-opensource-src-4.8.6/configure 2015-02-16 08:06:43.198794608 -0600
@@ -8044,7 +8044,7 @@ g++*)
3.*)
COMPILER_VERSION="3.*"
;;
- 4.*)
+ 5.*|4.*)
COMPILER_VERSION="4"
;;
*)

13
qt.spec
View File

@ -35,7 +35,7 @@ Summary: Qt toolkit
Name: qt
Epoch: 1
Version: 4.8.6
Release: 23%{?dist}
Release: 24%{?dist}
# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
License: (LGPLv2 with exceptions or GPLv3 with exceptions) and ASL 2.0 and BSD and FTL and MIT
@ -98,10 +98,14 @@ Patch28: qt-everywhere-opensource-src-4.8.5-qt_plugin_path.patch
# add support for pkgconfig's Requires.private to qmake
Patch50: qt-everywhere-opensource-src-4.8.4-qmake_pkgconfig_requires_private.patch
# backport 'Fix detection of GCC5'
# backport part of 'Fix detection of GCC5'
# https://qt.gitorious.org/qt/qtbase/commit/9fb4c2c412621b63c06dbbd899f44041b2e126c2
Patch51: qt-fix_detection_of_gcc5.patch
# F22's gcc5 uses gcc4 ABI, so ensure QT_BUILD_KEY remains the same too
# TODO: ask upstream how to handle gcc5 moving forward, use g++-5 or not?
Patch52: qt-gcc5_compat_qt_build_key.patch
# fix invalid inline assembly in qatomic_{i386,x86_64}.h (de)ref implementations
Patch53: qt-x11-opensource-src-4.5.0-fix-qatomic-inline-asm.patch
@ -544,6 +548,8 @@ rm -fv mkspecs/linux-g++*/qmake.conf.multilib-optflags
%patch28 -p1 -b .qt_plugin_path
%patch50 -p1 -b .qmake_pkgconfig_requires_private
%patch51 -p1 -b .fix_detection_of_gcc5
error
%patch52 -p1 -b .gcc5_compat_qt_build_key
## TODO: still worth carrying? if so, upstream it.
%patch53 -p1 -b .qatomic-inline-asm
## TODO: upstream me
@ -1308,6 +1314,9 @@ fi
%changelog
* Mon Feb 16 2015 Rex Dieter <rdieter@fedoraproject.org> 1:4.8.6-24
- more gcc5 detection fixes, in particular, ensure same QT_BUILD_KEY as gcc4 for now
* Fri Feb 13 2015 Rex Dieter <rdieter@fedoraproject.org> - 1:4.8.6-23
- Qt: FTBFS with gcc5 (#1192464)
- Make Adwaita the default theme for applications running in the GNOME DE (#1192453)