import no_Werror patch from qtwebkit

This commit is contained in:
Rex Dieter 2011-09-17 15:13:04 -05:00
parent e5126ea57e
commit 10cc1b1e10
2 changed files with 21 additions and 3 deletions

12
qt.spec
View File

@ -69,6 +69,10 @@ Patch66: qt-everywhere-opensource-src-4.8.0-tp-openssl.patch
# fix the outdated standalone copy of JavaScriptCore
Patch67: qt-everywhere-opensource-src-4.8.0-beta1-s390.patch
# https://bugs.webkit.org/show_bug.cgi?id=63941
# -Wall + -Werror = fail
Patch68: webkit-qtwebkit-2.2-no_Werror.patch
# upstream patches
# security patches
@ -370,9 +374,8 @@ Qt libraries used for drawing widgets and OpenGL items.
%prep
%setup -q -n qt-everywhere-opensource-src-%{version}
%setup -D -a 100 -n qt-everywhere-opensource-src-%{version}
%setup -q -n qt-everywhere-opensource-src-%{version} -a 100
#setup -q -D -a 100 -n qt-everywhere-opensource-src-%{version}
%patch2 -p1 -b .multilib-optflags
# drop backup file(s), else they get installed too, http://bugzilla.redhat.com/639463
@ -390,6 +393,9 @@ rm -fv mkspecs/linux-g++*/qmake.conf.multilib-optflags
%patch65 -p1 -b .qtreeview-kpackagekit-crash
%patch66 -p1 -b .ssl
%patch67 -p1 -b .s390
pushd src/3rdparty/webkit
%patch68 -p1 -b .no_Werror
popd
# upstream patches

View File

@ -0,0 +1,12 @@
diff -up webkit-qtwebkit/Source/WebKit.pri.Werror webkit-qtwebkit/Source/WebKit.pri
--- webkit-qtwebkit/Source/WebKit.pri.Werror 2011-05-12 09:42:28.000000000 -0500
+++ webkit-qtwebkit/Source/WebKit.pri 2011-05-13 12:42:09.956080365 -0500
@@ -92,7 +92,7 @@ CONFIG -= warn_on
# Treat warnings as errors on x86/Linux/GCC
linux-g++* {
- isEqual(QT_ARCH,x86_64)|isEqual(QT_ARCH,i386): QMAKE_CXXFLAGS += -Werror
+ #isEqual(QT_ARCH,x86_64)|isEqual(QT_ARCH,i386): QMAKE_CXXFLAGS += -Werror
greaterThan(QT_GCC_MAJOR_VERSION, 3):greaterThan(QT_GCC_MINOR_VERSION, 5) {
if (!contains(QMAKE_CXXFLAGS, -std=c++0x) && !contains(QMAKE_CXXFLAGS, -std=gnu++0x)) {