drop multilib portion from qt_plugin_path.patch
This commit is contained in:
parent
085037d44f
commit
088b772329
@ -1,7 +1,7 @@
|
|||||||
diff -up qt-everywhere-opensource-src-4.8.5/src/corelib/kernel/qcoreapplication.cpp.kde4_plugins qt-everywhere-opensource-src-4.8.5/src/corelib/kernel/qcoreapplication.cpp
|
diff -up qt-everywhere-opensource-src-4.8.5/src/corelib/kernel/qcoreapplication.cpp.qt_plugin_path qt-everywhere-opensource-src-4.8.5/src/corelib/kernel/qcoreapplication.cpp
|
||||||
--- qt-everywhere-opensource-src-4.8.5/src/corelib/kernel/qcoreapplication.cpp.kde4_plugins 2013-06-07 00:16:52.000000000 -0500
|
--- qt-everywhere-opensource-src-4.8.5/src/corelib/kernel/qcoreapplication.cpp.qt_plugin_path 2013-06-07 00:16:52.000000000 -0500
|
||||||
+++ qt-everywhere-opensource-src-4.8.5/src/corelib/kernel/qcoreapplication.cpp 2013-06-18 13:31:35.357173956 -0500
|
+++ qt-everywhere-opensource-src-4.8.5/src/corelib/kernel/qcoreapplication.cpp 2013-06-21 07:14:10.045039936 -0500
|
||||||
@@ -2511,6 +2511,24 @@ QStringList QCoreApplication::libraryPat
|
@@ -2511,6 +2511,15 @@ QStringList QCoreApplication::libraryPat
|
||||||
if (!app_libpaths->contains(installPathPlugins))
|
if (!app_libpaths->contains(installPathPlugins))
|
||||||
app_libpaths->append(installPathPlugins);
|
app_libpaths->append(installPathPlugins);
|
||||||
}
|
}
|
||||||
@ -13,15 +13,6 @@ diff -up qt-everywhere-opensource-src-4.8.5/src/corelib/kernel/qcoreapplication.
|
|||||||
+ //kde4PathPlugins = QDir(kde4PathPlugins).canonicalPath();
|
+ //kde4PathPlugins = QDir(kde4PathPlugins).canonicalPath();
|
||||||
+ if (!app_libpaths->contains(kde4PathPlugins))
|
+ if (!app_libpaths->contains(kde4PathPlugins))
|
||||||
+ app_libpaths->append(kde4PathPlugins);
|
+ app_libpaths->append(kde4PathPlugins);
|
||||||
+ }
|
|
||||||
+
|
|
||||||
+ // hack in support for multilib qt4 plugin path -- Rex
|
|
||||||
+ QString qt4_multilibPathPlugins = QLatin1String("/usr/lib/qt4/plugins");
|
|
||||||
+ if (QFile::exists(qt4_multilibPathPlugins)) {
|
|
||||||
+ // Make sure we convert from backslashes to slashes.
|
|
||||||
+ //qt4_multilibPathPlugins = QDir(qt4_multilibPathPlugins).canonicalPath();
|
|
||||||
+ if (!app_libpaths->contains(qt4_multilibPathPlugins))
|
|
||||||
+ app_libpaths->append(qt4_multilibPathPlugins);
|
|
||||||
+ }
|
+ }
|
||||||
#endif
|
#endif
|
||||||
|
|
||||||
|
5
qt.spec
5
qt.spec
@ -27,7 +27,7 @@ Summary: Qt toolkit
|
|||||||
Name: qt
|
Name: qt
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 4.8.5
|
Version: 4.8.5
|
||||||
Release: 0.4.%{pre}%{?dist}
|
Release: 0.5.%{pre}%{?dist}
|
||||||
|
|
||||||
# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
|
# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
|
||||||
License: (LGPLv2 with exceptions or GPLv3 with exceptions) and ASL 2.0 and BSD and FTL and MIT
|
License: (LGPLv2 with exceptions or GPLv3 with exceptions) and ASL 2.0 and BSD and FTL and MIT
|
||||||
@ -1173,6 +1173,9 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jun 21 2013 Rex Dieter <rdieter@fedoraproject.org> 4.8.5-0.5.rc2
|
||||||
|
- drop multilib portion from qt_plugin_path.patch
|
||||||
|
|
||||||
* Tue Jun 18 2013 Rex Dieter <rdieter@fedoraproject.org> 4.8.5-0.4.rc2
|
* Tue Jun 18 2013 Rex Dieter <rdieter@fedoraproject.org> 4.8.5-0.4.rc2
|
||||||
- (re)add kde4/multilib QT_PLUGIN_PATH
|
- (re)add kde4/multilib QT_PLUGIN_PATH
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user