1:4.8.3-1
- qt-4.8.3 final - revert QtScript-JIT commit
This commit is contained in:
parent
4f64405c27
commit
087ab1fb17
11
.gitignore
vendored
11
.gitignore
vendored
@ -1,13 +1,4 @@
|
|||||||
/hi128-app-qt4-logo.png
|
/hi128-app-qt4-logo.png
|
||||||
/hi48-app-qt4-logo.png
|
/hi48-app-qt4-logo.png
|
||||||
/gstreamer-logo.svg
|
|
||||||
/hi128-phonon-gstreamer.png
|
|
||||||
/hi16-phonon-gstreamer.png
|
|
||||||
/hi22-phonon-gstreamer.png
|
|
||||||
/hi32-phonon-gstreamer.png
|
|
||||||
/hi48-phonon-gstreamer.png
|
|
||||||
/hi64-phonon-gstreamer.png
|
|
||||||
/qt-everywhere-opensource-src-4.7.4.tar.gz
|
|
||||||
/qt-everywhere-opensource-src-4.8.0.tar.gz
|
|
||||||
/qt-everywhere-opensource-src-4.8.1.tar.gz
|
|
||||||
/qt-everywhere-opensource-src-4.8.2.tar.gz
|
/qt-everywhere-opensource-src-4.8.2.tar.gz
|
||||||
|
/qt-everywhere-opensource-src-4.8.3.tar.gz
|
||||||
|
@ -1,12 +0,0 @@
|
|||||||
diff -up qt-everywhere-opensource-src-4.8.1/src/3rdparty/webkit/Source/WebKit.pri.no_Werror qt-everywhere-opensource-src-4.8.1/src/3rdparty/webkit/Source/WebKit.pri
|
|
||||||
--- qt-everywhere-opensource-src-4.8.1/src/3rdparty/webkit/Source/WebKit.pri.no_Werror 2012-03-14 15:01:29.000000000 +0100
|
|
||||||
+++ qt-everywhere-opensource-src-4.8.1/src/3rdparty/webkit/Source/WebKit.pri 2012-03-28 17:12:33.391294004 +0200
|
|
||||||
@@ -102,8 +102,6 @@ CONFIG -= warn_on
|
|
||||||
|
|
||||||
# Treat warnings as errors on x86/Linux/GCC
|
|
||||||
linux-g++* {
|
|
||||||
- !CONFIG(standalone_package):isEqual(QT_ARCH,x86_64)|isEqual(QT_ARCH,i386): QMAKE_CXXFLAGS += -Werror
|
|
||||||
-
|
|
||||||
greaterThan(QT_GCC_MAJOR_VERSION, 3):greaterThan(QT_GCC_MINOR_VERSION, 5) {
|
|
||||||
if (!contains(QMAKE_CXXFLAGS, -std=c++0x) && !contains(QMAKE_CXXFLAGS, -std=gnu++0x)) {
|
|
||||||
# We need to deactivate those warnings because some names conflicts with upcoming c++0x types (e.g.nullptr).
|
|
@ -1,32 +0,0 @@
|
|||||||
From ca89c49fa2c5cbb3945897046f33eed9f7da846c Mon Sep 17 00:00:00 2001
|
|
||||||
From: Jiang Jiang <jiang.jiang@nokia.com>
|
|
||||||
Date: Tue, 3 Jul 2012 10:17:49 +0200
|
|
||||||
Subject: Fix cursor truncate to include line position
|
|
||||||
|
|
||||||
Since we could have moved the line position (QTextLine::setPosition),
|
|
||||||
the truncating position should be adjusted with that.
|
|
||||||
|
|
||||||
Change-Id: Ie1acd4a1b6a4adfbeeb9ce8ee2dfa19d992470e8
|
|
||||||
Reviewed-by: Eskil Abrahamsen Blomfeldt <eskil.abrahamsen-blomfeldt@nokia.com>
|
|
||||||
---
|
|
||||||
src/gui/text/qtextlayout.cpp | 4 ++--
|
|
||||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/gui/text/qtextlayout.cpp b/src/gui/text/qtextlayout.cpp
|
|
||||||
index 16f7150..52f2793 100644
|
|
||||||
--- a/src/gui/text/qtextlayout.cpp
|
|
||||||
+++ b/src/gui/text/qtextlayout.cpp
|
|
||||||
@@ -2616,8 +2616,8 @@ qreal QTextLine::cursorToX(int *cursorPos, Edge edge) const
|
|
||||||
x += eng->offsetInLigature(si, pos, end, glyph_pos);
|
|
||||||
}
|
|
||||||
|
|
||||||
- if (eng->option.wrapMode() != QTextOption::NoWrap && x > line.width)
|
|
||||||
- x = line.width;
|
|
||||||
+ if (eng->option.wrapMode() != QTextOption::NoWrap && x > line.x + line.width)
|
|
||||||
+ x = line.x + line.width;
|
|
||||||
|
|
||||||
*cursorPos = pos + si->position;
|
|
||||||
return x.toReal();
|
|
||||||
--
|
|
||||||
1.7.10.4
|
|
||||||
|
|
@ -1,12 +0,0 @@
|
|||||||
diff -ur qt-everywhere-opensource-src-4.8.0/src/3rdparty/webkit/Source/JavaScriptCore/wtf/gobject/GTypedefs.h qt-everywhere-opensource-src-4.8.0-qtwebkit-glib231/src/3rdparty/webkit/Source/JavaScriptCore/wtf/gobject/GTypedefs.h
|
|
||||||
--- qt-everywhere-opensource-src-4.8.0/src/3rdparty/webkit/Source/JavaScriptCore/wtf/gobject/GTypedefs.h 2011-10-04 05:44:31.000000000 +0200
|
|
||||||
+++ qt-everywhere-opensource-src-4.8.0-qtwebkit-glib231/src/3rdparty/webkit/Source/JavaScriptCore/wtf/gobject/GTypedefs.h 2011-10-28 02:12:16.000000000 +0200
|
|
||||||
@@ -52,7 +52,7 @@
|
|
||||||
typedef struct _GHashTable GHashTable;
|
|
||||||
typedef struct _GInputStream GInputStream;
|
|
||||||
typedef struct _GList GList;
|
|
||||||
-typedef struct _GMutex GMutex;
|
|
||||||
+typedef union _GMutex GMutex;
|
|
||||||
typedef struct _GPatternSpec GPatternSpec;
|
|
||||||
typedef struct _GPollableOutputStream GPollableOutputStream;
|
|
||||||
typedef struct _GSocketClient GSocketClient;
|
|
@ -1,23 +0,0 @@
|
|||||||
diff -up qt-everywhere-opensource-src-4.8.1/src/corelib/tools/qlocale_icu.cpp.icu_no_spam qt-everywhere-opensource-src-4.8.1/src/corelib/tools/qlocale_icu.cpp
|
|
||||||
--- qt-everywhere-opensource-src-4.8.1/src/corelib/tools/qlocale_icu.cpp.icu_no_spam 2012-03-14 09:01:17.000000000 -0500
|
|
||||||
+++ qt-everywhere-opensource-src-4.8.1/src/corelib/tools/qlocale_icu.cpp 2012-04-17 07:30:01.652251482 -0500
|
|
||||||
@@ -83,7 +83,9 @@ bool qt_initIcu(const QString &localeStr
|
|
||||||
// resolve libicui18n
|
|
||||||
QLibrary lib(QLatin1String("icui18n"), QLatin1String(U_ICU_VERSION_SHORT));
|
|
||||||
if (!lib.load()) {
|
|
||||||
+#ifndef QT_NO_DEBUG
|
|
||||||
qWarning() << "Unable to load library icui18n" << lib.errorString();
|
|
||||||
+#endif
|
|
||||||
status = ErrorLoading;
|
|
||||||
return false;
|
|
||||||
}
|
|
||||||
@@ -112,7 +114,9 @@ bool qt_initIcu(const QString &localeStr
|
|
||||||
// resolve libicuuc
|
|
||||||
QLibrary ucLib(QLatin1String("icuuc"), QLatin1String(U_ICU_VERSION_SHORT));
|
|
||||||
if (!ucLib.load()) {
|
|
||||||
+#ifndef QT_NO_DEBUG
|
|
||||||
qWarning() << "Unable to load library icuuc" << ucLib.errorString();
|
|
||||||
+#endif
|
|
||||||
status = ErrorLoading;
|
|
||||||
return false;
|
|
||||||
}
|
|
@ -1,26 +0,0 @@
|
|||||||
diff -up qt-everywhere-opensource-src-4.8.1/src/corelib/plugin/qelfparser_p.cpp.me qt-everywhere-opensource-src-4.8.1/src/corelib/plugin/qelfparser_p.cpp
|
|
||||||
--- qt-everywhere-opensource-src-4.8.1/src/corelib/plugin/qelfparser_p.cpp.me 2012-05-16 14:45:30.542709580 +0200
|
|
||||||
+++ qt-everywhere-opensource-src-4.8.1/src/corelib/plugin/qelfparser_p.cpp 2012-05-16 14:49:02.266017265 +0200
|
|
||||||
@@ -61,8 +61,8 @@ const char *QElfParser::parseSectionHead
|
|
||||||
+ sizeof(qelfaddr_t); // sh_addr
|
|
||||||
sh->offset = read<qelfoff_t>(data);
|
|
||||||
data += sizeof(qelfoff_t); // sh_offset
|
|
||||||
- sh->size = read<qelfword_t>(data);
|
|
||||||
- data += sizeof(qelfword_t); // sh_size
|
|
||||||
+ sh->size = read<qelfoff_t>(data);
|
|
||||||
+ data += sizeof(qelfoff_t); // sh_size
|
|
||||||
return data;
|
|
||||||
}
|
|
||||||
|
|
||||||
diff -up qt-everywhere-opensource-src-4.8.1/src/corelib/plugin/qelfparser_p.h.me qt-everywhere-opensource-src-4.8.1/src/corelib/plugin/qelfparser_p.h
|
|
||||||
--- qt-everywhere-opensource-src-4.8.1/src/corelib/plugin/qelfparser_p.h.me 2012-05-16 14:45:41.006724793 +0200
|
|
||||||
+++ qt-everywhere-opensource-src-4.8.1/src/corelib/plugin/qelfparser_p.h 2012-05-16 14:47:49.017910811 +0200
|
|
||||||
@@ -80,7 +80,7 @@ public:
|
|
||||||
qelfword_t name;
|
|
||||||
qelfword_t type;
|
|
||||||
qelfoff_t offset;
|
|
||||||
- qelfword_t size;
|
|
||||||
+ qelfoff_t size;
|
|
||||||
};
|
|
||||||
|
|
||||||
int m_endian;
|
|
23
qt-everywhere-opensource-src-4.8.3-icu_no_debug.patch
Normal file
23
qt-everywhere-opensource-src-4.8.3-icu_no_debug.patch
Normal file
@ -0,0 +1,23 @@
|
|||||||
|
diff -up qt-everywhere-opensource-src-4.8.3/src/corelib/tools/qlocale_icu.cpp.icu_no_debug qt-everywhere-opensource-src-4.8.3/src/corelib/tools/qlocale_icu.cpp
|
||||||
|
--- qt-everywhere-opensource-src-4.8.3/src/corelib/tools/qlocale_icu.cpp.icu_no_debug 2012-09-06 02:33:45.000000000 -0500
|
||||||
|
+++ qt-everywhere-opensource-src-4.8.3/src/corelib/tools/qlocale_icu.cpp 2012-09-11 09:04:21.542379795 -0500
|
||||||
|
@@ -84,7 +84,9 @@ bool qt_initIcu(const QString &localeStr
|
||||||
|
QLibrary lib(QLatin1String("icui18n"), QLatin1String(U_ICU_VERSION_SHORT));
|
||||||
|
lib.setLoadHints(QLibrary::ImprovedSearchHeuristics);
|
||||||
|
if (!lib.load()) {
|
||||||
|
+#ifndef QT_NO_DEBUG
|
||||||
|
qWarning() << "Unable to load library icui18n" << lib.errorString();
|
||||||
|
+#endif
|
||||||
|
status = ErrorLoading;
|
||||||
|
return false;
|
||||||
|
}
|
||||||
|
@@ -114,7 +116,9 @@ bool qt_initIcu(const QString &localeStr
|
||||||
|
QLibrary ucLib(QLatin1String("icuuc"), QLatin1String(U_ICU_VERSION_SHORT));
|
||||||
|
ucLib.setLoadHints(QLibrary::ImprovedSearchHeuristics);
|
||||||
|
if (!ucLib.load()) {
|
||||||
|
+#ifndef QT_NO_DEBUG
|
||||||
|
qWarning() << "Unable to load library icuuc" << ucLib.errorString();
|
||||||
|
+#endif
|
||||||
|
status = ErrorLoading;
|
||||||
|
return false;
|
||||||
|
}
|
12
qt-everywhere-opensource-src-4.8.3-no_Werror.patch
Normal file
12
qt-everywhere-opensource-src-4.8.3-no_Werror.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up qt-everywhere-opensource-src-4.8.3/src/3rdparty/webkit/Source/WebKit.pri.no_Werror qt-everywhere-opensource-src-4.8.3/src/3rdparty/webkit/Source/WebKit.pri
|
||||||
|
--- qt-everywhere-opensource-src-4.8.3/src/3rdparty/webkit/Source/WebKit.pri.no_Werror 2012-09-06 02:33:50.000000000 -0500
|
||||||
|
+++ qt-everywhere-opensource-src-4.8.3/src/3rdparty/webkit/Source/WebKit.pri 2012-09-11 09:03:19.152159783 -0500
|
||||||
|
@@ -102,7 +102,7 @@ CONFIG -= warn_on
|
||||||
|
|
||||||
|
# Treat warnings as errors on x86/Linux/GCC
|
||||||
|
linux-g++* {
|
||||||
|
- !CONFIG(standalone_package):if(isEqual(QT_ARCH,x86_64)|isEqual(QT_ARCH,i386)): QMAKE_CXXFLAGS += -Werror
|
||||||
|
+ #!CONFIG(standalone_package):if(isEqual(QT_ARCH,x86_64)|isEqual(QT_ARCH,i386)): QMAKE_CXXFLAGS += -Werror
|
||||||
|
|
||||||
|
greaterThan(QT_GCC_MAJOR_VERSION, 3):greaterThan(QT_GCC_MINOR_VERSION, 5) {
|
||||||
|
if (!contains(QMAKE_CXXFLAGS, -std=c++0x) && !contains(QMAKE_CXXFLAGS, -std=gnu++0x)) {
|
@ -1,6 +1,6 @@
|
|||||||
diff -up qt-everywhere-opensource-src-4.8.1/src/dbus/qdbusconnection.cpp.qdbusconnection_nodebug qt-everywhere-opensource-src-4.8.1/src/dbus/qdbusconnection.cpp
|
diff -up qt-everywhere-opensource-src-4.8.3/src/dbus/qdbusconnection.cpp.qdbusconnection_no_debug.patch qt-everywhere-opensource-src-4.8.3/src/dbus/qdbusconnection.cpp
|
||||||
--- qt-everywhere-opensource-src-4.8.1/src/dbus/qdbusconnection.cpp.qdbusconnection_nodebug 2012-04-17 07:18:51.536629078 -0500
|
--- qt-everywhere-opensource-src-4.8.3/src/dbus/qdbusconnection.cpp.qdbusconnection_no_debug.patch 2012-09-06 02:33:44.000000000 -0500
|
||||||
+++ qt-everywhere-opensource-src-4.8.1/src/dbus/qdbusconnection.cpp 2012-04-17 07:18:56.910561895 -0500
|
+++ qt-everywhere-opensource-src-4.8.3/src/dbus/qdbusconnection.cpp 2012-09-11 08:55:29.854026815 -0500
|
||||||
@@ -1109,8 +1109,10 @@ public:
|
@@ -1109,8 +1109,10 @@ public:
|
||||||
// make sure this connection is running on the main thread
|
// make sure this connection is running on the main thread
|
||||||
QCoreApplication *instance = QCoreApplication::instance();
|
QCoreApplication *instance = QCoreApplication::instance();
|
||||||
@ -9,6 +9,6 @@ diff -up qt-everywhere-opensource-src-4.8.1/src/dbus/qdbusconnection.cpp.qdbusco
|
|||||||
qWarning("QDBusConnection: %s D-Bus connection created before QCoreApplication. Application may misbehave.",
|
qWarning("QDBusConnection: %s D-Bus connection created before QCoreApplication. Application may misbehave.",
|
||||||
type == SessionBus ? "session" : type == SystemBus ? "system" : "generic");
|
type == SessionBus ? "session" : type == SystemBus ? "system" : "generic");
|
||||||
+#endif
|
+#endif
|
||||||
} else {
|
} else if (QDBusConnectionPrivate::d(*this)) {
|
||||||
QDBusConnectionPrivate::d(*this)->moveToThread(instance->thread());
|
QDBusConnectionPrivate::d(*this)->moveToThread(instance->thread());
|
||||||
}
|
}
|
37
qt.spec
37
qt.spec
@ -15,14 +15,14 @@
|
|||||||
Summary: Qt toolkit
|
Summary: Qt toolkit
|
||||||
Name: qt
|
Name: qt
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 4.8.2
|
Version: 4.8.3
|
||||||
Release: 6%{?dist}
|
Release: 1%{?dist}
|
||||||
|
|
||||||
# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
|
# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
|
||||||
License: (LGPLv2 with exceptions or GPLv3 with exceptions) and ASL 2.0 and BSD and FTL and MIT
|
License: (LGPLv2 with exceptions or GPLv3 with exceptions) and ASL 2.0 and BSD and FTL and MIT
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
Url: http://qt.nokia.com/
|
Url: http://qt.nokia.com/
|
||||||
Source0: http://releases.qt-project.org/qt4/source/qt-everywhere-opensource-src-%{version}.tar.gz
|
Source0: http://releases.qt-project.org/qt4/source/qt-everywhere-opensource-src-%{version}%{?pre:-%{pre}}.tar.gz
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
Obsoletes: qt4 < %{version}-%{release}
|
Obsoletes: qt4 < %{version}-%{release}
|
||||||
@ -53,7 +53,7 @@ Patch24: qt-everywhere-opensource-src-4.8.0-rc1-moc-boost148.patch
|
|||||||
|
|
||||||
# hack out largely useless (to users) warnings about qdbusconnection
|
# hack out largely useless (to users) warnings about qdbusconnection
|
||||||
# (often in kde apps), keep an eye on https://git.reviewboard.kde.org/r/103699/
|
# (often in kde apps), keep an eye on https://git.reviewboard.kde.org/r/103699/
|
||||||
Patch25: qt-everywhere-opensource-src-4.8.1-qdbusconnection_no_debug.patch
|
Patch25: qt-everywhere-opensource-src-4.8.3-qdbusconnection_no_debug.patch
|
||||||
|
|
||||||
# lrelease-qt4 tries to run qmake not qmake-qt4 (http://bugzilla.redhat.com/820767)
|
# lrelease-qt4 tries to run qmake not qmake-qt4 (http://bugzilla.redhat.com/820767)
|
||||||
Patch26: qt-everywhere-opensource-src-4.8.1-linguist_qmake-qt4.patch
|
Patch26: qt-everywhere-opensource-src-4.8.1-linguist_qmake-qt4.patch
|
||||||
@ -83,7 +83,7 @@ Patch67: qt-everywhere-opensource-src-4.8.0-beta1-s390.patch
|
|||||||
|
|
||||||
# https://bugs.webkit.org/show_bug.cgi?id=63941
|
# https://bugs.webkit.org/show_bug.cgi?id=63941
|
||||||
# -Wall + -Werror = fail
|
# -Wall + -Werror = fail
|
||||||
Patch68: qt-4.8.1-webkit-no_Werror.patch
|
Patch68: qt-everywhere-opensource-src-4.8.3-no_Werror.patch
|
||||||
|
|
||||||
# revert qlist.h commit that seems to induce crashes in qDeleteAll<QList (QTBUG-22037)
|
# revert qlist.h commit that seems to induce crashes in qDeleteAll<QList (QTBUG-22037)
|
||||||
Patch69: qt-everywhere-opensource-src-4.8.0-QTBUG-22037.patch
|
Patch69: qt-everywhere-opensource-src-4.8.0-QTBUG-22037.patch
|
||||||
@ -94,10 +94,6 @@ Patch70: qt-everywhere-opensource-src-4.8.0-QTBUG-14724.patch
|
|||||||
# Buttons in Qt applications not clickable when run under gnome-shell (#742658, QTBUG-21900)
|
# Buttons in Qt applications not clickable when run under gnome-shell (#742658, QTBUG-21900)
|
||||||
Patch71: qt-everywhere-opensource-src-4.8.0-QTBUG-21900.patch
|
Patch71: qt-everywhere-opensource-src-4.8.0-QTBUG-21900.patch
|
||||||
|
|
||||||
# QtWebKit wtf library: GMutex is a union rather than a struct in GLib >= 2.31
|
|
||||||
# fixes FTBFS: https://bugs.webkit.org/show_bug.cgi?id=69840
|
|
||||||
Patch73: qt-everywhere-opensource-src-4.8.0-qtwebkit-glib231.patch
|
|
||||||
|
|
||||||
# workaround
|
# workaround
|
||||||
# sql/drivers/tds/qsql_tds.cpp:341:49: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
|
# sql/drivers/tds/qsql_tds.cpp:341:49: warning: dereferencing type-punned pointer will break strict-aliasing rules [-Wstrict-aliasing]
|
||||||
Patch74: qt-everywhere-opensource-src-4.7.4-tds_no_strict_aliasing.patch
|
Patch74: qt-everywhere-opensource-src-4.7.4-tds_no_strict_aliasing.patch
|
||||||
@ -106,7 +102,7 @@ Patch74: qt-everywhere-opensource-src-4.7.4-tds_no_strict_aliasing.patch
|
|||||||
Patch76: qt-everywhere-opensource-src-4.8.0-s390-atomic.patch
|
Patch76: qt-everywhere-opensource-src-4.8.0-s390-atomic.patch
|
||||||
|
|
||||||
# don't spam in release/no_debug mode if libicu is not present at runtime
|
# don't spam in release/no_debug mode if libicu is not present at runtime
|
||||||
Patch77: qt-everywhere-opensource-src-4.8.1-icu_no_debug.patch
|
Patch77: qt-everywhere-opensource-src-4.8.3-icu_no_debug.patch
|
||||||
|
|
||||||
# gcc doesn't support flag -fuse-ld=gold
|
# gcc doesn't support flag -fuse-ld=gold
|
||||||
Patch80: qt-everywhere-opensource-src-4.8.0-ld-gold.patch
|
Patch80: qt-everywhere-opensource-src-4.8.0-ld-gold.patch
|
||||||
@ -117,11 +113,6 @@ Patch81: ./qt-everywhere-opensource-src-4.8.2--assistant-crash.patch
|
|||||||
# upstream patches
|
# upstream patches
|
||||||
# http://codereview.qt-project.org/#change,22006
|
# http://codereview.qt-project.org/#change,22006
|
||||||
Patch100: qt-everywhere-opensource-src-4.8.1-qtgahandle.patch
|
Patch100: qt-everywhere-opensource-src-4.8.1-qtgahandle.patch
|
||||||
# text cursor blinks not in the current cell (kde#296490)
|
|
||||||
Patch101: qt-Fix-cursor-truncate-to-include-line-position.patch
|
|
||||||
# fix crash on big endian machines
|
|
||||||
# https://bugreports.qt-project.org/browse/QTBUG-22960
|
|
||||||
Patch102: qt-everywhere-opensource-src-4.8.1-type.patch
|
|
||||||
# fix JIT crash
|
# fix JIT crash
|
||||||
# https://bugreports.qt-project.org/browse/QTBUG-23871
|
# https://bugreports.qt-project.org/browse/QTBUG-23871
|
||||||
# https://bugs.kde.org/show_bug.cgi?id=297661
|
# https://bugs.kde.org/show_bug.cgi?id=297661
|
||||||
@ -440,7 +431,7 @@ rm -fv mkspecs/linux-g++*/qmake.conf.multilib-optflags
|
|||||||
%patch15 -p1 -b .enable_ft_lcdfilter
|
%patch15 -p1 -b .enable_ft_lcdfilter
|
||||||
%patch23 -p1 -b .glib_eventloop_nullcheck
|
%patch23 -p1 -b .glib_eventloop_nullcheck
|
||||||
%patch24 -p1 -b .moc-boost148
|
%patch24 -p1 -b .moc-boost148
|
||||||
%patch25 -p1 -b .qdbusconnection_no_debug.patch
|
%patch25 -p1 -b .qdbusconnection_no_debug
|
||||||
%patch26 -p1 -b .linguist_qtmake-qt4
|
%patch26 -p1 -b .linguist_qtmake-qt4
|
||||||
%patch27 -p1 -b .qt3support_debuginfo
|
%patch27 -p1 -b .qt3support_debuginfo
|
||||||
## TODO: still worth carrying? if so, upstream it.
|
## TODO: still worth carrying? if so, upstream it.
|
||||||
@ -455,11 +446,6 @@ rm -fv mkspecs/linux-g++*/qmake.conf.multilib-optflags
|
|||||||
%patch69 -p1 -b .QTBUG-22037
|
%patch69 -p1 -b .QTBUG-22037
|
||||||
%patch70 -p1 -b .QTBUG-14724
|
%patch70 -p1 -b .QTBUG-14724
|
||||||
%patch71 -p1 -b .QTBUG-21900
|
%patch71 -p1 -b .QTBUG-21900
|
||||||
%if 0%{?fedora} > 16 || 0%{?rhel} > 6
|
|
||||||
# This quick fix works ONLY with GLib >= 2.31. It's harder to fix this portably.
|
|
||||||
# See https://bugs.webkit.org/show_bug.cgi?id=69840 for the gory details.
|
|
||||||
%patch73 -p1 -b .qtwebkit-glib231
|
|
||||||
%endif
|
|
||||||
%patch74 -p1 -b .tds_no_strict_aliasing
|
%patch74 -p1 -b .tds_no_strict_aliasing
|
||||||
%patch76 -p1 -b .s390-atomic
|
%patch76 -p1 -b .s390-atomic
|
||||||
%patch77 -p1 -b .icu_no_debug
|
%patch77 -p1 -b .icu_no_debug
|
||||||
@ -468,9 +454,8 @@ rm -fv mkspecs/linux-g++*/qmake.conf.multilib-optflags
|
|||||||
|
|
||||||
# upstream patches
|
# upstream patches
|
||||||
%patch100 -p1 -b .QTgaHandler
|
%patch100 -p1 -b .QTgaHandler
|
||||||
%patch101 -p1 -b .fix_cursor_blink
|
## 4.8.3 includes this patch, revert it to avoid regressions for now -- rex
|
||||||
%patch102 -p1 -b .bigendian
|
%patch103 -p1 -R -b .QtScript_JIT
|
||||||
#patch103 -p1 -b .QtScript_JIT
|
|
||||||
|
|
||||||
# security fixes
|
# security fixes
|
||||||
%patch200 -p1 -b .CVE-2011-3922
|
%patch200 -p1 -b .CVE-2011-3922
|
||||||
@ -1102,6 +1087,10 @@ fi
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Sep 13 2012 Rex Dieter <rdieter@fedoraproject.org> - 1:4.8.3-1
|
||||||
|
- qt-4.8.3 final
|
||||||
|
- revert QtScript-JIT commit
|
||||||
|
|
||||||
* Tue Sep 04 2012 Rex Dieter <rdieter@fedoraproject.org> 4.8.2-6
|
* Tue Sep 04 2012 Rex Dieter <rdieter@fedoraproject.org> 4.8.2-6
|
||||||
- revert "fix QtScript JIT crash" patch, causes frequent segmentation faults (#853587)
|
- revert "fix QtScript JIT crash" patch, causes frequent segmentation faults (#853587)
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1,3 +1,3 @@
|
|||||||
d9f511e4b51983b4e10eb58b320416d5 hi128-app-qt4-logo.png
|
d9f511e4b51983b4e10eb58b320416d5 hi128-app-qt4-logo.png
|
||||||
6dcc0672ff9e60a6b83f95c5f42bec5b hi48-app-qt4-logo.png
|
6dcc0672ff9e60a6b83f95c5f42bec5b hi48-app-qt4-logo.png
|
||||||
3c1146ddf56247e16782f96910a8423b qt-everywhere-opensource-src-4.8.2.tar.gz
|
a663b6c875f8d7caa8ac9c30e4a4ec3b qt-everywhere-opensource-src-4.8.3.tar.gz
|
||||||
|
Loading…
Reference in New Issue
Block a user