(re)add kde4/multilib QT_PLUGIN_PATH
This commit is contained in:
parent
81d355e657
commit
085037d44f
28
qt-everywhere-opensource-src-4.8.5-qt_plugin_path.patch
Normal file
28
qt-everywhere-opensource-src-4.8.5-qt_plugin_path.patch
Normal file
@ -0,0 +1,28 @@
|
||||
diff -up qt-everywhere-opensource-src-4.8.5/src/corelib/kernel/qcoreapplication.cpp.kde4_plugins qt-everywhere-opensource-src-4.8.5/src/corelib/kernel/qcoreapplication.cpp
|
||||
--- qt-everywhere-opensource-src-4.8.5/src/corelib/kernel/qcoreapplication.cpp.kde4_plugins 2013-06-07 00:16:52.000000000 -0500
|
||||
+++ qt-everywhere-opensource-src-4.8.5/src/corelib/kernel/qcoreapplication.cpp 2013-06-18 13:31:35.357173956 -0500
|
||||
@@ -2511,6 +2511,24 @@ QStringList QCoreApplication::libraryPat
|
||||
if (!app_libpaths->contains(installPathPlugins))
|
||||
app_libpaths->append(installPathPlugins);
|
||||
}
|
||||
+
|
||||
+ // hack in support for kde4 plugin paths -- Rex
|
||||
+ QString kde4PathPlugins = QLibraryInfo::location(QLibraryInfo::LibrariesPath) + QLatin1String("/kde4/plugins");
|
||||
+ if (QFile::exists(kde4PathPlugins)) {
|
||||
+ // Make sure we convert from backslashes to slashes.
|
||||
+ //kde4PathPlugins = QDir(kde4PathPlugins).canonicalPath();
|
||||
+ if (!app_libpaths->contains(kde4PathPlugins))
|
||||
+ app_libpaths->append(kde4PathPlugins);
|
||||
+ }
|
||||
+
|
||||
+ // hack in support for multilib qt4 plugin path -- Rex
|
||||
+ QString qt4_multilibPathPlugins = QLatin1String("/usr/lib/qt4/plugins");
|
||||
+ if (QFile::exists(qt4_multilibPathPlugins)) {
|
||||
+ // Make sure we convert from backslashes to slashes.
|
||||
+ //qt4_multilibPathPlugins = QDir(qt4_multilibPathPlugins).canonicalPath();
|
||||
+ if (!app_libpaths->contains(qt4_multilibPathPlugins))
|
||||
+ app_libpaths->append(qt4_multilibPathPlugins);
|
||||
+ }
|
||||
#endif
|
||||
|
||||
// If QCoreApplication is not yet instantiated,
|
9
qt.spec
9
qt.spec
@ -27,7 +27,7 @@ Summary: Qt toolkit
|
||||
Name: qt
|
||||
Epoch: 1
|
||||
Version: 4.8.5
|
||||
Release: 0.3.%{pre}%{?dist}
|
||||
Release: 0.4.%{pre}%{?dist}
|
||||
|
||||
# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
|
||||
License: (LGPLv2 with exceptions or GPLv3 with exceptions) and ASL 2.0 and BSD and FTL and MIT
|
||||
@ -73,6 +73,9 @@ Patch26: qt-everywhere-opensource-src-4.8.1-linguist_qmake-qt4.patch
|
||||
# enable debuginfo in libQt3Support
|
||||
Patch27: qt-everywhere-opensource-src-4.8.1-qt3support_debuginfo.patch
|
||||
|
||||
# kde4/multilib QT_PLUGIN_PATH
|
||||
Patch28: qt-everywhere-opensource-src-4.8.5-qt_plugin_path.patch
|
||||
|
||||
## upstreamable bits
|
||||
# add support for pkgconfig's Requires.private to qmake
|
||||
Patch50: qt-everywhere-opensource-src-4.8.4-qmake_pkgconfig_requires_private.patch
|
||||
@ -467,6 +470,7 @@ rm -fv mkspecs/linux-g++*/qmake.conf.multilib-optflags
|
||||
%patch25 -p1 -b .qdbusconnection_no_debug
|
||||
%patch26 -p1 -b .linguist_qtmake-qt4
|
||||
%patch27 -p1 -b .qt3support_debuginfo
|
||||
%patch28 -p1 -b .qt_plugin_path
|
||||
%patch50 -p1 -b .qmake_pkgconfig_requires_private
|
||||
## TODO: still worth carrying? if so, upstream it.
|
||||
%patch53 -p1 -b .qatomic-inline-asm
|
||||
@ -1169,6 +1173,9 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Jun 18 2013 Rex Dieter <rdieter@fedoraproject.org> 4.8.5-0.4.rc2
|
||||
- (re)add kde4/multilib QT_PLUGIN_PATH
|
||||
|
||||
* Mon Jun 10 2013 Rex Dieter <rdieter@fedoraproject.org> 4.8.5-0.3.rc2
|
||||
- 4.8.5-rc2
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user