- drop the hack, apply patch to install Global header, gstreamer.desktop

and dbus services file
This commit is contained in:
Than Ngo 2009-06-07 14:01:42 +00:00
parent df025bf73d
commit 01e5321efa
3 changed files with 62 additions and 11 deletions

View File

@ -0,0 +1,39 @@
diff -up qt-x11-opensource-src-4.5.1/src/3rdparty/phonon/gstreamer/gstreamer.desktop.orig qt-x11-opensource-src-4.5.1/src/3rdparty/phonon/gstreamer/gstreamer.desktop
--- qt-x11-opensource-src-4.5.1/src/3rdparty/phonon/gstreamer/gstreamer.desktop.orig 2009-06-07 14:00:40.000000000 +0200
+++ qt-x11-opensource-src-4.5.1/src/3rdparty/phonon/gstreamer/gstreamer.desktop 2009-06-07 14:00:46.000000000 +0200
@@ -2,7 +2,7 @@
Type=Service
X-KDE-ServiceTypes=PhononBackend
MimeType=application/x-annodex;video/quicktime;video/x-quicktime;audio/x-m4a;application/x-quicktimeplayer;video/mkv;video/msvideo;video/x-msvideo;video/x-flic;audio/x-aiff;audio/aiff;audio/x-pn-aiff;audio/x-realaudio;audio/basic;audio/x-basic;audio/x-pn-au;audio/x-8svx;audio/8svx;audio/x-16sv;audio/168sv;image/x-ilbm;image/ilbm;video/x-anim;video/anim;image/png;image/x-png;video/mng;video/x-mng;audio/x-ogg;audio/x-speex+ogg;application/ogg;application/ogg;audio/vnd.rn-realaudio;audio/x-pn-realaudio-plugin;audio/x-real-audio;application/vnd.rn-realmedia;video/mpeg;video/x-mpeg;audio/x-wav;audio/wav;audio/x-pn-wav;audio/x-pn-windows-acm;audio/mpeg2;audio/x-mpeg2;audio/mpeg3;audio/x-mpeg3;audio/mpeg;audio/x-mpeg;x-mpegurl;audio/x-mpegurl;audio/mp3;audio/mpeg;
-X-KDE-Library=phonon_gstreamer
+X-KDE-Library=libphonon_gstreamer
X-KDE-PhononBackendInfo-InterfaceVersion=1
X-KDE-PhononBackendInfo-Version=0.1
X-KDE-PhononBackendInfo-Website=http://gstreamer.freedesktop.org/
diff -up qt-x11-opensource-src-4.5.1/src/phonon/phonon.pro.orig qt-x11-opensource-src-4.5.1/src/phonon/phonon.pro
--- qt-x11-opensource-src-4.5.1/src/phonon/phonon.pro.orig 2009-06-07 12:38:34.000000000 +0200
+++ qt-x11-opensource-src-4.5.1/src/phonon/phonon.pro 2009-06-07 13:55:48.000000000 +0200
@@ -112,4 +112,9 @@ contains(QT_CONFIG, dbus) {
DEFINES += QT_NO_DBUS
}
+# install dbus service file
+sources.files = $$PHONON_DIR/org.kde.Phonon.AudioOutput.xml
+sources.path = /usr/share/dbus-1/interfaces
+INSTALLS += sources
+
contains(QT_CONFIG, reduce_exports): CONFIG += hide_symbols
diff -up qt-x11-opensource-src-4.5.1/src/plugins/phonon/gstreamer/gstreamer.pro.orig qt-x11-opensource-src-4.5.1/src/plugins/phonon/gstreamer/gstreamer.pro
--- qt-x11-opensource-src-4.5.1/src/plugins/phonon/gstreamer/gstreamer.pro.orig 2009-06-07 13:11:28.000000000 +0200
+++ qt-x11-opensource-src-4.5.1/src/plugins/phonon/gstreamer/gstreamer.pro 2009-06-07 13:57:15.000000000 +0200
@@ -62,6 +62,9 @@ SOURCES += $$PHONON_GSTREAMER_DIR/audioo
}
target.path = $$[QT_INSTALL_PLUGINS]/phonon_backend
-INSTALLS += target
+services.files = $$PHONON_GSTREAMER_DIR/gstreamer.desktop
+services.path = kde4/services/phononbackends
+services.path = /usr/share/kde4/services/phononbackends
+INSTALLS += target services
include(../../qpluginbase.pri)

View File

@ -0,0 +1,11 @@
--- qt-x11-opensource-src-4.5.1/configure 2009-04-22 01:57:35.000000000 +0200
+++ qt-x11-opensource-src-4.5.1.new/configure 2009-06-02 17:58:00.000000000 +0200
@@ -3970,7 +3984,7 @@
[ "$CFG_DEV" = "yes" ] && SYNCQT_OPTS="$SYNCQT_OPTS -check-includes"
if [ "$OPT_SHADOW" = "yes" ]; then
"$outpath/bin/syncqt" $SYNCQT_OPTS
- elif [ "$CFG_DEV" = "yes" ]; then
+ elif [ "$CFG_DEV" = "yes" ] || [ ! -d $relpath/include ]; then
QTDIR="$relpath" perl "$outpath/bin/syncqt" $SYNCQT_OPTS
fi
fi

23
qt.spec
View File

@ -12,7 +12,7 @@ Epoch: 1
Name: qt4
%endif
Version: 4.5.1
Release: 16%{?dist}
Release: 17%{?dist}
# See LGPL_EXCEPTIONS.txt, LICENSE.GPL3, respectively, for exception details
License: LGPLv2 with exceptions or GPLv3 with exceptions
@ -33,9 +33,6 @@ Source4: Trolltech.conf
%define multilib_archs x86_64 %{ix86} ppc64 ppc s390x s390 sparc64 sparcv9
Source5: qconfig-multilib.h
# Hack around missing Phonon/Global header
Source6: Global
# multilib hacks
Patch2: qt-x11-opensource-src-4.2.2-multilib-optflags.patch
Patch3: qt-x11-opensource-src-4.2.2-multilib-QMAKEPATH.patch
@ -51,6 +48,8 @@ Patch16: qt-x11-opensource-src-4.5.1-kde4_plugins.patch
# (The GStreamer backend handles this entirely differently, with a separate
# "sink" setting, and should pick up the PulseAudio "sink" without patches.)
Patch17: phonon-4.2.96-pulseaudio.patch
Patch18: qt-x11-opensource-src-4.5.1-syncqt-header.patch
Patch19: qt-x11-opensource-src-4.5.1-phonon.patch
## upstreamable bits
# http://bugzilla.redhat.com/485677
@ -76,7 +75,6 @@ Source21: designer.desktop
Source22: linguist.desktop
Source23: qtdemo.desktop
Source24: qtconfig.desktop
Source25: gstreamer.desktop
# upstream qt4-logo, http://trolltech.com/images/products/qt/qt4-logo
Source30: hi128-app-qt4-logo.png
@ -368,6 +366,8 @@ test -x apply_patches && ./apply_patches
pushd src/3rdparty/phonon
%patch17 -p1 -b .phonon-pulseaudio
popd
%patch18 -p1 -b .header
%patch19 -p1 -b .servicesfile
%patch51 -p1 -b .qdoc3
%patch52 -p1 -b .sparc64
%patch53 -p1 -b .qatomic-inline-asm
@ -410,6 +410,8 @@ if [ "%{_lib}" == "lib64" ] ; then
sed -i -e "s,/lib /usr/lib,/%{_lib} /usr/%{_lib},g" config.tests/{unix,x11}/*.test
fi
# let syncqt to create new header
rm -rf include
%build
@ -630,12 +632,6 @@ mkdir -p %{buildroot}%{_qt4_plugindir}/phonon_backend
pushd %{buildroot}%{_qt4_headerdir}
ln -s phonon Phonon
popd
if [ -f %{buildroot}%{_qt4_headerdir}/Phonon/Global ]; then
echo "WARNING: Phonon/Global exists, can remove specfile hack"
else
install -p -m644 %{SOURCE6} %{buildroot}%{_qt4_headerdir}/Phonon/Global
fi
install -p -m644 -D %{SOURCE25} %{buildroot}%{_datadir}/kde4/services/phononbackends/gstreamer.desktop
%endif
@ -828,6 +824,7 @@ gtk-update-icon-cache -q %{_datadir}/icons/hicolor 2> /dev/null ||:
%if 0%{?phonon:1}
%{_qt4_libdir}/libphonon.so.4*
%{_datadir}/kde4
%{_datadir}/dbus-1
%endif
%{_qt4_libdir}/libQt3Support.so.*
%{_qt4_libdir}/libQtAssistantClient.so.*
@ -855,6 +852,10 @@ gtk-update-icon-cache -q %{_datadir}/icons/hicolor 2> /dev/null ||:
%changelog
* Sun Jun 07 2009 Than Ngo <than@redhat.com> - 4.5.1-17
- drop the hack, apply patch to install Global header, gstreamer.desktop
and dbus services file
* Sat Jun 06 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.5.1-16
- install awol Phonon/Global header