1.2.2-0.11.20140317git169da60c
- split packaging - (re)enable translations - better rpath handling
This commit is contained in:
parent
94f21a98e8
commit
3fd819b03b
37
qt-mobility-opensource-src-1.2.2-no_rpath.patch
Normal file
37
qt-mobility-opensource-src-1.2.2-no_rpath.patch
Normal file
@ -0,0 +1,37 @@
|
||||
diff -up qt-mobility-opensource-src-1.2.2/common.pri.no_rpath qt-mobility-opensource-src-1.2.2/common.pri
|
||||
--- qt-mobility-opensource-src-1.2.2/common.pri.no_rpath 2014-03-25 14:26:00.000000000 -0500
|
||||
+++ qt-mobility-opensource-src-1.2.2/common.pri 2014-04-28 12:04:08.741039693 -0500
|
||||
@@ -105,7 +105,7 @@ contains(build_unit_tests, yes) {
|
||||
MOC_DIR = $$OUTPUT_DIR/build/$$SUBDIRPART/$$TARGET/moc
|
||||
RCC_DIR = $$OUTPUT_DIR/build/$$SUBDIRPART/$$TARGET/rcc
|
||||
UI_DIR = $$OUTPUT_DIR/build/$$SUBDIRPART/$$TARGET/ui
|
||||
- QMAKE_RPATHDIR += $$QT_MOBILITY_LIB
|
||||
+ #QMAKE_RPATHDIR += $$QT_MOBILITY_LIB
|
||||
} else {
|
||||
# Unit test code (no plugins! test plugins are just normal plugins installed elsewhere)
|
||||
testcase:QT *= testlib
|
||||
diff -up qt-mobility-opensource-src-1.2.2/features/basic_examples_setup.pri.no_rpath qt-mobility-opensource-src-1.2.2/features/basic_examples_setup.pri
|
||||
--- qt-mobility-opensource-src-1.2.2/features/basic_examples_setup.pri.no_rpath 2014-03-25 14:26:00.000000000 -0500
|
||||
+++ qt-mobility-opensource-src-1.2.2/features/basic_examples_setup.pri 2014-04-28 12:12:15.075887547 -0500
|
||||
@@ -42,7 +42,7 @@ mac:contains(QT_CONFIG,qt_framework) {
|
||||
}
|
||||
QMAKE_LIBDIR = $$OUTPUT_DIR/lib
|
||||
|
||||
-QMAKE_RPATHDIR+=$$QT_MOBILITY_LIB
|
||||
+#QMAKE_RPATHDIR+=$$QT_MOBILITY_LIB
|
||||
INCLUDEPATH+= $$QT_MOBILITY_SOURCE_TREE/src/global
|
||||
|
||||
maemo6 {
|
||||
diff -up qt-mobility-opensource-src-1.2.2/features/mobility.prf.no_rpath qt-mobility-opensource-src-1.2.2/features/mobility.prf
|
||||
diff -up qt-mobility-opensource-src-1.2.2/features/mobility.prf.template.no_rpath qt-mobility-opensource-src-1.2.2/features/mobility.prf.template
|
||||
--- qt-mobility-opensource-src-1.2.2/features/mobility.prf.template.no_rpath 2014-03-25 14:26:00.000000000 -0500
|
||||
+++ qt-mobility-opensource-src-1.2.2/features/mobility.prf.template 2014-04-28 12:12:02.418021642 -0500
|
||||
@@ -36,7 +36,7 @@ defineTest(qtMobilityAddLibrary) {
|
||||
LIBS+= -L$${MOBILITY_LIB}
|
||||
}
|
||||
|
||||
-QMAKE_RPATHDIR+=$${MOBILITY_LIB}
|
||||
+#QMAKE_RPATHDIR+=$${MOBILITY_LIB}
|
||||
|
||||
# versit depends on contacts
|
||||
contains(MOBILITY, versit) {
|
267
qt-mobility.spec
267
qt-mobility.spec
@ -9,7 +9,7 @@
|
||||
Name: qt-mobility
|
||||
Summary: Qt Mobility Framework
|
||||
Version: 1.2.2
|
||||
Release: 0.10.%{snap}git%{git_short}%{?dist}
|
||||
Release: 0.11.%{snap}git%{git_short}%{?dist}
|
||||
|
||||
License: LGPLv2 with exceptions
|
||||
URL: http://qt.nokia.com/products/qt-addons/mobility
|
||||
@ -24,6 +24,10 @@ Source0: http://get.qt.nokia.com/qt/add-ons/qt-mobility-opensource-src-%{version
|
||||
Provides: qt4-mobility = %{version}-%{release}
|
||||
Provides: qt4-mobility%{?_isa} = %{version}-%{release}
|
||||
|
||||
## local patches
|
||||
# kill rpath
|
||||
Patch1: qt-mobility-opensource-src-1.2.2-no_rpath.patch
|
||||
|
||||
## upstreamable patches
|
||||
Patch50: qt-mobility-opensource-src-1.2.0-translationsdir.patch
|
||||
# add pkgconfig for linux-* platforms too, Requires.private: QtCore
|
||||
@ -35,7 +39,6 @@ Patch53: qt-mobility-opensource-src-1.1.0-pulseaudio-lib.patch
|
||||
|
||||
## upstream patches
|
||||
|
||||
BuildRequires: chrpath
|
||||
BuildRequires: pkgconfig(alsa)
|
||||
BuildRequires: pkgconfig(blkid)
|
||||
BuildRequires: pkgconfig(bluez)
|
||||
@ -46,15 +49,31 @@ BuildRequires: pkgconfig(libpulse)
|
||||
BuildRequires: pkgconfig(libudev)
|
||||
%endif
|
||||
BuildRequires: pkgconfig(NetworkManager)
|
||||
BuildRequires: pkgconfig(QtCore) pkgconfig(QtGui) pkgconfig(QtOpenGL)
|
||||
BuildRequires: pkgconfig(QtCore)
|
||||
BuildRequires: pkgconfig(QtDeclarative)
|
||||
BuildRequires: pkgconfig(QtGui) pkgconfig(QtOpenGL)
|
||||
BuildRequires: pkgconfig(QtNetwork) >= 4.7
|
||||
BuildRequires: pkgconfig(xv)
|
||||
BuildRequires: proj-devel
|
||||
|
||||
## under review, http://bugzilla.redhat.com/626122
|
||||
# BuildRequires: libqmf-devel >= 1.0
|
||||
Provides: qt4-mobility = %{version}-%{release}
|
||||
Provides: qt4-mobility%{?_isa} = %{version}-%{release}
|
||||
|
||||
%{?_qt4_version:Requires: qt4%{?_isa} >= %{_qt4_version}}
|
||||
# base metapackage pulls in split stuff for upgrade path
|
||||
Requires: %{name}-bearer%{?_isa} = %{version}-%{release}
|
||||
Requires: %{name}-connectivity%{?_isa} = %{version}-%{release}
|
||||
Requires: %{name}-feedback%{?_isa} = %{version}-%{release}
|
||||
Requires: %{name}-gallery%{?_isa} = %{version}-%{release}
|
||||
Requires: %{name}-location%{?_isa} = %{version}-%{release}
|
||||
Requires: %{name}-multimediakit%{?_isa} = %{version}-%{release}
|
||||
Requires: %{name}-pim%{?_isa} = %{version}-%{release}
|
||||
#Requires: %{name}-contacts%{?_isa} = %{version}-%{release}
|
||||
#Requires: %{name}-organizer%{?_isa} = %{version}-%{release}
|
||||
#Requires: %{name}-versit%{?_isa} = %{version}-%{release}
|
||||
Requires: %{name}-publishsubscribe%{?_isa} = %{version}-%{release}
|
||||
Requires: %{name}-sensors%{?_isa} = %{version}-%{release}
|
||||
Requires: %{name}-serviceframework%{?_isa} = %{version}-%{release}
|
||||
Requires: %{name}-systeminfo%{?_isa} = %{version}-%{release}
|
||||
|
||||
%description
|
||||
Qt Mobility Project delivers a set of new APIs to Qt with features that are well
|
||||
@ -64,6 +83,12 @@ them to phones, netbooks and non-mobile personal computers. The framework not
|
||||
only improves many aspects of a mobile experience, because it improves the use
|
||||
of these technologies, but has applicability beyond the mobile device arena.
|
||||
|
||||
%package common
|
||||
Summary: Common files for %{name}
|
||||
%{?_qt4_version:Requires: qt4%{?_isa} >= %{_qt4_version}}
|
||||
%description common
|
||||
%{summary}.
|
||||
|
||||
%package devel
|
||||
Summary: Qt Mobility Framework development files
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
@ -71,15 +96,18 @@ Requires: qt4-devel
|
||||
Provides: qt4-mobility-devel = %{version}-%{release}
|
||||
Provides: qt4-mobility-devel%{?_isa} = %{version}-%{release}
|
||||
Provides: %{name}-bearer-devel = %{version}-%{release}
|
||||
Provides: %{name}-versit-devel = %{version}-%{release}
|
||||
Provides: %{name}-connectivity-devel = %{version}-%{release}
|
||||
Provides: %{name}-contacts-devel = %{version}-%{release}
|
||||
Provides: %{name}-feedback-devel = %{version}-%{release}
|
||||
Provides: %{name}-gallery-devel = %{version}-%{release}
|
||||
Provides: %{name}-location-devel = %{version}-%{release}
|
||||
Provides: %{name}-messaging-devel = %{version}-%{release}
|
||||
Provides: %{name}-multimedia-devel = %{version}-%{release}
|
||||
Provides: %{name}-multimediakit-devel = %{version}-%{release}
|
||||
Provides: %{name}-organizer-devel = %{version}-%{release}
|
||||
Provides: %{name}-publishsubscribe-devel = %{version}-%{release}
|
||||
Provides: %{name}-sensors-devel = %{version}-%{release}
|
||||
Provides: %{name}-serviceframework-devel = %{version}-%{release}
|
||||
Provides: %{name}-systeminfo-devel = %{version}-%{release}
|
||||
Provides: %{name}-versit-devel = %{version}-%{release}
|
||||
%description devel
|
||||
%{summary}.
|
||||
|
||||
@ -96,11 +124,117 @@ Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
%description examples
|
||||
%{summary}.
|
||||
|
||||
%package bearer
|
||||
Summary: QtBearer support
|
||||
Requires: %{name}-common%{?_isa} = %{version}-%{release}
|
||||
%description bearer
|
||||
%{summary}.
|
||||
|
||||
%package connectivity
|
||||
Summary: QtConnectivity support
|
||||
Requires: %{name}-common%{?_isa} = %{version}-%{release}
|
||||
%description connectivity
|
||||
%{summary}.
|
||||
|
||||
%package contacts
|
||||
Summary: QtContacts support
|
||||
Requires: %{name}-common%{?_isa} = %{version}-%{release}
|
||||
Requires: %{name}-serviceframework%{?_isa} = %{version}-%{release}
|
||||
Requires: %{name}-versit%{?_isa} = %{version}-%{release}
|
||||
%description contacts
|
||||
%{summary}.
|
||||
|
||||
%package feedback
|
||||
Summary: QtFeedback support
|
||||
Requires: %{name}-common%{?_isa} = %{version}-%{release}
|
||||
Requires: %{name}-multimediakit%{?_isa} = %{version}-%{release}
|
||||
%description feedback
|
||||
%{summary}.
|
||||
|
||||
%package gallery
|
||||
Summary: QtGallery support
|
||||
Requires: %{name}-common%{?_isa} = %{version}-%{release}
|
||||
%description gallery
|
||||
%{summary}.
|
||||
|
||||
%package location
|
||||
Summary: QtLocation support
|
||||
Requires: %{name}-common%{?_isa} = %{version}-%{release}
|
||||
%description location
|
||||
%{summary}.
|
||||
|
||||
%package multimediakit
|
||||
Summary: QtMultiMediaKit support
|
||||
Requires: %{name}-common%{?_isa} = %{version}-%{release}
|
||||
%description multimediakit
|
||||
%{summary}.
|
||||
|
||||
%package organizer
|
||||
Summary: QtOrganizer support
|
||||
Requires: %{name}-common%{?_isa} = %{version}-%{release}
|
||||
Requires: %{name}-contacts%{?_isa} = %{version}-%{release}
|
||||
Requires: %{name}-versit%{?_isa} = %{version}-%{release}
|
||||
%description organizer
|
||||
%{summary}.
|
||||
|
||||
# Combine these items since they are (currently) interdependant anyway
|
||||
%package pim
|
||||
Summary: Qt Mobility Personal Information Management support
|
||||
Requires: %{name}-common%{?_isa} = %{version}-%{release}
|
||||
## contacts
|
||||
Provides: %{name}-contacts%{?_isa} = %{version}-%{release}
|
||||
Requires: %{name}-serviceframework%{?_isa} = %{version}-%{release}
|
||||
#Requires: %{name}-versit%{?_isa} = %{version}-%{release}
|
||||
## organizer
|
||||
Provides: %{name}-organizer%{?_isa} = %{version}-%{release}
|
||||
#Requires: %{name}-contacts%{?_isa} = %{version}-%{release}
|
||||
#Requires: %{name}-versit%{?_isa} = %{version}-%{release}
|
||||
## versit
|
||||
Provides: %{name}-versit%{?_isa} = %{version}-%{release}
|
||||
#Requires: %{name}-contacts%{?_isa} = %{version}-%{release}
|
||||
#Requires: %{name}-organizer%{?_isa} = %{version}-%{release}
|
||||
%description pim
|
||||
%{summary}, including:
|
||||
QtContacts, QtOrganzier, QtVersit, QtVersitOrganizer.
|
||||
|
||||
%package publishsubscribe
|
||||
Summary: QtPublishSubscribe support
|
||||
Requires: %{name}-common%{?_isa} = %{version}-%{release}
|
||||
%description publishsubscribe
|
||||
%{summary}.
|
||||
|
||||
%package sensors
|
||||
Summary: QtSensors support
|
||||
Requires: %{name}-common%{?_isa} = %{version}-%{release}
|
||||
%description sensors
|
||||
%{summary}.
|
||||
|
||||
%package serviceframework
|
||||
Summary: QtServiceFramework support
|
||||
Requires: %{name}-common%{?_isa} = %{version}-%{release}
|
||||
%description serviceframework
|
||||
%{summary}.
|
||||
|
||||
%package systeminfo
|
||||
Summary: QtSystemInfo support
|
||||
Requires: %{name}-common%{?_isa} = %{version}-%{release}
|
||||
%description systeminfo
|
||||
%{summary}.
|
||||
|
||||
%package versit
|
||||
Summary: QtVersit and QtVersitOrganzier support
|
||||
Requires: %{name}-common%{?_isa} = %{version}-%{release}
|
||||
Requires: %{name}-contacts%{?_isa} = %{version}-%{release}
|
||||
Requires: %{name}-organizer%{?_isa} = %{version}-%{release}
|
||||
%description versit
|
||||
%{summary}.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-opensource-src-%{version}
|
||||
rm -r src/3rdparty/proj
|
||||
|
||||
%patch1 -p1 -b .no_rpath
|
||||
%patch50 -p1 -b .translationsdir
|
||||
%patch51 -p1 -b .pkgconfig
|
||||
%patch52 -p1 -b .sensors_ftbfs
|
||||
@ -114,6 +248,7 @@ PATH=%{_qt4_bindir}:$PATH; export PATH
|
||||
-prefix %{_qt4_prefix} \
|
||||
-bindir %{_bindir} \
|
||||
-headerdir %{_qt4_headerdir} \
|
||||
-languages "ar cs da de es fr he hu ja ko pl pt ru sk sl sv uk zh_CN zh_TW" \
|
||||
-libdir %{_qt4_libdir} \
|
||||
-plugindir %{_qt4_plugindir} \
|
||||
-qmake-exec %{_qt4_qmake} \
|
||||
@ -133,39 +268,108 @@ install -p -m644 -D doc/qch/qtmobility.qch %{buildroot}%{_qt4_docdir}/qch/qtmobi
|
||||
mkdir -p %{buildroot}%{_qt4_docdir}/html/qtmobility
|
||||
cp -a doc/html/* %{buildroot}%{_qt4_docdir}/html/qtmobility/
|
||||
|
||||
## WTF, translations went awol in 1.1.0 ? -- Rex
|
||||
#find_lang %{name} --all-name --with-qt --without-mo
|
||||
%find_lang %{name} --all-name --with-qt --without-mo
|
||||
|
||||
# die rpath, die
|
||||
chrpath --delete %{buildroot}%{_bindir}/* ||:
|
||||
chrpath --delete %{buildroot}%{_qt4_libdir}/libQt*.so ||:
|
||||
chrpath --delete %{buildroot}%{_qt4_plugindir}/*/*.so ||:
|
||||
chrpath --delete %{buildroot}%{_qt4_importdir}/*/*.so ||:
|
||||
chrpath --delete %{buildroot}%{_qt4_importdir}/*/*/*.so ||:
|
||||
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
# empty metapackage
|
||||
|
||||
%files common -f %{name}.lang
|
||||
%doc LICENSE.LGPL LGPL_EXCEPTION.txt
|
||||
%dir %{_qt4_importdir}/QtMobility/
|
||||
|
||||
%post bearer -p /sbin/ldconfig
|
||||
%postun bearer -p /sbin/ldconfig
|
||||
|
||||
%files bearer
|
||||
%{_qt4_libdir}/libQtBearer.so.1*
|
||||
%{_qt4_libdir}/libQtContacts.so.1*
|
||||
|
||||
%post connectivity -p /sbin/ldconfig
|
||||
%postun connectivity -p /sbin/ldconfig
|
||||
|
||||
%files connectivity
|
||||
%{_qt4_libdir}/libQtConnectivity.so.1*
|
||||
%{_qt4_importdir}/QtMobility/connectivity/
|
||||
|
||||
%post feedback -p /sbin/ldconfig
|
||||
%postun feedback -p /sbin/ldconfig
|
||||
|
||||
%files feedback
|
||||
%{_qt4_libdir}/libQtFeedback.so.1*
|
||||
%{_qt4_importdir}/QtMobility/feedback/
|
||||
%{_qt4_plugindir}/feedback/
|
||||
|
||||
%post gallery -p /sbin/ldconfig
|
||||
%postun gallery -p /sbin/ldconfig
|
||||
|
||||
%files gallery
|
||||
%{_qt4_libdir}/libQtGallery.so.1*
|
||||
%{_qt4_importdir}/QtMobility/gallery/
|
||||
|
||||
%post location -p /sbin/ldconfig
|
||||
%postun location -p /sbin/ldconfig
|
||||
|
||||
%files location
|
||||
%{_qt4_libdir}/libQtLocation.so.1*
|
||||
%{_qt4_importdir}/QtMobility/location/
|
||||
%{_qt4_plugindir}/geoservices/
|
||||
%{_qt4_plugindir}/landmarks/
|
||||
|
||||
%post multimediakit -p /sbin/ldconfig
|
||||
%postun multimediakit -p /sbin/ldconfig
|
||||
|
||||
%files multimediakit
|
||||
%{_qt4_libdir}/libQtMultimediaKit.so.1*
|
||||
%{_qt4_importdir}/QtMultimediaKit/
|
||||
%{_qt4_plugindir}/audio/
|
||||
%{_qt4_plugindir}/mediaservice/
|
||||
%{_qt4_plugindir}/playlistformats/
|
||||
|
||||
%post pim -p /sbin/ldconfig
|
||||
%postun pim -p /sbin/ldconfig
|
||||
|
||||
%files pim
|
||||
#files contacts
|
||||
%{_qt4_libdir}/libQtContacts.so.1*
|
||||
%{_qt4_importdir}/QtMobility/contacts/
|
||||
%{_qt4_plugindir}/contacts/
|
||||
#files organizer
|
||||
%{_qt4_libdir}/libQtOrganizer.so.1*
|
||||
%{_qt4_libdir}/libQtPublishSubscribe.so.1*
|
||||
%{_qt4_libdir}/libQtSensors.so.1*
|
||||
%{_qt4_libdir}/libQtServiceFramework.so.1*
|
||||
%{_qt4_libdir}/libQtSystemInfo.so.1*
|
||||
%{_qt4_importdir}/QtMobility/organizer/
|
||||
#files versit
|
||||
%{_qt4_libdir}/libQtVersit.so.1*
|
||||
%{_qt4_libdir}/libQtVersitOrganizer.so.1*
|
||||
%{_qt4_importdir}/QtMobility/
|
||||
%{_qt4_importdir}/QtMultimediaKit/
|
||||
%{_qt4_plugindir}/*
|
||||
%{_qt4_plugindir}/versit/
|
||||
|
||||
%post publishsubscribe -p /sbin/ldconfig
|
||||
%postun publishsubscribe -p /sbin/ldconfig
|
||||
|
||||
%files publishsubscribe
|
||||
%{_qt4_libdir}/libQtPublishSubscribe.so.1*
|
||||
%{_qt4_importdir}/QtMobility/publishsubscribe/
|
||||
|
||||
%post sensors -p /sbin/ldconfig
|
||||
%postun sensors -p /sbin/ldconfig
|
||||
|
||||
%files sensors
|
||||
%{_qt4_libdir}/libQtSensors.so.1*
|
||||
%{_qt4_importdir}/QtMobility/sensors/
|
||||
%{_qt4_plugindir}/sensorgestures/
|
||||
%{_qt4_plugindir}/sensors/
|
||||
|
||||
%post serviceframework -p /sbin/ldconfig
|
||||
%postun serviceframework -p /sbin/ldconfig
|
||||
|
||||
%files serviceframework
|
||||
%{_qt4_libdir}/libQtServiceFramework.so.1*
|
||||
%{_qt4_importdir}/QtMobility/serviceframework/
|
||||
|
||||
%post systeminfo -p /sbin/ldconfig
|
||||
%postun systeminfo -p /sbin/ldconfig
|
||||
|
||||
%files systeminfo
|
||||
%{_qt4_libdir}/libQtSystemInfo.so.1*
|
||||
%{_qt4_importdir}/QtMobility/systeminfo/
|
||||
|
||||
%files devel
|
||||
%{_bindir}/icheck
|
||||
@ -234,6 +438,11 @@ chrpath --delete %{buildroot}%{_qt4_importdir}/*/*/*.so ||:
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Apr 28 2014 Rex Dieter <rdieter@fedoraproject.org> - 1.2.2-0.11.20140317git169da60c
|
||||
- split packaging
|
||||
- (re)enable translations
|
||||
- better rpath handling
|
||||
|
||||
* Mon Apr 28 2014 Rex Dieter <rdieter@fedoraproject.org> 1.2.2-0.10.20140317git169da60c
|
||||
- fresh snapshot
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user