36 lines
946 B
Diff
36 lines
946 B
Diff
Install header files and static library, add missing header.
|
|
|
|
diff --git a/build/general/Makefile.inc b/build/general/Makefile.inc
|
|
index 77d4b65..e887471 100644
|
|
--- a/build/general/Makefile.inc
|
|
+++ b/build/general/Makefile.inc
|
|
@@ -4,6 +4,7 @@ CXX ?= g++
|
|
CC ?= gcc
|
|
AR ?= ar
|
|
RANLIB ?= ranlib
|
|
+INSTALL ?= install -p
|
|
|
|
CFLAGS := $(CFLAGS) -I.
|
|
CXXFLAGS := $(CXXFLAGS) -I.
|
|
@@ -42,6 +43,7 @@ HEADERS := base/Pitch.h \
|
|
maths/KLDivergence.h \
|
|
maths/MathAliases.h \
|
|
maths/MathUtilities.h \
|
|
+ maths/nan-inf.h \
|
|
maths/Polyfit.h \
|
|
maths/pca/pca.h \
|
|
thread/AsynchronousTask.h \
|
|
@@ -89,6 +91,12 @@ $(LIBRARY): $(OBJECTS)
|
|
$(AR) cr $@ $^
|
|
$(RANLIB) $@
|
|
|
|
+install:
|
|
+ $(INSTALL) -D -m 0644 $(LIBRARY) $(DESTDIR)$(LIBDIR)/$(LIBRARY)
|
|
+ for h in $(HEADERS); do \
|
|
+ $(INSTALL) -D -m 0644 $$h $(DESTDIR)$(PREFIX)/include/qm-dsp/$$h; \
|
|
+ done
|
|
+
|
|
clean:
|
|
rm $(OBJECTS)
|
|
|