Update to 1.7.1 (#1279112)
* New homepage * Unbundled new kiss-fft library * Removed C++ patch released in upstream * Rebased build flags and install patches * New packaging guidelines (license tag) * Enabled tests
This commit is contained in:
parent
613cef4399
commit
18d0630040
1
.gitignore
vendored
1
.gitignore
vendored
@ -1 +1,2 @@
|
||||
/qm-dsp-1.7.tar.gz
|
||||
/qm-dsp-1.7.1.tar.gz
|
||||
|
@ -1,34 +0,0 @@
|
||||
Fix build with gcc 4.6
|
||||
|
||||
diff -r 410f9e18a249 -r 915365c58758 build/linux/Makefile.linux
|
||||
--- a/build/linux/Makefile.linux Fri Oct 14 09:41:38 2011 +0100
|
||||
+++ b/build/linux/Makefile.linux Fri Oct 14 09:48:47 2011 +0100
|
||||
@@ -1,5 +1,5 @@
|
||||
|
||||
-CFLAGS := -DNDEBUG -O3 -fno-exceptions -fPIC -ffast-math -msse -mfpmath=sse -ftree-vectorize -fomit-frame-pointer -DUSE_PTHREADS
|
||||
+CFLAGS := -DNDEBUG -O3 -fno-exceptions -fPIC -ffast-math -msse -mfpmath=sse -ftree-vectorize -fomit-frame-pointer -DUSE_PTHREADS -I./include
|
||||
CXXFLAGS := $(CFLAGS)
|
||||
|
||||
include build/general/Makefile.inc
|
||||
diff -r 410f9e18a249 -r 915365c58758 dsp/tempotracking/DownBeat.h
|
||||
--- a/dsp/tempotracking/DownBeat.h Fri Oct 14 09:41:38 2011 +0100
|
||||
+++ b/dsp/tempotracking/DownBeat.h Fri Oct 14 09:48:47 2011 +0100
|
||||
@@ -17,6 +17,7 @@
|
||||
#define DOWNBEAT_H
|
||||
|
||||
#include <vector>
|
||||
+#include <cstddef>
|
||||
|
||||
#include "dsp/rateconversion/Decimator.h"
|
||||
|
||||
diff -r 410f9e18a249 -r 915365c58758 dsp/tempotracking/TempoTrackV2.h
|
||||
--- a/dsp/tempotracking/TempoTrackV2.h Fri Oct 14 09:41:38 2011 +0100
|
||||
+++ b/dsp/tempotracking/TempoTrackV2.h Fri Oct 14 09:48:47 2011 +0100
|
||||
@@ -18,6 +18,7 @@
|
||||
#define TEMPOTRACKV2_H
|
||||
|
||||
#include <vector>
|
||||
+#include <cstddef>
|
||||
|
||||
using std::vector;
|
||||
|
@ -1,27 +1,21 @@
|
||||
Build flags and not using internal lapack headers.
|
||||
Author: František Dvořák <valtri@civ.zcu.cz>
|
||||
Date: Wed Nov 4 14:11:41 2015 +0100
|
||||
|
||||
diff --git a/build/linux/Makefile.linux b/build/linux/Makefile.linux
|
||||
index 5f2b331..a60a4ee 100644
|
||||
--- a/build/linux/Makefile.linux
|
||||
+++ b/build/linux/Makefile.linux
|
||||
@@ -1,6 +1,7 @@
|
||||
Build flags and not using internal lapack headers.
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index e501466..7f91722 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -1,9 +1,10 @@
|
||||
|
||||
-CFLAGS := -DNDEBUG -O3 -fPIC -ffast-math -msse -mfpmath=sse -ftree-vectorize -fomit-frame-pointer -DUSE_PTHREADS -I./include
|
||||
+CFLAGS := -DNDEBUG -fPIC -ffast-math -ftree-vectorize -fomit-frame-pointer -DUSE_PTHREADS -I./include $(CFLAGS)
|
||||
|
||||
#CFLAGS := -DNDEBUG -g -fPIC -DUSE_PTHREADS -I./include
|
||||
|
||||
-CFLAGS := -DNDEBUG -O3 -fno-exceptions -fPIC -ffast-math -msse -mfpmath=sse -ftree-vectorize -fomit-frame-pointer -DUSE_PTHREADS -I./include
|
||||
+CFLAGS := -DNDEBUG -fno-exceptions -fPIC -ffast-math -ftree-vectorize -fomit-frame-pointer -DUSE_PTHREADS $(CFLAGS)
|
||||
CXXFLAGS := $(CFLAGS)
|
||||
+LDFLAGS := $(LDFLAGS)
|
||||
|
||||
include build/general/Makefile.inc
|
||||
|
||||
diff --git a/build/linux/Makefile.linux64 b/build/linux/Makefile.linux64
|
||||
deleted file mode 100644
|
||||
index b5460d4..0000000
|
||||
--- a/build/linux/Makefile.linux64
|
||||
+++ /dev/null
|
||||
@@ -1,6 +0,0 @@
|
||||
-
|
||||
-CFLAGS := -DNDEBUG -O3 -fno-exceptions -fPIC -ffast-math -msse -mfpmath=sse -ftree-vectorize -fomit-frame-pointer -DUSE_PTHREADS -Ibuild/linux/amd64
|
||||
-CXXFLAGS := $(CFLAGS)
|
||||
-
|
||||
-include build/general/Makefile.inc
|
||||
-
|
||||
|
@ -1,28 +1,58 @@
|
||||
Install header files and static library, add missing header.
|
||||
Author: František Dvořák <valtri@civ.zcu.cz>
|
||||
Date: Wed Nov 4 20:25:16 2015 +0100
|
||||
|
||||
Update Makefile:
|
||||
* install target: headers, static library
|
||||
* add missing header
|
||||
* kill bundled kissfft
|
||||
|
||||
diff --git a/build/general/Makefile.inc b/build/general/Makefile.inc
|
||||
index 77d4b65..e887471 100644
|
||||
index da0644b..b3a7319 100644
|
||||
--- a/build/general/Makefile.inc
|
||||
+++ b/build/general/Makefile.inc
|
||||
@@ -4,6 +4,7 @@ CXX ?= g++
|
||||
@@ -4,9 +4,10 @@ CXX ?= g++
|
||||
CC ?= gcc
|
||||
AR ?= ar
|
||||
RANLIB ?= ranlib
|
||||
+INSTALL ?= install -p
|
||||
|
||||
CFLAGS := $(CFLAGS) -I.
|
||||
CXXFLAGS := $(CXXFLAGS) -I.
|
||||
@@ -42,6 +43,7 @@ HEADERS := base/Pitch.h \
|
||||
maths/KLDivergence.h \
|
||||
-CFLAGS := $(CFLAGS) -I. -Iext/kissfft -Iext/kissfft/tools -Dkiss_fft_scalar=double
|
||||
-CXXFLAGS := $(CXXFLAGS) -I. -Iext/kissfft -Iext/kissfft/tools -Dkiss_fft_scalar=double
|
||||
+CFLAGS := $(CFLAGS) -I. -Dkiss_fft_scalar=double
|
||||
+CXXFLAGS := $(CXXFLAGS) -I. -Dkiss_fft_scalar=double
|
||||
|
||||
HEADERS := base/Pitch.h \
|
||||
base/Window.h \
|
||||
@@ -47,13 +48,12 @@ HEADERS := base/Pitch.h \
|
||||
maths/MathAliases.h \
|
||||
maths/MathUtilities.h \
|
||||
maths/MedianFilter.h \
|
||||
+ maths/nan-inf.h \
|
||||
maths/Polyfit.h \
|
||||
maths/pca/pca.h \
|
||||
thread/AsynchronousTask.h \
|
||||
@@ -89,6 +91,12 @@ $(LIBRARY): $(OBJECTS)
|
||||
$(AR) cr $@ $^
|
||||
$(RANLIB) $@
|
||||
thread/BlockAllocator.h \
|
||||
- thread/Thread.h \
|
||||
- ext/kissfft/kiss_fft.h \
|
||||
- ext/kissfft/tools/kiss_fftr.h
|
||||
+ thread/Thread.h
|
||||
|
||||
SOURCES := base/Pitch.cpp \
|
||||
base/KaiserWindow.cpp \
|
||||
@@ -91,9 +91,7 @@ SOURCES := base/Pitch.cpp \
|
||||
maths/KLDivergence.cpp \
|
||||
maths/MathUtilities.cpp \
|
||||
maths/pca/pca.c \
|
||||
- thread/Thread.cpp \
|
||||
- ext/kissfft/kiss_fft.c \
|
||||
- ext/kissfft/tools/kiss_fftr.c
|
||||
+ thread/Thread.cpp
|
||||
|
||||
OBJECTS := $(SOURCES:.cpp=.o)
|
||||
OBJECTS := $(OBJECTS:.c=.o)
|
||||
@@ -106,6 +104,12 @@ $(LIBRARY): $(OBJECTS)
|
||||
depend:
|
||||
makedepend -fbuild/general/Makefile.inc -Y -- $(CFLAGS) -- $(SOURCES)
|
||||
|
||||
+install:
|
||||
+ $(INSTALL) -D -m 0644 $(LIBRARY) $(DESTDIR)$(LIBDIR)/$(LIBRARY)
|
||||
@ -31,5 +61,5 @@ index 77d4b65..e887471 100644
|
||||
+ done
|
||||
+
|
||||
clean:
|
||||
rm $(OBJECTS)
|
||||
rm -f $(OBJECTS)
|
||||
|
||||
|
67
qm-dsp.spec
67
qm-dsp.spec
@ -2,25 +2,31 @@
|
||||
%global debug_package %{nil}
|
||||
|
||||
Name: qm-dsp
|
||||
Version: 1.7
|
||||
Release: 4%{?dist}
|
||||
Version: 1.7.1
|
||||
Release: 1%{?dist}
|
||||
Summary: Library for DSP and Music Informatics purposes
|
||||
|
||||
# some source files with different original licenses, see README.txt
|
||||
License: GPLv2+
|
||||
URL: http://isophonics.net/QMVampPlugins
|
||||
Source0: https://code.soundsoftware.ac.uk/attachments/download/103/%{name}-%{version}.tar.gz
|
||||
# C++ build fix
|
||||
# https://code.soundsoftware.ac.uk/projects/qm-dsp/repository/revisions/915365c58758
|
||||
Patch0: qm-dsp-cxx-build.patch
|
||||
# original homepage: http://isophonics.net/QMVampPlugins
|
||||
URL: http://vamp-plugins.org/plugin-doc/qm-vamp-plugins.html
|
||||
Source0: https://code.soundsoftware.ac.uk/attachments/download/1582/%{name}-%{version}.tar.gz
|
||||
# build flags
|
||||
# (not intended for upstream)
|
||||
Patch1: qm-dsp-flags.patch
|
||||
Patch0: qm-dsp-flags.patch
|
||||
# install header files
|
||||
# http://vamp-plugins.org/forum/index.php/topic,270.0.html
|
||||
Patch2: qm-dsp-install.patch
|
||||
Patch1: qm-dsp-install.patch
|
||||
|
||||
BuildRequires: atlas-devel
|
||||
BuildRequires: imake
|
||||
BuildRequires: kiss-fft-static
|
||||
BuildRequires: valgrind
|
||||
%if 0%{?rhel} && 0%{?rhel} <= 7
|
||||
BuildRequires: boost148-devel
|
||||
%else
|
||||
BuildRequires: boost-devel
|
||||
%endif
|
||||
|
||||
%description
|
||||
%{name} is a C++ library of functions for DSP and Music Informatics purposes
|
||||
@ -43,13 +49,23 @@ qm-dsp.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
cp -p build/linux/Makefile.linux32 Makefile
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
ln -s build/linux/Makefile.linux Makefile
|
||||
# use specified CFLAGS for tests
|
||||
cat >> tests/Makefile <<EOF
|
||||
|
||||
%.o: %.cpp
|
||||
\$(CXX) \$(CPPFLAGS) \$(CFLAGS) -c \$<
|
||||
EOF
|
||||
# unbundle kiss-fft
|
||||
rm -rf ext/
|
||||
|
||||
|
||||
%build
|
||||
# unbundle kiss-fft
|
||||
make depend
|
||||
|
||||
# extra cflags used in upstream
|
||||
%ifarch %{ix86}
|
||||
EXTRA_CFLAGS="-msse -mfpmath=sse"
|
||||
@ -58,7 +74,8 @@ EXTRA_CFLAGS="-msse -mfpmath=sse"
|
||||
EXTRA_CFLAGS="-msse -msse2 -mfpmath=sse"
|
||||
%endif
|
||||
|
||||
CFLAGS="$EXTRA_CFLAGS %{?optflags}" \
|
||||
# build
|
||||
CFLAGS="$EXTRA_CFLAGS %{?optflags} -I%{_includedir}/kissfft" \
|
||||
LDFLAGS="%{?__global_ldflags}" \
|
||||
make %{?_smp_mflags}
|
||||
|
||||
@ -67,13 +84,33 @@ make %{?_smp_mflags}
|
||||
make install DESTDIR=%{buildroot} PREFIX=%{_prefix} LIBDIR=%{_libdir}
|
||||
|
||||
|
||||
%check
|
||||
%if 0%{?rhel} && 0%{?rhel} <= 7
|
||||
BOOST_CPPFLAGS="-I%{_includedir}/boost148"
|
||||
BOOST_LDFLAGS="-L%{_libdir}/boost148"
|
||||
%endif
|
||||
CFLAGS="${BOOST_CPPFLAGS} %{?optflags} -Dkiss_fft_scalar=double" \
|
||||
LDFLAGS="${BOOST_LDFLAGS} %{?__global_ldflags} -lkiss_fft_double -lkiss_fftr_double" \
|
||||
make %{?_smp_mflags} -C tests
|
||||
|
||||
|
||||
%files devel
|
||||
%doc COPYING README.txt
|
||||
%license COPYING
|
||||
%doc README.txt
|
||||
%{_libdir}/libqm-dsp.a
|
||||
%{_includedir}/%{name}
|
||||
%{_includedir}/%{name}/
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Nov 14 2016 František Dvořák <valtri@civ.zcu.cz> - 1.7.1-1
|
||||
- Update to 1.7.1 (#1279112)
|
||||
- New homepage
|
||||
- Unbundled new kiss-fft library
|
||||
- Removed C++ patch released in upstream
|
||||
- Rebased build flags and install patches
|
||||
- New packaging guidelines (license tag)
|
||||
- Enabled tests
|
||||
|
||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.7-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
@ -81,7 +118,7 @@ make install DESTDIR=%{buildroot} PREFIX=%{_prefix} LIBDIR=%{_libdir}
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Wed Nov 05 2014 František Dvořák <valtri@civ.zcu.cz> - 1.7-2
|
||||
- Update patches and add comments
|
||||
- Updated patches and added comments
|
||||
|
||||
* Sun Aug 3 2014 František Dvořák <valtri@civ.zcu.cz> - 1.7-1
|
||||
- Initial package
|
||||
|
Loading…
x
Reference in New Issue
Block a user