86 lines
3.1 KiB
Diff
86 lines
3.1 KiB
Diff
From: Riku Voipio <riku.voipio@iki.fi>
|
|
Subject: [Qemu-devel] [PATCH] Make binary stripping conditional
|
|
|
|
Currently qemu unconditionally strips binaries on install. This
|
|
is a problem for packagers who may want to store/ship debug symbols
|
|
of compiled packages for debugging purposes.
|
|
|
|
Keep stripping as default for the oldtimers and add a
|
|
--disable-strip flag to override.
|
|
|
|
Signed-off-by: Riku Voipio <riku.voipio@iki.fi>
|
|
---
|
|
Makefile | 2 +-
|
|
Makefile.target | 2 +-
|
|
configure | 9 ++++++++-
|
|
3 files changed, 10 insertions(+), 3 deletions(-)
|
|
|
|
Index: qemu-kvm-0.10/qemu/Makefile
|
|
===================================================================
|
|
--- qemu-kvm-0.10.orig/qemu/Makefile
|
|
+++ qemu-kvm-0.10/qemu/Makefile
|
|
@@ -256,7 +256,7 @@ endif
|
|
install: all $(if $(BUILD_DOCS),install-doc)
|
|
mkdir -p "$(DESTDIR)$(bindir)"
|
|
ifneq ($(TOOLS),)
|
|
- $(INSTALL) -m 755 -s $(TOOLS) "$(DESTDIR)$(bindir)"
|
|
+ $(INSTALL) -m 755 $(STRIP_OPT) $(TOOLS) "$(DESTDIR)$(bindir)"
|
|
endif
|
|
ifneq ($(BLOBS),)
|
|
mkdir -p "$(DESTDIR)$(datadir)"
|
|
Index: qemu-kvm-0.10/qemu/configure
|
|
===================================================================
|
|
--- qemu-kvm-0.10.orig/qemu/configure
|
|
+++ qemu-kvm-0.10/qemu/configure
|
|
@@ -154,6 +154,7 @@ case "$cpu" in
|
|
esac
|
|
gprof="no"
|
|
sparse="no"
|
|
+strip_opt="yes"
|
|
bigendian="no"
|
|
mingw32="no"
|
|
EXESUF=""
|
|
@@ -403,6 +404,8 @@ for opt do
|
|
;;
|
|
--disable-sparse) sparse="no"
|
|
;;
|
|
+ --disable-strip) strip_opt="no"
|
|
+ ;;
|
|
--disable-vnc-tls) vnc_tls="no"
|
|
;;
|
|
--disable-vnc-sasl) vnc_sasl="no"
|
|
@@ -556,6 +559,7 @@ echo " --install=INSTALL use spe
|
|
echo " --static enable static build [$static]"
|
|
echo " --enable-sparse enable sparse checker"
|
|
echo " --disable-sparse disable sparse checker (default)"
|
|
+echo " --disable-strip disable stripping binaries"
|
|
echo " --disable-werror disable compilation abort on warning"
|
|
echo " --disable-sdl disable SDL"
|
|
echo " --enable-cocoa enable COCOA (Mac OS X only)"
|
|
@@ -1242,6 +1246,7 @@ echo "host big endian $bigendian"
|
|
echo "target list $target_list"
|
|
echo "gprof enabled $gprof"
|
|
echo "sparse enabled $sparse"
|
|
+echo "strip binaries $strip_opt"
|
|
echo "profiler $profiler"
|
|
echo "static build $static"
|
|
echo "-Werror enabled $werror"
|
|
@@ -1318,7 +1323,6 @@ echo "INSTALL=$install" >> $config_mak
|
|
echo "CC=$cc" >> $config_mak
|
|
echo "HOST_CC=$host_cc" >> $config_mak
|
|
echo "AR=$ar" >> $config_mak
|
|
-echo "STRIP=$strip -s -R .comment -R .note" >> $config_mak
|
|
# XXX: only use CFLAGS and LDFLAGS ?
|
|
# XXX: should export HOST_CFLAGS and HOST_LDFLAGS for cross
|
|
# compilation of dyngen tool (useful for win32 build on Linux host)
|
|
@@ -1405,6 +1409,9 @@ if test "$sparse" = "yes" ; then
|
|
echo "HOST_CC := REAL_CC=\"\$(HOST_CC)\" cgcc" >> $config_mak
|
|
echo "CFLAGS += -Wbitwise -Wno-transparent-union -Wno-old-initializer -Wno-non-pointer-null" >> $config_mak
|
|
fi
|
|
+if test "$strip_opt" = "yes" ; then
|
|
+ echo "STRIP_OPT=-s" >> $config_mak
|
|
+fi
|
|
if test "$bigendian" = "yes" ; then
|
|
echo "WORDS_BIGENDIAN=yes" >> $config_mak
|
|
echo "#define WORDS_BIGENDIAN 1" >> $config_h
|