qemu/qemu-fix-cpuid-trimming.patch
Mark McLoughlin da7d236358 Patches now managed in a git tree:
http://git.et.redhat.com/?p=qemu-fedora.git
Update the current patches with ones produced using format-patch, no real
    changes here.
Dropped add-cache-utils patch as it's not referenced in qemu.spec
2009-06-24 16:22:39 +00:00

34 lines
1.1 KiB
Diff

From 5ce45fee67cca7b2a7dc240f71898cbfab0ab917 Mon Sep 17 00:00:00 2001
From: Mark McLoughlin <markmc@redhat.com>
Date: Tue, 12 May 2009 12:42:42 +0100
Subject: [PATCH 7/7] Work around supported cpuid ioctl() brokenness
KVM_GET_SUPPORTED_CPUID has been known to fail to return -E2BIG
when it runs out of entries. Detect this by always trying again
with a bigger table if the ioctl() fills the table.
(cherry picked from commit 8fa3b3ce6ed2a12062422b75d5b4ab9eab0ae4e9)
Signed-off-by: Mark McLoughlin <markmc@redhat.com>
Signed-off-by: Avi Kivity <avi@redhat.com>
---
kvm/libkvm/libkvm-x86.c | 2 ++
1 files changed, 2 insertions(+), 0 deletions(-)
diff --git a/kvm/libkvm/libkvm-x86.c b/kvm/libkvm/libkvm-x86.c
index a2f6320..4f9539a 100644
--- a/kvm/libkvm/libkvm-x86.c
+++ b/kvm/libkvm/libkvm-x86.c
@@ -575,6 +575,8 @@ static struct kvm_cpuid2 *try_get_cpuid(kvm_context_t kvm, int max)
r = ioctl(kvm->fd, KVM_GET_SUPPORTED_CPUID, cpuid);
if (r == -1)
r = -errno;
+ else if (r == 0 && cpuid->nent >= max)
+ r = -E2BIG;
if (r < 0) {
if (r == -E2BIG) {
free(cpuid);
--
1.6.2.2