195 lines
5.5 KiB
Diff
195 lines
5.5 KiB
Diff
From f35ef58b2bac932bbd379602fe23e7a190530075 Mon Sep 17 00:00:00 2001
|
|
From: Fam Zheng <famz@redhat.com>
|
|
Date: Mon, 21 Aug 2017 22:10:05 +0800
|
|
Subject: [PATCH 04/15] scsi: Refactor scsi sense interpreting code
|
|
|
|
So that it can be reused outside of iscsi.c.
|
|
|
|
Also update MAINTAINERS to include the new files in SCSI section.
|
|
|
|
Signed-off-by: Fam Zheng <famz@redhat.com>
|
|
Message-Id: <20170821141008.19383-2-famz@redhat.com>
|
|
Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
|
|
---
|
|
MAINTAINERS | 2 ++
|
|
block/iscsi.c | 45 ++++-----------------------------------------
|
|
include/scsi/scsi.h | 19 +++++++++++++++++++
|
|
util/Makefile.objs | 1 +
|
|
util/scsi.c | 52 ++++++++++++++++++++++++++++++++++++++++++++++++++++
|
|
5 files changed, 78 insertions(+), 41 deletions(-)
|
|
create mode 100644 include/scsi/scsi.h
|
|
create mode 100644 util/scsi.c
|
|
|
|
diff --git a/MAINTAINERS b/MAINTAINERS
|
|
index ccee28b12d..2a4e5036ae 100644
|
|
--- a/MAINTAINERS
|
|
+++ b/MAINTAINERS
|
|
@@ -969,7 +969,9 @@ SCSI
|
|
M: Paolo Bonzini <pbonzini@redhat.com>
|
|
S: Supported
|
|
F: include/hw/scsi/*
|
|
+F: include/scsi/*
|
|
F: hw/scsi/*
|
|
+F: util/scsi*
|
|
F: tests/virtio-scsi-test.c
|
|
T: git git://github.com/bonzini/qemu.git scsi-next
|
|
|
|
diff --git a/block/iscsi.c b/block/iscsi.c
|
|
index d557c99668..4bed63cd6d 100644
|
|
--- a/block/iscsi.c
|
|
+++ b/block/iscsi.c
|
|
@@ -40,6 +40,7 @@
|
|
#include "qmp-commands.h"
|
|
#include "qapi/qmp/qstring.h"
|
|
#include "crypto/secret.h"
|
|
+#include "scsi/scsi.h"
|
|
|
|
#include <iscsi/iscsi.h>
|
|
#include <iscsi/scsi-lowlevel.h>
|
|
@@ -209,47 +210,9 @@ static inline unsigned exp_random(double mean)
|
|
|
|
static int iscsi_translate_sense(struct scsi_sense *sense)
|
|
{
|
|
- int ret;
|
|
-
|
|
- switch (sense->key) {
|
|
- case SCSI_SENSE_NOT_READY:
|
|
- return -EBUSY;
|
|
- case SCSI_SENSE_DATA_PROTECTION:
|
|
- return -EACCES;
|
|
- case SCSI_SENSE_COMMAND_ABORTED:
|
|
- return -ECANCELED;
|
|
- case SCSI_SENSE_ILLEGAL_REQUEST:
|
|
- /* Parse ASCQ */
|
|
- break;
|
|
- default:
|
|
- return -EIO;
|
|
- }
|
|
- switch (sense->ascq) {
|
|
- case SCSI_SENSE_ASCQ_PARAMETER_LIST_LENGTH_ERROR:
|
|
- case SCSI_SENSE_ASCQ_INVALID_OPERATION_CODE:
|
|
- case SCSI_SENSE_ASCQ_INVALID_FIELD_IN_CDB:
|
|
- case SCSI_SENSE_ASCQ_INVALID_FIELD_IN_PARAMETER_LIST:
|
|
- ret = -EINVAL;
|
|
- break;
|
|
- case SCSI_SENSE_ASCQ_LBA_OUT_OF_RANGE:
|
|
- ret = -ENOSPC;
|
|
- break;
|
|
- case SCSI_SENSE_ASCQ_LOGICAL_UNIT_NOT_SUPPORTED:
|
|
- ret = -ENOTSUP;
|
|
- break;
|
|
- case SCSI_SENSE_ASCQ_MEDIUM_NOT_PRESENT:
|
|
- case SCSI_SENSE_ASCQ_MEDIUM_NOT_PRESENT_TRAY_CLOSED:
|
|
- case SCSI_SENSE_ASCQ_MEDIUM_NOT_PRESENT_TRAY_OPEN:
|
|
- ret = -ENOMEDIUM;
|
|
- break;
|
|
- case SCSI_SENSE_ASCQ_WRITE_PROTECTED:
|
|
- ret = -EACCES;
|
|
- break;
|
|
- default:
|
|
- ret = -EIO;
|
|
- break;
|
|
- }
|
|
- return ret;
|
|
+ return - scsi_sense_to_errno(sense->key,
|
|
+ (sense->ascq & 0xFF00) >> 8,
|
|
+ sense->ascq & 0xFF);
|
|
}
|
|
|
|
/* Called (via iscsi_service) with QemuMutex held. */
|
|
diff --git a/include/scsi/scsi.h b/include/scsi/scsi.h
|
|
new file mode 100644
|
|
index 0000000000..f894ace4bf
|
|
--- /dev/null
|
|
+++ b/include/scsi/scsi.h
|
|
@@ -0,0 +1,19 @@
|
|
+/*
|
|
+ * SCSI helpers
|
|
+ *
|
|
+ * Copyright 2017 Red Hat, Inc.
|
|
+ *
|
|
+ * Authors:
|
|
+ * Fam Zheng <famz@redhat.com>
|
|
+ *
|
|
+ * This program is free software; you can redistribute it and/or modify it
|
|
+ * under the terms of the GNU General Public License as published by the Free
|
|
+ * Software Foundation; either version 2 of the License, or (at your option)
|
|
+ * any later version.
|
|
+ */
|
|
+#ifndef QEMU_SCSI_H
|
|
+#define QEMU_SCSI_H
|
|
+
|
|
+int scsi_sense_to_errno(int key, int asc, int ascq);
|
|
+
|
|
+#endif
|
|
diff --git a/util/Makefile.objs b/util/Makefile.objs
|
|
index 50a55ecc75..c9e6c493d3 100644
|
|
--- a/util/Makefile.objs
|
|
+++ b/util/Makefile.objs
|
|
@@ -45,3 +45,4 @@ util-obj-y += qht.o
|
|
util-obj-y += range.o
|
|
util-obj-y += stats64.o
|
|
util-obj-y += systemd.o
|
|
+util-obj-y += scsi.o
|
|
diff --git a/util/scsi.c b/util/scsi.c
|
|
new file mode 100644
|
|
index 0000000000..a6710799fc
|
|
--- /dev/null
|
|
+++ b/util/scsi.c
|
|
@@ -0,0 +1,52 @@
|
|
+/*
|
|
+ * SCSI helpers
|
|
+ *
|
|
+ * Copyright 2017 Red Hat, Inc.
|
|
+ *
|
|
+ * Authors:
|
|
+ * Fam Zheng <famz@redhat.com>
|
|
+ *
|
|
+ * This program is free software; you can redistribute it and/or modify it
|
|
+ * under the terms of the GNU General Public License as published by the Free
|
|
+ * Software Foundation; either version 2 of the License, or (at your option)
|
|
+ * any later version.
|
|
+ */
|
|
+
|
|
+#include "qemu/osdep.h"
|
|
+#include "scsi/scsi.h"
|
|
+
|
|
+int scsi_sense_to_errno(int key, int asc, int ascq)
|
|
+{
|
|
+ switch (key) {
|
|
+ case 0x02: /* NOT READY */
|
|
+ return EBUSY;
|
|
+ case 0x07: /* DATA PROTECTION */
|
|
+ return EACCES;
|
|
+ case 0x0b: /* COMMAND ABORTED */
|
|
+ return ECANCELED;
|
|
+ case 0x05: /* ILLEGAL REQUEST */
|
|
+ /* Parse ASCQ */
|
|
+ break;
|
|
+ default:
|
|
+ return EIO;
|
|
+ }
|
|
+ switch ((asc << 8) | ascq) {
|
|
+ case 0x1a00: /* PARAMETER LIST LENGTH ERROR */
|
|
+ case 0x2000: /* INVALID OPERATION CODE */
|
|
+ case 0x2400: /* INVALID FIELD IN CDB */
|
|
+ case 0x2600: /* INVALID FIELD IN PARAMETER LIST */
|
|
+ return EINVAL;
|
|
+ case 0x2100: /* LBA OUT OF RANGE */
|
|
+ return ENOSPC;
|
|
+ case 0x2500: /* LOGICAL UNIT NOT SUPPORTED */
|
|
+ return ENOTSUP;
|
|
+ case 0x3a00: /* MEDIUM NOT PRESENT */
|
|
+ case 0x3a01: /* MEDIUM NOT PRESENT TRAY CLOSED */
|
|
+ case 0x3a02: /* MEDIUM NOT PRESENT TRAY OPEN */
|
|
+ return ENOMEDIUM;
|
|
+ case 0x2700: /* WRITE PROTECTED */
|
|
+ return EACCES;
|
|
+ default:
|
|
+ return EIO;
|
|
+ }
|
|
+}
|
|
--
|
|
2.13.5
|
|
|