9290838132
Fix segfault with zero length virtio-scsi disk (bz #847549)
23 lines
816 B
Diff
23 lines
816 B
Diff
From 9fbc22fddb14b1e474807bc02ab31e35af25d3a3 Mon Sep 17 00:00:00 2001
|
|
From: Alon Levy <alevy@redhat.com>
|
|
Date: Wed, 28 Nov 2012 16:38:43 +0200
|
|
Subject: [PATCH] libcacard: fix missing symbols in libcacard.so
|
|
|
|
---
|
|
libcacard/Makefile | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/libcacard/Makefile b/libcacard/Makefile
|
|
index 63990b7..9ce3117 100644
|
|
--- a/libcacard/Makefile
|
|
+++ b/libcacard/Makefile
|
|
@@ -7,7 +7,7 @@ libcacard_includedir=$(includedir)/cacard
|
|
$(call set-vpath, $(SRC_PATH))
|
|
|
|
# objects linked into a shared library, built with libtool with -fPIC if required
|
|
-QEMU_OBJS=$(oslib-obj-y) qemu-timer-common.o $(trace-obj-y)
|
|
+QEMU_OBJS=$(oslib-obj-y) qemu-timer-common.o iov.o cutils.o qemu-user.o $(trace-obj-y)
|
|
QEMU_OBJS_LIB=$(patsubst %.o,%.lo,$(QEMU_OBJS))
|
|
|
|
QEMU_CFLAGS+=-I../
|