d28bc6cae6
- merge qemu 0.10.6 - fix -net socket,listen - live migration: don't send gratuitous packets all at once - serial: fix lost characters after sysrq - Delete io-handler before closing fd after migration - Fix qemu_aio_flush - i386: fix cpu reset - Prevent CD-ROM eject while device is locked - Fix migration after hot remove with eepro100 - Don't start a VM after failed migration if stopped - Fix live migration under heavy IO load - Honor -S on incoming migration - Reset PS2 keyboard/mouse on reset - build and install extboot - Drop upstreamed qemu-prevent-cdrom-media-eject-while-device-is-locked.patch and qemu-fix-net-socket-list-init.patch and
367 lines
10 KiB
Diff
367 lines
10 KiB
Diff
From 202790c357fcff7f1222f4e7777e0cf561b516d5 Mon Sep 17 00:00:00 2001
|
|
From: aliguori <aliguori@c046a42c-6fe2-441c-8c8c-71466251a162>
|
|
Date: Fri, 6 Mar 2009 20:27:10 +0000
|
|
Subject: [PATCH] Refactor keymap code to avoid duplication ("Daniel P. Berrange")
|
|
|
|
Each of the graphical frontends #include a .c file, for keymap code
|
|
resulting in duplicated definitions & duplicated compiled code. A
|
|
couple of small changes allowed this to be sanitized, so instead of
|
|
doing a #include "keymaps.c", duplicating all code, we can have a
|
|
shared keymaps.h file, and only compile code once. This allows the
|
|
next patch to move the VncState struct out into a header file without
|
|
causing clashing definitions.
|
|
|
|
(cherry picked from commit 0483755a4d1fd61fe9c284166f67ae08af8d858b)
|
|
|
|
Signed-off-by: Daniel P. Berrange <berrange@redhat.com>
|
|
Signed-off-by: Anthony Liguori <aliguori@us.ibm.com>
|
|
Signed-off-by: Mark McLoughlin <markmc@redhat.com>
|
|
Fedora-patch: 03-display-keymaps.patch
|
|
---
|
|
Makefile | 9 +++++--
|
|
curses.c | 3 +-
|
|
curses_keys.h | 9 +++----
|
|
keymaps.c | 45 ++++++++++++++++--------------------------
|
|
keymaps.h | 60 +++++++++++++++++++++++++++++++++++++++++++++++++++++++++
|
|
sdl.c | 3 +-
|
|
sdl_keysym.h | 7 ++---
|
|
vnc.c | 5 +--
|
|
vnc_keysym.h | 7 ++---
|
|
9 files changed, 97 insertions(+), 51 deletions(-)
|
|
create mode 100644 keymaps.h
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index 92eb447..f74b7eb 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -141,6 +141,7 @@ endif
|
|
AUDIO_OBJS+= wavcapture.o
|
|
OBJS+=$(addprefix audio/, $(AUDIO_OBJS))
|
|
|
|
+OBJS+=keymaps.o
|
|
ifdef CONFIG_SDL
|
|
OBJS+=sdl.o x_keymap.o
|
|
endif
|
|
@@ -165,15 +166,17 @@ LIBS+=$(VDE_LIBS)
|
|
|
|
cocoa.o: cocoa.m
|
|
|
|
-sdl.o: sdl.c keymaps.c sdl_keysym.h
|
|
+keymaps.o: keymaps.c keymaps.h
|
|
+
|
|
+sdl.o: sdl.c keymaps.h sdl_keysym.h
|
|
|
|
sdl.o audio/sdlaudio.o: CFLAGS += $(SDL_CFLAGS)
|
|
|
|
-vnc.o: vnc.c keymaps.c sdl_keysym.h vnchextile.h d3des.c d3des.h
|
|
+vnc.o: vnc.c keymaps.h sdl_keysym.h vnchextile.h d3des.c d3des.h
|
|
|
|
vnc.o: CFLAGS += $(CONFIG_VNC_TLS_CFLAGS)
|
|
|
|
-curses.o: curses.c keymaps.c curses_keys.h
|
|
+curses.o: curses.c keymaps.h curses_keys.h
|
|
|
|
bt-host.o: CFLAGS += $(CONFIG_BLUEZ_CFLAGS)
|
|
|
|
diff --git a/curses.c b/curses.c
|
|
index d699b5e..434e1cf 100644
|
|
--- a/curses.c
|
|
+++ b/curses.c
|
|
@@ -158,7 +158,6 @@ static void curses_cursor_position(DisplayState *ds, int x, int y)
|
|
/* generic keyboard conversion */
|
|
|
|
#include "curses_keys.h"
|
|
-#include "keymaps.c"
|
|
|
|
static kbd_layout_t *kbd_layout = 0;
|
|
static int keycode2keysym[CURSES_KEYS];
|
|
@@ -311,7 +310,7 @@ static void curses_keyboard_setup(void)
|
|
keyboard_layout = "en-us";
|
|
#endif
|
|
if(keyboard_layout) {
|
|
- kbd_layout = init_keyboard_layout(keyboard_layout);
|
|
+ kbd_layout = init_keyboard_layout(name2keysym, keyboard_layout);
|
|
if (!kbd_layout)
|
|
exit(1);
|
|
}
|
|
diff --git a/curses_keys.h b/curses_keys.h
|
|
index 0105279..fd25451 100644
|
|
--- a/curses_keys.h
|
|
+++ b/curses_keys.h
|
|
@@ -21,6 +21,10 @@
|
|
* OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
|
|
* THE SOFTWARE.
|
|
*/
|
|
+
|
|
+#include "keymaps.h"
|
|
+
|
|
+
|
|
#define KEY_RELEASE 0x80
|
|
#define KEY_MASK 0x7f
|
|
#define SHIFT_CODE 0x2a
|
|
@@ -239,11 +243,6 @@ static const int curses2keysym[CURSES_KEYS] = {
|
|
|
|
};
|
|
|
|
-typedef struct {
|
|
- const char* name;
|
|
- int keysym;
|
|
-} name2keysym_t;
|
|
-
|
|
static const name2keysym_t name2keysym[] = {
|
|
/* Plain ASCII */
|
|
{ "space", 0x020 },
|
|
diff --git a/keymaps.c b/keymaps.c
|
|
index 216e378..3b86dc1 100644
|
|
--- a/keymaps.c
|
|
+++ b/keymaps.c
|
|
@@ -22,34 +22,20 @@
|
|
* THE SOFTWARE.
|
|
*/
|
|
|
|
-static int get_keysym(const char *name)
|
|
+#include "keymaps.h"
|
|
+#include "sysemu.h"
|
|
+
|
|
+static int get_keysym(const name2keysym_t *table,
|
|
+ const char *name)
|
|
{
|
|
const name2keysym_t *p;
|
|
- for(p = name2keysym; p->name != NULL; p++) {
|
|
+ for(p = table; p->name != NULL; p++) {
|
|
if (!strcmp(p->name, name))
|
|
return p->keysym;
|
|
}
|
|
return 0;
|
|
}
|
|
|
|
-struct key_range {
|
|
- int start;
|
|
- int end;
|
|
- struct key_range *next;
|
|
-};
|
|
-
|
|
-#define MAX_NORMAL_KEYCODE 512
|
|
-#define MAX_EXTRA_COUNT 256
|
|
-typedef struct {
|
|
- uint16_t keysym2keycode[MAX_NORMAL_KEYCODE];
|
|
- struct {
|
|
- int keysym;
|
|
- uint16_t keycode;
|
|
- } keysym2keycode_extra[MAX_EXTRA_COUNT];
|
|
- int extra_count;
|
|
- struct key_range *keypad_range;
|
|
- struct key_range *numlock_range;
|
|
-} kbd_layout_t;
|
|
|
|
static void add_to_key_range(struct key_range **krp, int code) {
|
|
struct key_range *kr;
|
|
@@ -73,7 +59,8 @@ static void add_to_key_range(struct key_range **krp, int code) {
|
|
}
|
|
}
|
|
|
|
-static kbd_layout_t *parse_keyboard_layout(const char *language,
|
|
+static kbd_layout_t *parse_keyboard_layout(const name2keysym_t *table,
|
|
+ const char *language,
|
|
kbd_layout_t * k)
|
|
{
|
|
FILE *f;
|
|
@@ -102,7 +89,7 @@ static kbd_layout_t *parse_keyboard_layout(const char *language,
|
|
if (!strncmp(line, "map ", 4))
|
|
continue;
|
|
if (!strncmp(line, "include ", 8)) {
|
|
- parse_keyboard_layout(line + 8, k);
|
|
+ parse_keyboard_layout(table, line + 8, k);
|
|
} else {
|
|
char *end_of_keysym = line;
|
|
while (*end_of_keysym != 0 && *end_of_keysym != ' ')
|
|
@@ -110,7 +97,7 @@ static kbd_layout_t *parse_keyboard_layout(const char *language,
|
|
if (*end_of_keysym) {
|
|
int keysym;
|
|
*end_of_keysym = 0;
|
|
- keysym = get_keysym(line);
|
|
+ keysym = get_keysym(table, line);
|
|
if (keysym == 0) {
|
|
// fprintf(stderr, "Warning: unknown keysym %s\n", line);
|
|
} else {
|
|
@@ -154,12 +141,14 @@ static kbd_layout_t *parse_keyboard_layout(const char *language,
|
|
return k;
|
|
}
|
|
|
|
-static void *init_keyboard_layout(const char *language)
|
|
+
|
|
+void *init_keyboard_layout(const name2keysym_t *table, const char *language)
|
|
{
|
|
- return parse_keyboard_layout(language, 0);
|
|
+ return parse_keyboard_layout(table, language, 0);
|
|
}
|
|
|
|
-static int keysym2scancode(void *kbd_layout, int keysym)
|
|
+
|
|
+int keysym2scancode(void *kbd_layout, int keysym)
|
|
{
|
|
kbd_layout_t *k = kbd_layout;
|
|
if (keysym < MAX_NORMAL_KEYCODE) {
|
|
@@ -180,7 +169,7 @@ static int keysym2scancode(void *kbd_layout, int keysym)
|
|
return 0;
|
|
}
|
|
|
|
-static inline int keycode_is_keypad(void *kbd_layout, int keycode)
|
|
+int keycode_is_keypad(void *kbd_layout, int keycode)
|
|
{
|
|
kbd_layout_t *k = kbd_layout;
|
|
struct key_range *kr;
|
|
@@ -191,7 +180,7 @@ static inline int keycode_is_keypad(void *kbd_layout, int keycode)
|
|
return 0;
|
|
}
|
|
|
|
-static inline int keysym_is_numlock(void *kbd_layout, int keysym)
|
|
+int keysym_is_numlock(void *kbd_layout, int keysym)
|
|
{
|
|
kbd_layout_t *k = kbd_layout;
|
|
struct key_range *kr;
|
|
diff --git a/keymaps.h b/keymaps.h
|
|
new file mode 100644
|
|
index 0000000..17f6efd
|
|
--- /dev/null
|
|
+++ b/keymaps.h
|
|
@@ -0,0 +1,60 @@
|
|
+/*
|
|
+ * QEMU keysym to keycode conversion using rdesktop keymaps
|
|
+ *
|
|
+ * Copyright (c) 2004 Johannes Schindelin
|
|
+ *
|
|
+ * Permission is hereby granted, free of charge, to any person obtaining a copy
|
|
+ * of this software and associated documentation files (the "Software"), to deal
|
|
+ * in the Software without restriction, including without limitation the rights
|
|
+ * to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
|
|
+ * copies of the Software, and to permit persons to whom the Software is
|
|
+ * furnished to do so, subject to the following conditions:
|
|
+ *
|
|
+ * The above copyright notice and this permission notice shall be included in
|
|
+ * all copies or substantial portions of the Software.
|
|
+ *
|
|
+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
|
|
+ * IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
|
|
+ * FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
|
|
+ * THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
|
|
+ * LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
|
|
+ * OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
|
|
+ * THE SOFTWARE.
|
|
+ */
|
|
+
|
|
+#ifndef __QEMU_KEYMAPS_H__
|
|
+#define __QEMU_KEYMAPS_H__
|
|
+
|
|
+#include "qemu-common.h"
|
|
+
|
|
+typedef struct {
|
|
+ const char* name;
|
|
+ int keysym;
|
|
+} name2keysym_t;
|
|
+
|
|
+struct key_range {
|
|
+ int start;
|
|
+ int end;
|
|
+ struct key_range *next;
|
|
+};
|
|
+
|
|
+#define MAX_NORMAL_KEYCODE 512
|
|
+#define MAX_EXTRA_COUNT 256
|
|
+typedef struct {
|
|
+ uint16_t keysym2keycode[MAX_NORMAL_KEYCODE];
|
|
+ struct {
|
|
+ int keysym;
|
|
+ uint16_t keycode;
|
|
+ } keysym2keycode_extra[MAX_EXTRA_COUNT];
|
|
+ int extra_count;
|
|
+ struct key_range *keypad_range;
|
|
+ struct key_range *numlock_range;
|
|
+} kbd_layout_t;
|
|
+
|
|
+
|
|
+void *init_keyboard_layout(const name2keysym_t *table, const char *language);
|
|
+int keysym2scancode(void *kbd_layout, int keysym);
|
|
+int keycode_is_keypad(void *kbd_layout, int keycode);
|
|
+int keysym_is_numlock(void *kbd_layout, int keysym);
|
|
+
|
|
+#endif /* __QEMU_KEYMAPS_H__ */
|
|
diff --git a/sdl.c b/sdl.c
|
|
index 95efe8d..8b7a1fe 100644
|
|
--- a/sdl.c
|
|
+++ b/sdl.c
|
|
@@ -109,7 +109,6 @@ static void sdl_resize(DisplayState *ds)
|
|
/* generic keyboard conversion */
|
|
|
|
#include "sdl_keysym.h"
|
|
-#include "keymaps.c"
|
|
|
|
static kbd_layout_t *kbd_layout = NULL;
|
|
|
|
@@ -680,7 +679,7 @@ void sdl_display_init(DisplayState *ds, int full_screen, int no_frame)
|
|
keyboard_layout = "en-us";
|
|
#endif
|
|
if(keyboard_layout) {
|
|
- kbd_layout = init_keyboard_layout(keyboard_layout);
|
|
+ kbd_layout = init_keyboard_layout(name2keysym, keyboard_layout);
|
|
if (!kbd_layout)
|
|
exit(1);
|
|
}
|
|
diff --git a/sdl_keysym.h b/sdl_keysym.h
|
|
index c9087d7..c213ef8 100644
|
|
--- a/sdl_keysym.h
|
|
+++ b/sdl_keysym.h
|
|
@@ -1,7 +1,6 @@
|
|
-typedef struct {
|
|
- const char* name;
|
|
- int keysym;
|
|
-} name2keysym_t;
|
|
+
|
|
+#include "keymaps.h"
|
|
+
|
|
static const name2keysym_t name2keysym[]={
|
|
/* ascii */
|
|
{ "space", 0x020},
|
|
diff --git a/vnc.c b/vnc.c
|
|
index d7d9b91..969d5b0 100644
|
|
--- a/vnc.c
|
|
+++ b/vnc.c
|
|
@@ -35,7 +35,6 @@
|
|
|
|
#include "vnc.h"
|
|
#include "vnc_keysym.h"
|
|
-#include "keymaps.c"
|
|
#include "d3des.h"
|
|
|
|
#ifdef CONFIG_VNC_TLS
|
|
@@ -2428,9 +2427,9 @@ void vnc_display_init(DisplayState *ds)
|
|
vs->ds = ds;
|
|
|
|
if (keyboard_layout)
|
|
- vs->kbd_layout = init_keyboard_layout(keyboard_layout);
|
|
+ vs->kbd_layout = init_keyboard_layout(name2keysym, keyboard_layout);
|
|
else
|
|
- vs->kbd_layout = init_keyboard_layout("en-us");
|
|
+ vs->kbd_layout = init_keyboard_layout(name2keysym, "en-us");
|
|
|
|
if (!vs->kbd_layout)
|
|
exit(1);
|
|
diff --git a/vnc_keysym.h b/vnc_keysym.h
|
|
index ce355d8..2d255c9 100644
|
|
--- a/vnc_keysym.h
|
|
+++ b/vnc_keysym.h
|
|
@@ -1,7 +1,6 @@
|
|
-typedef struct {
|
|
- const char* name;
|
|
- int keysym;
|
|
-} name2keysym_t;
|
|
+
|
|
+#include "keymaps.h"
|
|
+
|
|
static const name2keysym_t name2keysym[]={
|
|
/* ascii */
|
|
{ "space", 0x020},
|
|
--
|
|
1.6.2.5
|
|
|