f36b5bbd6f
Signed-off-by: Cole Robinson <crobinso@redhat.com>
59 lines
2.1 KiB
Diff
59 lines
2.1 KiB
Diff
From e4a112c75a02a789e7710e805f66211426087d55 Mon Sep 17 00:00:00 2001
|
|
Message-ID: <e4a112c75a02a789e7710e805f66211426087d55.1692544104.git.crobinso@redhat.com>
|
|
From: Cole Robinson <crobinso@redhat.com>
|
|
Date: Sun, 20 Aug 2023 10:49:12 -0400
|
|
Subject: [PATCH] tests: Disable iotests, like RHEL does
|
|
Content-type: text/plain
|
|
|
|
Signed-off-by: Cole Robinson <crobinso@redhat.com>
|
|
---
|
|
tests/qemu-iotests/meson.build | 34 +++++++++++++++++-----------------
|
|
1 file changed, 17 insertions(+), 17 deletions(-)
|
|
|
|
diff --git a/tests/qemu-iotests/meson.build b/tests/qemu-iotests/meson.build
|
|
index 44761e1e4d..78c5836325 100644
|
|
--- a/tests/qemu-iotests/meson.build
|
|
+++ b/tests/qemu-iotests/meson.build
|
|
@@ -51,21 +51,21 @@ foreach format, speed: qemu_iotests_formats
|
|
check: true,
|
|
)
|
|
|
|
- foreach item: rc.stdout().strip().split()
|
|
- args = [qemu_iotests_check_cmd,
|
|
- '-tap', '-' + format, item,
|
|
- '--source-dir', meson.current_source_dir(),
|
|
- '--build-dir', meson.current_build_dir()]
|
|
- # Some individual tests take as long as 45 seconds
|
|
- # Bump the timeout to 3 minutes for some headroom
|
|
- # on slow machines to minimize spurious failures
|
|
- test('io-' + format + '-' + item,
|
|
- python,
|
|
- args: args,
|
|
- depends: qemu_iotests_binaries,
|
|
- env: qemu_iotests_env,
|
|
- protocol: 'tap',
|
|
- timeout: 180,
|
|
- suite: suites)
|
|
- endforeach
|
|
+# foreach item: rc.stdout().strip().split()
|
|
+# args = [qemu_iotests_check_cmd,
|
|
+# '-tap', '-' + format, item,
|
|
+# '--source-dir', meson.current_source_dir(),
|
|
+# '--build-dir', meson.current_build_dir()]
|
|
+# # Some individual tests take as long as 45 seconds
|
|
+# # Bump the timeout to 3 minutes for some headroom
|
|
+# # on slow machines to minimize spurious failures
|
|
+# test('io-' + format + '-' + item,
|
|
+# python,
|
|
+# args: args,
|
|
+# depends: qemu_iotests_binaries,
|
|
+# env: qemu_iotests_env,
|
|
+# protocol: 'tap',
|
|
+# timeout: 180,
|
|
+# suite: suites)
|
|
+# endforeach
|
|
endforeach
|
|
--
|
|
2.41.0
|
|
|