qemu/qemu-fix-build-for-esd-audio.patch
Mark McLoughlin a8abd8e63a - Update to kvm-88, see http://www.linux-kvm.org/page/ChangeLog
- Package mutiboot.bin
- Update for how extboot is built
- Fix sf.net source URL
- Drop qemu-fix-ppc-softmmu-kvm-disabled-build.patch
- Drop qemu-fix-pcspk-build-with-kvm-disabled.patch
- Cherry-pick fix for esound support build failure
2009-07-16 11:15:53 +00:00

45 lines
1006 B
Diff

From b37fb38b6043e319768fa92d5541fe20afb4741b Mon Sep 17 00:00:00 2001
From: Anthony Liguori <aliguori@us.ibm.com>
Date: Wed, 1 Jul 2009 10:07:16 -0500
Subject: [PATCH 4/4] Fix build for ESD audio
(cherry picked from commit c6a5a71a3a1886afad5eeb214eb6e8785f4e0319)
Signed-off-by: Anthony Liguori <aliguori@us.ibm.com>
Signed-off-by: Mark McLoughlin <markmc@redhat.com>
---
Makefile | 10 +++++-----
1 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/Makefile b/Makefile
index fc40431..f5deae9 100644
--- a/Makefile
+++ b/Makefile
@@ -139,18 +139,18 @@ obj-y += migration-exec.o
endif
ifdef CONFIG_COREAUDIO
-AUDIO_PT = yes
+AUDIO_PT = y
endif
ifdef CONFIG_FMOD
audio/audio.o audio/fmodaudio.o: CPPFLAGS := -I$(CONFIG_FMOD_INC) $(CPPFLAGS)
endif
ifdef CONFIG_ESD
-AUDIO_PT = yes
-AUDIO_PT_INT = yes
+AUDIO_PT = y
+AUDIO_PT_INT = y
endif
ifdef CONFIG_PA
-AUDIO_PT = yes
-AUDIO_PT_INT = yes
+AUDIO_PT = y
+AUDIO_PT_INT = y
endif
ifdef AUDIO_PT
LDFLAGS += -pthread
--
1.6.3.3