New release qemu-9.0.0-rc4
Signed-off-by: Cole Robinson <crobinso@redhat.com>
This commit is contained in:
parent
7d58afccfc
commit
fa9ecd2d1f
@ -1,52 +0,0 @@
|
||||
From 12cbd48e1e78f07b19df900b0f9ccdd633aa42ee Mon Sep 17 00:00:00 2001
|
||||
From: Cole Robinson <crobinso@redhat.com>
|
||||
Date: Mon, 27 Nov 2023 12:51:25 -0500
|
||||
Subject: [PATCH] pc-bios/optionrom: Fix pvh.img ld build failure on fedora
|
||||
rawhide
|
||||
Content-type: text/plain
|
||||
|
||||
binutils 2.39 shows some warnings when building pvh.img
|
||||
|
||||
/usr/bin/ld: warning: pvh.o: missing .note.GNU-stack section implies executable stack
|
||||
/usr/bin/ld: NOTE: This behaviour is deprecated and will be removed in a future version of the linker
|
||||
/usr/bin/ld: warning: pvh.img has a LOAD segment with RWX permissions
|
||||
|
||||
The latter of which is fatal on Fedora rawhide for some reason.
|
||||
|
||||
Add linker options to suppress the errors
|
||||
|
||||
Signed-off-by: Cole Robinson <crobinso@redhat.com>
|
||||
---
|
||||
pc-bios/optionrom/Makefile | 12 +++++++++++-
|
||||
1 file changed, 11 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/pc-bios/optionrom/Makefile b/pc-bios/optionrom/Makefile
|
||||
index 30d07026c7..87cfc484c7 100644
|
||||
--- a/pc-bios/optionrom/Makefile
|
||||
+++ b/pc-bios/optionrom/Makefile
|
||||
@@ -38,6 +38,16 @@ config-cc.mak: Makefile
|
||||
|
||||
override LDFLAGS = -nostdlib -Wl,--build-id=none,-T,$(SRC_DIR)/flat.lds
|
||||
|
||||
+ld-test = $(LD) -v $1 >/dev/null 2>/dev/null
|
||||
+ld-option = if $(call ld-test, $1); then \
|
||||
+ echo "$(TARGET_PREFIX)$1 detected" && echo "override LDFLAGS += -Wl,$1" >&3; else \
|
||||
+ echo "$(TARGET_PREFIX)$1 not detected" $(if $2,&& echo "override LDFLAGS += $2" >&3); fi
|
||||
+
|
||||
+config-ld.mak: Makefile
|
||||
+ $(quiet-@)($(call ld-option,--no-warn-rwx-segments); \
|
||||
+ $(call ld-option,--no-warn-execstack)) 3> config-ld.mak
|
||||
+-include config-ld.mak
|
||||
+
|
||||
pvh.img: pvh.o pvh_main.o
|
||||
|
||||
%.o: %.S
|
||||
@@ -61,7 +71,7 @@ clean:
|
||||
rm -f *.o *.d *.raw *.img *.bin *~
|
||||
|
||||
distclean:
|
||||
- rm -f config-cc.mak
|
||||
+ rm -f config-cc.mak config-ld.mak
|
||||
|
||||
# suppress auto-removal of intermediate files
|
||||
.SECONDARY:
|
@ -1,82 +0,0 @@
|
||||
From 2df5c1f5b014126595a26c6797089d284a3b211c Mon Sep 17 00:00:00 2001
|
||||
From: Harsh Prateek Bora <harshpb@linux.ibm.com>
|
||||
Date: Wed, 24 Jan 2024 10:30:55 +1000
|
||||
Subject: [PATCH] ppc/spapr: Introduce SPAPR_IRQ_NR_IPIS to refer IRQ range for
|
||||
CPU IPIs.
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
spapr_irq_init currently uses existing macro SPAPR_XIRQ_BASE to refer to
|
||||
the range of CPU IPIs during initialization of nr-irqs property.
|
||||
It is more appropriate to have its own define which can be further
|
||||
reused as appropriate for correct interpretation.
|
||||
|
||||
Suggested-by: Cedric Le Goater <clg@kaod.org>
|
||||
Reviewed-by: Cédric Le Goater <clg@kaod.org>
|
||||
Tested-by: Kowshik Jois <kowsjois@linux.ibm.com>
|
||||
Signed-off-by: Harsh Prateek Bora <harshpb@linux.ibm.com>
|
||||
Signed-off-by: Nicholas Piggin <npiggin@gmail.com>
|
||||
---
|
||||
hw/ppc/spapr_irq.c | 6 ++++--
|
||||
include/hw/ppc/spapr_irq.h | 14 +++++++++++++-
|
||||
2 files changed, 17 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/hw/ppc/spapr_irq.c b/hw/ppc/spapr_irq.c
|
||||
index a0d1e1298e1e..97b2fc42ab03 100644
|
||||
--- a/hw/ppc/spapr_irq.c
|
||||
+++ b/hw/ppc/spapr_irq.c
|
||||
@@ -23,6 +23,8 @@
|
||||
|
||||
#include "trace.h"
|
||||
|
||||
+QEMU_BUILD_BUG_ON(SPAPR_IRQ_NR_IPIS > SPAPR_XIRQ_BASE);
|
||||
+
|
||||
static const TypeInfo spapr_intc_info = {
|
||||
.name = TYPE_SPAPR_INTC,
|
||||
.parent = TYPE_INTERFACE,
|
||||
@@ -329,7 +331,7 @@ void spapr_irq_init(SpaprMachineState *spapr, Error **errp)
|
||||
int i;
|
||||
|
||||
dev = qdev_new(TYPE_SPAPR_XIVE);
|
||||
- qdev_prop_set_uint32(dev, "nr-irqs", smc->nr_xirqs + SPAPR_XIRQ_BASE);
|
||||
+ qdev_prop_set_uint32(dev, "nr-irqs", smc->nr_xirqs + SPAPR_IRQ_NR_IPIS);
|
||||
/*
|
||||
* 8 XIVE END structures per CPU. One for each available
|
||||
* priority
|
||||
@@ -356,7 +358,7 @@ void spapr_irq_init(SpaprMachineState *spapr, Error **errp)
|
||||
}
|
||||
|
||||
spapr->qirqs = qemu_allocate_irqs(spapr_set_irq, spapr,
|
||||
- smc->nr_xirqs + SPAPR_XIRQ_BASE);
|
||||
+ smc->nr_xirqs + SPAPR_IRQ_NR_IPIS);
|
||||
|
||||
/*
|
||||
* Mostly we don't actually need this until reset, except that not
|
||||
diff --git a/include/hw/ppc/spapr_irq.h b/include/hw/ppc/spapr_irq.h
|
||||
index c22a72c9e270..4fd2d5853d8b 100644
|
||||
--- a/include/hw/ppc/spapr_irq.h
|
||||
+++ b/include/hw/ppc/spapr_irq.h
|
||||
@@ -14,9 +14,21 @@
|
||||
#include "qom/object.h"
|
||||
|
||||
/*
|
||||
- * IRQ range offsets per device type
|
||||
+ * The XIVE IRQ backend uses the same layout as the XICS backend but
|
||||
+ * covers the full range of the IRQ number space. The IRQ numbers for
|
||||
+ * the CPU IPIs are allocated at the bottom of this space, below 4K,
|
||||
+ * to preserve compatibility with XICS which does not use that range.
|
||||
+ */
|
||||
+
|
||||
+/*
|
||||
+ * CPU IPI range (XIVE only)
|
||||
*/
|
||||
#define SPAPR_IRQ_IPI 0x0
|
||||
+#define SPAPR_IRQ_NR_IPIS 0x1000
|
||||
+
|
||||
+/*
|
||||
+ * IRQ range offsets per device type
|
||||
+ */
|
||||
|
||||
#define SPAPR_XIRQ_BASE XICS_IRQ_BASE /* 0x1000 */
|
||||
#define SPAPR_IRQ_EPOW (SPAPR_XIRQ_BASE + 0x0000)
|
@ -1,75 +0,0 @@
|
||||
From c4f91d7b7be76c47015521ab0109c6e998a369b0 Mon Sep 17 00:00:00 2001
|
||||
From: Harsh Prateek Bora <harshpb@linux.ibm.com>
|
||||
Date: Wed, 24 Jan 2024 10:30:55 +1000
|
||||
Subject: [PATCH] ppc/spapr: Initialize max_cpus limit to SPAPR_IRQ_NR_IPIS.
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Initialize the machine specific max_cpus limit as per the maximum range
|
||||
of CPU IPIs available. Keeping between 4096 to 8192 will throw IRQ not
|
||||
free error due to XIVE/XICS limitation and keeping beyond 8192 will hit
|
||||
assert in tcg_region_init or spapr_xive_claim_irq.
|
||||
|
||||
Logs:
|
||||
|
||||
Without patch fix:
|
||||
|
||||
[root@host build]# qemu-system-ppc64 -accel tcg -smp 10,maxcpus=4097
|
||||
qemu-system-ppc64: IRQ 4096 is not free
|
||||
[root@host build]#
|
||||
|
||||
On LPAR:
|
||||
[root@host build]# qemu-system-ppc64 -accel tcg -smp 10,maxcpus=8193
|
||||
**
|
||||
ERROR:../tcg/region.c:774:tcg_region_init: assertion failed:
|
||||
(region_size >= 2 * page_size)
|
||||
Bail out! ERROR:../tcg/region.c:774:tcg_region_init: assertion failed:
|
||||
(region_size >= 2 * page_size)
|
||||
Aborted (core dumped)
|
||||
[root@host build]#
|
||||
|
||||
On x86:
|
||||
[root@host build]# qemu-system-ppc64 -accel tcg -smp 10,maxcpus=8193
|
||||
qemu-system-ppc64: ../hw/intc/spapr_xive.c:596: spapr_xive_claim_irq:
|
||||
Assertion `lisn < xive->nr_irqs' failed.
|
||||
Aborted (core dumped)
|
||||
[root@host build]#
|
||||
|
||||
With patch fix:
|
||||
[root@host build]# qemu-system-ppc64 -accel tcg -smp 10,maxcpus=4097
|
||||
qemu-system-ppc64: Invalid SMP CPUs 4097. The max CPUs supported by
|
||||
machine 'pseries-8.2' is 4096
|
||||
[root@host build]#
|
||||
|
||||
|
||||
Reported-by: Kowshik Jois <kowsjois@linux.ibm.com>
|
||||
Tested-by: Kowshik Jois <kowsjois@linux.ibm.com>
|
||||
Reviewed-by: Cédric Le Goater <clg@kaod.org>
|
||||
Signed-off-by: Harsh Prateek Bora <harshpb@linux.ibm.com>
|
||||
Signed-off-by: Nicholas Piggin <npiggin@gmail.com>
|
||||
---
|
||||
hw/ppc/spapr.c | 9 +++------
|
||||
1 file changed, 3 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/hw/ppc/spapr.c b/hw/ppc/spapr.c
|
||||
index 0d72d286d80f..0028ce0b673b 100644
|
||||
--- a/hw/ppc/spapr.c
|
||||
+++ b/hw/ppc/spapr.c
|
||||
@@ -4639,13 +4639,10 @@ static void spapr_machine_class_init(ObjectClass *oc, void *data)
|
||||
mc->block_default_type = IF_SCSI;
|
||||
|
||||
/*
|
||||
- * Setting max_cpus to INT32_MAX. Both KVM and TCG max_cpus values
|
||||
- * should be limited by the host capability instead of hardcoded.
|
||||
- * max_cpus for KVM guests will be checked in kvm_init(), and TCG
|
||||
- * guests are welcome to have as many CPUs as the host are capable
|
||||
- * of emulate.
|
||||
+ * While KVM determines max cpus in kvm_init() using kvm_max_vcpus(),
|
||||
+ * In TCG the limit is restricted by the range of CPU IPIs available.
|
||||
*/
|
||||
- mc->max_cpus = INT32_MAX;
|
||||
+ mc->max_cpus = SPAPR_IRQ_NR_IPIS;
|
||||
|
||||
mc->no_parallel = 1;
|
||||
mc->default_boot_order = "";
|
@ -1,210 +0,0 @@
|
||||
From qemu-devel-bounces+rjones=redhat.com@nongnu.org Tue Feb 20 14:15:07 2024
|
||||
X-Spam-Checker-Version: SpamAssassin 3.4.2 (2018-09-13) on
|
||||
rhmail.home.annexia.org
|
||||
X-Spam-Level:
|
||||
X-Spam-Status: No, score=-3.6 required=5.0 tests=BAYES_00,DKIM_ADSP_CUSTOM_MED,
|
||||
FREEMAIL_FROM,MAILING_LIST_MULTI,RCVD_IN_DNSWL_LOW,SPF_HELO_NONE,
|
||||
T_SCC_BODY_TEXT_LINE autolearn=ham autolearn_force=no version=3.4.2
|
||||
Delivered-To: rjones@gapps.redhat.com
|
||||
Received: from imap.gmail.com [2a00:1450:400c:c06::6c]
|
||||
by rhmail.home.annexia.org with IMAP (fetchmail-6.3.24)
|
||||
for <rjones@localhost> (single-drop); Tue, 20 Feb 2024 14:15:07 +0000 (GMT)
|
||||
Received: by 2002:adf:9c85:0:b0:337:c4af:7eda with SMTP id d5csp1377865wre;
|
||||
Tue, 20 Feb 2024 06:14:45 -0800 (PST)
|
||||
X-Forwarded-Encrypted: i=2;
|
||||
AJvYcCVmEOlyyvvd2pjxJlVqmm6wAsFvP2QS6RrV8WHdcPQ9BbSQtwkd4h6dvrOsn7U4WKwJ+S9i3pICvKhQ6p2IG/C63ey7jQaX6g==
|
||||
X-Google-Smtp-Source: AGHT+IE5mSiEO9H5JEkHNlHfhZDS2s9/kx/Heg/BJJ4bRe1DByou2O4YqVcehEElFPcfnv1EbTzP
|
||||
X-Received: by 2002:ac8:7e82:0:b0:42e:1a0c:5561 with SMTP id
|
||||
w2-20020ac87e82000000b0042e1a0c5561mr4869415qtj.11.1708438485118; Tue, 20 Feb
|
||||
2024 06:14:45 -0800 (PST)
|
||||
ARC-Seal: i=1; a=rsa-sha256; t=1708438485; cv=none; d=google.com;
|
||||
s=arc-20160816;
|
||||
b=ey2nB0Hz7p8/LRoN4jZjtpNuGZQ63SBhaAnxzcDl/T2RrxPzHh65rz1zmLdWzVCLkQ
|
||||
v+yYlKkQFU8NNp3UT4S4zYwfeGSE1kFImALTRCMrWHrkw9LZZZb2BeEsiziU3hlaWROV
|
||||
UVjYZdUHzbALZboflhpU0jK2UBurjafvHopQR7okuWukM2MkehE707uhOPscNCgZG8f9
|
||||
ZtrZX2StAQhzGbE+rGPka9c6AdsKBWYcVUbAe//oQeRl1NCUorQedrseU25E1dcobqwl
|
||||
80kRNnHYH+GOx7inmTEi8W2DSWb3g48Q0EEVWc/sfDB/f2t6PO4sELzmSvhytswBISkg D57A==
|
||||
ARC-Message-Signature: i=1; a=rsa-sha256; c=relaxed/relaxed; d=google.com;
|
||||
s=arc-20160816;
|
||||
h=content-transfer-encoding:sender:errors-to:list-subscribe:list-help
|
||||
:list-post:list-archive:list-unsubscribe:list-id:precedence
|
||||
:mime-version:message-id:date:subject:cc:to:from:delivered-to;
|
||||
bh=uNCdCIQzg/12W/RrXAVFQ1Isw/BMjvNQW4Y14ZuF5vg=;
|
||||
fh=k0ip+oilfdxldYSElE+D70uElArHhwV8D0y78HTEik8=;
|
||||
b=U8UgVOefnhiU8Ata8X00Xvx9Y6fexE3GSwQioOOaRIx9xhn1c0xjhLQ4N5DB19Cbt2
|
||||
U+lqbgtVw4xI915hyyC1NRT3w/ImfJLikpDpzXLpmbJCOMYj0J7qkTFPsPXBLMx/fDi8
|
||||
Ctg2koPP9m5EG4cAEIacP85/2vee28uKUFbdeB/B8DIsSIQYWGskfMNaqv2NOvW9O4Fj
|
||||
qyhK2YEImZY2KK3xW48LAtPW/oqqvfmtYmJn40otnhiU6eErtS71NJmccE1lca4P7xil
|
||||
dtz0Rqc3C8iTH8eayxAeT7xD4AFZznehPPWbMxK3C5kecZ8bnceNw5cmQqfvQRmR0yGB bNKA==;
|
||||
dara=google.com
|
||||
ARC-Authentication-Results: i=1; mx.google.com; spf=pass (google.com: domain
|
||||
of qemu-devel-bounces+rjones=redhat.com@nongnu.org designates 209.51.188.17
|
||||
as permitted sender)
|
||||
smtp.mailfrom="qemu-devel-bounces+rjones=redhat.com@nongnu.org"
|
||||
Return-Path: <qemu-devel-bounces+rjones=redhat.com@nongnu.org>
|
||||
Received: from us-smtp-inbound-delivery-1.mimecast.com
|
||||
(us-smtp-delivery-1.mimecast.com. [205.139.110.120]) by mx.google.com with
|
||||
ESMTPS id
|
||||
m9-20020ac86889000000b0042c2147b5d1si8208493qtq.474.2024.02.20.06.14.44 for
|
||||
<rjones@gapps.redhat.com> (version=TLS1_3 cipher=TLS_AES_256_GCM_SHA384
|
||||
bits=256/256); Tue, 20 Feb 2024 06:14:45 -0800 (PST)
|
||||
Received-SPF: pass (google.com: domain of
|
||||
qemu-devel-bounces+rjones=redhat.com@nongnu.org designates 209.51.188.17 as
|
||||
permitted sender) client-ip=209.51.188.17;
|
||||
Authentication-Results: mx.google.com; spf=pass (google.com: domain of
|
||||
qemu-devel-bounces+rjones=redhat.com@nongnu.org designates 209.51.188.17 as
|
||||
permitted sender)
|
||||
smtp.mailfrom="qemu-devel-bounces+rjones=redhat.com@nongnu.org"
|
||||
Received: from mimecast-mx02.redhat.com (mimecast-mx02.redhat.com
|
||||
[66.187.233.88]) by relay.mimecast.com with ESMTP with STARTTLS
|
||||
(version=TLSv1.3, cipher=TLS_AES_256_GCM_SHA384) id
|
||||
us-mta-656-0vwFszxbMwexl4X3OxB3MQ-1; Tue, 20 Feb 2024 09:14:43 -0500
|
||||
X-MC-Unique: 0vwFszxbMwexl4X3OxB3MQ-1
|
||||
Received: from smtp.corp.redhat.com (int-mx03.intmail.prod.int.rdu2.redhat.com
|
||||
[10.11.54.3]) (using TLSv1.3 with cipher TLS_AES_256_GCM_SHA384 (256/256
|
||||
bits) key-exchange X25519 server-signature RSA-PSS (2048 bits) server-digest
|
||||
SHA256) (No client certificate requested) by mimecast-mx02.redhat.com
|
||||
(Postfix) with ESMTPS id 792F8863732 for <rjones@gapps.redhat.com>; Tue, 20
|
||||
Feb 2024 14:14:43 +0000 (UTC)
|
||||
Received: by smtp.corp.redhat.com (Postfix) id 761ED11422B9; Tue, 20 Feb 2024
|
||||
14:14:43 +0000 (UTC)
|
||||
Delivered-To: rjones@redhat.com
|
||||
Received: from mimecast-mx02.redhat.com
|
||||
(mimecast10.extmail.prod.ext.rdu2.redhat.com [10.11.55.26]) by
|
||||
smtp.corp.redhat.com (Postfix) with ESMTPS id 3BBF311422B4 for
|
||||
<rjones@redhat.com>; Tue, 20 Feb 2024 14:14:43 +0000 (UTC)
|
||||
Received: from us-smtp-inbound-delivery-1.mimecast.com
|
||||
(us-smtp-delivery-1.mimecast.com [207.211.31.120]) (using TLSv1.3 with cipher
|
||||
TLS_AES_256_GCM_SHA384 (256/256 bits) key-exchange X25519 server-signature
|
||||
RSA-PSS (2048 bits) server-digest SHA256) (No client certificate requested)
|
||||
by mimecast-mx02.redhat.com (Postfix) with ESMTPS id 1EC691C54037 for
|
||||
<rjones@redhat.com>; Tue, 20 Feb 2024 14:14:43 +0000 (UTC)
|
||||
Received: from lists.gnu.org (lists.gnu.org [209.51.188.17]) by
|
||||
relay.mimecast.com with ESMTP with STARTTLS (version=TLSv1.2,
|
||||
cipher=TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384) id
|
||||
us-mta-467-K7PF_hWUMIuYn6nNX_NhGQ-1; Tue, 20 Feb 2024 09:14:41 -0500
|
||||
X-MC-Unique: K7PF_hWUMIuYn6nNX_NhGQ-1
|
||||
Received: from localhost ([::1] helo=lists1p.gnu.org) by lists.gnu.org with
|
||||
esmtp (Exim 4.90_1) (envelope-from <qemu-devel-bounces@nongnu.org>) id
|
||||
1rcQsH-00027z-CN; Tue, 20 Feb 2024 09:13:33 -0500
|
||||
Received: from eggs.gnu.org ([2001:470:142:3::10]) by lists.gnu.org with
|
||||
esmtps (TLS1.2:ECDHE_RSA_AES_256_GCM_SHA384:256) (Exim 4.90_1) (envelope-from
|
||||
<michael.vogt@gmail.com>) id 1rcNp8-0004k1-C7 for qemu-devel@nongnu.org; Tue,
|
||||
20 Feb 2024 05:58:06 -0500
|
||||
Received: from mail-wm1-x32a.google.com ([2a00:1450:4864:20::32a]) by
|
||||
eggs.gnu.org with esmtps (TLS1.2:ECDHE_RSA_AES_128_GCM_SHA256:128) (Exim
|
||||
4.90_1) (envelope-from <michael.vogt@gmail.com>) id 1rcNp6-0004zw-Uh for
|
||||
qemu-devel@nongnu.org; Tue, 20 Feb 2024 05:58:06 -0500
|
||||
Received: by mail-wm1-x32a.google.com with SMTP id
|
||||
5b1f17b1804b1-412698cdd77so8973055e9.1 for <qemu-devel@nongnu.org>; Tue, 20
|
||||
Feb 2024 02:58:04 -0800 (PST)
|
||||
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net;
|
||||
s=20230601; t=1708426683; x=1709031483;
|
||||
h=content-transfer-encoding:mime-version:message-id:date:subject:cc
|
||||
:to:from:x-gm-message-state:from:to:cc:subject:date:message-id :reply-to;
|
||||
bh=uNCdCIQzg/12W/RrXAVFQ1Isw/BMjvNQW4Y14ZuF5vg=;
|
||||
b=anLCtG+2+69Viw2YFg93vXg3ZBx/82tUVKrUPKG0+3CgiM2BmSukRsME1L+upQkYAV
|
||||
Llc9ODBvHts9RRZU1MeybdSSRMnAHrXrIJ6HZP30K1cHOxyXB7DOp27hCfOelFBBffpM
|
||||
IVwjaKn+XnJ95IUMwMrhZ2T5Mcicw8tbRkCyDQwqrIpfpGWpOEq2HkEbe9T6z143sCBZ
|
||||
XYDpDvFRQauxu+SUoVeQjDxt1gm0XHFzwdGH/QjQ/2YDwkkB/yUtlaDHgXafwnzwow/8
|
||||
uHvdTZ9neIWDCUHEiHqRg9tHudOy1VhxH6T4jxzakzyTEit+mh2qB05/Yg2brj+hBo1u SaDg==
|
||||
X-Gm-Message-State: AOJu0YxyvxpfZhEbdDWqHqfThgFNUwkmqMXvDaxwAQH7HqdpGm5oVEbJ
|
||||
rzstVAif1eTUKOE4NOnCiMyJ9q/vEtd63Er7imeDi7lVutB0bby6fZFsj8mI
|
||||
X-Received: by 2002:a05:600c:4f43:b0:411:e86d:85a3 with SMTP id
|
||||
m3-20020a05600c4f4300b00411e86d85a3mr16304898wmq.16.1708426682414; Tue, 20
|
||||
Feb 2024 02:58:02 -0800 (PST)
|
||||
Received: from top.fritz.box (p5dd94bc2.dip0.t-ipconnect.de. [93.217.75.194])
|
||||
by smtp.gmail.com with ESMTPSA id
|
||||
co18-20020a0560000a1200b0033d4c3b0beesm7032427wrb.19.2024.02.20.02.58.01
|
||||
(version=TLS1_3 cipher=TLS_AES_256_GCM_SHA384 bits=256/256); Tue, 20 Feb 2024
|
||||
02:58:02 -0800 (PST)
|
||||
From: Michael Vogt <michael.vogt@gmail.com>
|
||||
To: qemu-devel@nongnu.org
|
||||
Cc: Michael Vogt <michael.vogt@gmail.com>
|
||||
Subject: [PATCH] linux-user: Add FIFREEZE and FITHAW ioctls
|
||||
Date: Tue, 20 Feb 2024 11:57:21 +0100
|
||||
Message-ID: <20240220105726.8852-1-michael.vogt@gmail.com>
|
||||
MIME-Version: 1.0
|
||||
X-Spam_score_int: -20
|
||||
X-Spam_score: -2.1
|
||||
X-Spam_bar: --
|
||||
X-Spam_report: (-2.1 / 5.0 requ) BAYES_00=-1.9, DKIM_SIGNED=0.1,
|
||||
DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, DKIM_VALID_EF=-0.1, FREEMAIL_FROM=0.001,
|
||||
RCVD_IN_DNSWL_NONE=-0.0001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001,
|
||||
T_SCC_BODY_TEXT_LINE=-0.01 autolearn=ham autolearn_force=no
|
||||
X-Spam_action: no action
|
||||
X-Mailman-Approved-At: Tue, 20 Feb 2024 09:13:26 -0500
|
||||
X-BeenThere: qemu-devel@nongnu.org
|
||||
X-Mailman-Version: 2.1.29
|
||||
Precedence: list
|
||||
List-Id: <qemu-devel.nongnu.org>
|
||||
List-Unsubscribe: <https://lists.nongnu.org/mailman/options/qemu-devel>,
|
||||
<mailto:qemu-devel-request@nongnu.org?subject=unsubscribe>
|
||||
List-Archive: <https://lists.nongnu.org/archive/html/qemu-devel>
|
||||
List-Post: <mailto:qemu-devel@nongnu.org>
|
||||
List-Help: <mailto:qemu-devel-request@nongnu.org?subject=help>
|
||||
List-Subscribe: <https://lists.nongnu.org/mailman/listinfo/qemu-devel>,
|
||||
<mailto:qemu-devel-request@nongnu.org?subject=subscribe>
|
||||
Errors-To: qemu-devel-bounces+rjones=redhat.com@nongnu.org
|
||||
Sender: qemu-devel-bounces+rjones=redhat.com@nongnu.org
|
||||
X-Mimecast-Impersonation-Protect: Policy=CLT - Impersonation Protection
|
||||
Definition;Similar Internal Domain=false;Similar Monitored External
|
||||
Domain=false;Custom External Domain=false;Mimecast External
|
||||
Domain=false;Newly Observed Domain=false;Internal User Name=false;Custom
|
||||
Display Name List=false;Reply-to Address Mismatch=false;Targeted Threat
|
||||
Dictionary=false;Mimecast Threat Dictionary=false;Custom Threat
|
||||
Dictionary=false
|
||||
X-Mimecast-Bulk-Signature: yes
|
||||
X-Mimecast-Spam-Signature: bulk
|
||||
X-Scanned-By: MIMEDefang 3.4.1 on 10.11.54.3
|
||||
X-Mimecast-Spam-Score: 0
|
||||
X-Mimecast-Originator: gmail.com
|
||||
Content-Transfer-Encoding: 8bit
|
||||
Content-Type: text/plain; charset="US-ASCII"; x-default=true
|
||||
Status: RO
|
||||
Content-Length: 1327
|
||||
Lines: 42
|
||||
|
||||
Add missing FIFREEZE and FITHAW ioctls.
|
||||
|
||||
Signed-off-by: Michael Vogt <michael.vogt@gmail.com>
|
||||
---
|
||||
linux-user/ioctls.h | 6 ++++++
|
||||
linux-user/syscall_defs.h | 3 +++
|
||||
2 files changed, 9 insertions(+)
|
||||
|
||||
diff --git a/linux-user/ioctls.h b/linux-user/ioctls.h
|
||||
index 071f7ca253..1aec9d5836 100644
|
||||
--- a/linux-user/ioctls.h
|
||||
+++ b/linux-user/ioctls.h
|
||||
@@ -134,6 +134,12 @@
|
||||
IOCTL(FICLONE, IOC_W, TYPE_INT)
|
||||
IOCTL(FICLONERANGE, IOC_W, MK_PTR(MK_STRUCT(STRUCT_file_clone_range)))
|
||||
#endif
|
||||
+#ifdef FIFREEZE
|
||||
+ IOCTL(FIFREEZE, IOC_W | IOC_R, TYPE_INT)
|
||||
+#endif
|
||||
+#ifdef FITHAW
|
||||
+ IOCTL(FITHAW, IOC_W | IOC_R, TYPE_INT)
|
||||
+#endif
|
||||
|
||||
IOCTL(FIGETBSZ, IOC_R, MK_PTR(TYPE_LONG))
|
||||
#ifdef CONFIG_FIEMAP
|
||||
diff --git a/linux-user/syscall_defs.h b/linux-user/syscall_defs.h
|
||||
index 77ba343c85..744fda599e 100644
|
||||
--- a/linux-user/syscall_defs.h
|
||||
+++ b/linux-user/syscall_defs.h
|
||||
@@ -943,6 +943,9 @@ struct target_rtc_pll_info {
|
||||
#define TARGET_FICLONE TARGET_IOW(0x94, 9, abi_int)
|
||||
#define TARGET_FICLONERANGE TARGET_IOW(0x94, 13, struct file_clone_range)
|
||||
|
||||
+#define TARGET_FIFREEZE TARGET_IOWR('X', 119, abi_int)
|
||||
+#define TARGET_FITHAW TARGET_IOWR('X', 120, abi_int)
|
||||
+
|
||||
/*
|
||||
* Note that the ioctl numbers for FS_IOC_<GET|SET><FLAGS|VERSION>
|
||||
* claim type "long" but the actual type used by the kernel is "int".
|
||||
--
|
||||
2.43.0
|
||||
|
||||
|
43
qemu.spec
43
qemu.spec
@ -354,18 +354,18 @@ Obsoletes: %{name}-system-unicore32-core <= %{epoch}:%{version}-%{release} \
|
||||
Obsoletes: sgabios-bin <= 1:0.20180715git-10.fc38
|
||||
|
||||
# Release candidate version tracking
|
||||
#global rcver rc2
|
||||
%global rcver rc4
|
||||
%if 0%{?rcver:1}
|
||||
%global rcrel .%{rcver}
|
||||
%global rcstr -%{rcver}
|
||||
%endif
|
||||
|
||||
# To prevent rpmdev-bumpspec breakage
|
||||
%global baserelease 2
|
||||
%global baserelease 0.1
|
||||
|
||||
Summary: QEMU is a FAST! processor emulator
|
||||
Name: qemu
|
||||
Version: 8.2.2
|
||||
Version: 9.0.0
|
||||
Release: %{baserelease}%{?rcrel}%{?dist}
|
||||
Epoch: 2
|
||||
License: Apache-2.0 AND BSD-2-Clause AND BSD-3-Clause AND FSFAP AND GPL-1.0-or-later AND GPL-2.0-only AND GPL-2.0-or-later AND GPL-2.0-or-later WITH GCC-exception-2.0 AND LGPL-2.0-only AND LGPL-2.0-or-later AND LGPL-2.1-only AND LGPL-2.1-or-later AND MIT AND LicenseRef-Fedora-Public-Domain AND CC-BY-3.0
|
||||
@ -377,20 +377,12 @@ Source0: %{dlurl}/%{name}-%{version}%{?rcstr}.tar.xz
|
||||
Source1: %{dlurl}/%{name}-%{version}%{?rcstr}.tar.xz.sig
|
||||
Source2: gpgkey-CEACC9E15534EBABB82D3FA03353C9CEF108B584.gpg
|
||||
|
||||
# Fix pvh.img ld build failure on fedora rawhide
|
||||
# Not yet submitted upstream in this form. Original attempt is here:
|
||||
# https://patchwork.kernel.org/project/qemu-devel/patch/20231128143647.847668-1-crobinso@redhat.com/
|
||||
Patch: 0001-pc-bios-optionrom-Fix-pvh.img-ld-build-failure-on-fe.patch
|
||||
|
||||
# Fix user-emulation of FIFREEZE and FITHAW ioctls
|
||||
# Posted upstream 20-02-2024
|
||||
# https://lists.nongnu.org/archive/html/qemu-devel/2024-02/msg03971.html
|
||||
Patch: qemu-fifreeze-fithaw.patch
|
||||
|
||||
# ppc/spapr: Initialize max_cpus limit to SPAPR_IRQ_NR_IPIS
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=2265982
|
||||
Patch: https://github.com/qemu/qemu/commit/2df5c1f5b014126595a26c6797089d284a3b211c.patch
|
||||
Patch: https://github.com/qemu/qemu/commit/c4f91d7b7be76c47015521ab0109c6e998a369b0.patch
|
||||
# qemu 9.0.0 errors with:
|
||||
# RPM build errors:
|
||||
# Missing build-id in /tmp/rpmbuild/BUILDROOT/qemu-9.0.0-1.rc2.fc41.x86_64/usr/share/qemu/hppa-firmware.img
|
||||
# Missing build-id in /tmp/rpmbuild/BUILDROOT/qemu-9.0.0-1.rc2.fc41.x86_64/usr/share/qemu/hppa-firmware64.img
|
||||
# Generating build-id links failed
|
||||
%global _missing_build_ids_terminate_build 0
|
||||
|
||||
Source10: qemu-guest-agent.service
|
||||
Source11: 99-qemu-guest-agent.rules
|
||||
@ -2292,6 +2284,19 @@ useradd -r -u 107 -g qemu -G kvm -d / -s /sbin/nologin \
|
||||
%{_mandir}/man1/qemu-storage-daemon.1*
|
||||
%{_mandir}/man7/qemu-storage-daemon-qmp-ref.7*
|
||||
|
||||
%{_datadir}/systemtap/tapset/qemu-img.stp
|
||||
%{_datadir}/systemtap/tapset/qemu-img-log.stp
|
||||
%{_datadir}/systemtap/tapset/qemu-img-simpletrace.stp
|
||||
%{_datadir}/systemtap/tapset/qemu-io.stp
|
||||
%{_datadir}/systemtap/tapset/qemu-io-log.stp
|
||||
%{_datadir}/systemtap/tapset/qemu-io-simpletrace.stp
|
||||
%{_datadir}/systemtap/tapset/qemu-nbd.stp
|
||||
%{_datadir}/systemtap/tapset/qemu-nbd-log.stp
|
||||
%{_datadir}/systemtap/tapset/qemu-nbd-simpletrace.stp
|
||||
%{_datadir}/systemtap/tapset/qemu-storage-daemon.stp
|
||||
%{_datadir}/systemtap/tapset/qemu-storage-daemon-log.stp
|
||||
%{_datadir}/systemtap/tapset/qemu-storage-daemon-simpletrace.stp
|
||||
|
||||
|
||||
%files -n qemu-guest-agent
|
||||
%doc COPYING README.rst
|
||||
@ -2940,6 +2945,7 @@ useradd -r -u 107 -g qemu -G kvm -d / -s /sbin/nologin \
|
||||
%{_datadir}/systemtap/tapset/qemu-system-hppa-simpletrace.stp
|
||||
%{_mandir}/man1/qemu-system-hppa.1*
|
||||
%{_datadir}/%{name}/hppa-firmware.img
|
||||
%{_datadir}/%{name}/hppa-firmware64.img
|
||||
|
||||
|
||||
%files system-loongarch64
|
||||
@ -3157,6 +3163,9 @@ useradd -r -u 107 -g qemu -G kvm -d / -s /sbin/nologin \
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Apr 23 2024 Cole Robinson <crobinso@redhat.com> - 9.0.0-0.1.rc4
|
||||
- New release qemu 9.0.0-rc4
|
||||
|
||||
* Sat Apr 06 2024 Cole Robinson <crobinso@redhat.com> - 8.2.2-2
|
||||
- Rebuild for new libiscsi
|
||||
|
||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (qemu-8.2.2.tar.xz) = dfd2e1305f9e51bfbc90a7738c69336d5f805481a626ea527b971bdfb6dbe6867e5df7461d48d1c22b79be2dc18e057ea9fa36ef593127cd8b262a5c33f1aa41
|
||||
SHA512 (qemu-8.2.2.tar.xz.sig) = 2a2dac01cc8f1aff8fbc4e6bfd13d7dd80b7bf6505388c04605a76a27aff870e1520d9879a5781508e65d1feb74e8c036d9cd4f21ab1e35fb7a845c2d66476de
|
||||
SHA512 (qemu-9.0.0-rc4.tar.xz) = 691be20a69f3c364b541e99a33c2dfa86fb43cf70786c14662d59979311c70ecfdc50062ea121084874866aad82a307687eb52f6ba1f02ce331c1e679835e8a3
|
||||
SHA512 (qemu-9.0.0-rc4.tar.xz.sig) = fe9881f9bb0ec07712a578e50321fc02df1f92db23aaddd3ed41e808fe301e72e2688f4ae8f402c2a3123f34f017c8b062c714e26f9cdaf1399b63345b1cebe9
|
||||
|
Loading…
Reference in New Issue
Block a user