fix missing error_set symbol in libcacard.so

2:1.2.2-5
This commit is contained in:
Alon Levy 2013-01-23 18:02:50 +02:00
parent 83889a9bd2
commit e051f2359e
2 changed files with 40 additions and 1 deletions

View File

@ -0,0 +1,33 @@
From a198c5ee0b8311aadffb682a70587cb92368b3fc Mon Sep 17 00:00:00 2001
From: Alon Levy <alevy@redhat.com>
Date: Wed, 28 Nov 2012 11:16:26 +0200
Subject: [PATCH] libcacard: fix missing symbol in libcacard.so
Before patch:
$ make libcacard.la
$ nm ./libcacard/.libs/libcacard.so.0.0.0 | grep " U " | \
egrep -v "(g_)|(GLIBC)|(SECMOD)|(PK11)|(CERT)|(NSS)|(PORT)|(PR)"
U error_set
Signed-off-by: Alon Levy <alevy@redhat.com>
Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
---
libcacard/Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/libcacard/Makefile b/libcacard/Makefile
index 88ed064..7973f8d 100644
--- a/libcacard/Makefile
+++ b/libcacard/Makefile
@@ -7,7 +7,7 @@ libcacard_includedir=$(includedir)/cacard
$(call set-vpath, $(SRC_PATH))
# objects linked into a shared library, built with libtool with -fPIC if required
-QEMU_OBJS=$(oslib-obj-y) qemu-timer-common.o iov.o cutils.o qemu-user.o $(trace-obj-y)
+QEMU_OBJS=$(oslib-obj-y) qemu-timer-common.o error.o iov.o cutils.o qemu-user.o $(trace-obj-y)
QEMU_OBJS_LIB=$(patsubst %.o,%.lo,$(QEMU_OBJS))
QEMU_CFLAGS+=-I../
--
1.8.0.1

View File

@ -109,7 +109,7 @@
Summary: QEMU is a FAST! processor emulator
Name: qemu
Version: 1.2.2
Release: 4%{?dist}
Release: 5%{?dist}
# Epoch because we pushed a qemu-1.0 package. AIUI this can't ever be dropped
Epoch: 2
License: GPLv2+ and LGPLv2+ and BSD
@ -531,6 +531,8 @@ Patch0708: 0708-seccomp-adding-new-syscalls-bugzilla-855162.patch
# CVE-2012-6075: Buffer overflow in e1000 nic (bz 889301, bz 889304)
Patch709: 0709-e1000-Discard-oversized-packets-based-on-SBP-LPE.patch
Patch710: 0710-libcacard-fix-missing-symbols-in-libcacard.so.patch
BuildRequires: SDL-devel
BuildRequires: zlib-devel
@ -1339,6 +1341,7 @@ CAC emulation development files.
%patch0707 -p1
%patch0708 -p1
%patch709 -p1
%patch710 -p1
%build
@ -1948,6 +1951,9 @@ getent passwd qemu >/dev/null || \
%{_libdir}/pkgconfig/libcacard.pc
%changelog
* Wed Jan 23 2013 Alon Levy <alevy@redhat.com> - 2:1.2.2-5
- Add fix for missing error_set in libcacard.so picked from upstream.
* Mon Jan 21 2013 Hans de Goede <hdegoede@redhat.com> - 2:1.2.2-4
- Add "qxl: call dpy_gfx_resize when entering vga mode" patch, fixing
an often reported use after free crash (rhbz#873845)