- Update to qemu-kvm-0.11.0-rc1-rc0
- This is a pre-release of the official -rc1 - A vista installer regression is blocking the official -rc1 release - Drop qemu-prefer-sysfs-for-usb-host-devices.patch - Drop qemu-fix-build-for-esd-audio.patch - Drop qemu-slirp-Fix-guestfwd-for-incoming-data.patch - Add patch to ensure extboot.bin is installed
This commit is contained in:
parent
6614511d65
commit
ddfcbf7137
@ -1,4 +1,4 @@
|
||||
From dd5a9dedba205ad51ef2fc70f0a1dddea7ff4a4f Mon Sep 17 00:00:00 2001
|
||||
From ad6bfcfe0292ac09aac0de729343dabf91c16f93 Mon Sep 17 00:00:00 2001
|
||||
From: Glauber Costa <glommer@redhat.com>
|
||||
Date: Wed, 24 Jun 2009 14:31:41 +0100
|
||||
Subject: [PATCH] compute checksum for roms bigger than a segment
|
||||
@ -23,10 +23,10 @@ Fedora-patch: qemu-bios-bigger-roms.patch
|
||||
1 files changed, 27 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/kvm/bios/rombios.c b/kvm/bios/rombios.c
|
||||
index 6186199..fc289c0 100644
|
||||
index 6e1d446..8a96d8e 100644
|
||||
--- a/kvm/bios/rombios.c
|
||||
+++ b/kvm/bios/rombios.c
|
||||
@@ -10170,22 +10170,43 @@ no_serial:
|
||||
@@ -10189,22 +10189,43 @@ no_serial:
|
||||
ret
|
||||
|
||||
rom_checksum:
|
||||
|
@ -1,45 +0,0 @@
|
||||
From 17588a0bbf311ad95c6d3ad84f5edb8f98353d58 Mon Sep 17 00:00:00 2001
|
||||
From: Anthony Liguori <aliguori@us.ibm.com>
|
||||
Date: Wed, 1 Jul 2009 10:07:16 -0500
|
||||
Subject: [PATCH] Fix build for ESD audio
|
||||
|
||||
(cherry picked from commit c6a5a71a3a1886afad5eeb214eb6e8785f4e0319)
|
||||
|
||||
Signed-off-by: Anthony Liguori <aliguori@us.ibm.com>
|
||||
Signed-off-by: Mark McLoughlin <markmc@redhat.com>
|
||||
Fedora-patch: qemu-fix-build-for-esd-audio.patch
|
||||
---
|
||||
Makefile | 10 +++++-----
|
||||
1 files changed, 5 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index fc40431..f5deae9 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -139,18 +139,18 @@ obj-y += migration-exec.o
|
||||
endif
|
||||
|
||||
ifdef CONFIG_COREAUDIO
|
||||
-AUDIO_PT = yes
|
||||
+AUDIO_PT = y
|
||||
endif
|
||||
ifdef CONFIG_FMOD
|
||||
audio/audio.o audio/fmodaudio.o: CPPFLAGS := -I$(CONFIG_FMOD_INC) $(CPPFLAGS)
|
||||
endif
|
||||
ifdef CONFIG_ESD
|
||||
-AUDIO_PT = yes
|
||||
-AUDIO_PT_INT = yes
|
||||
+AUDIO_PT = y
|
||||
+AUDIO_PT_INT = y
|
||||
endif
|
||||
ifdef CONFIG_PA
|
||||
-AUDIO_PT = yes
|
||||
-AUDIO_PT_INT = yes
|
||||
+AUDIO_PT = y
|
||||
+AUDIO_PT_INT = y
|
||||
endif
|
||||
ifdef AUDIO_PT
|
||||
LDFLAGS += -pthread
|
||||
--
|
||||
1.6.2.5
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 052506320166112bec0b5b7aa272973c1a508551 Mon Sep 17 00:00:00 2001
|
||||
From 6def4aea8b88f52de678ffca117ba70b1e6878c2 Mon Sep 17 00:00:00 2001
|
||||
From: Mark McLoughlin <markmc@redhat.com>
|
||||
Date: Mon, 29 Jun 2009 14:49:03 +0100
|
||||
Subject: [PATCH] Fix linux-user build on ppc
|
||||
|
35
qemu-fix-optionrom-install.patch
Normal file
35
qemu-fix-optionrom-install.patch
Normal file
@ -0,0 +1,35 @@
|
||||
From e941daafed39ae5db507af42da8a35b60a8be363 Mon Sep 17 00:00:00 2001
|
||||
From: Mark McLoughlin <markmc@redhat.com>
|
||||
Date: Thu, 30 Jul 2009 17:17:43 +0100
|
||||
Subject: [PATCH] Revert "Don't copy multiboot.bin into pc-bios after built"
|
||||
|
||||
This reverts commit 24d904eab3e806dc4d1ccdabbc3b4dcb64ddf497.
|
||||
|
||||
This ensures:
|
||||
|
||||
a) extboot.bin is copied to pc-bios and installed
|
||||
|
||||
b) the built mutliboot.bin overwrites the multiboot.bin
|
||||
shipped in the tarball
|
||||
|
||||
Signed-of-by: Mark McLoughlin <markmc@redhat.com>
|
||||
Fedora-patch: qemu-fix-optionrom-install.patch
|
||||
---
|
||||
pc-bios/optionrom/Makefile | 1 +
|
||||
1 files changed, 1 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/pc-bios/optionrom/Makefile b/pc-bios/optionrom/Makefile
|
||||
index 4cc3dae..e06ca72 100644
|
||||
--- a/pc-bios/optionrom/Makefile
|
||||
+++ b/pc-bios/optionrom/Makefile
|
||||
@@ -41,6 +41,7 @@ build-all: multiboot.bin extboot.bin
|
||||
|
||||
%.bin: %.raw
|
||||
$(SRC_PATH)/pc-bios/optionrom/signrom.sh $< $@
|
||||
+ cp $@ $(SRC_PATH)/pc-bios/
|
||||
|
||||
clean:
|
||||
$(RM) *.o *.img *.bin *~
|
||||
--
|
||||
1.6.2.5
|
||||
|
@ -1,65 +0,0 @@
|
||||
From dfeae76a9a941c12ffe828848476a4a31a358205 Mon Sep 17 00:00:00 2001
|
||||
From: Mark McLoughlin <markmc@redhat.com>
|
||||
Date: Fri, 3 Jul 2009 09:17:20 +0100
|
||||
Subject: [PATCH] Prefer sysfs for USB host devices
|
||||
|
||||
Scanning for devices via /sys/bus/usb/devices/ and using them via the
|
||||
/dev/bus/usb/<bus>/<device> character devices is the prefered method
|
||||
on modern kernels, so try that first.
|
||||
|
||||
When using SELinux and libvirt, qemu will have access to /sys/bus/usb
|
||||
but not /proc/bus/usb, so although the current code will work just
|
||||
fine, it will generate SELinux AVC warnings.
|
||||
|
||||
See also:
|
||||
|
||||
https://bugzilla.redhat.com/508326
|
||||
|
||||
(cherry picked from commit 554962405cb18a3e624edf05b6257eaf9273810c)
|
||||
|
||||
Reported-by: Daniel Berrange <berrange@redhat.com>
|
||||
Signed-off-by: Mark McLoughlin <markmc@redhat.com>
|
||||
Fedora-patch: qemu-prefer-sysfs-for-usb-host-devices.patch
|
||||
---
|
||||
usb-linux.c | 18 +++++++++---------
|
||||
1 files changed, 9 insertions(+), 9 deletions(-)
|
||||
|
||||
diff --git a/usb-linux.c b/usb-linux.c
|
||||
index 67e4acd..3c724ba 100644
|
||||
--- a/usb-linux.c
|
||||
+++ b/usb-linux.c
|
||||
@@ -1265,6 +1265,15 @@ static int usb_host_scan(void *opaque, USBScanFunc *func)
|
||||
|
||||
/* only check the host once */
|
||||
if (!usb_fs_type) {
|
||||
+ dir = opendir(USBSYSBUS_PATH "/devices");
|
||||
+ if (dir) {
|
||||
+ /* devices found in /dev/bus/usb/ (yes - not a mistake!) */
|
||||
+ strcpy(devpath, USBDEVBUS_PATH);
|
||||
+ usb_fs_type = USB_FS_SYS;
|
||||
+ closedir(dir);
|
||||
+ dprintf(USBDBG_DEVOPENED, USBSYSBUS_PATH);
|
||||
+ goto found_devices;
|
||||
+ }
|
||||
f = fopen(USBPROCBUS_PATH "/devices", "r");
|
||||
if (f) {
|
||||
/* devices found in /proc/bus/usb/ */
|
||||
@@ -1284,15 +1293,6 @@ static int usb_host_scan(void *opaque, USBScanFunc *func)
|
||||
dprintf(USBDBG_DEVOPENED, USBDEVBUS_PATH);
|
||||
goto found_devices;
|
||||
}
|
||||
- dir = opendir(USBSYSBUS_PATH "/devices");
|
||||
- if (dir) {
|
||||
- /* devices found in /dev/bus/usb/ (yes - not a mistake!) */
|
||||
- strcpy(devpath, USBDEVBUS_PATH);
|
||||
- usb_fs_type = USB_FS_SYS;
|
||||
- closedir(dir);
|
||||
- dprintf(USBDBG_DEVOPENED, USBSYSBUS_PATH);
|
||||
- goto found_devices;
|
||||
- }
|
||||
found_devices:
|
||||
if (!usb_fs_type) {
|
||||
monitor_printf(mon, "husb: unable to access USB devices\n");
|
||||
--
|
||||
1.6.2.5
|
||||
|
@ -1,103 +0,0 @@
|
||||
From 57ab33ece875e62e47d09e52bcd0d9d108594729 Mon Sep 17 00:00:00 2001
|
||||
From: Jan Kiszka <jan.kiszka@siemens.com>
|
||||
Date: Wed, 22 Jul 2009 17:03:52 +0200
|
||||
Subject: [PATCH] slirp: Fix guestfwd for incoming data
|
||||
|
||||
Unless a virtual server address was explicitly defined (which is
|
||||
impossible with the legacy -net channel format), guestfwd did not
|
||||
properly forwarded host->guest packets. This patch fixes it.
|
||||
|
||||
(cherry picked from commit bb53fc5394201c0cbe3c89a1c9fa5fbd6a3b832c)
|
||||
|
||||
Signed-off-by: Jan Kiszka <jan.kiszka@siemens.com>
|
||||
Signed-off-by: Anthony Liguori <aliguori@us.ibm.com>
|
||||
Signed-off-by: Mark McLoughlin <markmc@redhat.com>
|
||||
Fedora-patch: qemu-slirp-Fix-guestfwd-for-incoming-data.patch
|
||||
---
|
||||
net.c | 11 ++++++-----
|
||||
slirp/libslirp.h | 2 +-
|
||||
slirp/slirp.c | 14 +++++++-------
|
||||
3 files changed, 14 insertions(+), 13 deletions(-)
|
||||
|
||||
diff --git a/net.c b/net.c
|
||||
index a34f1d3..7e1edf6 100644
|
||||
--- a/net.c
|
||||
+++ b/net.c
|
||||
@@ -1170,7 +1170,7 @@ static void slirp_smb(SlirpState* s, Monitor *mon, const char *exported_dir,
|
||||
snprintf(smb_cmdline, sizeof(smb_cmdline), "%s -s %s",
|
||||
SMBD_COMMAND, smb_conf);
|
||||
|
||||
- if (slirp_add_exec(s->slirp, 0, smb_cmdline, vserver_addr, 139) < 0) {
|
||||
+ if (slirp_add_exec(s->slirp, 0, smb_cmdline, &vserver_addr, 139) < 0) {
|
||||
slirp_smb_cleanup(s);
|
||||
config_error(mon, "conflicting/invalid smbserver address\n");
|
||||
}
|
||||
@@ -1259,16 +1259,17 @@ static void slirp_guestfwd(SlirpState *s, Monitor *mon, const char *config_str,
|
||||
qemu_free(fwd);
|
||||
return;
|
||||
}
|
||||
- fwd->server = server;
|
||||
- fwd->port = port;
|
||||
- fwd->slirp = s->slirp;
|
||||
|
||||
- if (slirp_add_exec(s->slirp, 3, fwd->hd, server, port) < 0) {
|
||||
+ if (slirp_add_exec(s->slirp, 3, fwd->hd, &server, port) < 0) {
|
||||
config_error(mon, "conflicting/invalid host:port in guest forwarding "
|
||||
"rule '%s'\n", config_str);
|
||||
qemu_free(fwd);
|
||||
return;
|
||||
}
|
||||
+ fwd->server = server;
|
||||
+ fwd->port = port;
|
||||
+ fwd->slirp = s->slirp;
|
||||
+
|
||||
qemu_chr_add_handlers(fwd->hd, guestfwd_can_read, guestfwd_read,
|
||||
NULL, fwd);
|
||||
return;
|
||||
diff --git a/slirp/libslirp.h b/slirp/libslirp.h
|
||||
index 3bcc392..93087ed 100644
|
||||
--- a/slirp/libslirp.h
|
||||
+++ b/slirp/libslirp.h
|
||||
@@ -33,7 +33,7 @@ int slirp_add_hostfwd(Slirp *slirp, int is_udp,
|
||||
int slirp_remove_hostfwd(Slirp *slirp, int is_udp,
|
||||
struct in_addr host_addr, int host_port);
|
||||
int slirp_add_exec(Slirp *slirp, int do_pty, const void *args,
|
||||
- struct in_addr guest_addr, int guest_port);
|
||||
+ struct in_addr *guest_addr, int guest_port);
|
||||
|
||||
void slirp_connection_info(Slirp *slirp, Monitor *mon);
|
||||
|
||||
diff --git a/slirp/slirp.c b/slirp/slirp.c
|
||||
index 0ce62a3..9be8553 100644
|
||||
--- a/slirp/slirp.c
|
||||
+++ b/slirp/slirp.c
|
||||
@@ -794,19 +794,19 @@ int slirp_add_hostfwd(Slirp *slirp, int is_udp, struct in_addr host_addr,
|
||||
}
|
||||
|
||||
int slirp_add_exec(Slirp *slirp, int do_pty, const void *args,
|
||||
- struct in_addr guest_addr, int guest_port)
|
||||
+ struct in_addr *guest_addr, int guest_port)
|
||||
{
|
||||
- if (!guest_addr.s_addr) {
|
||||
- guest_addr.s_addr = slirp->vnetwork_addr.s_addr |
|
||||
+ if (!guest_addr->s_addr) {
|
||||
+ guest_addr->s_addr = slirp->vnetwork_addr.s_addr |
|
||||
(htonl(0x0204) & ~slirp->vnetwork_mask.s_addr);
|
||||
}
|
||||
- if ((guest_addr.s_addr & slirp->vnetwork_mask.s_addr) !=
|
||||
+ if ((guest_addr->s_addr & slirp->vnetwork_mask.s_addr) !=
|
||||
slirp->vnetwork_addr.s_addr ||
|
||||
- guest_addr.s_addr == slirp->vhost_addr.s_addr ||
|
||||
- guest_addr.s_addr == slirp->vnameserver_addr.s_addr) {
|
||||
+ guest_addr->s_addr == slirp->vhost_addr.s_addr ||
|
||||
+ guest_addr->s_addr == slirp->vnameserver_addr.s_addr) {
|
||||
return -1;
|
||||
}
|
||||
- return add_exec(&slirp->exec_list, do_pty, (char *)args, guest_addr,
|
||||
+ return add_exec(&slirp->exec_list, do_pty, (char *)args, *guest_addr,
|
||||
htons(guest_port));
|
||||
}
|
||||
|
||||
--
|
||||
1.6.2.5
|
||||
|
33
qemu.spec
33
qemu.spec
@ -1,18 +1,18 @@
|
||||
%define kvmvernum 88
|
||||
%define kvmvertag kvm%{kvmvernum}
|
||||
%define kvmverfull kvm-devel-%{kvmvernum}
|
||||
%define kvmvertag rc1.rc0
|
||||
%define kvmverfull kvm-0.11.0-rc1-rc0
|
||||
|
||||
Summary: QEMU is a FAST! processor emulator
|
||||
Name: qemu
|
||||
Version: 0.10.50
|
||||
Release: 14.%{kvmvertag}%{?dist}
|
||||
Version: 0.10.91
|
||||
Release: 0.1.%{kvmvertag}%{?dist}
|
||||
# Epoch because we pushed a qemu-1.0 package
|
||||
Epoch: 2
|
||||
License: GPLv2+ and LGPLv2+ and BSD
|
||||
Group: Development/Tools
|
||||
URL: http://www.qemu.org/
|
||||
|
||||
Source0: http://downloads.sourceforge.net/sourceforge/kvm/qemu-%{kvmverfull}.tar.gz
|
||||
Source0: http://markmc.fedorapeople.org/kvm/qemu-%{kvmverfull}.tar.gz
|
||||
#Source0: http://downloads.sourceforge.net/sourceforge/kvm/qemu-%{kvmverfull}.tar.gz
|
||||
Source1: qemu.init
|
||||
Source2: kvm.modules
|
||||
Source3: 80-kvm.rules
|
||||
@ -23,14 +23,8 @@ Patch01: qemu-bios-bigger-roms.patch
|
||||
# Works around broken linux-user build on ppc
|
||||
Patch02: qemu-fix-linux-user-build-on-ppc.patch
|
||||
|
||||
# Prefer sysfs over usbfs for usb passthrough (#508326)
|
||||
Patch03: qemu-prefer-sysfs-for-usb-host-devices.patch
|
||||
|
||||
# Fix build with esound audio enabled, cherry-picked from upstream
|
||||
Patch04: qemu-fix-build-for-esd-audio.patch
|
||||
|
||||
# Fix guestfwd behaviour, cherrypicked from upstream (#513249)
|
||||
Patch05: qemu-slirp-Fix-guestfwd-for-incoming-data.patch
|
||||
# Make sure multiboot.bin/extboot.bin gets installed
|
||||
Patch03: qemu-fix-optionrom-install.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: SDL-devel zlib-devel which texi2html gnutls-devel cyrus-sasl-devel
|
||||
@ -215,8 +209,6 @@ such as kvmtrace and kvm_stat.
|
||||
%patch01 -p1
|
||||
%patch02 -p1
|
||||
%patch03 -p1
|
||||
%patch04 -p1
|
||||
%patch05 -p1
|
||||
|
||||
%build
|
||||
# systems like rhel build system does not have a recent enough linker so
|
||||
@ -481,6 +473,15 @@ getent passwd qemu >/dev/null || \
|
||||
%{_mandir}/man1/qemu-img.1*
|
||||
|
||||
%changelog
|
||||
* Thu Jul 30 2009 Mark McLoughlin <markmc@redhat.com> - 2:0.10.91-0.1.rc1.rc0
|
||||
- Update to qemu-kvm-0.11.0-rc1-rc0
|
||||
- This is a pre-release of the official -rc1
|
||||
- A vista installer regression is blocking the official -rc1 release
|
||||
- Drop qemu-prefer-sysfs-for-usb-host-devices.patch
|
||||
- Drop qemu-fix-build-for-esd-audio.patch
|
||||
- Drop qemu-slirp-Fix-guestfwd-for-incoming-data.patch
|
||||
- Add patch to ensure extboot.bin is installed
|
||||
|
||||
* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2:0.10.50-14.kvm88
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user