Fix default accelerator for non-KVM builds (rhbz #724814)
This commit is contained in:
parent
5e10b14df0
commit
db8fd942f7
18
qemu-kvm-default-accelerator.patch
Normal file
18
qemu-kvm-default-accelerator.patch
Normal file
@ -0,0 +1,18 @@
|
|||||||
|
diff --git a/vl.c b/vl.c
|
||||||
|
index 7ae549e..28fd2f3 100644
|
||||||
|
--- a/vl.c
|
||||||
|
+++ b/vl.c
|
||||||
|
@@ -1953,8 +1953,13 @@ static int configure_accelerator(void)
|
||||||
|
}
|
||||||
|
|
||||||
|
if (p == NULL) {
|
||||||
|
+#ifdef CONFIG_KVM
|
||||||
|
/* Use the default "accelerator", kvm */
|
||||||
|
p = "kvm";
|
||||||
|
+#else
|
||||||
|
+ /* Use the default "accelerator", tcg */
|
||||||
|
+ p = "tcg";
|
||||||
|
+#endif
|
||||||
|
}
|
||||||
|
|
||||||
|
while (!accel_initalised && *p != '\0') {
|
10
qemu.spec
10
qemu.spec
@ -3,7 +3,7 @@
|
|||||||
Summary: QEMU is a FAST! processor emulator
|
Summary: QEMU is a FAST! processor emulator
|
||||||
Name: qemu
|
Name: qemu
|
||||||
Version: 0.15.0
|
Version: 0.15.0
|
||||||
Release: 0.2.20110728%githead%{?dist}
|
Release: 0.3.20110728%githead%{?dist}
|
||||||
# Epoch because we pushed a qemu-1.0 package
|
# Epoch because we pushed a qemu-1.0 package
|
||||||
Epoch: 2
|
Epoch: 2
|
||||||
License: GPLv2+ and LGPLv2+ and BSD
|
License: GPLv2+ and LGPLv2+ and BSD
|
||||||
@ -55,6 +55,9 @@ Patch11: 0011-usb-redir-Add-flow-control-support.patch
|
|||||||
Patch12: 0012-usb-redir-Call-qemu_chr_guest_open-close.patch
|
Patch12: 0012-usb-redir-Call-qemu_chr_guest_open-close.patch
|
||||||
Patch13: 0013-spice-qemu-char-Generate-chardev-open-close-events.patch
|
Patch13: 0013-spice-qemu-char-Generate-chardev-open-close-events.patch
|
||||||
|
|
||||||
|
# Fix for default accelerator in non-KVM builds
|
||||||
|
Patch100: qemu-kvm-default-accelerator.patch
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: SDL-devel zlib-devel which texi2html gnutls-devel cyrus-sasl-devel
|
BuildRequires: SDL-devel zlib-devel which texi2html gnutls-devel cyrus-sasl-devel
|
||||||
BuildRequires: libaio-devel
|
BuildRequires: libaio-devel
|
||||||
@ -241,6 +244,8 @@ such as kvm_stat.
|
|||||||
%patch12 -p1
|
%patch12 -p1
|
||||||
%patch13 -p1
|
%patch13 -p1
|
||||||
|
|
||||||
|
%patch100 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# By default we build everything, but allow x86 to build a minimal version
|
# By default we build everything, but allow x86 to build a minimal version
|
||||||
# with only similar arch target support
|
# with only similar arch target support
|
||||||
@ -550,6 +555,9 @@ fi
|
|||||||
%{_mandir}/man1/qemu-img.1*
|
%{_mandir}/man1/qemu-img.1*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Aug 4 2011 Daniel P. Berrange <berrange@redhat.com> - 2:0.15.0-0.3.2011072859fadcc
|
||||||
|
- Fix default accelerator for non-KVM builds (rhbz #724814)
|
||||||
|
|
||||||
* Thu Jul 28 2011 Justin M. Forbes <jforbes@redhat.com> - 2:0.15.0-0.1.2011072859fadcc
|
* Thu Jul 28 2011 Justin M. Forbes <jforbes@redhat.com> - 2:0.15.0-0.1.2011072859fadcc
|
||||||
- Update to 0.15.0-rc0 as we prepare for 0.15.0 release
|
- Update to 0.15.0-rc0 as we prepare for 0.15.0 release
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user