Clean up according to Enrico's comments
This commit is contained in:
parent
5c373480b5
commit
c8e4b31cf3
48
qemu-0.6.1-build.patch
Normal file
48
qemu-0.6.1-build.patch
Normal file
@ -0,0 +1,48 @@
|
|||||||
|
--- qemu-0.6.1/Makefile.strip 2005-02-13 14:38:23.000000000 +0000
|
||||||
|
+++ qemu-0.6.1/Makefile 2005-02-13 14:42:27.000000000 +0000
|
||||||
|
@@ -1,6 +1,6 @@
|
||||||
|
-include config-host.mak
|
||||||
|
|
||||||
|
-CFLAGS=-Wall -O2 -g -fno-strict-aliasing
|
||||||
|
+CFLAGS=$(RPM_OPT_FLAGS) -Wall -fno-strict-aliasing
|
||||||
|
ifdef CONFIG_DARWIN
|
||||||
|
CFLAGS+= -mdynamic-no-pic
|
||||||
|
endif
|
||||||
|
@@ -45,7 +45,7 @@
|
||||||
|
install: all
|
||||||
|
mkdir -p "$(bindir)"
|
||||||
|
ifndef CONFIG_WIN32
|
||||||
|
- install -m 755 -s $(TOOLS) "$(bindir)"
|
||||||
|
+ install -m 755 $(TOOLS) "$(bindir)"
|
||||||
|
endif
|
||||||
|
mkdir -p "$(datadir)"
|
||||||
|
install -m 644 pc-bios/bios.bin pc-bios/vgabios.bin \
|
||||||
|
--- qemu-0.6.1/Makefile.target.strip 2005-02-13 14:38:19.000000000 +0000
|
||||||
|
+++ qemu-0.6.1/Makefile.target 2005-02-13 14:42:49.000000000 +0000
|
||||||
|
@@ -7,7 +7,7 @@
|
||||||
|
VPATH+=:$(SRC_PATH)/linux-user
|
||||||
|
DEFINES+=-I$(SRC_PATH)/linux-user -I$(SRC_PATH)/linux-user/$(TARGET_ARCH)
|
||||||
|
endif
|
||||||
|
-CFLAGS=-Wall -O2 -g -fno-strict-aliasing
|
||||||
|
+CFLAGS=$(RPM_OPT_FLAGS) -Wall -fno-strict-aliasing
|
||||||
|
LDFLAGS=-g
|
||||||
|
LIBS=
|
||||||
|
HELPER_CFLAGS=$(CFLAGS)
|
||||||
|
@@ -148,7 +148,7 @@
|
||||||
|
ifeq ($(ARCH),alpha)
|
||||||
|
# -msmall-data is not used because we want two-instruction relocations
|
||||||
|
# for the constant constructions
|
||||||
|
-OP_CFLAGS=-Wall -O2 -g
|
||||||
|
+OP_CFLAGS=$(RPM_OPT_FLAGS) -Wall
|
||||||
|
# Ensure there's only a single GP
|
||||||
|
CFLAGS += -msmall-data
|
||||||
|
LDFLAGS+=-Wl,-T,$(SRC_PATH)/alpha.ld
|
||||||
|
@@ -397,7 +397,7 @@
|
||||||
|
|
||||||
|
install: all
|
||||||
|
ifneq ($(PROGS),)
|
||||||
|
- install -m 755 -s $(PROGS) "$(bindir)"
|
||||||
|
+ install -m 755 $(PROGS) "$(bindir)"
|
||||||
|
endif
|
||||||
|
|
||||||
|
ifneq ($(wildcard .depend),)
|
21
qemu.spec
21
qemu.spec
@ -1,12 +1,13 @@
|
|||||||
Summary: QEMU is a FAST! processor emulator
|
Summary: QEMU is a FAST! processor emulator
|
||||||
Name: qemu
|
Name: qemu
|
||||||
Version: 0.6.1
|
Version: 0.6.1
|
||||||
Release: 1
|
Release: 2
|
||||||
License: LGPL
|
License: GPL/LGPL
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
URL: http://fabrice.bellard.free.fr/qemu
|
URL: http://fabrice.bellard.free.fr/qemu
|
||||||
Source0: http://fabrice.bellard.free.fr/qemu/%{name}-%{version}.tar.gz
|
Source0: http://fabrice.bellard.free.fr/qemu/%{name}-%{version}.tar.gz
|
||||||
Source1: qemu.init
|
Source1: qemu.init
|
||||||
|
Patch0: qemu-0.6.1-build.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
BuildRequires: SDL-devel
|
BuildRequires: SDL-devel
|
||||||
PreReq: /sbin/chkconfig
|
PreReq: /sbin/chkconfig
|
||||||
@ -31,6 +32,7 @@ As QEMU requires no host kernel patches to run, it is very safe and easy to use.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
./configure --prefix=%{_prefix} --interp-prefix=%{_prefix}/qemu-%%M
|
./configure --prefix=%{_prefix} --interp-prefix=%{_prefix}/qemu-%%M
|
||||||
@ -43,7 +45,7 @@ make prefix="${RPM_BUILD_ROOT}%{_prefix}" \
|
|||||||
bindir="${RPM_BUILD_ROOT}%{_bindir}" \
|
bindir="${RPM_BUILD_ROOT}%{_bindir}" \
|
||||||
sharedir="${RPM_BUILD_ROOT}%{_prefix}/share/qemu" \
|
sharedir="${RPM_BUILD_ROOT}%{_prefix}/share/qemu" \
|
||||||
mandir="${RPM_BUILD_ROOT}%{_mandir}" \
|
mandir="${RPM_BUILD_ROOT}%{_mandir}" \
|
||||||
docdir="${RPM_BUILD_ROOT}%{_docdir}" \
|
docdir="${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}" \
|
||||||
datadir="${RPM_BUILD_ROOT}%{_prefix}/share/qemu" install
|
datadir="${RPM_BUILD_ROOT}%{_prefix}/share/qemu" install
|
||||||
|
|
||||||
install -D $RPM_SOURCE_DIR/qemu.init $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/qemu
|
install -D $RPM_SOURCE_DIR/qemu.init $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/qemu
|
||||||
@ -58,19 +60,22 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
if [ $1 = 0 ]; then
|
if [ $1 = 0 ]; then
|
||||||
/sbin/service qemu stop > /dev/null 2>&1
|
/sbin/service qemu stop > /dev/null 2>&1
|
||||||
fi
|
fi
|
||||||
|
/sbin/chkconfig --del qemu
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%doc Changelog README README.distrib TODO
|
%doc Changelog README README.distrib TODO
|
||||||
%doc qemu-tech.texi qemu-doc.texi
|
%doc qemu-tech.texi qemu-doc.texi
|
||||||
%doc linux-2.6-qemu-fast.patch
|
%doc linux-2.6-qemu-fast.patch *.html
|
||||||
%doc %{_docdir}
|
%{_bindir}/qemu*
|
||||||
%{_bindir}
|
|
||||||
%{_prefix}/share/qemu
|
%{_prefix}/share/qemu
|
||||||
%{_mandir}
|
%{_mandir}/man?/*
|
||||||
%{_sysconfdir}/rc.d/init.d/qemu
|
%config %{_sysconfdir}/rc.d/init.d/qemu
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Feb 13 2005 David Woodhouse <dwmw2@infradead.org> 0.6.1-2
|
||||||
|
- Package cleanup
|
||||||
|
|
||||||
* Sun Nov 21 2004 David Woodhouse <dwmw2@redhat.com> 0.6.1-1
|
* Sun Nov 21 2004 David Woodhouse <dwmw2@redhat.com> 0.6.1-1
|
||||||
- Update to 0.6.1
|
- Update to 0.6.1
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user