Merge branch 'master' of ssh://pkgs.fedoraproject.org/qemu

Conflicts:
	qemu.spec
This commit is contained in:
Justin M. Forbes 2011-08-04 14:10:38 -05:00
commit b51ebd0cd2
2 changed files with 26 additions and 0 deletions

View File

@ -0,0 +1,18 @@
diff --git a/vl.c b/vl.c
index 7ae549e..28fd2f3 100644
--- a/vl.c
+++ b/vl.c
@@ -1953,8 +1953,13 @@ static int configure_accelerator(void)
}
if (p == NULL) {
+#ifdef CONFIG_KVM
/* Use the default "accelerator", kvm */
p = "kvm";
+#else
+ /* Use the default "accelerator", tcg */
+ p = "tcg";
+#endif
}
while (!accel_initalised && *p != '\0') {

View File

@ -67,6 +67,9 @@ Patch23: 0023-qxl-add-QXL_IO_FLUSH_-SURFACES-RELEASE-for-guest-S3-.patch
Patch24: 0024-qxl-bump-pci-rev.patch
Patch25: 0025-virtio-serial-bus-replay-guest_open-on-migration.patch
# Fix for default accelerator in non-KVM builds
Patch100: qemu-kvm-default-accelerator.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: SDL-devel zlib-devel which texi2html gnutls-devel cyrus-sasl-devel
BuildRequires: libaio-devel
@ -265,6 +268,8 @@ such as kvm_stat.
%patch24 -p1
%patch25 -p1
%patch100 -p1
%build
# By default we build everything, but allow x86 to build a minimal version
# with only similar arch target support
@ -577,6 +582,9 @@ fi
* Thu Aug 04 2011 Justin M. Forbes <jforbes@redhat.com> - 2:0.15.0-0.3.201108040af4922
- Update to 0.15.0-rc1 as we prepare for 0.15.0 release
* Thu Aug 4 2011 Daniel P. Berrange <berrange@redhat.com> - 2:0.15.0-0.3.2011072859fadcc
- Fix default accelerator for non-KVM builds (rhbz #724814)
* Thu Jul 28 2011 Justin M. Forbes <jforbes@redhat.com> - 2:0.15.0-0.1.2011072859fadcc
- Update to 0.15.0-rc0 as we prepare for 0.15.0 release