- Package mutiboot.bin
- Update for how extboot is built
- Fix sf.net source URL
- Drop qemu-fix-ppc-softmmu-kvm-disabled-build.patch
- Drop qemu-fix-pcspk-build-with-kvm-disabled.patch
- Cherry-pick fix for esound support build failure
This commit is contained in:
Mark McLoughlin 2009-07-16 11:15:53 +00:00
parent fc8b74dc5b
commit a8abd8e63a
6 changed files with 72 additions and 29 deletions

View File

@ -1,7 +1,7 @@
From 8b08062b369c913c9b9a66c20618f9bd82a6b676 Mon Sep 17 00:00:00 2001
From c9aea972de34bad96814301988df698063ccf608 Mon Sep 17 00:00:00 2001
From: Glauber Costa <glommer@redhat.com>
Date: Wed, 24 Jun 2009 14:31:41 +0100
Subject: [PATCH] compute checksum for roms bigger than a segment
Subject: [PATCH 1/4] compute checksum for roms bigger than a segment
Some option roms (e1000 provided by gpxe project as an example)
are bigger than a segment. The current algorithm to compute the
@ -76,5 +76,5 @@ index 6186199..fc289c0 100644
--
1.6.2.5
1.6.3.3

View File

@ -0,0 +1,44 @@
From b37fb38b6043e319768fa92d5541fe20afb4741b Mon Sep 17 00:00:00 2001
From: Anthony Liguori <aliguori@us.ibm.com>
Date: Wed, 1 Jul 2009 10:07:16 -0500
Subject: [PATCH 4/4] Fix build for ESD audio
(cherry picked from commit c6a5a71a3a1886afad5eeb214eb6e8785f4e0319)
Signed-off-by: Anthony Liguori <aliguori@us.ibm.com>
Signed-off-by: Mark McLoughlin <markmc@redhat.com>
---
Makefile | 10 +++++-----
1 files changed, 5 insertions(+), 5 deletions(-)
diff --git a/Makefile b/Makefile
index fc40431..f5deae9 100644
--- a/Makefile
+++ b/Makefile
@@ -139,18 +139,18 @@ obj-y += migration-exec.o
endif
ifdef CONFIG_COREAUDIO
-AUDIO_PT = yes
+AUDIO_PT = y
endif
ifdef CONFIG_FMOD
audio/audio.o audio/fmodaudio.o: CPPFLAGS := -I$(CONFIG_FMOD_INC) $(CPPFLAGS)
endif
ifdef CONFIG_ESD
-AUDIO_PT = yes
-AUDIO_PT_INT = yes
+AUDIO_PT = y
+AUDIO_PT_INT = y
endif
ifdef CONFIG_PA
-AUDIO_PT = yes
-AUDIO_PT_INT = yes
+AUDIO_PT = y
+AUDIO_PT_INT = y
endif
ifdef AUDIO_PT
LDFLAGS += -pthread
--
1.6.3.3

View File

@ -1,7 +1,7 @@
From 8da41d2477abdafbbc484a12fd74f2d54336188b Mon Sep 17 00:00:00 2001
From 978e305a8cb8533bef2c6238c88e96913f7d09d0 Mon Sep 17 00:00:00 2001
From: Mark McLoughlin <markmc@redhat.com>
Date: Mon, 29 Jun 2009 14:49:03 +0100
Subject: [PATCH] Fix linux-user build on ppc
Subject: [PATCH 2/4] Fix linux-user build on ppc
kvm-87 build fails on ppc:
@ -36,10 +36,6 @@ kvm-87 build fails on ppc:
Problem seems to be that signal.h is pulling in a bunch of ppc
headers which expose elf_greg_t, R_PPC_* and PPC_FEATURE_*.
Signed-off-by: Mark McLoughlin <markmc@redhat.com>
More linux-user on ppc build fixes
Signed-off-by: Mark McLoughlin <markmc@redhat.com>
---
elf.h | 2 ++
@ -134,5 +130,5 @@ index d31cca7..3ccfdda 100644
#define ELF_HWCAP get_elf_hwcap()
--
1.6.2.5
1.6.3.3

View File

@ -1,7 +1,7 @@
From 9cf0574418cc7657618a738dd31337739c635875 Mon Sep 17 00:00:00 2001
From da1377c5e28ea68a6492b627725e8dd5f7acbb0a Mon Sep 17 00:00:00 2001
From: Mark McLoughlin <markmc@redhat.com>
Date: Fri, 3 Jul 2009 09:17:20 +0100
Subject: [PATCH] Prefer sysfs for USB host devices
Subject: [PATCH 3/4] Prefer sysfs for USB host devices
Scanning for devices via /sys/bus/usb/devices/ and using them via the
/dev/bus/usb/<bus>/<device> character devices is the prefered method
@ -58,5 +58,5 @@ index 67e4acd..3c724ba 100644
if (!usb_fs_type) {
monitor_printf(mon, "husb: unable to access USB devices\n");
--
1.6.2.5
1.6.3.3

View File

@ -1,18 +1,18 @@
%define kvmvernum 87
%define kvmvernum 88
%define kvmvertag kvm%{kvmvernum}
%define kvmverfull kvm-devel-%{kvmvernum}
Summary: QEMU is a FAST! processor emulator
Name: qemu
Version: 0.10.50
Release: 10.%{kvmvertag}%{?dist}
Release: 11.%{kvmvertag}%{?dist}
# Epoch because we pushed a qemu-1.0 package
Epoch: 2
License: GPLv2+ and LGPLv2+ and BSD
Group: Development/Tools
URL: http://www.qemu.org/
Source0: http://download.sourceforge.net/sourceforge/kvm/qemu-%{kvmverfull}.tar.gz
Source0: http://downloads.sourceforge.net/sourceforge/kvm/qemu-%{kvmverfull}.tar.gz
Source1: qemu.init
Source2: kvm.modules
Source3: 80-kvm.rules
@ -20,17 +20,14 @@ Source3: 80-kvm.rules
# Not upstream, why?
Patch01: qemu-bios-bigger-roms.patch
# Fixes ppc-softmmu target build, cherry-picked from upstream
Patch02: qemu-fix-ppc-softmmu-kvm-disabled-build.patch
# Works around broken linux-user build on ppc
Patch03: qemu-fix-linux-user-build-on-ppc.patch
# Fix for hw/pcspk.c errors with --disable-kvm
Patch04: qemu-fix-pcspk-build-with-kvm-disabled.patch
Patch02: qemu-fix-linux-user-build-on-ppc.patch
# Prefer sysfs over usbfs for usb passthrough (#508326)
Patch05: qemu-prefer-sysfs-for-usb-host-devices.patch
Patch03: qemu-prefer-sysfs-for-usb-host-devices.patch
# Fix build with esound audio enabled, cherry-picked from upstream
Patch04: qemu-fix-build-for-esd-audio.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: SDL-devel zlib-devel which texi2html gnutls-devel cyrus-sasl-devel
@ -216,7 +213,6 @@ such as kvmtrace and kvm_stat.
%patch02 -p1
%patch03 -p1
%patch04 -p1
%patch05 -p1
%build
# systems like rhel build system does not have a recent enough linker so
@ -250,8 +246,6 @@ make V=1 %{?_smp_mflags} $buildldflags
cp -a x86_64-softmmu/qemu-system-x86_64 qemu-kvm
make clean
make -C kvm/extboot extboot.bin
cd kvm/user
./configure --prefix=%{_prefix} --kerneldir=$(pwd)/../kernel/
make kvmtrace
@ -287,7 +281,6 @@ mkdir -p $RPM_BUILD_ROOT%{_datadir}/%{name}
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
install -m 0755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/modules/kvm.modules
install -m 0755 kvm/extboot/extboot.bin $RPM_BUILD_ROOT%{_datadir}/%{name}
install -m 0755 kvm/user/kvmtrace $RPM_BUILD_ROOT%{_bindir}/
install -m 0755 kvm/user/kvmtrace_format $RPM_BUILD_ROOT%{_bindir}/
install -m 0755 kvm/kvm_stat $RPM_BUILD_ROOT%{_bindir}/
@ -416,6 +409,7 @@ fi
%{_datadir}/%{name}/pxe-ne2k_pci.bin
%ifarch %{ix86} x86_64
%{_datadir}/%{name}/extboot.bin
%{_datadir}/%{name}/multiboot.bin
%{_bindir}/qemu-kvm
%{_sysconfdir}/sysconfig/modules/kvm.modules
%{_sysconfdir}/udev/rules.d/80-kvm.rules
@ -466,6 +460,15 @@ fi
%{_mandir}/man1/qemu-img.1*
%changelog
* Thu Jul 16 2009 Mark McLoughlin <markmc@redhat.com> - 2:0.10.50-11.kvm88
- Update to kvm-88, see http://www.linux-kvm.org/page/ChangeLog
- Package mutiboot.bin
- Update for how extboot is built
- Fix sf.net source URL
- Drop qemu-fix-ppc-softmmu-kvm-disabled-build.patch
- Drop qemu-fix-pcspk-build-with-kvm-disabled.patch
- Cherry-pick fix for esound support build failure
* Wed Jul 15 2009 Daniel Berrange <berrange@lettuce.camlab.fab.redhat.com> - 2:0.10.50-10.kvm87
- Add udev rules to make /dev/kvm world accessible & group=kvm (rhbz #497341)
- Create a kvm group if it doesn't exist (rhbz #346151)

View File

@ -1 +1 @@
949e6e072fe1f24361d1b17dea52be7f qemu-kvm-devel-87.tar.gz
0564b071fb1bb7211f51ef588ebb4a7c qemu-kvm-devel-88.tar.gz