Update to snapshot kvm20090323. Removed patch2 (upstream). use upstream's
new split package. --with-patched-kernel flag not needed anymore Tell how to get the sources.
This commit is contained in:
parent
a2460b87f1
commit
9e9690ba92
@ -1 +1 @@
|
|||||||
kvm-84.git-snapshot-20090310.tar.gz
|
qemu-kvm-devel-85rc1.git-snapshot-20090323.tar.gz
|
||||||
|
@ -1,87 +0,0 @@
|
|||||||
Newer gcc versions support a R"..." construct, so we can't use
|
|
||||||
"abc"R"def" constructs without any space between R and the quotes,
|
|
||||||
when using -std=gnu99 (that is used by the user/test code).
|
|
||||||
|
|
||||||
This fixes this error:
|
|
||||||
|
|
||||||
test/x86/vmexit.c:34:26: error: invalid character ' ' in raw string
|
|
||||||
delimiter
|
|
||||||
test/x86/vmexit.c: In function ‘main’:
|
|
||||||
test/x86/vmexit.c:34: error: stray ‘R’ in program
|
|
||||||
test/x86/vmexit.c:34:46: error: invalid character '
|
|
||||||
' in raw string delimiter
|
|
||||||
test/x86/vmexit.c:34: error: expected ‘:’ or ‘)’ before string constant
|
|
||||||
test/x86/vmexit.c:34: error: stray ‘R’ in program
|
|
||||||
|
|
||||||
Signed-off-by: Eduardo Habkost <ehabkost@redhat.com>
|
|
||||||
---
|
|
||||||
user/test/x86/apic.c | 32 ++++++++++++++++----------------
|
|
||||||
user/test/x86/vmexit.c | 2 +-
|
|
||||||
2 files changed, 17 insertions(+), 17 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/user/test/x86/apic.c b/user/test/x86/apic.c
|
|
||||||
index 9c6205b..2d963dc 100644
|
|
||||||
--- a/user/test/x86/apic.c
|
|
||||||
+++ b/user/test/x86/apic.c
|
|
||||||
@@ -54,14 +54,14 @@ asm (
|
|
||||||
"push %r9 \n\t"
|
|
||||||
"push %r8 \n\t"
|
|
||||||
#endif
|
|
||||||
- "push %"R"di \n\t"
|
|
||||||
- "push %"R"si \n\t"
|
|
||||||
- "push %"R"bp \n\t"
|
|
||||||
- "push %"R"sp \n\t"
|
|
||||||
- "push %"R"bx \n\t"
|
|
||||||
- "push %"R"dx \n\t"
|
|
||||||
- "push %"R"cx \n\t"
|
|
||||||
- "push %"R"ax \n\t"
|
|
||||||
+ "push %" R "di \n\t"
|
|
||||||
+ "push %" R "si \n\t"
|
|
||||||
+ "push %" R "bp \n\t"
|
|
||||||
+ "push %" R "sp \n\t"
|
|
||||||
+ "push %" R "bx \n\t"
|
|
||||||
+ "push %" R "dx \n\t"
|
|
||||||
+ "push %" R "cx \n\t"
|
|
||||||
+ "push %" R "ax \n\t"
|
|
||||||
#ifdef __x86_64__
|
|
||||||
"mov %rsp, %rdi \n\t"
|
|
||||||
"callq *8*16(%rsp) \n\t"
|
|
||||||
@@ -70,14 +70,14 @@ asm (
|
|
||||||
"calll *4+4*8(%esp) \n\t"
|
|
||||||
"add $4, %esp \n\t"
|
|
||||||
#endif
|
|
||||||
- "pop %"R"ax \n\t"
|
|
||||||
- "pop %"R"cx \n\t"
|
|
||||||
- "pop %"R"dx \n\t"
|
|
||||||
- "pop %"R"bx \n\t"
|
|
||||||
- "pop %"R"bp \n\t"
|
|
||||||
- "pop %"R"bp \n\t"
|
|
||||||
- "pop %"R"si \n\t"
|
|
||||||
- "pop %"R"di \n\t"
|
|
||||||
+ "pop %" R "ax \n\t"
|
|
||||||
+ "pop %" R "cx \n\t"
|
|
||||||
+ "pop %" R "dx \n\t"
|
|
||||||
+ "pop %" R "bx \n\t"
|
|
||||||
+ "pop %" R "bp \n\t"
|
|
||||||
+ "pop %" R "bp \n\t"
|
|
||||||
+ "pop %" R "si \n\t"
|
|
||||||
+ "pop %" R "di \n\t"
|
|
||||||
#ifdef __x86_64__
|
|
||||||
"pop %r8 \n\t"
|
|
||||||
"pop %r9 \n\t"
|
|
||||||
diff --git a/user/test/x86/vmexit.c b/user/test/x86/vmexit.c
|
|
||||||
index bd57bfa..7339e2b 100644
|
|
||||||
--- a/user/test/x86/vmexit.c
|
|
||||||
+++ b/user/test/x86/vmexit.c
|
|
||||||
@@ -31,7 +31,7 @@ int main()
|
|
||||||
|
|
||||||
t1 = rdtsc();
|
|
||||||
for (i = 0; i < N; ++i)
|
|
||||||
- asm volatile ("push %%"R"bx; cpuid; pop %%"R"bx"
|
|
||||||
+ asm volatile ("push %%" R "bx; cpuid; pop %%" R "bx"
|
|
||||||
: : : "eax", "ecx", "edx");
|
|
||||||
t2 = rdtsc();
|
|
||||||
printf("vmexit latency: %d\n", (int)((t2 - t1) / N));
|
|
||||||
--
|
|
||||||
1.6.0.2.GIT
|
|
||||||
|
|
25
qemu.spec
25
qemu.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: QEMU is a FAST! processor emulator
|
Summary: QEMU is a FAST! processor emulator
|
||||||
Name: qemu
|
Name: qemu
|
||||||
Version: 0.10
|
Version: 0.10
|
||||||
Release: 0.10.kvm20090310git%{?dist}
|
Release: 0.11.kvm20090323git%{?dist}
|
||||||
# I have mistakenly thought the revision name would be 1.0.
|
# I have mistakenly thought the revision name would be 1.0.
|
||||||
# So 0.10 series get Epoch = 1
|
# So 0.10 series get Epoch = 1
|
||||||
Epoch: 2
|
Epoch: 2
|
||||||
@ -9,13 +9,18 @@ License: GPLv2+ and LGPLv2+ and BSD
|
|||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
URL: http://www.qemu.org/
|
URL: http://www.qemu.org/
|
||||||
#Source0: http://www.qemu.org/%{name}-%{version}.tar.gz
|
#Source0: http://www.qemu.org/%{name}-%{version}.tar.gz
|
||||||
# FIXME: Say how to get the sources
|
# git clone git://git.kernel.org/pub/scm/linux/kernel/git/avi/kvm.git
|
||||||
Source0: kvm-84.git-snapshot-20090310.tar.gz
|
# git clone git://git.kernel.org/pub/scm/linux/kernel/git/avi/kvm-userspace.git
|
||||||
|
# echo "kdir=$(pwd)/kvm" > ~/.kvm-release-config
|
||||||
|
# cd kvm-userspace
|
||||||
|
# mkdir $(HOME)/sf-releases
|
||||||
|
# ./scripts/make-release kvm-85rc-1.git-snapshot-date +%Y%m%d HEAD HEAD
|
||||||
|
|
||||||
|
Source0: qemu-kvm-devel-85rc1.git-snapshot-20090323.tar.gz
|
||||||
Source1: qemu.init
|
Source1: qemu.init
|
||||||
Source2: kvm.modules
|
Source2: kvm.modules
|
||||||
|
|
||||||
Patch1: kvm-upstream-ppc.patch
|
Patch1: kvm-upstream-ppc.patch
|
||||||
Patch2: kvm-fix-strayR.patch
|
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: SDL-devel zlib-devel which texi2html gnutls-devel cyrus-sasl-devel
|
BuildRequires: SDL-devel zlib-devel which texi2html gnutls-devel cyrus-sasl-devel
|
||||||
@ -177,9 +182,8 @@ such as kvmtrace and kvm_stat.
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n kvm-84.git-snapshot-20090310
|
%setup -q -n qemu-kvm-devel-85rc1.git-snapshot-20090323
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
%patch2 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# systems like rhel build system does not have a recent enough linker so
|
# systems like rhel build system does not have a recent enough linker so
|
||||||
@ -204,7 +208,7 @@ echo "%{name}-%{version}" > $(pwd)/kernel/.kernelrelease
|
|||||||
# sdl outputs to alsa or pulseaudio directly depending on what the system has configured
|
# sdl outputs to alsa or pulseaudio directly depending on what the system has configured
|
||||||
# alsa works, but causes huge CPU load due to bugs
|
# alsa works, but causes huge CPU load due to bugs
|
||||||
# oss works, but is very problematic because it grabs exclusive control of the device causing other apps to go haywire
|
# oss works, but is very problematic because it grabs exclusive control of the device causing other apps to go haywire
|
||||||
./configure --with-patched-kernel --target-list=x86_64-softmmu \
|
./configure --target-list=x86_64-softmmu \
|
||||||
--kerneldir=$(pwd)/kernel --prefix=%{_prefix} \
|
--kerneldir=$(pwd)/kernel --prefix=%{_prefix} \
|
||||||
--audio-drv-list=sdl,alsa,oss \
|
--audio-drv-list=sdl,alsa,oss \
|
||||||
--qemu-ldflags=$extraldflags \
|
--qemu-ldflags=$extraldflags \
|
||||||
@ -405,6 +409,13 @@ fi
|
|||||||
%{_mandir}/man1/qemu-img.1*
|
%{_mandir}/man1/qemu-img.1*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Mar 23 2009 Glauber Costa <glommer@redhat.com> - 2:0.10-0.11.kvm20090323git
|
||||||
|
- Update to snapshot kvm20090323.
|
||||||
|
- Removed patch2 (upstream).
|
||||||
|
- use upstream's new split package.
|
||||||
|
- --with-patched-kernel flag not needed anymore
|
||||||
|
- Tell how to get the sources.
|
||||||
|
|
||||||
* Wed Mar 18 2009 Glauber Costa <glommer@redhat.com> - 2:0.10-0.10.kvm20090310git
|
* Wed Mar 18 2009 Glauber Costa <glommer@redhat.com> - 2:0.10-0.10.kvm20090310git
|
||||||
- Added extboot to files list.
|
- Added extboot to files list.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user