Fix missing error_set symbol in libcacard.so (bz #891552)
Signed-off-by: Alon Levy <alevy@redhat.com>
This commit is contained in:
parent
83b95606fe
commit
9e8e016378
35
0114-libcacard-fix-missing-symbol-in-libcacard.so.patch
Normal file
35
0114-libcacard-fix-missing-symbol-in-libcacard.so.patch
Normal file
@ -0,0 +1,35 @@
|
||||
From 27d509fdc239785b4748599c62115b36abeac32d Mon Sep 17 00:00:00 2001
|
||||
From: Alon Levy <alevy@redhat.com>
|
||||
Date: Wed, 28 Nov 2012 11:16:26 +0200
|
||||
Subject: [PATCH] libcacard: fix missing symbol in libcacard.so
|
||||
|
||||
Before patch:
|
||||
$ make libcacard.la
|
||||
$ nm ./libcacard/.libs/libcacard.so.0.0.0 | grep " U " | \
|
||||
egrep -v "(g_)|(GLIBC)|(SECMOD)|(PK11)|(CERT)|(NSS)|(PORT)|(PR)"
|
||||
U error_set
|
||||
|
||||
Signed-off-by: Alon Levy <alevy@redhat.com>
|
||||
Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
|
||||
|
||||
modified from e832341bde5448a6a1392ea903a553497a13763b
|
||||
---
|
||||
libcacard/Makefile | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/libcacard/Makefile b/libcacard/Makefile
|
||||
index 750713a..e3192c9 100644
|
||||
--- a/libcacard/Makefile
|
||||
+++ b/libcacard/Makefile
|
||||
@@ -7,7 +7,7 @@ libcacard_includedir=$(includedir)/cacard
|
||||
$(call set-vpath, $(SRC_PATH))
|
||||
|
||||
# objects linked into a shared library, built with libtool with -fPIC if required
|
||||
-QEMU_OBJS=$(oslib-obj-y) qemu-timer-common.o iov.o cutils.o qemu-user.o $(trace-obj-y) $(stub-obj-y)
|
||||
+QEMU_OBJS=$(oslib-obj-y) qemu-timer-common.o error.o iov.o cutils.o qemu-user.o $(trace-obj-y) $(stub-obj-y)
|
||||
QEMU_OBJS_LIB=$(patsubst %.o,%.lo,$(QEMU_OBJS))
|
||||
|
||||
QEMU_CFLAGS+=-I../
|
||||
--
|
||||
1.8.0.1
|
||||
|
@ -120,7 +120,7 @@
|
||||
Summary: QEMU is a FAST! processor emulator
|
||||
Name: qemu
|
||||
Version: 1.3.0
|
||||
Release: 4%{?dist}
|
||||
Release: 5%{?dist}
|
||||
# Epoch because we pushed a qemu-1.0 package. AIUI this can't ever be dropped
|
||||
Epoch: 2
|
||||
License: GPLv2+ and LGPLv2+ and BSD
|
||||
@ -161,6 +161,7 @@ Patch0110: 0110-spice-qemu-char.c-remove-intermediate-buffer.patch
|
||||
Patch0111: 0111-usb-redir-Add-flow-control-support.patch
|
||||
Patch0112: 0112-char-Disable-write-callback-if-throttled-chardev-is-.patch
|
||||
Patch0113: 0113-hw-virtio-serial-bus-replay-guest-open-on-destinatio.patch
|
||||
Patch0114: 0114-libcacard-fix-missing-symbol-in-libcacard.so.patch
|
||||
|
||||
|
||||
Source1: qemu.binfmt
|
||||
@ -646,7 +647,7 @@ CAC emulation development files.
|
||||
%patch0112 -p1
|
||||
%patch0113 -p1
|
||||
|
||||
|
||||
%patch0114 -p1
|
||||
|
||||
%build
|
||||
%if %{with kvmonly}
|
||||
@ -1258,6 +1259,9 @@ getent passwd qemu >/dev/null || \
|
||||
%{_libdir}/pkgconfig/libcacard.pc
|
||||
|
||||
%changelog
|
||||
* Tue Jan 22 2013 Alon Levy <alevy redhat com> - 2:1.3.0-5
|
||||
- Fix missing error_set symbol in libcacard.so (bz #891552)
|
||||
|
||||
* Mon Jan 21 2013 Adam Tkac <atkac redhat com> - 2:1.3.0-4
|
||||
- rebuild due to "jpeg8-ABI" feature drop
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user