- Update to 0.11.0 release
- Drop a couple of upstreamed patches
This commit is contained in:
parent
1c9931d838
commit
904b1d4314
@ -1,4 +1,4 @@
|
||||
From ef44e9475ab38ec73b30e83241279170fac06b22 Mon Sep 17 00:00:00 2001
|
||||
From c6c94b043e8b3593d0beb52966dce43069233840 Mon Sep 17 00:00:00 2001
|
||||
From: Izik Eidus <ieidus@redhat.com>
|
||||
Date: Tue, 28 Jul 2009 19:14:26 +0300
|
||||
Subject: [PATCH] kvm userspace: ksm support
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 4f5019c88e710be0aa597c81017b683d494c532d Mon Sep 17 00:00:00 2001
|
||||
From 8ab0d97572264051176ff45171484fa463d1287f Mon Sep 17 00:00:00 2001
|
||||
From: Mark McLoughlin <markmc@redhat.com>
|
||||
Date: Fri, 4 Sep 2009 11:24:03 +0100
|
||||
Subject: [PATCH] Allow pulseaudio backend to be the default
|
||||
|
@ -1,4 +1,4 @@
|
||||
From f751c8937a81116469149357359c767a71ee8ebd Mon Sep 17 00:00:00 2001
|
||||
From b5c99e96655e8dc938f801e1ac0dbdf2d6dfba37 Mon Sep 17 00:00:00 2001
|
||||
From: Glauber Costa <glommer@redhat.com>
|
||||
Date: Wed, 24 Jun 2009 14:31:41 +0100
|
||||
Subject: [PATCH] compute checksum for roms bigger than a segment
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 2b76390876db26fb279d26de86b2c0b8260ff142 Mon Sep 17 00:00:00 2001
|
||||
From 3675a0dde74f890404f392e194f1adc6b24285f7 Mon Sep 17 00:00:00 2001
|
||||
From: Glauber Costa <glommer@redhat.com>
|
||||
Date: Wed, 23 Sep 2009 09:49:43 +0100
|
||||
Subject: [PATCH] Correctly free nd structure
|
||||
@ -29,10 +29,10 @@ Fedora-patch: qemu-correctly-free-nic-info-structure.patch
|
||||
3 files changed, 16 insertions(+), 10 deletions(-)
|
||||
|
||||
diff --git a/net.c b/net.c
|
||||
index 61c9649..b58945f 100644
|
||||
index a1c1111..da2f428 100644
|
||||
--- a/net.c
|
||||
+++ b/net.c
|
||||
@@ -2564,7 +2564,7 @@ void qemu_check_nic_model_list(NICInfo *nd, const char * const *models,
|
||||
@@ -2559,7 +2559,7 @@ void qemu_check_nic_model_list(NICInfo *nd, const char * const *models,
|
||||
int i, exit_status = 0;
|
||||
|
||||
if (!nd->model)
|
||||
@ -41,7 +41,7 @@ index 61c9649..b58945f 100644
|
||||
|
||||
if (strcmp(nd->model, "?") != 0) {
|
||||
for (i = 0 ; models[i]; i++)
|
||||
@@ -2634,6 +2634,7 @@ int net_client_init(Monitor *mon, const char *device, const char *p)
|
||||
@@ -2629,6 +2629,7 @@ int net_client_init(Monitor *mon, const char *device, const char *p)
|
||||
goto out;
|
||||
}
|
||||
nd = &nd_table[idx];
|
||||
@ -49,7 +49,7 @@ index 61c9649..b58945f 100644
|
||||
macaddr = nd->macaddr;
|
||||
macaddr[0] = 0x52;
|
||||
macaddr[1] = 0x54;
|
||||
@@ -2650,13 +2651,13 @@ int net_client_init(Monitor *mon, const char *device, const char *p)
|
||||
@@ -2645,13 +2646,13 @@ int net_client_init(Monitor *mon, const char *device, const char *p)
|
||||
}
|
||||
}
|
||||
if (get_param_value(buf, sizeof(buf), "model", p)) {
|
||||
@ -66,7 +66,7 @@ index 61c9649..b58945f 100644
|
||||
}
|
||||
nd->nvectors = NIC_NVECTORS_UNSPECIFIED;
|
||||
if (get_param_value(buf, sizeof(buf), "vectors", p)) {
|
||||
@@ -3003,8 +3004,13 @@ void net_client_uninit(NICInfo *nd)
|
||||
@@ -2998,8 +2999,13 @@ void net_client_uninit(NICInfo *nd)
|
||||
{
|
||||
nd->vlan->nb_guest_devs--;
|
||||
nb_nics--;
|
||||
@ -82,10 +82,10 @@ index 61c9649..b58945f 100644
|
||||
|
||||
static int net_host_check_device(const char *device)
|
||||
diff --git a/net.h b/net.h
|
||||
index b172691..ec78d0a 100644
|
||||
index 57ab031..94db0d7 100644
|
||||
--- a/net.h
|
||||
+++ b/net.h
|
||||
@@ -100,10 +100,10 @@ enum {
|
||||
@@ -101,10 +101,10 @@ enum {
|
||||
|
||||
struct NICInfo {
|
||||
uint8_t macaddr[6];
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 22c6c8c5dfe66a5e7f81dd4a296e1b2b245c5d28 Mon Sep 17 00:00:00 2001
|
||||
From 8f4d4cb4e4e73d0533aa2cb421c14210c75f6edc Mon Sep 17 00:00:00 2001
|
||||
From: Mark McLoughlin <markmc@redhat.com>
|
||||
Date: Mon, 29 Jun 2009 14:49:03 +0100
|
||||
Subject: [PATCH] Fix linux-user build on ppc
|
||||
|
@ -1,48 +0,0 @@
|
||||
From 80380f566e2c1d4c9e02e0c0dff405ecc86d134e Mon Sep 17 00:00:00 2001
|
||||
From: Michael S. Tsirkin <mst@redhat.com>
|
||||
Date: Thu, 23 Jul 2009 16:34:13 +0300
|
||||
Subject: [PATCH] Fix error handling in msix vector add
|
||||
|
||||
When adding a vector fails, the used counter should
|
||||
not be incremented, otherwise on vector change we will
|
||||
try to update the routing entry.
|
||||
|
||||
(cherry picked from commit aca6915d92743b11ac5555d6e412cc4737f27f34)
|
||||
|
||||
Signed-off-by: Michael S. Tsirkin <mst@redhat.com>
|
||||
Signed-off-by: Avi Kivity <avi@redhat.com>
|
||||
Signed-off-by: Mark McLoughlin <markmc@redhat.com>
|
||||
Fedora-patch: qemu-fix-msix-error-handling-on-older-kernels.patch
|
||||
---
|
||||
hw/msix.c | 10 ++++++++--
|
||||
1 files changed, 8 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/hw/msix.c b/hw/msix.c
|
||||
index 974268d..b6c3f17 100644
|
||||
--- a/hw/msix.c
|
||||
+++ b/hw/msix.c
|
||||
@@ -503,13 +503,19 @@ void msix_reset(PCIDevice *dev)
|
||||
/* Mark vector as used. */
|
||||
int msix_vector_use(PCIDevice *dev, unsigned vector)
|
||||
{
|
||||
+ int ret;
|
||||
if (vector >= dev->msix_entries_nr)
|
||||
return -EINVAL;
|
||||
- if (dev->msix_entry_used[vector]++)
|
||||
+ if (dev->msix_entry_used[vector]) {
|
||||
return 0;
|
||||
+ }
|
||||
if (kvm_enabled() && qemu_kvm_irqchip_in_kernel()) {
|
||||
- return kvm_msix_add(dev, vector);
|
||||
+ ret = kvm_msix_add(dev, vector);
|
||||
+ if (ret) {
|
||||
+ return ret;
|
||||
+ }
|
||||
}
|
||||
+ ++dev->msix_entry_used[vector];
|
||||
return 0;
|
||||
}
|
||||
|
||||
--
|
||||
1.6.2.5
|
||||
|
@ -1,78 +0,0 @@
|
||||
From 70415c7d31bf6420d1a2d685fe14661ce1cfd9cb Mon Sep 17 00:00:00 2001
|
||||
From: Dustin Kirkland <kirkland@canonical.com>
|
||||
Date: Fri, 4 Sep 2009 14:38:30 -0500
|
||||
Subject: [PATCH] qemu-kvm: fix segfault when running kvm without /dev/kvm
|
||||
|
||||
qemu-kvm segfaults on systems without access to /dev/kvm.
|
||||
The global kvm_allowed is being set too late in vl.c.
|
||||
|
||||
This patch moves the kvm initialization a bit higher in the
|
||||
vl.c main, just after the daemonize fork.
|
||||
|
||||
This fix is intended to be a short term solution, solving the
|
||||
segfaults.
|
||||
|
||||
In the longer term, the suggested approach requires a bit more
|
||||
development and testing:
|
||||
* If no arg given => try kvm, try kqemu, try tcg
|
||||
* If --accelmode arg given => try $arg, and fail if unavailable
|
||||
|
||||
(cherry picked from commit c06b44bfc9814930b6a94db7bbeb3be1cd39c0d2)
|
||||
|
||||
Signed-off-by: Dustin Kirkland <kirkland@canonical.com>
|
||||
Signed-off-by: Marcelo Tosatti <mtosatti@redhat.com>
|
||||
Signed-off-by: Mark McLoughlin <markmc@redhat.com>
|
||||
Fedora-patch: qemu-fix-no-kvm-segfault.patch
|
||||
---
|
||||
vl.c | 28 ++++++++++++++--------------
|
||||
1 files changed, 14 insertions(+), 14 deletions(-)
|
||||
|
||||
diff --git a/vl.c b/vl.c
|
||||
index db75470..26bced8 100644
|
||||
--- a/vl.c
|
||||
+++ b/vl.c
|
||||
@@ -5831,6 +5831,20 @@ int main(int argc, char **argv, char **envp)
|
||||
}
|
||||
#endif
|
||||
|
||||
+ if (kvm_enabled()) {
|
||||
+ int ret;
|
||||
+
|
||||
+ ret = kvm_init(smp_cpus);
|
||||
+ if (ret < 0) {
|
||||
+#if defined(KVM_UPSTREAM) || defined(NO_CPU_EMULATION)
|
||||
+ fprintf(stderr, "failed to initialize KVM\n");
|
||||
+ exit(1);
|
||||
+#endif
|
||||
+ fprintf(stderr, "Could not initialize KVM, will disable KVM support\n");
|
||||
+ kvm_allowed = 0;
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
#ifdef CONFIG_KQEMU
|
||||
if (smp_cpus > 1)
|
||||
kqemu_allowed = 0;
|
||||
@@ -6002,20 +6016,6 @@ int main(int argc, char **argv, char **envp)
|
||||
}
|
||||
}
|
||||
|
||||
- if (kvm_enabled()) {
|
||||
- int ret;
|
||||
-
|
||||
- ret = kvm_init(smp_cpus);
|
||||
- if (ret < 0) {
|
||||
-#if defined(KVM_UPSTREAM) || defined(NO_CPU_EMULATION)
|
||||
- fprintf(stderr, "failed to initialize KVM\n");
|
||||
- exit(1);
|
||||
-#endif
|
||||
- fprintf(stderr, "Could not initialize KVM, will disable KVM support\n");
|
||||
- kvm_allowed = 0;
|
||||
- }
|
||||
- }
|
||||
-
|
||||
if (monitor_device) {
|
||||
monitor_hd = qemu_chr_open("monitor", monitor_device, NULL);
|
||||
if (!monitor_hd) {
|
||||
--
|
||||
1.6.2.5
|
||||
|
22
qemu.spec
22
qemu.spec
@ -1,16 +1,14 @@
|
||||
%define kvmverfull kvm-0.11.0-rc2
|
||||
|
||||
Summary: QEMU is a FAST! processor emulator
|
||||
Name: qemu
|
||||
Version: 0.10.92
|
||||
Release: 5%{?dist}
|
||||
Version: 0.11.0
|
||||
Release: 1%{?dist}
|
||||
# Epoch because we pushed a qemu-1.0 package
|
||||
Epoch: 2
|
||||
License: GPLv2+ and LGPLv2+ and BSD
|
||||
Group: Development/Tools
|
||||
URL: http://www.qemu.org/
|
||||
|
||||
Source0: http://downloads.sourceforge.net/sourceforge/kvm/qemu-%{kvmverfull}.tar.gz
|
||||
Source0: http://downloads.sourceforge.net/sourceforge/kvm/qemu-kvm-%{version}.tar.gz
|
||||
Source1: qemu.init
|
||||
|
||||
# Loads kvm kernel modules at boot
|
||||
@ -38,14 +36,8 @@ Patch03: qemu-allow-pulseaudio-to-be-the-default.patch
|
||||
# Add KSM support - see https://fedoraproject.org/wiki/Features/KSM
|
||||
Patch04: qemu-add-ksm-support.patch
|
||||
|
||||
# Fix MSI-X error handling on older kernels (#519787)
|
||||
Patch05: qemu-fix-msix-error-handling-on-older-kernels.patch
|
||||
|
||||
# Fix segfault when qemu-kvm is invoked inside a VM (bug #516543)
|
||||
Patch06: qemu-fix-no-kvm-segfault.patch
|
||||
|
||||
# Fix issue causing NIC hotplug confusion when no model is specified (#524022)
|
||||
Patch07: qemu-correctly-free-nic-info-structure.patch
|
||||
Patch05: qemu-correctly-free-nic-info-structure.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: SDL-devel zlib-devel which texi2html gnutls-devel cyrus-sasl-devel
|
||||
@ -235,8 +227,6 @@ such as kvmtrace and kvm_stat.
|
||||
%patch03 -p1
|
||||
%patch04 -p1
|
||||
%patch05 -p1
|
||||
%patch06 -p1
|
||||
%patch07 -p1
|
||||
|
||||
%build
|
||||
# systems like rhel build system does not have a recent enough linker so
|
||||
@ -530,6 +520,10 @@ fi
|
||||
%{_mandir}/man1/qemu-img.1*
|
||||
|
||||
%changelog
|
||||
* Mon Sep 28 2009 Mark McLoughlin <markmc@redhat.com> - 2:0.11.0-1
|
||||
- Update to 0.11.0 release
|
||||
- Drop a couple of upstreamed patches
|
||||
|
||||
* Wed Sep 23 2009 Mark McLoughlin <markmc@redhat.com> - 2:0.10.92-5
|
||||
- Fix issue causing NIC hotplug confusion when no model is specified (#524022)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user