Rebased to version 1.5.1
This commit is contained in:
parent
81a3da8be9
commit
8a0cce2bab
1
.gitignore
vendored
1
.gitignore
vendored
@ -20,3 +20,4 @@ qemu-kvm-0.13.0-25fdf4a.tar.gz
|
|||||||
/qemu-1.4.0.tar.bz2
|
/qemu-1.4.0.tar.bz2
|
||||||
/qemu-1.4.1.tar.bz2
|
/qemu-1.4.1.tar.bz2
|
||||||
/qemu-1.5.0.tar.bz2
|
/qemu-1.5.0.tar.bz2
|
||||||
|
/qemu-1.5.1.tar.bz2
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
From 7cd5a50e02ed4866932c2a70680bec48a75dae72 Mon Sep 17 00:00:00 2001
|
From 0f8c8df923aea533c4b573a013b9a35c3581c2df Mon Sep 17 00:00:00 2001
|
||||||
From: Cole Robinson <crobinso@redhat.com>
|
From: Cole Robinson <crobinso@redhat.com>
|
||||||
Date: Tue, 19 Feb 2013 14:39:05 -0500
|
Date: Tue, 19 Feb 2013 14:39:05 -0500
|
||||||
Subject: [PATCH] configure: Add --enable-migration-from-qemu-kvm
|
Subject: [PATCH] configure: Add --enable-migration-from-qemu-kvm
|
||||||
@ -14,7 +14,7 @@ not a big loss (and I don't know any way to avoid it).
|
|||||||
1 file changed, 10 insertions(+)
|
1 file changed, 10 insertions(+)
|
||||||
|
|
||||||
diff --git a/configure b/configure
|
diff --git a/configure b/configure
|
||||||
index 5ae7e4a..fb41cb6 100755
|
index eb74510..f558a21 100755
|
||||||
--- a/configure
|
--- a/configure
|
||||||
+++ b/configure
|
+++ b/configure
|
||||||
@@ -179,6 +179,7 @@ xfs=""
|
@@ -179,6 +179,7 @@ xfs=""
|
||||||
@ -25,7 +25,7 @@ index 5ae7e4a..fb41cb6 100755
|
|||||||
gprof="no"
|
gprof="no"
|
||||||
debug_tcg="no"
|
debug_tcg="no"
|
||||||
debug="no"
|
debug="no"
|
||||||
@@ -777,6 +778,8 @@ for opt do
|
@@ -776,6 +777,8 @@ for opt do
|
||||||
;;
|
;;
|
||||||
--enable-kvm) kvm="yes"
|
--enable-kvm) kvm="yes"
|
||||||
;;
|
;;
|
||||||
@ -34,7 +34,7 @@ index 5ae7e4a..fb41cb6 100755
|
|||||||
--disable-tcg-interpreter) tcg_interpreter="no"
|
--disable-tcg-interpreter) tcg_interpreter="no"
|
||||||
;;
|
;;
|
||||||
--enable-tcg-interpreter) tcg_interpreter="yes"
|
--enable-tcg-interpreter) tcg_interpreter="yes"
|
||||||
@@ -1136,6 +1139,9 @@ echo " --enable-bluez enable bluez stack connectivity"
|
@@ -1135,6 +1138,9 @@ echo " --enable-bluez enable bluez stack connectivity"
|
||||||
echo " --disable-slirp disable SLIRP userspace network connectivity"
|
echo " --disable-slirp disable SLIRP userspace network connectivity"
|
||||||
echo " --disable-kvm disable KVM acceleration support"
|
echo " --disable-kvm disable KVM acceleration support"
|
||||||
echo " --enable-kvm enable KVM acceleration support"
|
echo " --enable-kvm enable KVM acceleration support"
|
||||||
@ -44,7 +44,7 @@ index 5ae7e4a..fb41cb6 100755
|
|||||||
echo " --enable-tcg-interpreter enable TCG with bytecode interpreter (TCI)"
|
echo " --enable-tcg-interpreter enable TCG with bytecode interpreter (TCI)"
|
||||||
echo " --disable-nptl disable usermode NPTL support"
|
echo " --disable-nptl disable usermode NPTL support"
|
||||||
echo " --enable-nptl enable usermode NPTL support"
|
echo " --enable-nptl enable usermode NPTL support"
|
||||||
@@ -3554,6 +3560,7 @@ echo "Linux AIO support $linux_aio"
|
@@ -3553,6 +3559,7 @@ echo "Linux AIO support $linux_aio"
|
||||||
echo "ATTR/XATTR support $attr"
|
echo "ATTR/XATTR support $attr"
|
||||||
echo "Install blobs $blobs"
|
echo "Install blobs $blobs"
|
||||||
echo "KVM support $kvm"
|
echo "KVM support $kvm"
|
||||||
@ -52,7 +52,7 @@ index 5ae7e4a..fb41cb6 100755
|
|||||||
echo "TCG interpreter $tcg_interpreter"
|
echo "TCG interpreter $tcg_interpreter"
|
||||||
echo "fdt support $fdt"
|
echo "fdt support $fdt"
|
||||||
echo "preadv support $preadv"
|
echo "preadv support $preadv"
|
||||||
@@ -3863,6 +3870,9 @@ fi
|
@@ -3862,6 +3869,9 @@ fi
|
||||||
if test "$signalfd" = "yes" ; then
|
if test "$signalfd" = "yes" ; then
|
||||||
echo "CONFIG_SIGNALFD=y" >> $config_host_mak
|
echo "CONFIG_SIGNALFD=y" >> $config_host_mak
|
||||||
fi
|
fi
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
From 9df0fd5765377d32a0e9f2d855dc1d428c19f767 Mon Sep 17 00:00:00 2001
|
From eebf11b36cdd88ed2273eda6258760c59a9aaf9b Mon Sep 17 00:00:00 2001
|
||||||
From: Cole Robinson <crobinso@redhat.com>
|
From: Cole Robinson <crobinso@redhat.com>
|
||||||
Date: Tue, 19 Feb 2013 14:44:49 -0500
|
Date: Tue, 19 Feb 2013 14:44:49 -0500
|
||||||
Subject: [PATCH] acpi_piix4: Drop minimum_version_id to handle qemu-kvm
|
Subject: [PATCH] acpi_piix4: Drop minimum_version_id to handle qemu-kvm
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
From e1f0936bbf84664d7d7fe7bbbdd1595be745b539 Mon Sep 17 00:00:00 2001
|
From 05d94ec26781d83f78bb6e9c7a5610cf88f69293 Mon Sep 17 00:00:00 2001
|
||||||
From: Cole Robinson <crobinso@redhat.com>
|
From: Cole Robinson <crobinso@redhat.com>
|
||||||
Date: Tue, 19 Feb 2013 15:04:59 -0500
|
Date: Tue, 19 Feb 2013 15:04:59 -0500
|
||||||
Subject: [PATCH] i8254: Fix migration from qemu-kvm < 1.1
|
Subject: [PATCH] i8254: Fix migration from qemu-kvm < 1.1
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
From 3e580f65ac69c7a84b672a59de6772dae24b5a8a Mon Sep 17 00:00:00 2001
|
From 437b8cb633fa6402546bf0f2e808a64ea447b55e Mon Sep 17 00:00:00 2001
|
||||||
From: Cole Robinson <crobinso@redhat.com>
|
From: Cole Robinson <crobinso@redhat.com>
|
||||||
Date: Tue, 19 Feb 2013 15:35:40 -0500
|
Date: Tue, 19 Feb 2013 15:35:40 -0500
|
||||||
Subject: [PATCH] pc_piix: Add compat handling for qemu-kvm VGA mem size
|
Subject: [PATCH] pc_piix: Add compat handling for qemu-kvm VGA mem size
|
||||||
@ -19,7 +19,7 @@ all others. This will break incoming qemu migration for qemu < 1.3.
|
|||||||
1 file changed, 16 insertions(+), 4 deletions(-)
|
1 file changed, 16 insertions(+), 4 deletions(-)
|
||||||
|
|
||||||
diff --git a/hw/i386/pc_piix.c b/hw/i386/pc_piix.c
|
diff --git a/hw/i386/pc_piix.c b/hw/i386/pc_piix.c
|
||||||
index 43ab480..48fb7b7 100644
|
index 06416ce..0787f38 100644
|
||||||
--- a/hw/i386/pc_piix.c
|
--- a/hw/i386/pc_piix.c
|
||||||
+++ b/hw/i386/pc_piix.c
|
+++ b/hw/i386/pc_piix.c
|
||||||
@@ -383,6 +383,13 @@ static QEMUMachine pc_machine_v1_3 = {
|
@@ -383,6 +383,13 @@ static QEMUMachine pc_machine_v1_3 = {
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
From ae8d642477d87287b42b0b40c133637dd1cdd8b9 Mon Sep 17 00:00:00 2001
|
From 9642978bbeba188570ec62fd989cad4da32589c3 Mon Sep 17 00:00:00 2001
|
||||||
From: Cole Robinson <crobinso@redhat.com>
|
From: Cole Robinson <crobinso@redhat.com>
|
||||||
Date: Tue, 19 Feb 2013 16:19:02 -0500
|
Date: Tue, 19 Feb 2013 16:19:02 -0500
|
||||||
Subject: [PATCH] qxl: Add rom_size compat property, fix migration from 1.2
|
Subject: [PATCH] qxl: Add rom_size compat property, fix migration from 1.2
|
||||||
@ -64,7 +64,7 @@ index c475cb1..74f07c0 100644
|
|||||||
};
|
};
|
||||||
|
|
||||||
diff --git a/hw/i386/pc_piix.c b/hw/i386/pc_piix.c
|
diff --git a/hw/i386/pc_piix.c b/hw/i386/pc_piix.c
|
||||||
index 48fb7b7..2307d26 100644
|
index 0787f38..e26c93d 100644
|
||||||
--- a/hw/i386/pc_piix.c
|
--- a/hw/i386/pc_piix.c
|
||||||
+++ b/hw/i386/pc_piix.c
|
+++ b/hw/i386/pc_piix.c
|
||||||
@@ -369,6 +369,14 @@ static QEMUMachine pc_i440fx_machine_v1_4 = {
|
@@ -369,6 +369,14 @@ static QEMUMachine pc_i440fx_machine_v1_4 = {
|
||||||
|
@ -1,4 +1,4 @@
|
|||||||
From 7e72644adb7ed1092a90cf26c4edbba4b3f2b11b Mon Sep 17 00:00:00 2001
|
From 93178ab04a3dd129848e398838e14f22ba0ba23f Mon Sep 17 00:00:00 2001
|
||||||
From: Peter Crosthwaite <peter.crosthwaite@xilinx.com>
|
From: Peter Crosthwaite <peter.crosthwaite@xilinx.com>
|
||||||
Date: Mon, 27 May 2013 14:20:57 +1000
|
Date: Mon, 27 May 2013 14:20:57 +1000
|
||||||
Subject: [PATCH] configure: dtc: Probe for libfdt_env.h
|
Subject: [PATCH] configure: dtc: Probe for libfdt_env.h
|
||||||
@ -28,10 +28,10 @@ Signed-off-by: Peter Maydell <peter.maydell@linaro.org>
|
|||||||
delete mode 100644 include/libfdt_env.h
|
delete mode 100644 include/libfdt_env.h
|
||||||
|
|
||||||
diff --git a/configure b/configure
|
diff --git a/configure b/configure
|
||||||
index fb41cb6..7e07cb7 100755
|
index f558a21..ed09648 100755
|
||||||
--- a/configure
|
--- a/configure
|
||||||
+++ b/configure
|
+++ b/configure
|
||||||
@@ -2526,7 +2526,9 @@ fi
|
@@ -2525,7 +2525,9 @@ fi
|
||||||
# fdt probe
|
# fdt probe
|
||||||
if test "$fdt" != "no" ; then
|
if test "$fdt" != "no" ; then
|
||||||
fdt_libs="-lfdt"
|
fdt_libs="-lfdt"
|
@ -1,47 +0,0 @@
|
|||||||
From 4044e0670486ad089367952843f17351c4f6faa0 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Stefan Hajnoczi <stefanha@redhat.com>
|
|
||||||
Date: Wed, 22 May 2013 14:50:18 +0200
|
|
||||||
Subject: [PATCH] rtl8139: flush queued packets when RxBufPtr is written
|
|
||||||
|
|
||||||
Net queues support efficient "receive disable". For example, tap's file
|
|
||||||
descriptor will not be polled while its peer has receive disabled. This
|
|
||||||
saves CPU cycles for needlessly copying and then dropping packets which
|
|
||||||
the peer cannot receive.
|
|
||||||
|
|
||||||
rtl8139 is missing the qemu_flush_queued_packets() call that wakes the
|
|
||||||
queue up when receive becomes possible again.
|
|
||||||
|
|
||||||
As a result, the Windows 7 guest driver reaches a state where the
|
|
||||||
rtl8139 cannot receive packets. The driver has actually refilled the
|
|
||||||
receive buffer but we never resume reception.
|
|
||||||
|
|
||||||
The bug can be reproduced by running a large FTP 'get' inside a Windows
|
|
||||||
7 guest:
|
|
||||||
|
|
||||||
$ qemu -netdev tap,id=tap0,...
|
|
||||||
-device rtl8139,netdev=tap0
|
|
||||||
|
|
||||||
The Linux guest driver does not trigger the bug, probably due to a
|
|
||||||
different buffer management strategy.
|
|
||||||
|
|
||||||
Reported-by: Oliver Francke <oliver.francke@filoo.de>
|
|
||||||
Signed-off-by: Stefan Hajnoczi <stefanha@redhat.com>
|
|
||||||
(cherry picked from commit 00b7ade807b5ce6779ddd86ce29c5521ec5c529a)
|
|
||||||
---
|
|
||||||
hw/net/rtl8139.c | 3 +++
|
|
||||||
1 file changed, 3 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/hw/net/rtl8139.c b/hw/net/rtl8139.c
|
|
||||||
index 9369507..7993f9f 100644
|
|
||||||
--- a/hw/net/rtl8139.c
|
|
||||||
+++ b/hw/net/rtl8139.c
|
|
||||||
@@ -2575,6 +2575,9 @@ static void rtl8139_RxBufPtr_write(RTL8139State *s, uint32_t val)
|
|
||||||
/* this value is off by 16 */
|
|
||||||
s->RxBufPtr = MOD2(val + 0x10, s->RxBufferSize);
|
|
||||||
|
|
||||||
+ /* more buffer space may be available so try to receive */
|
|
||||||
+ qemu_flush_queued_packets(qemu_get_queue(s->nic));
|
|
||||||
+
|
|
||||||
DPRINTF(" CAPR write: rx buffer length %d head 0x%04x read 0x%04x\n",
|
|
||||||
s->RxBufferSize, s->RxBufAddr, s->RxBufPtr);
|
|
||||||
}
|
|
15
qemu.spec
15
qemu.spec
@ -139,8 +139,8 @@
|
|||||||
|
|
||||||
Summary: QEMU is a FAST! processor emulator
|
Summary: QEMU is a FAST! processor emulator
|
||||||
Name: qemu
|
Name: qemu
|
||||||
Version: 1.5.0
|
Version: 1.5.1
|
||||||
Release: 9%{?dist}
|
Release: 1%{?dist}
|
||||||
Epoch: 2
|
Epoch: 2
|
||||||
License: GPLv2+ and LGPLv2+ and BSD
|
License: GPLv2+ and LGPLv2+ and BSD
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
@ -188,10 +188,8 @@ Patch0003: 0003-i8254-Fix-migration-from-qemu-kvm-1.1.patch
|
|||||||
Patch0004: 0004-pc_piix-Add-compat-handling-for-qemu-kvm-VGA-mem-siz.patch
|
Patch0004: 0004-pc_piix-Add-compat-handling-for-qemu-kvm-VGA-mem-siz.patch
|
||||||
# Fix migration w/ qxl from qemu-kvm 1.2 (solution pending upstream)
|
# Fix migration w/ qxl from qemu-kvm 1.2 (solution pending upstream)
|
||||||
Patch0005: 0005-qxl-Add-rom_size-compat-property-fix-migration-from-.patch
|
Patch0005: 0005-qxl-Add-rom_size-compat-property-fix-migration-from-.patch
|
||||||
# Fix rtl8139 + windows 7 + large transfers (bz #970240)
|
|
||||||
Patch0006: 0006-rtl8139-flush-queued-packets-when-RxBufPtr-is-writte.patch
|
|
||||||
# Fix build with rawhide libfdt
|
# Fix build with rawhide libfdt
|
||||||
Patch0007: 0007-configure-dtc-Probe-for-libfdt_env.h.patch
|
Patch0006: 0006-configure-dtc-Probe-for-libfdt_env.h.patch
|
||||||
|
|
||||||
BuildRequires: SDL-devel
|
BuildRequires: SDL-devel
|
||||||
BuildRequires: zlib-devel
|
BuildRequires: zlib-devel
|
||||||
@ -688,10 +686,8 @@ CAC emulation development files.
|
|||||||
%patch0004 -p1
|
%patch0004 -p1
|
||||||
# Fix migration w/ qxl from qemu-kvm 1.2 (solution pending upstream)
|
# Fix migration w/ qxl from qemu-kvm 1.2 (solution pending upstream)
|
||||||
%patch0005 -p1
|
%patch0005 -p1
|
||||||
# Fix rtl8139 + windows 7 + large transfers (bz #970240)
|
|
||||||
%patch0006 -p1
|
|
||||||
# Fix build with rawhide libfdt
|
# Fix build with rawhide libfdt
|
||||||
%patch0007 -p1
|
%patch0006 -p1
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -1378,6 +1374,9 @@ getent passwd qemu >/dev/null || \
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jun 28 2013 Cole Robinson <crobinso@redhat.com> - 2:1.5.1-1
|
||||||
|
- Rebased to version 1.5.1
|
||||||
|
|
||||||
* Wed Jun 19 2013 Cole Robinson <crobinso@redhat.com> - 2:1.5.0-9
|
* Wed Jun 19 2013 Cole Robinson <crobinso@redhat.com> - 2:1.5.0-9
|
||||||
- Don't install conflicting binfmt handler on arm (bz #974804)
|
- Don't install conflicting binfmt handler on arm (bz #974804)
|
||||||
- Use upstream patch for libfdt build fix
|
- Use upstream patch for libfdt build fix
|
||||||
|
Loading…
Reference in New Issue
Block a user