Update to qemu-2.12.0-rc3
- Remove upstream patch. - Fixes issues with partition / LV minimum alignment (RHBZ#1565714).
This commit is contained in:
parent
7b9b67b1ec
commit
6dab4a0cbd
1
.gitignore
vendored
1
.gitignore
vendored
@ -20,3 +20,4 @@
|
|||||||
/qemu-2.12.0-rc0.tar.xz
|
/qemu-2.12.0-rc0.tar.xz
|
||||||
/qemu-2.12.0-rc1.tar.xz
|
/qemu-2.12.0-rc1.tar.xz
|
||||||
/qemu-2.12.0-rc2.tar.xz
|
/qemu-2.12.0-rc2.tar.xz
|
||||||
|
/qemu-2.12.0-rc3.tar.xz
|
||||||
|
@ -1,48 +0,0 @@
|
|||||||
From 11e1a77f98b2663a6fb0b640bff2ceedc6fc79f8 Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?Daniel=20P=2E=20Berrang=C3=A9?= <berrange@redhat.com>
|
|
||||||
Date: Wed, 28 Feb 2018 14:04:38 +0000
|
|
||||||
Subject: [PATCH] crypto: ensure we use a predictable TLS priority setting
|
|
||||||
MIME-Version: 1.0
|
|
||||||
Content-Type: text/plain; charset=UTF-8
|
|
||||||
Content-Transfer-Encoding: 8bit
|
|
||||||
|
|
||||||
The TLS test cert generation relies on a fixed set of algorithms that are
|
|
||||||
only usable under GNUTLS' default priority setting. When building QEMU
|
|
||||||
with a custom distro specific priority setting, this can cause the TLS
|
|
||||||
tests to fail. By forcing the tests to always use "NORMAL" priority we
|
|
||||||
can make them more robust.
|
|
||||||
|
|
||||||
Reviewed-by: Eric Blake <eblake@redhat.com>
|
|
||||||
Signed-off-by: Daniel P. Berrangé <berrange@redhat.com>
|
|
||||||
---
|
|
||||||
tests/test-crypto-tlssession.c | 1 +
|
|
||||||
tests/test-io-channel-tls.c | 1 +
|
|
||||||
2 files changed, 2 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/tests/test-crypto-tlssession.c b/tests/test-crypto-tlssession.c
|
|
||||||
index 1a4a066d76..82f21c27f2 100644
|
|
||||||
--- a/tests/test-crypto-tlssession.c
|
|
||||||
+++ b/tests/test-crypto-tlssession.c
|
|
||||||
@@ -75,6 +75,7 @@ static QCryptoTLSCreds *test_tls_creds_create(QCryptoTLSCredsEndpoint endpoint,
|
|
||||||
"server" : "client"),
|
|
||||||
"dir", certdir,
|
|
||||||
"verify-peer", "yes",
|
|
||||||
+ "priority", "NORMAL",
|
|
||||||
/* We skip initial sanity checks here because we
|
|
||||||
* want to make sure that problems are being
|
|
||||||
* detected at the TLS session validation stage,
|
|
||||||
diff --git a/tests/test-io-channel-tls.c b/tests/test-io-channel-tls.c
|
|
||||||
index a210d01ba5..47ba603e8d 100644
|
|
||||||
--- a/tests/test-io-channel-tls.c
|
|
||||||
+++ b/tests/test-io-channel-tls.c
|
|
||||||
@@ -78,6 +78,7 @@ static QCryptoTLSCreds *test_tls_creds_create(QCryptoTLSCredsEndpoint endpoint,
|
|
||||||
"server" : "client"),
|
|
||||||
"dir", certdir,
|
|
||||||
"verify-peer", "yes",
|
|
||||||
+ "priority", "NORMAL",
|
|
||||||
/* We skip initial sanity checks here because we
|
|
||||||
* want to make sure that problems are being
|
|
||||||
* detected at the TLS session validation stage,
|
|
||||||
--
|
|
||||||
2.14.3
|
|
||||||
|
|
12
qemu.spec
12
qemu.spec
@ -94,7 +94,7 @@ Requires: %{name}-ui-sdl = %{epoch}:%{version}-%{release}
|
|||||||
|
|
||||||
|
|
||||||
# Release candidate version tracking
|
# Release candidate version tracking
|
||||||
%global rcver rc2
|
%global rcver rc3
|
||||||
%if 0%{?rcver:1}
|
%if 0%{?rcver:1}
|
||||||
%global rcrel .%{rcver}
|
%global rcrel .%{rcver}
|
||||||
%global rcstr -%{rcver}
|
%global rcstr -%{rcver}
|
||||||
@ -104,7 +104,7 @@ Requires: %{name}-ui-sdl = %{epoch}:%{version}-%{release}
|
|||||||
Summary: QEMU is a FAST! processor emulator
|
Summary: QEMU is a FAST! processor emulator
|
||||||
Name: qemu
|
Name: qemu
|
||||||
Version: 2.12.0
|
Version: 2.12.0
|
||||||
Release: 0.6%{?rcrel}%{?dist}
|
Release: 0.7%{?rcrel}%{?dist}
|
||||||
Epoch: 2
|
Epoch: 2
|
||||||
License: GPLv2 and BSD and MIT and CC-BY
|
License: GPLv2 and BSD and MIT and CC-BY
|
||||||
URL: http://www.qemu.org/
|
URL: http://www.qemu.org/
|
||||||
@ -137,9 +137,6 @@ Source21: 50-kvm-s390x.conf
|
|||||||
# /etc/security/limits.d/95-kvm-ppc64-memlock.conf
|
# /etc/security/limits.d/95-kvm-ppc64-memlock.conf
|
||||||
Source22: 95-kvm-ppc64-memlock.conf
|
Source22: 95-kvm-ppc64-memlock.conf
|
||||||
|
|
||||||
# Avoid breakage in tests due to stricter crypto policies
|
|
||||||
Patch0001: 0001-crypto-ensure-we-use-a-predictable-TLS-priority-sett.patch
|
|
||||||
|
|
||||||
# documentation deps
|
# documentation deps
|
||||||
BuildRequires: texinfo
|
BuildRequires: texinfo
|
||||||
# For /usr/bin/pod2man
|
# For /usr/bin/pod2man
|
||||||
@ -1666,6 +1663,11 @@ getent passwd qemu >/dev/null || \
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Apr 16 2018 Richard W.M. Jones <rjones@redhat.com> - 2:2.12.0-0.7.rc3
|
||||||
|
- Update to qemu-2.12.0-rc3
|
||||||
|
- Remove upstream patch.
|
||||||
|
- Fixes issues with partition / LV minimum alignment (RHBZ#1565714).
|
||||||
|
|
||||||
* Thu Apr 05 2018 Cole Robinson <crobinso@redhat.com> - 2:2.12.0-0.6.rc2
|
* Thu Apr 05 2018 Cole Robinson <crobinso@redhat.com> - 2:2.12.0-0.6.rc2
|
||||||
- Update to qemu-2.12.0-rc2
|
- Update to qemu-2.12.0-rc2
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (qemu-2.12.0-rc2.tar.xz) = 0dd0816e6b2f21585f574f6f4b7c510e0fb165f4c68ff0837a137bcb5c6851776d2077d44325ae4e0fbf2c98abb9433bf378234723b571b41c9b9e247d3411db
|
SHA512 (qemu-2.12.0-rc3.tar.xz) = 303dbd1f906d81888e215ac8f61778c05c767f654c7f538187a61bb1afcab65b4c8ebafc58d35574cbf7a7277af08ace9fabc7f04ca1233d59e0142a69ec29b9
|
||||||
|
Loading…
Reference in New Issue
Block a user