- Add upstream qemu patch 'Allow to leave type on default in -machine'
(2645c6dcaf6ea2a51a3b6dfa407dd203004e4d11).
This commit is contained in:
parent
1528fef34a
commit
6ba4785b4a
14
qemu-Allow-to-leave-type-on-default-in-machine.patch
Normal file
14
qemu-Allow-to-leave-type-on-default-in-machine.patch
Normal file
@ -0,0 +1,14 @@
|
||||
--- qemu-kvm-0.15.0.old/vl.c 2011-08-09 13:40:29.000000000 +0100
|
||||
+++ qemu-kvm-0.15.0/vl.c 2011-08-18 16:38:51.487515037 +0100
|
||||
@@ -2718,7 +2718,10 @@
|
||||
fprintf(stderr, "parse error: %s\n", optarg);
|
||||
exit(1);
|
||||
}
|
||||
- machine = machine_parse(qemu_opt_get(opts, "type"));
|
||||
+ optarg = qemu_opt_get(opts, "type");
|
||||
+ if (optarg) {
|
||||
+ machine = machine_parse(optarg);
|
||||
+ }
|
||||
break;
|
||||
case QEMU_OPTION_no_kvm:
|
||||
olist = qemu_find_opts("machine");
|
13
qemu.spec
13
qemu.spec
@ -1,7 +1,7 @@
|
||||
Summary: QEMU is a FAST! processor emulator
|
||||
Name: qemu
|
||||
Version: 0.15.0
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
# Epoch because we pushed a qemu-1.0 package
|
||||
Epoch: 2
|
||||
License: GPLv2+ and LGPLv2+ and BSD
|
||||
@ -64,6 +64,11 @@ Patch26: 0026-usb-redir-Call-qemu_chr_guest_open-close.patch
|
||||
Patch27: 0027-usb-redir-Device-disconnect-re-connect-robustness-fi.patch
|
||||
Patch28: 0028-usb-redir-Don-t-try-to-write-to-the-chardev-after-a-.patch
|
||||
|
||||
# Allow -machine parameter to be used without specifying a machine type.
|
||||
# Upstream in qemu but apparently not in qemu-kvm yet.
|
||||
# qemu commit 2645c6dcaf6ea2a51a3b6dfa407dd203004e4d11
|
||||
Patch100: qemu-Allow-to-leave-type-on-default-in-machine.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: SDL-devel zlib-devel which texi2html gnutls-devel cyrus-sasl-devel
|
||||
BuildRequires: libaio-devel
|
||||
@ -265,6 +270,8 @@ such as kvm_stat.
|
||||
%patch27 -p1
|
||||
%patch28 -p1
|
||||
|
||||
%patch100 -p1
|
||||
|
||||
%build
|
||||
# By default we build everything, but allow x86 to build a minimal version
|
||||
# with only similar arch target support
|
||||
@ -574,6 +581,10 @@ fi
|
||||
%{_mandir}/man1/qemu-img.1*
|
||||
|
||||
%changelog
|
||||
* Thu Aug 18 2011 Richard W.M. Jones <rjones@redhat.com> - 2:0.15.0-2
|
||||
- Add upstream qemu patch 'Allow to leave type on default in -machine'
|
||||
(2645c6dcaf6ea2a51a3b6dfa407dd203004e4d11).
|
||||
|
||||
* Sun Aug 14 2011 Justin M. Forbes <jforbes@redhat.com> - 2:0.15.0-1
|
||||
- Update to 0.15.0 stable release.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user