Rebased to version 1.5.2
Fix mouse display with spice and latest libvirt (bz #981094)
This commit is contained in:
parent
b6a83a54d0
commit
67ad330b45
1
.gitignore
vendored
1
.gitignore
vendored
@ -21,3 +21,4 @@ qemu-kvm-0.13.0-25fdf4a.tar.gz
|
||||
/qemu-1.4.1.tar.bz2
|
||||
/qemu-1.5.0.tar.bz2
|
||||
/qemu-1.5.1.tar.bz2
|
||||
/qemu-1.5.2.tar.bz2
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 0f8c8df923aea533c4b573a013b9a35c3581c2df Mon Sep 17 00:00:00 2001
|
||||
From e49e68d5b504f22919c6134e3a06d3838e872d2f Mon Sep 17 00:00:00 2001
|
||||
From: Cole Robinson <crobinso@redhat.com>
|
||||
Date: Tue, 19 Feb 2013 14:39:05 -0500
|
||||
Subject: [PATCH] configure: Add --enable-migration-from-qemu-kvm
|
||||
|
@ -1,4 +1,4 @@
|
||||
From eebf11b36cdd88ed2273eda6258760c59a9aaf9b Mon Sep 17 00:00:00 2001
|
||||
From 28886fb9f7d908bf0f2406dc6f39ee6fe9040cfd Mon Sep 17 00:00:00 2001
|
||||
From: Cole Robinson <crobinso@redhat.com>
|
||||
Date: Tue, 19 Feb 2013 14:44:49 -0500
|
||||
Subject: [PATCH] acpi_piix4: Drop minimum_version_id to handle qemu-kvm
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 05d94ec26781d83f78bb6e9c7a5610cf88f69293 Mon Sep 17 00:00:00 2001
|
||||
From 08aac015d8ba0228dc4277dd7163f014b20c1ca5 Mon Sep 17 00:00:00 2001
|
||||
From: Cole Robinson <crobinso@redhat.com>
|
||||
Date: Tue, 19 Feb 2013 15:04:59 -0500
|
||||
Subject: [PATCH] i8254: Fix migration from qemu-kvm < 1.1
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 437b8cb633fa6402546bf0f2e808a64ea447b55e Mon Sep 17 00:00:00 2001
|
||||
From 9def7a9ed113f7b40e868f663bfaa4f9717219ae Mon Sep 17 00:00:00 2001
|
||||
From: Cole Robinson <crobinso@redhat.com>
|
||||
Date: Tue, 19 Feb 2013 15:35:40 -0500
|
||||
Subject: [PATCH] pc_piix: Add compat handling for qemu-kvm VGA mem size
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 9642978bbeba188570ec62fd989cad4da32589c3 Mon Sep 17 00:00:00 2001
|
||||
From dbeb3f1e3282bef66b459e3197b2078c24ad7daf Mon Sep 17 00:00:00 2001
|
||||
From: Cole Robinson <crobinso@redhat.com>
|
||||
Date: Tue, 19 Feb 2013 16:19:02 -0500
|
||||
Subject: [PATCH] qxl: Add rom_size compat property, fix migration from 1.2
|
||||
|
@ -1,4 +1,4 @@
|
||||
From 93178ab04a3dd129848e398838e14f22ba0ba23f Mon Sep 17 00:00:00 2001
|
||||
From 12f9c64a068d3c5e67886dde367ccacde48fbbbd Mon Sep 17 00:00:00 2001
|
||||
From: Peter Crosthwaite <peter.crosthwaite@xilinx.com>
|
||||
Date: Mon, 27 May 2013 14:20:57 +1000
|
||||
Subject: [PATCH] configure: dtc: Probe for libfdt_env.h
|
||||
|
92
0007-spice-fix-display-initialization.patch
Normal file
92
0007-spice-fix-display-initialization.patch
Normal file
@ -0,0 +1,92 @@
|
||||
From 49c090ab950547cb807e90866439072a191513d1 Mon Sep 17 00:00:00 2001
|
||||
From: Gerd Hoffmann <kraxel@redhat.com>
|
||||
Date: Tue, 23 Jul 2013 13:55:43 +0200
|
||||
Subject: [PATCH] spice: fix display initialization
|
||||
|
||||
Spice has two display interface implementations: One integrated into
|
||||
the qxl graphics card, and one generic which can operate with every
|
||||
qemu-emulated graphics card.
|
||||
|
||||
The generic one is activated in case spice is used without qxl. The
|
||||
logic for that only caught the "-vga qxl" case, "-device qxl-vga" goes
|
||||
unnoticed. Fix that by adding a check in the spice interface
|
||||
registration so we'll notice the qxl card no matter how it is created.
|
||||
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=981094
|
||||
|
||||
Signed-off-by: Gerd Hoffmann <kraxel@redhat.com>
|
||||
---
|
||||
include/sysemu/sysemu.h | 1 -
|
||||
include/ui/qemu-spice.h | 2 ++
|
||||
ui/spice-core.c | 5 +++++
|
||||
vl.c | 2 +-
|
||||
4 files changed, 8 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/include/sysemu/sysemu.h b/include/sysemu/sysemu.h
|
||||
index 2fb71af..8c8a36f 100644
|
||||
--- a/include/sysemu/sysemu.h
|
||||
+++ b/include/sysemu/sysemu.h
|
||||
@@ -103,7 +103,6 @@ typedef enum {
|
||||
|
||||
extern int vga_interface_type;
|
||||
#define xenfb_enabled (vga_interface_type == VGA_XENFB)
|
||||
-#define qxl_enabled (vga_interface_type == VGA_QXL)
|
||||
|
||||
extern int graphic_width;
|
||||
extern int graphic_height;
|
||||
diff --git a/include/ui/qemu-spice.h b/include/ui/qemu-spice.h
|
||||
index eba6d77..c6c756b 100644
|
||||
--- a/include/ui/qemu-spice.h
|
||||
+++ b/include/ui/qemu-spice.h
|
||||
@@ -27,6 +27,7 @@
|
||||
#include "monitor/monitor.h"
|
||||
|
||||
extern int using_spice;
|
||||
+extern int spice_displays;
|
||||
|
||||
void qemu_spice_init(void);
|
||||
void qemu_spice_input_init(void);
|
||||
@@ -57,6 +58,7 @@ static inline CharDriverState *qemu_chr_open_spice_port(const char *name)
|
||||
#include "monitor/monitor.h"
|
||||
|
||||
#define using_spice 0
|
||||
+#define spice_displays 0
|
||||
static inline int qemu_spice_set_passwd(const char *passwd,
|
||||
bool fail_if_connected,
|
||||
bool disconnect_if_connected)
|
||||
diff --git a/ui/spice-core.c b/ui/spice-core.c
|
||||
index bcc4199..c8337ab 100644
|
||||
--- a/ui/spice-core.c
|
||||
+++ b/ui/spice-core.c
|
||||
@@ -48,6 +48,7 @@ static char *auth_passwd;
|
||||
static time_t auth_expires = TIME_MAX;
|
||||
static int spice_migration_completed;
|
||||
int using_spice = 0;
|
||||
+int spice_displays;
|
||||
|
||||
static QemuThread me;
|
||||
|
||||
@@ -823,6 +824,10 @@ int qemu_spice_add_interface(SpiceBaseInstance *sin)
|
||||
qemu_add_vm_change_state_handler(vm_change_state_handler, NULL);
|
||||
}
|
||||
|
||||
+ if (strcmp(sin->sif->type, SPICE_INTERFACE_QXL) == 0) {
|
||||
+ spice_displays++;
|
||||
+ }
|
||||
+
|
||||
return spice_server_add_interface(spice_server, sin);
|
||||
}
|
||||
|
||||
diff --git a/vl.c b/vl.c
|
||||
index efb073f..3559f76 100644
|
||||
--- a/vl.c
|
||||
+++ b/vl.c
|
||||
@@ -4374,7 +4374,7 @@ int main(int argc, char **argv, char **envp)
|
||||
}
|
||||
#endif
|
||||
#ifdef CONFIG_SPICE
|
||||
- if (using_spice && !qxl_enabled) {
|
||||
+ if (using_spice && !spice_displays) {
|
||||
qemu_spice_display_init(ds);
|
||||
}
|
||||
#endif
|
14
qemu.spec
14
qemu.spec
@ -139,8 +139,8 @@
|
||||
|
||||
Summary: QEMU is a FAST! processor emulator
|
||||
Name: qemu
|
||||
Version: 1.5.1
|
||||
Release: 2%{?dist}
|
||||
Version: 1.5.2
|
||||
Release: 1%{?dist}
|
||||
Epoch: 2
|
||||
License: GPLv2+ and LGPLv2+ and BSD
|
||||
Group: Development/Tools
|
||||
@ -190,6 +190,9 @@ Patch0004: 0004-pc_piix-Add-compat-handling-for-qemu-kvm-VGA-mem-siz.patch
|
||||
Patch0005: 0005-qxl-Add-rom_size-compat-property-fix-migration-from-.patch
|
||||
# Fix build with rawhide libfdt
|
||||
Patch0006: 0006-configure-dtc-Probe-for-libfdt_env.h.patch
|
||||
# Fix mouse display with spice and latest libvirt (bz #981094)
|
||||
# (patch posted upstream but not applied yet)
|
||||
Patch0007: 0007-spice-fix-display-initialization.patch
|
||||
|
||||
BuildRequires: SDL-devel
|
||||
BuildRequires: zlib-devel
|
||||
@ -687,6 +690,9 @@ CAC emulation development files.
|
||||
%patch0005 -p1
|
||||
# Fix build with rawhide libfdt
|
||||
%patch0006 -p1
|
||||
# Fix mouse display with spice and latest libvirt (bz #981094)
|
||||
# (patch posted upstream but not applied yet)
|
||||
%patch0007 -p1
|
||||
|
||||
|
||||
%build
|
||||
@ -1377,6 +1383,10 @@ getent passwd qemu >/dev/null || \
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Mon Jul 29 2013 Cole Robinson <crobinso@redhat.com> - 2:1.5.2-1
|
||||
- Rebased to version 1.5.2
|
||||
- Fix mouse display with spice and latest libvirt (bz #981094)
|
||||
|
||||
* Tue Jul 09 2013 Cole Robinson <crobinso@redhat.com> - 2:1.5.1-2
|
||||
- Update to work with seabios 1.7.3
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user