Rebase to qemu-5.2.0-rc4
Signed-off-by: Cole Robinson <crobinso@redhat.com>
This commit is contained in:
parent
4b48a789ef
commit
646ce0f5b5
@ -1,40 +0,0 @@
|
|||||||
From 800fb9e15c9672c79862ab608fe8cc41513310c3 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Greg Kurz <groug@kaod.org>
|
|
||||||
Date: Tue, 24 Nov 2020 08:43:43 +0100
|
|
||||||
Subject: [PATCH] tests/9pfs: Mark "local" tests as "slow"
|
|
||||||
|
|
||||||
The "local" tests can fail on some automated build systems as
|
|
||||||
reported here:
|
|
||||||
|
|
||||||
https://lists.nongnu.org/archive/html/qemu-devel/2020-11/msg05510.html
|
|
||||||
|
|
||||||
This will need to be investigated and addressed later. Let's go for a
|
|
||||||
workaround in the meantime : mark the "local" tests as "slow" so that
|
|
||||||
they aren't executed with a simple "make check" like in the case above.
|
|
||||||
|
|
||||||
Reported-by: Cole Robinson <crobinso@redhat.com>
|
|
||||||
Signed-off-by: Greg Kurz <groug@kaod.org>
|
|
||||||
---
|
|
||||||
tests/qtest/virtio-9p-test.c | 9 +++++++++
|
|
||||||
1 file changed, 9 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/tests/qtest/virtio-9p-test.c b/tests/qtest/virtio-9p-test.c
|
|
||||||
index 21e340fa5f..92a498f249 100644
|
|
||||||
--- a/tests/qtest/virtio-9p-test.c
|
|
||||||
+++ b/tests/qtest/virtio-9p-test.c
|
|
||||||
@@ -1456,6 +1456,15 @@ static void register_virtio_9p_test(void)
|
|
||||||
|
|
||||||
|
|
||||||
/* 9pfs test cases using the 'local' filesystem driver */
|
|
||||||
+
|
|
||||||
+ /*
|
|
||||||
+ * XXX: Until we are sure that these tests can run everywhere,
|
|
||||||
+ * keep them as "slow" so that they aren't run with "make check".
|
|
||||||
+ */
|
|
||||||
+ if (!g_test_slow()) {
|
|
||||||
+ return;
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
opts.before = assign_9p_local_driver;
|
|
||||||
qos_add_test("local/config", "virtio-9p", pci_config, &opts);
|
|
||||||
qos_add_test("local/create_dir", "virtio-9p", fs_create_dir, &opts);
|
|
@ -1,73 +0,0 @@
|
|||||||
From 0e330ca9023487b3635cdcee1b7ef03266ea9068 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Stefan Hajnoczi <stefanha@redhat.com>
|
|
||||||
Date: Thu, 19 Nov 2020 11:27:04 +0000
|
|
||||||
Subject: [PATCH] trace: use STAP_SDT_V2 to work around symbol visibility
|
|
||||||
MIME-Version: 1.0
|
|
||||||
Content-Type: text/plain; charset=UTF-8
|
|
||||||
Content-Transfer-Encoding: 8bit
|
|
||||||
|
|
||||||
QEMU binaries no longer launch successfully with recent SystemTap
|
|
||||||
releases. This is because modular QEMU builds link the sdt semaphores
|
|
||||||
into the main binary instead of into the shared objects where they are
|
|
||||||
used. The symbol visibility of semaphores is 'hidden' and the dynamic
|
|
||||||
linker prints an error during module loading:
|
|
||||||
|
|
||||||
$ ./configure --enable-trace-backends=dtrace --enable-modules ...
|
|
||||||
...
|
|
||||||
Failed to open module: /builddir/build/BUILD/qemu-4.2.0/s390x-softmmu/../block-curl.so: undefined symbol: qemu_curl_close_semaphore
|
|
||||||
|
|
||||||
The long-term solution is to generate per-module dtrace .o files and
|
|
||||||
link them into the module instead of the main binary.
|
|
||||||
|
|
||||||
In the short term we can define STAP_SDT_V2 so dtrace(1) produces a .o
|
|
||||||
file with 'default' symbol visibility instead of 'hidden'. This
|
|
||||||
workaround is small and easier to merge for QEMU 5.2.
|
|
||||||
|
|
||||||
Cc: Daniel P. Berrangé <berrange@redhat.com>
|
|
||||||
Cc: wcohen@redhat.com
|
|
||||||
Cc: fche@redhat.com
|
|
||||||
Cc: kraxel@redhat.com
|
|
||||||
Cc: rjones@redhat.com
|
|
||||||
Cc: mrezanin@redhat.com
|
|
||||||
Cc: ddepaula@redhat.com
|
|
||||||
Signed-off-by: Stefan Hajnoczi <stefanha@redhat.com>
|
|
||||||
---
|
|
||||||
configure | 1 +
|
|
||||||
trace/meson.build | 4 ++--
|
|
||||||
2 files changed, 3 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/configure b/configure
|
|
||||||
index 714e75b5d8..5d91d49c7b 100755
|
|
||||||
--- a/configure
|
|
||||||
+++ b/configure
|
|
||||||
@@ -4832,6 +4832,7 @@ if have_backend "dtrace"; then
|
|
||||||
trace_backend_stap="no"
|
|
||||||
if has 'stap' ; then
|
|
||||||
trace_backend_stap="yes"
|
|
||||||
+ QEMU_CFLAGS="$QEMU_CFLAGS -DSTAP_SDT_V2"
|
|
||||||
fi
|
|
||||||
fi
|
|
||||||
|
|
||||||
diff --git a/trace/meson.build b/trace/meson.build
|
|
||||||
index d5fc45c628..843ea14495 100644
|
|
||||||
--- a/trace/meson.build
|
|
||||||
+++ b/trace/meson.build
|
|
||||||
@@ -38,13 +38,13 @@ foreach dir : [ '.' ] + trace_events_subdirs
|
|
||||||
trace_dtrace_h = custom_target(fmt.format('trace-dtrace', 'h'),
|
|
||||||
output: fmt.format('trace-dtrace', 'h'),
|
|
||||||
input: trace_dtrace,
|
|
||||||
- command: [ 'dtrace', '-o', '@OUTPUT@', '-h', '-s', '@INPUT@' ])
|
|
||||||
+ command: [ 'dtrace', '-DSTAP_SDT_V2', '-o', '@OUTPUT@', '-h', '-s', '@INPUT@' ])
|
|
||||||
trace_ss.add(trace_dtrace_h)
|
|
||||||
if host_machine.system() != 'darwin'
|
|
||||||
trace_dtrace_o = custom_target(fmt.format('trace-dtrace', 'o'),
|
|
||||||
output: fmt.format('trace-dtrace', 'o'),
|
|
||||||
input: trace_dtrace,
|
|
||||||
- command: [ 'dtrace', '-o', '@OUTPUT@', '-G', '-s', '@INPUT@' ])
|
|
||||||
+ command: [ 'dtrace', '-DSTAP_SDT_V2', '-o', '@OUTPUT@', '-G', '-s', '@INPUT@' ])
|
|
||||||
trace_ss.add(trace_dtrace_o)
|
|
||||||
endif
|
|
||||||
|
|
||||||
--
|
|
||||||
2.28.0
|
|
||||||
|
|
12
qemu.spec
12
qemu.spec
@ -206,7 +206,7 @@
|
|||||||
%{obsoletes_block_rbd}
|
%{obsoletes_block_rbd}
|
||||||
|
|
||||||
# Release candidate version tracking
|
# Release candidate version tracking
|
||||||
%global rcver rc2
|
%global rcver rc4
|
||||||
%if 0%{?rcver:1}
|
%if 0%{?rcver:1}
|
||||||
%global rcrel .%{rcver}
|
%global rcrel .%{rcver}
|
||||||
%global rcstr -%{rcver}
|
%global rcstr -%{rcver}
|
||||||
@ -216,7 +216,7 @@
|
|||||||
Summary: QEMU is a FAST! processor emulator
|
Summary: QEMU is a FAST! processor emulator
|
||||||
Name: qemu
|
Name: qemu
|
||||||
Version: 5.2.0
|
Version: 5.2.0
|
||||||
Release: 0.7%{?rcrel}%{?dist}
|
Release: 0.8%{?rcrel}%{?dist}
|
||||||
Epoch: 2
|
Epoch: 2
|
||||||
License: GPLv2 and BSD and MIT and CC-BY
|
License: GPLv2 and BSD and MIT and CC-BY
|
||||||
URL: http://www.qemu.org/
|
URL: http://www.qemu.org/
|
||||||
@ -237,10 +237,6 @@ Source20: kvm-x86.modprobe.conf
|
|||||||
# /etc/security/limits.d/95-kvm-ppc64-memlock.conf
|
# /etc/security/limits.d/95-kvm-ppc64-memlock.conf
|
||||||
Source21: 95-kvm-ppc64-memlock.conf
|
Source21: 95-kvm-ppc64-memlock.conf
|
||||||
|
|
||||||
Patch0001: 0001-trace-use-STAP_SDT_V2-to-work-around-symbol-visibili.patch
|
|
||||||
|
|
||||||
# Fix running 9p tests in copr
|
|
||||||
Patch0002: 0001-tests-9pfs-Mark-local-tests-as-slow.patch
|
|
||||||
|
|
||||||
BuildRequires: meson
|
BuildRequires: meson
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
@ -1525,6 +1521,7 @@ getent passwd qemu >/dev/null || \
|
|||||||
%{_mandir}/man7/qemu-cpu-models.7*
|
%{_mandir}/man7/qemu-cpu-models.7*
|
||||||
%{_mandir}/man7/qemu-qmp-ref.7*
|
%{_mandir}/man7/qemu-qmp-ref.7*
|
||||||
%{_mandir}/man7/qemu-ga-ref.7*
|
%{_mandir}/man7/qemu-ga-ref.7*
|
||||||
|
%{_mandir}/man8/qemu-pr-helper.8*
|
||||||
%{_bindir}/elf2dmp
|
%{_bindir}/elf2dmp
|
||||||
%{_bindir}/qemu-edid
|
%{_bindir}/qemu-edid
|
||||||
%{_bindir}/qemu-keymap
|
%{_bindir}/qemu-keymap
|
||||||
@ -1907,6 +1904,9 @@ getent passwd qemu >/dev/null || \
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Dec 03 2020 Cole Robinson <aintdiscole@gmail.com> - 5.2.0-0.8.rc4
|
||||||
|
- Rebase to qemu-5.2.0-rc4
|
||||||
|
|
||||||
* Tue Nov 24 2020 Cole Robinson <aintdiscole@gmail.com> - 5.2.0-0.7.rc2
|
* Tue Nov 24 2020 Cole Robinson <aintdiscole@gmail.com> - 5.2.0-0.7.rc2
|
||||||
- Fix running 9p tests in copr
|
- Fix running 9p tests in copr
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (qemu-5.2.0-rc2.tar.xz) = 3f9730ffb0342a1b84d265c5425b53b8120db31bf09f7de441fa155213fceb763ef81af44f11be9ee4e50f122d905eec7f65b09eb1dc247bbd7c3fd0e4f906e0
|
SHA512 (qemu-5.2.0-rc4.tar.xz) = 47e918392609c34f904962e5759125485407ae52c273053729054300e10fc67fc7ed443c9af25d1d852a5f5c70eee125c703ce15d0e571068848f405de33db3b
|
||||||
|
Loading…
x
Reference in New Issue
Block a user