0.9.0
This commit is contained in:
parent
f5792256e9
commit
4cf268e250
@ -1 +1 @@
|
||||
qemu-0.8.2.tar.gz
|
||||
qemu-0.9.0.tar.gz
|
||||
|
@ -1,11 +0,0 @@
|
||||
diff -Naupr qemu-0.8.2.orig/usb-linux.c qemu-0.8.2/usb-linux.c
|
||||
--- qemu-0.8.2.orig/usb-linux.c 2006-07-22 19:23:34.000000000 +0200
|
||||
+++ qemu-0.8.2/usb-linux.c 2006-08-23 18:47:16.000000000 +0200
|
||||
@@ -26,7 +26,6 @@
|
||||
#if defined(__linux__)
|
||||
#include <dirent.h>
|
||||
#include <sys/ioctl.h>
|
||||
-#include <linux/compiler.h>
|
||||
#include <linux/usbdevice_fs.h>
|
||||
#include <linux/version.h>
|
||||
|
@ -1,82 +0,0 @@
|
||||
===================================================================
|
||||
RCS file: /sources/qemu/qemu/target-i386/translate.c,v
|
||||
retrieving revision 1.59
|
||||
retrieving revision 1.60
|
||||
diff -u -r1.59 -r1.60
|
||||
--- qemu/target-i386/translate.c 2006/07/10 19:53:04 1.59
|
||||
+++ qemu/target-i386/translate.c 2006/09/03 17:09:02 1.60
|
||||
@@ -1615,6 +1615,56 @@
|
||||
*offset_ptr = disp;
|
||||
}
|
||||
|
||||
+static void gen_nop_modrm(DisasContext *s, int modrm)
|
||||
+{
|
||||
+ int mod, rm, base, code;
|
||||
+
|
||||
+ mod = (modrm >> 6) & 3;
|
||||
+ if (mod == 3)
|
||||
+ return;
|
||||
+ rm = modrm & 7;
|
||||
+
|
||||
+ if (s->aflag) {
|
||||
+
|
||||
+ base = rm;
|
||||
+
|
||||
+ if (base == 4) {
|
||||
+ code = ldub_code(s->pc++);
|
||||
+ base = (code & 7);
|
||||
+ }
|
||||
+
|
||||
+ switch (mod) {
|
||||
+ case 0:
|
||||
+ if (base == 5) {
|
||||
+ s->pc += 4;
|
||||
+ }
|
||||
+ break;
|
||||
+ case 1:
|
||||
+ s->pc++;
|
||||
+ break;
|
||||
+ default:
|
||||
+ case 2:
|
||||
+ s->pc += 4;
|
||||
+ break;
|
||||
+ }
|
||||
+ } else {
|
||||
+ switch (mod) {
|
||||
+ case 0:
|
||||
+ if (rm == 6) {
|
||||
+ s->pc += 2;
|
||||
+ }
|
||||
+ break;
|
||||
+ case 1:
|
||||
+ s->pc++;
|
||||
+ break;
|
||||
+ default:
|
||||
+ case 2:
|
||||
+ s->pc += 2;
|
||||
+ break;
|
||||
+ }
|
||||
+ }
|
||||
+}
|
||||
+
|
||||
/* used for LEA and MOV AX, mem */
|
||||
static void gen_add_A0_ds_seg(DisasContext *s)
|
||||
{
|
||||
@@ -5791,10 +5841,15 @@
|
||||
gen_lea_modrm(s, modrm, ®_addr, &offset_addr);
|
||||
/* nothing more to do */
|
||||
break;
|
||||
- default:
|
||||
- goto illegal_op;
|
||||
+ default: /* nop (multi byte) */
|
||||
+ gen_nop_modrm(s, modrm);
|
||||
+ break;
|
||||
}
|
||||
break;
|
||||
+ case 0x119 ... 0x11f: /* nop (multi byte) */
|
||||
+ modrm = ldub_code(s->pc++);
|
||||
+ gen_nop_modrm(s, modrm);
|
||||
+ break;
|
||||
case 0x120: /* mov reg, crN */
|
||||
case 0x122: /* mov crN, reg */
|
||||
if (s->cpl != 0) {
|
@ -1,18 +0,0 @@
|
||||
diff -Naupr qemu-0.8.2.orig/target-sparc/op_helper.c qemu-0.8.2/target-sparc/op_helper.c
|
||||
--- qemu-0.8.2.orig/target-sparc/op_helper.c 2006-07-22 19:23:34.000000000 +0200
|
||||
+++ qemu-0.8.2/target-sparc/op_helper.c 2006-08-24 10:58:30.000000000 +0200
|
||||
@@ -12,12 +12,12 @@ void raise_exception(int tt)
|
||||
#ifdef USE_INT_TO_FLOAT_HELPERS
|
||||
void do_fitos(void)
|
||||
{
|
||||
- FT0 = int32_to_float32(*((int32_t *)&FT1));
|
||||
+ FT0 = int32_to_float32(*((int32_t *)&FT1), &env->fp_status);
|
||||
}
|
||||
|
||||
void do_fitod(void)
|
||||
{
|
||||
- DT0 = int32_to_float64(*((int32_t *)&FT1));
|
||||
+ DT0 = int32_to_float64(*((int32_t *)&FT1), &env->fp_status);
|
||||
}
|
||||
#endif
|
||||
|
15
qemu.spec
15
qemu.spec
@ -7,8 +7,8 @@
|
||||
|
||||
Summary: QEMU is a FAST! processor emulator
|
||||
Name: qemu
|
||||
Version: 0.8.2
|
||||
Release: 5%{?dist}
|
||||
Version: 0.9.0
|
||||
Release: 1%{?dist}
|
||||
License: GPL/LGPL
|
||||
Group: Development/Tools
|
||||
URL: http://www.qemu.org/
|
||||
@ -16,9 +16,6 @@ Source0: http://www.qemu.org/%{name}-%{version}.tar.gz
|
||||
Source1: qemu.init
|
||||
Patch0: qemu-0.7.0-build.patch
|
||||
Patch1: qemu-0.8.0-sdata.patch
|
||||
Patch2: qemu-0.8.2-kernheaders.patch
|
||||
Patch3: qemu-0.8.2-target-sparc.patch
|
||||
Patch4: qemu-0.8.2-mb-nops.diff
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: SDL-devel compat-gcc-%{gccver} zlib-devel which texi2html
|
||||
Requires(post): /sbin/chkconfig
|
||||
@ -43,9 +40,6 @@ As QEMU requires no host kernel patches to run, it is safe and easy to use.
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
|
||||
%build
|
||||
./configure \
|
||||
@ -86,7 +80,7 @@ fi
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%doc Changelog README README.distrib TODO
|
||||
%doc Changelog README TODO
|
||||
%doc qemu-doc.html qemu-tech.html
|
||||
%doc COPYING COPYING.LIB LICENSE
|
||||
%config %{_sysconfdir}/rc.d/init.d/qemu
|
||||
@ -95,6 +89,9 @@ fi
|
||||
%{_mandir}/man1/*
|
||||
|
||||
%changelog
|
||||
* Tue Feb 6 2007 David Woodhouse <dwmw2@infradead.org> 0.9.0-1
|
||||
- Update to 0.9.0
|
||||
|
||||
* Wed Jan 31 2007 David Woodhouse <dwmw2@infradead.org> 0.8.2-5
|
||||
- Include licences
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user