Add some test fixes

Signed-off-by: Cole Robinson <crobinso@redhat.com>
This commit is contained in:
Cole Robinson 2022-06-04 20:32:39 -04:00
parent a3d41732e4
commit 467b991168
3 changed files with 70 additions and 0 deletions

View File

@ -0,0 +1,36 @@
From: Cole Robinson <crobinso@redhat.com>
Date: Sat, 4 Jun 2022 20:28:58 -0400
Subject: [PATCH] Disable flakey dbus-display-test
Content-type: text/plain
Signed-off-by: Cole Robinson <crobinso@redhat.com>
---
tests/qtest/meson.build | 8 --------
1 file changed, 8 deletions(-)
diff --git a/tests/qtest/meson.build b/tests/qtest/meson.build
index d25f82bb5a..d085604727 100644
--- a/tests/qtest/meson.build
+++ b/tests/qtest/meson.build
@@ -94,10 +94,6 @@ qtests_i386 = \
'test-filter-redirector'
]
-if dbus_display
- qtests_i386 += ['dbus-display-test']
-endif
-
dbus_daemon = find_program('dbus-daemon', required: false)
if dbus_daemon.found() and config_host.has_key('GDBUS_CODEGEN')
# Temporarily disabled due to Patchew failures:
@@ -298,10 +294,6 @@ qtests = {
'vmgenid-test': files('boot-sector.c', 'acpi-utils.c'),
}
-if dbus_display
-qtests += {'dbus-display-test': [dbus_display1, gio]}
-endif
-
qtest_executables = {}
foreach dir : target_dirs
if not dir.endswith('-softmmu')

View File

@ -0,0 +1,32 @@
From: Cole Robinson <crobinso@redhat.com>
Date: Sat, 4 Jun 2022 20:29:46 -0400
Subject: [PATCH] Fix iotests with modules and qemu-system-s390x
Content-type: text/plain
Signed-off-by: Cole Robinson <crobinso@redhat.com>
---
tests/qemu-iotests/common.rc | 4 ++--
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/tests/qemu-iotests/common.rc b/tests/qemu-iotests/common.rc
index 227e0a5be9..97f8e0a15f 100644
--- a/tests/qemu-iotests/common.rc
+++ b/tests/qemu-iotests/common.rc
@@ -975,7 +975,7 @@ _require_large_file()
#
_require_devices()
{
- available=$($QEMU -M none -device help | \
+ available=$($QEMU -M none -device help 2> /dev/null | \
grep ^name | sed -e 's/^name "//' -e 's/".*$//')
for device
do
@@ -987,7 +987,7 @@ _require_devices()
_require_one_device_of()
{
- available=$($QEMU -M none -device help | \
+ available=$($QEMU -M none -device help 2> /dev/null | \
grep ^name | sed -e 's/^name "//' -e 's/".*$//')
for device
do

View File

@ -354,6 +354,8 @@ Patch0004: 0004-virtio-scsi-clean-up-virtio_scsi_handle_event_vq.patch
Patch0005: 0005-virtio-scsi-clean-up-virtio_scsi_handle_ctrl_vq.patch
Patch0006: 0006-virtio-scsi-clean-up-virtio_scsi_handle_cmd_vq.patch
Patch0007: 0007-virtio-scsi-move-request-related-items-from-.h-to-.c.patch
Patch0008: 0008-Disable-flakey-dbus-display-test.patch
Patch0009: 0009-Fix-iotests-with-modules-and-qemu-system-s390x.patch
BuildRequires: meson >= %{meson_version}
BuildRequires: zlib-devel